c2879fd933
* Thu Jan 13 2022 Florian Weimer <fweimer@redhat.com> - 2.34-18 - Backport optimized ELF dependency sorting algorithm (#2032647) * Thu Jan 13 2022 Florian Weimer <fweimer@redhat.com> - 2.34-17 - Sync with upstream branch release/2.34/master, commit 2fe2af88abd13ae5636881da2e26f461ecb7dfb5 - i386: Remove broken CAN_USE_REGISTER_ASM_EBP (bug 28771) - Update syscall lists for Linux 5.15 - powerpc: Fix unrecognized instruction errors with recent GCC - timezone: test-case for BZ #28707 - timezone: handle truncated timezones from tzcode-2021d and later (BZ #28707) - Fix subscript error with odd TZif file [BZ #28338] - AArch64: Check for SVE in ifuncs [BZ #28744] - intl/plural.y: Avoid conflicting declarations of yyerror and yylex - Linux: Fix 32-bit vDSO for clock_gettime on powerpc32 - linux: Add sparck brk implementation - Update sparc libm-test-ulps - Update hppa libm-test-ulps - riscv: align stack before calling _dl_init [BZ #28703] - riscv: align stack in clone [BZ #28702] - powerpc64[le]: Allocate extra stack frame on syscall.S - elf: Fix tst-cpu-features-cpuinfo for KVM guests on some AMD systems [BZ #28704] - nss: Use "files dns" as the default for the hosts database (bug 28700) - arm: Guard ucontext _rtld_global_ro access by SHARED, not PIC macro - mips: increase stack alignment in clone to match the ABI - mips: align stack in clone [BZ #28223] Resolves: #2032647 Resolves: #2033649
26 lines
814 B
Diff
26 lines
814 B
Diff
commit d3bf2f5927d51258a51ac7fde04f4805f8ee294a
|
|
Author: Adhemerval Zanella <adhemerval.zanella@linaro.org>
|
|
Date: Wed Nov 3 09:19:30 2021 -0300
|
|
|
|
elf: Do not run DSO sorting if tunables is not enabled
|
|
|
|
Since the argorithm selection requires tunables.
|
|
|
|
Checked on x86_64-linux-gnu with --enable-tunables=no.
|
|
|
|
diff --git a/elf/Makefile b/elf/Makefile
|
|
index 8dd2b24328113536..02ee834fdaf00a26 100644
|
|
--- a/elf/Makefile
|
|
+++ b/elf/Makefile
|
|
@@ -483,8 +483,10 @@ include $(objpfx)$(1).generated-makefile
|
|
endef
|
|
|
|
# Generate from each testcase description file
|
|
+ifeq (yes,$(have-tunables))
|
|
$(eval $(call include_dsosort_tests,dso-sort-tests-1.def))
|
|
$(eval $(call include_dsosort_tests,dso-sort-tests-2.def))
|
|
+endif
|
|
|
|
check-abi: $(objpfx)check-abi-ld.out
|
|
tests-special += $(objpfx)check-abi-ld.out
|