42eb238e49
* Tue Mar 15 2022 Florian Weimer <fweimer@redhat.com> - 2.34-29 - Sync with upstream branch release/2.34/master, commit 224d8c1890b6c57c7e4e8ddbb792dd9552086704: - debug: Synchronize feature guards in fortified functions [BZ #28746] - debug: Autogenerate _FORTIFY_SOURCE tests - Enable _FORTIFY_SOURCE=3 for gcc 12 and above - fortify: Fix spurious warning with realpath - __glibc_unsafe_len: Fix comment - debug: Add tests for _FORTIFY_SOURCE=3 - Make sure that the fortified function conditionals are constant - Don't add access size hints to fortifiable functions - nss: Protect against errno changes in function lookup (bug 28953) - nss: Do not mention NSS test modules in <gnu/lib-names.h> - io: Add fsync call in tst-stat - hppa: Fix warnings from _dl_lookup_address - nptl: Fix cleanups for stack grows up [BZ# 28899] - hppa: Revise gettext trampoline design - hppa: Fix swapcontext - Fix elf/tst-audit2 on hppa - localedef: Handle symbolic links when generating locale-archive - NEWS: Add a bug fix entry for BZ #28896 - x86: Fix TEST_NAME to make it a string in tst-strncmp-rtm.c - x86: Test wcscmp RTM in the wcsncmp overflow case [BZ #28896] - x86: Fallback {str|wcs}cmp RTM in the ncmp overflow case [BZ #28896] - string: Add a testcase for wcsncmp with SIZE_MAX [BZ #28755] - linux: fix accuracy of get_nprocs and get_nprocs_conf [BZ #28865] - Add reference to BZ#28860 on NEWS - linux: Fix missing __convert_scm_timestamps (BZ #28860) Resolves: #2063230 Resolves: #2033683 Resolves: #2063041 Resolves: #2063142
57 lines
2.0 KiB
Diff
57 lines
2.0 KiB
Diff
commit b53f0c11de409b04560a70570178d1a9d03d5860
|
|
Author: Florian Weimer <fweimer@redhat.com>
|
|
Date: Fri Mar 11 08:23:56 2022 +0100
|
|
|
|
nss: Do not mention NSS test modules in <gnu/lib-names.h>
|
|
|
|
They are not actually installed. Use the nss_files version instead
|
|
in nss/Makefile, similar to how __nss_shlib_revision is derived
|
|
from LIBNSS_FILES_SO.
|
|
|
|
Reviewed-by: Carlos O'Donell <carlos@redhat.com>
|
|
(cherry picked from commit aefc79ab5ad4bb9feea2876720cec70dca7cd8ed)
|
|
|
|
diff --git a/nss/Makefile b/nss/Makefile
|
|
index bccf9f2806c15651..e223243d9d62041c 100644
|
|
--- a/nss/Makefile
|
|
+++ b/nss/Makefile
|
|
@@ -171,17 +171,14 @@ $(objpfx)/libnss_test1.so: $(objpfx)nss_test1.os $(link-libc-deps)
|
|
$(objpfx)/libnss_test2.so: $(objpfx)nss_test2.os $(link-libc-deps)
|
|
$(build-module)
|
|
$(objpfx)nss_test2.os : nss_test1.c
|
|
-ifdef libnss_test1.so-version
|
|
-$(objpfx)/libnss_test1.so$(libnss_test1.so-version): $(objpfx)/libnss_test1.so
|
|
+# Use the nss_files suffix for these objects as well.
|
|
+$(objpfx)/libnss_test1.so$(libnss_files.so-version): $(objpfx)/libnss_test1.so
|
|
$(make-link)
|
|
-endif
|
|
-ifdef libnss_test2.so-version
|
|
-$(objpfx)/libnss_test2.so$(libnss_test2.so-version): $(objpfx)/libnss_test2.so
|
|
+$(objpfx)/libnss_test2.so$(libnss_files.so-version): $(objpfx)/libnss_test2.so
|
|
$(make-link)
|
|
-endif
|
|
$(patsubst %,$(objpfx)%.out,$(tests) $(tests-container)) : \
|
|
- $(objpfx)/libnss_test1.so$(libnss_test1.so-version) \
|
|
- $(objpfx)/libnss_test2.so$(libnss_test2.so-version)
|
|
+ $(objpfx)/libnss_test1.so$(libnss_files.so-version) \
|
|
+ $(objpfx)/libnss_test2.so$(libnss_files.so-version)
|
|
|
|
ifeq (yes,$(have-thread-library))
|
|
$(objpfx)tst-cancel-getpwuid_r: $(shared-thread-library)
|
|
diff --git a/shlib-versions b/shlib-versions
|
|
index df6603e6992b8382..b87ab50c59af1bfd 100644
|
|
--- a/shlib-versions
|
|
+++ b/shlib-versions
|
|
@@ -47,11 +47,6 @@ libnss_ldap=2
|
|
libnss_hesiod=2
|
|
libnss_db=2
|
|
|
|
-# Tests for NSS. They must have the same NSS_SHLIB_REVISION number as
|
|
-# the rest.
|
|
-libnss_test1=2
|
|
-libnss_test2=2
|
|
-
|
|
# Version for libnsl with YP and NIS+ functions.
|
|
libnsl=1
|
|
|