9c1694b310
Resolves: RHEL-46736
68 lines
2.2 KiB
Diff
68 lines
2.2 KiB
Diff
commit e3fdbe9f39747206b9c3fbb0219f29fd5b35d020
|
|
Author: Adhemerval Zanella <adhemerval.zanella@linaro.org>
|
|
Date: Thu Apr 8 17:36:07 2021 -0300
|
|
|
|
support: Add xmkfifo
|
|
|
|
Wrapper support mkfifo.
|
|
|
|
diff --git a/support/Makefile b/support/Makefile
|
|
index 25e8bbefd78c2268..0273c0f6306720c9 100644
|
|
--- a/support/Makefile
|
|
+++ b/support/Makefile
|
|
@@ -137,6 +137,7 @@ libsupport-routines = \
|
|
xmemstream \
|
|
xmkdir \
|
|
xmkdirp \
|
|
+ xmkfifo \
|
|
xmmap \
|
|
xmprotect \
|
|
xmunmap \
|
|
diff --git a/support/xmkfifo.c b/support/xmkfifo.c
|
|
new file mode 100644
|
|
index 0000000000000000..a8e196dbc209a47d
|
|
--- /dev/null
|
|
+++ b/support/xmkfifo.c
|
|
@@ -0,0 +1,29 @@
|
|
+/* mkfifo with error checking.
|
|
+ Copyright (C) 2022 Free Software Foundation, Inc.
|
|
+ This file is part of the GNU C Library.
|
|
+
|
|
+ The GNU C Library is free software; you can redistribute it and/or
|
|
+ modify it under the terms of the GNU Lesser General Public
|
|
+ License as published by the Free Software Foundation; either
|
|
+ version 2.1 of the License, or (at your option) any later version.
|
|
+
|
|
+ The GNU C Library is distributed in the hope that it will be useful,
|
|
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
|
+ Lesser General Public License for more details.
|
|
+
|
|
+ You should have received a copy of the GNU Lesser General Public
|
|
+ License along with the GNU C Library; if not, see
|
|
+ <https://www.gnu.org/licenses/>. */
|
|
+
|
|
+#include <support/check.h>
|
|
+#include <support/xunistd.h>
|
|
+#include <sys/stat.h>
|
|
+
|
|
+void
|
|
+xmkfifo (const char *pathname, mode_t mode)
|
|
+{
|
|
+ int r = mkfifo (pathname, mode);
|
|
+ if (r < 0)
|
|
+ FAIL_EXIT1 ("mkfifo (%s, 0%o): %m", pathname, mode);
|
|
+}
|
|
diff --git a/support/xunistd.h b/support/xunistd.h
|
|
index a25ecf1cf38ef328..94b1e1eb1b1e8253 100644
|
|
--- a/support/xunistd.h
|
|
+++ b/support/xunistd.h
|
|
@@ -61,6 +61,7 @@ void xsymlink (const char *target, const char *linkpath);
|
|
void xchdir (const char *path);
|
|
void xfchmod (int fd, mode_t mode);
|
|
void xchmod (const char *pathname, mode_t mode);
|
|
+void xmkfifo (const char *pathname, mode_t mode);
|
|
|
|
/* Equivalent of "mkdir -p". */
|
|
void xmkdirp (const char *, mode_t);
|