2a30b8f4b2
Upstream commit: dcaf51b41e259387602774829c45222d0507f90a - elf: Change ldconfig auxcache magic number (bug 32231) - Make tst-strtod-underflow type-generic - Add crt1-2.0.o for glibc 2.0 compatibility tests - Add tests of more strtod special cases - Add more tests of strtod end pointer - Make tst-strtod2 and tst-strtod5 type-generic - powerpc64le: Build new strtod tests with long double ABI flags (bug 32145) - Do not set errno for overflowing NaN payload in strtod/nan (bug 32045) - Improve NaN payload testing - Make __strtod_internal tests type-generic - Fix strtod subnormal rounding (bug 30220) - More thoroughly test underflow / errno in tst-strtod-round - Test errno setting on strtod overflow in tst-strtod-round - Add tests of fread - stdio-common: Add new test for fdopen - libio: Attempt wide backup free only for non-legacy code - debug: Fix read error handling in pcprofiledump - elf: Fix tst-dlopen-tlsreinit1.out test dependency - elf: Avoid re-initializing already allocated TLS in dlopen (bug 31717) - elf: Clarify and invert second argument of _dl_allocate_tls_init - elf: Support recursive use of dynamic TLS in interposed malloc - nptl: Use <support/check.h> facilities in tst-setuid3 - posix: Use <support/check.h> facilities in tst-truncate and tst-truncate64 - ungetc: Fix backup buffer leak on program exit [BZ #27821] - ungetc: Fix uninitialized read when putting into unused streams [BZ #27821] - Make tst-ungetc use libsupport - stdio-common: Add test for vfscanf with matches longer than INT_MAX [BZ #27650] - support: Add FAIL test failure helper - string: strerror, strsignal cannot use buffer after dlmopen (bug 32026) - Define __libc_initial for the static libc - x86: Fix bug in strchrnul-evex512 [BZ #32078] - Adjust check-local-headers test for libaudit 4.0 - x32/cet: Support shadow stack during startup for Linux 6.10 - x86-64: Remove sysdeps/x86_64/x32/dl-machine.h - support: Add options list terminator to the test driver - manual/stdio: Further clarify putc, putwc, getc, and getwc - Fix name space violation in fortify wrappers (bug 32052) - resolv: Fix tst-resolv-short-response for older GCC (bug 32042) - Add mremap tests - mremap: Update manual entry - linux: Update the mremap C implementation [BZ #31968] - Enhanced test coverage for strncmp, wcsncmp - Enhance test coverage for strnlen, wcsnlen Resolves: RHEL-57776 Resolves: RHEL-57777 Resolves: RHEL-61392
169 lines
5.3 KiB
Diff
169 lines
5.3 KiB
Diff
commit 3c5f493d871c11de9d8358b8ac84c144a0d848fa
|
|
Author: Maciej W. Rozycki <macro@redhat.com>
|
|
Date: Fri Jul 26 13:21:34 2024 +0100
|
|
|
|
stdio-common: Add test for vfscanf with matches longer than INT_MAX [BZ #27650]
|
|
|
|
Complement commit b03e4d7bd25b ("stdio: fix vfscanf with matches longer
|
|
than INT_MAX (bug 27650)") and add a test case for the issue, inspired
|
|
by the reproducer provided with the bug report.
|
|
|
|
This has been verified to succeed as from the commit referred and fail
|
|
beforehand.
|
|
|
|
As the test requires 2GiB of data to be passed around its performance
|
|
has been evaluated using a choice of systems and the execution time
|
|
determined to be respectively in the range of 9s for POWER9@2.166GHz,
|
|
24s for FU740@1.2GHz, and 40s for 74Kf@950MHz. As this is on the verge
|
|
of and beyond the default timeout it has been increased by the factor of
|
|
8. Regardless, following recent practice the test has been added to the
|
|
standard rather than extended set.
|
|
|
|
Reviewed-by: DJ Delorie <dj@redhat.com>
|
|
(cherry picked from commit 89cddc8a7096f3d9225868304d2bc0a1aaf07d63)
|
|
|
|
diff --git a/stdio-common/Makefile b/stdio-common/Makefile
|
|
index e312565f3b671463..159dc472e4c76b9a 100644
|
|
--- a/stdio-common/Makefile
|
|
+++ b/stdio-common/Makefile
|
|
@@ -243,6 +243,7 @@ tests := \
|
|
tst-scanf-binary-c2x \
|
|
tst-scanf-binary-gnu11 \
|
|
tst-scanf-binary-gnu89 \
|
|
+ tst-scanf-bz27650 \
|
|
tst-scanf-intn \
|
|
tst-scanf-round \
|
|
tst-scanf-to_inpunct \
|
|
@@ -313,6 +314,7 @@ generated += \
|
|
tst-printf-fp-free.mtrace \
|
|
tst-printf-fp-leak-mem.out \
|
|
tst-printf-fp-leak.mtrace \
|
|
+ tst-scanf-bz27650.mtrace \
|
|
tst-vfprintf-width-prec-mem.out \
|
|
tst-vfprintf-width-prec.mtrace \
|
|
# generated
|
|
@@ -402,6 +404,9 @@ tst-printf-fp-free-ENV = \
|
|
tst-printf-fp-leak-ENV = \
|
|
MALLOC_TRACE=$(objpfx)tst-printf-fp-leak.mtrace \
|
|
LD_PRELOAD=$(common-objpfx)/malloc/libc_malloc_debug.so
|
|
+tst-scanf-bz27650-ENV = \
|
|
+ MALLOC_TRACE=$(objpfx)tst-scanf-bz27650.mtrace \
|
|
+ LD_PRELOAD=$(common-objpfx)malloc/libc_malloc_debug.so
|
|
|
|
$(objpfx)tst-unbputc.out: tst-unbputc.sh $(objpfx)tst-unbputc
|
|
$(SHELL) $< $(common-objpfx) '$(test-program-prefix)'; \
|
|
diff --git a/stdio-common/tst-scanf-bz27650.c b/stdio-common/tst-scanf-bz27650.c
|
|
new file mode 100644
|
|
index 0000000000000000..3a742bc86556908c
|
|
--- /dev/null
|
|
+++ b/stdio-common/tst-scanf-bz27650.c
|
|
@@ -0,0 +1,108 @@
|
|
+/* Test for BZ #27650, formatted input matching beyond INT_MAX.
|
|
+ Copyright (C) 2024 Free Software Foundation, Inc.
|
|
+ This file is part of the GNU C Library.
|
|
+
|
|
+ The GNU C Library is free software; you can redistribute it and/or
|
|
+ modify it under the terms of the GNU Lesser General Public
|
|
+ License as published by the Free Software Foundation; either
|
|
+ version 2.1 of the License, or (at your option) any later version.
|
|
+
|
|
+ The GNU C Library is distributed in the hope that it will be useful,
|
|
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
|
+ Lesser General Public License for more details.
|
|
+
|
|
+ You should have received a copy of the GNU Lesser General Public
|
|
+ License along with the GNU C Library; if not, see
|
|
+ <https://www.gnu.org/licenses/>. */
|
|
+
|
|
+#include <error.h>
|
|
+#include <errno.h>
|
|
+#include <limits.h>
|
|
+#include <mcheck.h>
|
|
+#include <stddef.h>
|
|
+#include <stdio.h>
|
|
+#include <stdlib.h>
|
|
+#include <string.h>
|
|
+
|
|
+#include <sys/types.h>
|
|
+
|
|
+#include <support/check.h>
|
|
+#include <support/test-driver.h>
|
|
+
|
|
+/* Produce a stream of more than INT_MAX characters via buffer BUF of
|
|
+ size SIZE according to bookkeeping in COOKIE and then return EOF. */
|
|
+
|
|
+static ssize_t
|
|
+io_read (void *cookie, char *buf, size_t size)
|
|
+{
|
|
+ unsigned int *written = cookie;
|
|
+ unsigned int w = *written;
|
|
+
|
|
+ if (w > INT_MAX)
|
|
+ return 0;
|
|
+
|
|
+ memset (buf, 'a', size);
|
|
+ *written = w + size;
|
|
+ return size;
|
|
+}
|
|
+
|
|
+/* Consume a stream of more than INT_MAX characters from an artificial
|
|
+ input stream of which none is the new line character. The call to
|
|
+ fscanf is supposed to complete upon the EOF condition of input,
|
|
+ however in the presence of BZ #27650 it will terminate prematurely
|
|
+ with characters still outstanding in input. Diagnose the condition
|
|
+ and return status accordingly. */
|
|
+
|
|
+int
|
|
+do_test (void)
|
|
+{
|
|
+ static cookie_io_functions_t io_funcs = { .read = io_read };
|
|
+ unsigned int written = 0;
|
|
+ FILE *in;
|
|
+ int v;
|
|
+
|
|
+ mtrace ();
|
|
+
|
|
+ in = fopencookie (&written, "r", io_funcs);
|
|
+ if (in == NULL)
|
|
+ {
|
|
+ FAIL ("fopencookie: %m");
|
|
+ goto out;
|
|
+ }
|
|
+
|
|
+ v = fscanf (in, "%*[^\n]");
|
|
+ if (ferror (in))
|
|
+ {
|
|
+ FAIL ("fscanf: input failure, at %u: %m", written);
|
|
+ goto out_close;
|
|
+ }
|
|
+ else if (v == EOF)
|
|
+ {
|
|
+ FAIL ("fscanf: unexpected end of file, at %u", written);
|
|
+ goto out_close;
|
|
+ }
|
|
+
|
|
+ if (!feof (in))
|
|
+ {
|
|
+ v = fgetc (in);
|
|
+ if (ferror (in))
|
|
+ FAIL ("fgetc: input failure: %m");
|
|
+ else if (v == EOF)
|
|
+ FAIL ("fgetc: unexpected end of file after missing end of file");
|
|
+ else if (v == '\n')
|
|
+ FAIL ("unexpected new line character received");
|
|
+ else
|
|
+ FAIL ("character received after end of file expected: \\x%02x", v);
|
|
+ }
|
|
+
|
|
+out_close:
|
|
+ if (fclose (in) != 0)
|
|
+ FAIL ("fclose: %m");
|
|
+
|
|
+out:
|
|
+ return EXIT_SUCCESS;
|
|
+}
|
|
+
|
|
+#define TIMEOUT (DEFAULT_TIMEOUT * 8)
|
|
+#include <support/test-driver.c>
|