1a997221e3
Upstream commit: 5d070d12b3a52bc44dd1b71743abc4b6243862ae
Related: RHEL-25850
- x86: Expand the comment on when REP STOSB is used on memset
- x86: Do not prefer ERMS for memset on Zen3+
- x86: Fix Zen3/Zen4 ERMS selection (BZ 30994)
Resolves: RHEL-25530
- Add tst-gnu2-tls2mod1 to test-internal-extras
- elf: Enable TLS descriptor tests on aarch64
- arm: Update _dl_tlsdesc_dynamic to preserve caller-saved registers (BZ 31372)
- Ignore undefined symbols for -mtls-dialect=gnu2
- x86-64: Allocate state buffer space for RDI, RSI and RBX
- x86-64: Update _dl_tlsdesc_dynamic to preserve AMX registers
- x86: Update _dl_tlsdesc_dynamic to preserve caller-saved registers
Resolves: RHEL-29179
- x86-64: Save APX registers in ld.so trampoline
Resolves: RHEL-25045
- LoongArch: Correct {__ieee754, _}_scalb -> {__ieee754, _}_scalbf
- powerpc: Placeholder and infrastructure/build support to add Power11 related changes.
- powerpc: Add HWCAP3/HWCAP4 data to TCB for Power Architecture.
Resolves: RHEL-24761
Fedora 40 commit: 24af28d49b
39 lines
1.3 KiB
Diff
39 lines
1.3 KiB
Diff
commit 15aebdbada54098787715448c94701f17033fc92
|
|
Author: Adhemerval Zanella <adhemerval.zanella@linaro.org>
|
|
Date: Tue Mar 12 13:21:18 2024 -0300
|
|
|
|
Ignore undefined symbols for -mtls-dialect=gnu2
|
|
|
|
So it does not fail for arm config that defaults to -mtp=soft (which
|
|
issues a call to __aeabi_read_tp).
|
|
Reviewed-by: H.J. Lu <hjl.tools@gmail.com>
|
|
|
|
(cherry picked from commit 968b0ca9440040a2b31248a572891f0e55c1ab10)
|
|
|
|
diff --git a/configure b/configure
|
|
index 59ff1e415dda4fbf..117b48a421792eda 100755
|
|
--- a/configure
|
|
+++ b/configure
|
|
@@ -7020,7 +7020,7 @@ void foo (void)
|
|
}
|
|
EOF
|
|
if { ac_try='${CC-cc} $CFLAGS $CPPFLAGS -fPIC -mtls-dialect=gnu2 -nostdlib -nostartfiles
|
|
- conftest.c -o conftest 1>&5'
|
|
+ -shared conftest.c -o conftest 1>&5'
|
|
{ { eval echo "\"\$as_me\":${as_lineno-$LINENO}: \"$ac_try\""; } >&5
|
|
(eval $ac_try) 2>&5
|
|
ac_status=$?
|
|
diff --git a/configure.ac b/configure.ac
|
|
index 65799e56852a5356..19b88a47a52508a1 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -1297,7 +1297,7 @@ void foo (void)
|
|
}
|
|
EOF
|
|
if AC_TRY_COMMAND([${CC-cc} $CFLAGS $CPPFLAGS -fPIC -mtls-dialect=gnu2 -nostdlib -nostartfiles
|
|
- conftest.c -o conftest 1>&AS_MESSAGE_LOG_FD])
|
|
+ -shared conftest.c -o conftest 1>&AS_MESSAGE_LOG_FD])
|
|
then
|
|
libc_cv_mtls_dialect_gnu2=yes
|
|
else
|