e56f6d3b52
Resolves: RHEL-46725
455 lines
19 KiB
Diff
455 lines
19 KiB
Diff
commit c683ac8520e8064e7be3a22922d80849271290ac
|
|
Author: Maciej W. Rozycki <macro@redhat.com>
|
|
Date: Thu Nov 7 06:14:24 2024 +0000
|
|
|
|
stdio-common: Add tests for formatted sprintf output specifiers
|
|
|
|
Wire sprintf into test infrastructure for formatted printf output
|
|
specifiers.
|
|
|
|
Reviewed-by: DJ Delorie <dj@redhat.com>
|
|
|
|
diff --git a/stdio-common/Makefile b/stdio-common/Makefile
|
|
index 3a812073784fa3b6..7522cd76cc26a3a5 100644
|
|
--- a/stdio-common/Makefile
|
|
+++ b/stdio-common/Makefile
|
|
@@ -23,7 +23,7 @@ subdir := stdio-common
|
|
include ../Makeconfig
|
|
|
|
# List of markers for printf family function tests.
|
|
-xprintf-funcs := p as d f
|
|
+xprintf-funcs := p as d f s
|
|
|
|
# List of data types and formats for individual per-conversion printf tests.
|
|
fmt-convs := double ldouble
|
|
diff --git a/stdio-common/tst-printf-format-s-c.c b/stdio-common/tst-printf-format-s-c.c
|
|
new file mode 100644
|
|
index 0000000000000000..87dad077b9c05216
|
|
--- /dev/null
|
|
+++ b/stdio-common/tst-printf-format-s-c.c
|
|
@@ -0,0 +1,20 @@
|
|
+/* Test for formatted 'sprintf' output for the 'c' conversion.
|
|
+ Copyright (C) 2024 Free Software Foundation, Inc.
|
|
+ This file is part of the GNU C Library.
|
|
+
|
|
+ The GNU C Library is free software; you can redistribute it and/or
|
|
+ modify it under the terms of the GNU Lesser General Public
|
|
+ License as published by the Free Software Foundation; either
|
|
+ version 2.1 of the License, or (at your option) any later version.
|
|
+
|
|
+ The GNU C Library is distributed in the hope that it will be useful,
|
|
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
|
+ Lesser General Public License for more details.
|
|
+
|
|
+ You should have received a copy of the GNU Lesser General Public
|
|
+ License along with the GNU C Library; if not, see
|
|
+ <https://www.gnu.org/licenses/>. */
|
|
+
|
|
+#include "tst-printf-format-s.h"
|
|
+#include "tst-printf-format-skeleton-c.c"
|
|
diff --git a/stdio-common/tst-printf-format-s-char.c b/stdio-common/tst-printf-format-s-char.c
|
|
new file mode 100644
|
|
index 0000000000000000..f67ac94a5dd70cf4
|
|
--- /dev/null
|
|
+++ b/stdio-common/tst-printf-format-s-char.c
|
|
@@ -0,0 +1,20 @@
|
|
+/* Test for formatted 'sprintf' output for signed char conversions.
|
|
+ Copyright (C) 2024 Free Software Foundation, Inc.
|
|
+ This file is part of the GNU C Library.
|
|
+
|
|
+ The GNU C Library is free software; you can redistribute it and/or
|
|
+ modify it under the terms of the GNU Lesser General Public
|
|
+ License as published by the Free Software Foundation; either
|
|
+ version 2.1 of the License, or (at your option) any later version.
|
|
+
|
|
+ The GNU C Library is distributed in the hope that it will be useful,
|
|
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
|
+ Lesser General Public License for more details.
|
|
+
|
|
+ You should have received a copy of the GNU Lesser General Public
|
|
+ License along with the GNU C Library; if not, see
|
|
+ <https://www.gnu.org/licenses/>. */
|
|
+
|
|
+#include "tst-printf-format-s.h"
|
|
+#include "tst-printf-format-skeleton-char.c"
|
|
diff --git a/stdio-common/tst-printf-format-s-double.c b/stdio-common/tst-printf-format-s-double.c
|
|
new file mode 100644
|
|
index 0000000000000000..16186b5dc55eabaf
|
|
--- /dev/null
|
|
+++ b/stdio-common/tst-printf-format-s-double.c
|
|
@@ -0,0 +1,20 @@
|
|
+/* Test for formatted 'sprintf' output for double conversions.
|
|
+ Copyright (C) 2024 Free Software Foundation, Inc.
|
|
+ This file is part of the GNU C Library.
|
|
+
|
|
+ The GNU C Library is free software; you can redistribute it and/or
|
|
+ modify it under the terms of the GNU Lesser General Public
|
|
+ License as published by the Free Software Foundation; either
|
|
+ version 2.1 of the License, or (at your option) any later version.
|
|
+
|
|
+ The GNU C Library is distributed in the hope that it will be useful,
|
|
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
|
+ Lesser General Public License for more details.
|
|
+
|
|
+ You should have received a copy of the GNU Lesser General Public
|
|
+ License along with the GNU C Library; if not, see
|
|
+ <https://www.gnu.org/licenses/>. */
|
|
+
|
|
+#include "tst-printf-format-s.h"
|
|
+#include "tst-printf-format-skeleton-double.c"
|
|
diff --git a/stdio-common/tst-printf-format-s-int.c b/stdio-common/tst-printf-format-s-int.c
|
|
new file mode 100644
|
|
index 0000000000000000..2ed7b2df471cd96d
|
|
--- /dev/null
|
|
+++ b/stdio-common/tst-printf-format-s-int.c
|
|
@@ -0,0 +1,20 @@
|
|
+/* Test for formatted 'sprintf' output for int conversions.
|
|
+ Copyright (C) 2024 Free Software Foundation, Inc.
|
|
+ This file is part of the GNU C Library.
|
|
+
|
|
+ The GNU C Library is free software; you can redistribute it and/or
|
|
+ modify it under the terms of the GNU Lesser General Public
|
|
+ License as published by the Free Software Foundation; either
|
|
+ version 2.1 of the License, or (at your option) any later version.
|
|
+
|
|
+ The GNU C Library is distributed in the hope that it will be useful,
|
|
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
|
+ Lesser General Public License for more details.
|
|
+
|
|
+ You should have received a copy of the GNU Lesser General Public
|
|
+ License along with the GNU C Library; if not, see
|
|
+ <https://www.gnu.org/licenses/>. */
|
|
+
|
|
+#include "tst-printf-format-s.h"
|
|
+#include "tst-printf-format-skeleton-int.c"
|
|
diff --git a/stdio-common/tst-printf-format-s-ldouble.c b/stdio-common/tst-printf-format-s-ldouble.c
|
|
new file mode 100644
|
|
index 0000000000000000..0362cc50f78ffdfa
|
|
--- /dev/null
|
|
+++ b/stdio-common/tst-printf-format-s-ldouble.c
|
|
@@ -0,0 +1,20 @@
|
|
+/* Test for formatted 'sprintf' output for long double conversions.
|
|
+ Copyright (C) 2024 Free Software Foundation, Inc.
|
|
+ This file is part of the GNU C Library.
|
|
+
|
|
+ The GNU C Library is free software; you can redistribute it and/or
|
|
+ modify it under the terms of the GNU Lesser General Public
|
|
+ License as published by the Free Software Foundation; either
|
|
+ version 2.1 of the License, or (at your option) any later version.
|
|
+
|
|
+ The GNU C Library is distributed in the hope that it will be useful,
|
|
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
|
+ Lesser General Public License for more details.
|
|
+
|
|
+ You should have received a copy of the GNU Lesser General Public
|
|
+ License along with the GNU C Library; if not, see
|
|
+ <https://www.gnu.org/licenses/>. */
|
|
+
|
|
+#include "tst-printf-format-s.h"
|
|
+#include "tst-printf-format-skeleton-ldouble.c"
|
|
diff --git a/stdio-common/tst-printf-format-s-llong.c b/stdio-common/tst-printf-format-s-llong.c
|
|
new file mode 100644
|
|
index 0000000000000000..b49f84998a7e7ca2
|
|
--- /dev/null
|
|
+++ b/stdio-common/tst-printf-format-s-llong.c
|
|
@@ -0,0 +1,20 @@
|
|
+/* Test for formatted 'sprintf' output for long long int conversions.
|
|
+ Copyright (C) 2024 Free Software Foundation, Inc.
|
|
+ This file is part of the GNU C Library.
|
|
+
|
|
+ The GNU C Library is free software; you can redistribute it and/or
|
|
+ modify it under the terms of the GNU Lesser General Public
|
|
+ License as published by the Free Software Foundation; either
|
|
+ version 2.1 of the License, or (at your option) any later version.
|
|
+
|
|
+ The GNU C Library is distributed in the hope that it will be useful,
|
|
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
|
+ Lesser General Public License for more details.
|
|
+
|
|
+ You should have received a copy of the GNU Lesser General Public
|
|
+ License along with the GNU C Library; if not, see
|
|
+ <https://www.gnu.org/licenses/>. */
|
|
+
|
|
+#include "tst-printf-format-s.h"
|
|
+#include "tst-printf-format-skeleton-llong.c"
|
|
diff --git a/stdio-common/tst-printf-format-s-long.c b/stdio-common/tst-printf-format-s-long.c
|
|
new file mode 100644
|
|
index 0000000000000000..49224d7f29d7e65c
|
|
--- /dev/null
|
|
+++ b/stdio-common/tst-printf-format-s-long.c
|
|
@@ -0,0 +1,20 @@
|
|
+/* Test for formatted 'sprintf' output for long int conversions.
|
|
+ Copyright (C) 2024 Free Software Foundation, Inc.
|
|
+ This file is part of the GNU C Library.
|
|
+
|
|
+ The GNU C Library is free software; you can redistribute it and/or
|
|
+ modify it under the terms of the GNU Lesser General Public
|
|
+ License as published by the Free Software Foundation; either
|
|
+ version 2.1 of the License, or (at your option) any later version.
|
|
+
|
|
+ The GNU C Library is distributed in the hope that it will be useful,
|
|
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
|
+ Lesser General Public License for more details.
|
|
+
|
|
+ You should have received a copy of the GNU Lesser General Public
|
|
+ License along with the GNU C Library; if not, see
|
|
+ <https://www.gnu.org/licenses/>. */
|
|
+
|
|
+#include "tst-printf-format-s.h"
|
|
+#include "tst-printf-format-skeleton-long.c"
|
|
diff --git a/stdio-common/tst-printf-format-s-s.c b/stdio-common/tst-printf-format-s-s.c
|
|
new file mode 100644
|
|
index 0000000000000000..3a400f8907895db0
|
|
--- /dev/null
|
|
+++ b/stdio-common/tst-printf-format-s-s.c
|
|
@@ -0,0 +1,20 @@
|
|
+/* Test for formatted 'sprintf' output for the 's' conversion.
|
|
+ Copyright (C) 2024 Free Software Foundation, Inc.
|
|
+ This file is part of the GNU C Library.
|
|
+
|
|
+ The GNU C Library is free software; you can redistribute it and/or
|
|
+ modify it under the terms of the GNU Lesser General Public
|
|
+ License as published by the Free Software Foundation; either
|
|
+ version 2.1 of the License, or (at your option) any later version.
|
|
+
|
|
+ The GNU C Library is distributed in the hope that it will be useful,
|
|
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
|
+ Lesser General Public License for more details.
|
|
+
|
|
+ You should have received a copy of the GNU Lesser General Public
|
|
+ License along with the GNU C Library; if not, see
|
|
+ <https://www.gnu.org/licenses/>. */
|
|
+
|
|
+#include "tst-printf-format-s.h"
|
|
+#include "tst-printf-format-skeleton-s.c"
|
|
diff --git a/stdio-common/tst-printf-format-s-short.c b/stdio-common/tst-printf-format-s-short.c
|
|
new file mode 100644
|
|
index 0000000000000000..c98a808cff51c52a
|
|
--- /dev/null
|
|
+++ b/stdio-common/tst-printf-format-s-short.c
|
|
@@ -0,0 +1,20 @@
|
|
+/* Test for formatted 'sprintf' output for short int conversions.
|
|
+ Copyright (C) 2024 Free Software Foundation, Inc.
|
|
+ This file is part of the GNU C Library.
|
|
+
|
|
+ The GNU C Library is free software; you can redistribute it and/or
|
|
+ modify it under the terms of the GNU Lesser General Public
|
|
+ License as published by the Free Software Foundation; either
|
|
+ version 2.1 of the License, or (at your option) any later version.
|
|
+
|
|
+ The GNU C Library is distributed in the hope that it will be useful,
|
|
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
|
+ Lesser General Public License for more details.
|
|
+
|
|
+ You should have received a copy of the GNU Lesser General Public
|
|
+ License along with the GNU C Library; if not, see
|
|
+ <https://www.gnu.org/licenses/>. */
|
|
+
|
|
+#include "tst-printf-format-s.h"
|
|
+#include "tst-printf-format-skeleton-short.c"
|
|
diff --git a/stdio-common/tst-printf-format-s-uchar.c b/stdio-common/tst-printf-format-s-uchar.c
|
|
new file mode 100644
|
|
index 0000000000000000..befc36894975a9a1
|
|
--- /dev/null
|
|
+++ b/stdio-common/tst-printf-format-s-uchar.c
|
|
@@ -0,0 +1,20 @@
|
|
+/* Test for formatted 'sprintf' output for unsigned char conversions.
|
|
+ Copyright (C) 2024 Free Software Foundation, Inc.
|
|
+ This file is part of the GNU C Library.
|
|
+
|
|
+ The GNU C Library is free software; you can redistribute it and/or
|
|
+ modify it under the terms of the GNU Lesser General Public
|
|
+ License as published by the Free Software Foundation; either
|
|
+ version 2.1 of the License, or (at your option) any later version.
|
|
+
|
|
+ The GNU C Library is distributed in the hope that it will be useful,
|
|
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
|
+ Lesser General Public License for more details.
|
|
+
|
|
+ You should have received a copy of the GNU Lesser General Public
|
|
+ License along with the GNU C Library; if not, see
|
|
+ <https://www.gnu.org/licenses/>. */
|
|
+
|
|
+#include "tst-printf-format-s.h"
|
|
+#include "tst-printf-format-skeleton-uchar.c"
|
|
diff --git a/stdio-common/tst-printf-format-s-uint.c b/stdio-common/tst-printf-format-s-uint.c
|
|
new file mode 100644
|
|
index 0000000000000000..f3a4c49632a3be07
|
|
--- /dev/null
|
|
+++ b/stdio-common/tst-printf-format-s-uint.c
|
|
@@ -0,0 +1,20 @@
|
|
+/* Test for formatted 'sprintf' output for unsigned int conversions.
|
|
+ Copyright (C) 2024 Free Software Foundation, Inc.
|
|
+ This file is part of the GNU C Library.
|
|
+
|
|
+ The GNU C Library is free software; you can redistribute it and/or
|
|
+ modify it under the terms of the GNU Lesser General Public
|
|
+ License as published by the Free Software Foundation; either
|
|
+ version 2.1 of the License, or (at your option) any later version.
|
|
+
|
|
+ The GNU C Library is distributed in the hope that it will be useful,
|
|
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
|
+ Lesser General Public License for more details.
|
|
+
|
|
+ You should have received a copy of the GNU Lesser General Public
|
|
+ License along with the GNU C Library; if not, see
|
|
+ <https://www.gnu.org/licenses/>. */
|
|
+
|
|
+#include "tst-printf-format-s.h"
|
|
+#include "tst-printf-format-skeleton-uint.c"
|
|
diff --git a/stdio-common/tst-printf-format-s-ullong.c b/stdio-common/tst-printf-format-s-ullong.c
|
|
new file mode 100644
|
|
index 0000000000000000..4ce559037921e01f
|
|
--- /dev/null
|
|
+++ b/stdio-common/tst-printf-format-s-ullong.c
|
|
@@ -0,0 +1,20 @@
|
|
+/* Test for formatted 'sprintf' output for unsigned long long int conversions.
|
|
+ Copyright (C) 2024 Free Software Foundation, Inc.
|
|
+ This file is part of the GNU C Library.
|
|
+
|
|
+ The GNU C Library is free software; you can redistribute it and/or
|
|
+ modify it under the terms of the GNU Lesser General Public
|
|
+ License as published by the Free Software Foundation; either
|
|
+ version 2.1 of the License, or (at your option) any later version.
|
|
+
|
|
+ The GNU C Library is distributed in the hope that it will be useful,
|
|
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
|
+ Lesser General Public License for more details.
|
|
+
|
|
+ You should have received a copy of the GNU Lesser General Public
|
|
+ License along with the GNU C Library; if not, see
|
|
+ <https://www.gnu.org/licenses/>. */
|
|
+
|
|
+#include "tst-printf-format-s.h"
|
|
+#include "tst-printf-format-skeleton-ullong.c"
|
|
diff --git a/stdio-common/tst-printf-format-s-ulong.c b/stdio-common/tst-printf-format-s-ulong.c
|
|
new file mode 100644
|
|
index 0000000000000000..81f9eea893c194d2
|
|
--- /dev/null
|
|
+++ b/stdio-common/tst-printf-format-s-ulong.c
|
|
@@ -0,0 +1,20 @@
|
|
+/* Test for formatted 'sprintf' output for unsigned long int conversions.
|
|
+ Copyright (C) 2024 Free Software Foundation, Inc.
|
|
+ This file is part of the GNU C Library.
|
|
+
|
|
+ The GNU C Library is free software; you can redistribute it and/or
|
|
+ modify it under the terms of the GNU Lesser General Public
|
|
+ License as published by the Free Software Foundation; either
|
|
+ version 2.1 of the License, or (at your option) any later version.
|
|
+
|
|
+ The GNU C Library is distributed in the hope that it will be useful,
|
|
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
|
+ Lesser General Public License for more details.
|
|
+
|
|
+ You should have received a copy of the GNU Lesser General Public
|
|
+ License along with the GNU C Library; if not, see
|
|
+ <https://www.gnu.org/licenses/>. */
|
|
+
|
|
+#include "tst-printf-format-s.h"
|
|
+#include "tst-printf-format-skeleton-ulong.c"
|
|
diff --git a/stdio-common/tst-printf-format-s-ushort.c b/stdio-common/tst-printf-format-s-ushort.c
|
|
new file mode 100644
|
|
index 0000000000000000..4b1cca6e6cf6b342
|
|
--- /dev/null
|
|
+++ b/stdio-common/tst-printf-format-s-ushort.c
|
|
@@ -0,0 +1,20 @@
|
|
+/* Test for formatted 'sprintf' output for unsigned short int conversions.
|
|
+ Copyright (C) 2024 Free Software Foundation, Inc.
|
|
+ This file is part of the GNU C Library.
|
|
+
|
|
+ The GNU C Library is free software; you can redistribute it and/or
|
|
+ modify it under the terms of the GNU Lesser General Public
|
|
+ License as published by the Free Software Foundation; either
|
|
+ version 2.1 of the License, or (at your option) any later version.
|
|
+
|
|
+ The GNU C Library is distributed in the hope that it will be useful,
|
|
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
|
+ Lesser General Public License for more details.
|
|
+
|
|
+ You should have received a copy of the GNU Lesser General Public
|
|
+ License along with the GNU C Library; if not, see
|
|
+ <https://www.gnu.org/licenses/>. */
|
|
+
|
|
+#include "tst-printf-format-s.h"
|
|
+#include "tst-printf-format-skeleton-ushort.c"
|
|
diff --git a/stdio-common/tst-printf-format-s.h b/stdio-common/tst-printf-format-s.h
|
|
new file mode 100644
|
|
index 0000000000000000..7d1e72cffb7b20fb
|
|
--- /dev/null
|
|
+++ b/stdio-common/tst-printf-format-s.h
|
|
@@ -0,0 +1,60 @@
|
|
+/* Test feature wrapper for formatted 'sprintf' output.
|
|
+ Copyright (C) 2024 Free Software Foundation, Inc.
|
|
+ This file is part of the GNU C Library.
|
|
+
|
|
+ The GNU C Library is free software; you can redistribute it and/or
|
|
+ modify it under the terms of the GNU Lesser General Public
|
|
+ License as published by the Free Software Foundation; either
|
|
+ version 2.1 of the License, or (at your option) any later version.
|
|
+
|
|
+ The GNU C Library is distributed in the hope that it will be useful,
|
|
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
|
+ Lesser General Public License for more details.
|
|
+
|
|
+ You should have received a copy of the GNU Lesser General Public
|
|
+ License along with the GNU C Library; if not, see
|
|
+ <https://www.gnu.org/licenses/>. */
|
|
+
|
|
+#include <stdio.h>
|
|
+#include <stdlib.h>
|
|
+
|
|
+#include <support/next_to_fault.h>
|
|
+
|
|
+#define SPRINTF_BUFFER_SIZE 65536
|
|
+
|
|
+static struct support_next_to_fault ntf;
|
|
+
|
|
+#define PREPARE printf_under_test_init
|
|
+static void
|
|
+printf_under_test_init (int argc, char **argv)
|
|
+{
|
|
+ ntf = support_next_to_fault_allocate (SPRINTF_BUFFER_SIZE);
|
|
+}
|
|
+
|
|
+static void __attribute__ ((destructor))
|
|
+printf_under_test_fini (void)
|
|
+{
|
|
+ support_next_to_fault_free (&ntf);
|
|
+}
|
|
+
|
|
+#define printf_under_test(...) \
|
|
+({ \
|
|
+ __label__ out; \
|
|
+ char *str = ntf.buffer; \
|
|
+ int result; \
|
|
+ \
|
|
+ result = sprintf (str, __VA_ARGS__); \
|
|
+ if (result < 0) \
|
|
+ { \
|
|
+ perror ("sprintf"); \
|
|
+ goto out; \
|
|
+ } \
|
|
+ if (fwrite (str, sizeof (*str), result, stdout) != result) \
|
|
+ { \
|
|
+ perror ("fwrite"); \
|
|
+ result = -1; \
|
|
+ } \
|
|
+out: \
|
|
+ result; \
|
|
+})
|