e56f6d3b52
Resolves: RHEL-46725
424 lines
18 KiB
Diff
424 lines
18 KiB
Diff
commit 1dc5cdc3da19e10d47e50a5ea2ea3ce62ee2fa82
|
|
Author: Maciej W. Rozycki <macro@redhat.com>
|
|
Date: Thu Nov 7 06:14:24 2024 +0000
|
|
|
|
stdio-common: Add tests for formatted fprintf output specifiers
|
|
|
|
Wire fprintf into test infrastructure for formatted printf output
|
|
specifiers.
|
|
|
|
Reviewed-by: DJ Delorie <dj@redhat.com>
|
|
|
|
diff --git a/stdio-common/Makefile b/stdio-common/Makefile
|
|
index 2bc830597085678a..3a812073784fa3b6 100644
|
|
--- a/stdio-common/Makefile
|
|
+++ b/stdio-common/Makefile
|
|
@@ -23,7 +23,7 @@ subdir := stdio-common
|
|
include ../Makeconfig
|
|
|
|
# List of markers for printf family function tests.
|
|
-xprintf-funcs := p as d
|
|
+xprintf-funcs := p as d f
|
|
|
|
# List of data types and formats for individual per-conversion printf tests.
|
|
fmt-convs := double ldouble
|
|
diff --git a/stdio-common/tst-printf-format-f-c.c b/stdio-common/tst-printf-format-f-c.c
|
|
new file mode 100644
|
|
index 0000000000000000..1db9e2b5f3bb2d32
|
|
--- /dev/null
|
|
+++ b/stdio-common/tst-printf-format-f-c.c
|
|
@@ -0,0 +1,20 @@
|
|
+/* Test for formatted 'fprintf' output for the 'c' conversion.
|
|
+ Copyright (C) 2024 Free Software Foundation, Inc.
|
|
+ This file is part of the GNU C Library.
|
|
+
|
|
+ The GNU C Library is free software; you can redistribute it and/or
|
|
+ modify it under the terms of the GNU Lesser General Public
|
|
+ License as published by the Free Software Foundation; either
|
|
+ version 2.1 of the License, or (at your option) any later version.
|
|
+
|
|
+ The GNU C Library is distributed in the hope that it will be useful,
|
|
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
|
+ Lesser General Public License for more details.
|
|
+
|
|
+ You should have received a copy of the GNU Lesser General Public
|
|
+ License along with the GNU C Library; if not, see
|
|
+ <https://www.gnu.org/licenses/>. */
|
|
+
|
|
+#include "tst-printf-format-f.h"
|
|
+#include "tst-printf-format-skeleton-c.c"
|
|
diff --git a/stdio-common/tst-printf-format-f-char.c b/stdio-common/tst-printf-format-f-char.c
|
|
new file mode 100644
|
|
index 0000000000000000..a492f318620bc82e
|
|
--- /dev/null
|
|
+++ b/stdio-common/tst-printf-format-f-char.c
|
|
@@ -0,0 +1,20 @@
|
|
+/* Test for formatted 'fprintf' output for signed char conversions.
|
|
+ Copyright (C) 2024 Free Software Foundation, Inc.
|
|
+ This file is part of the GNU C Library.
|
|
+
|
|
+ The GNU C Library is free software; you can redistribute it and/or
|
|
+ modify it under the terms of the GNU Lesser General Public
|
|
+ License as published by the Free Software Foundation; either
|
|
+ version 2.1 of the License, or (at your option) any later version.
|
|
+
|
|
+ The GNU C Library is distributed in the hope that it will be useful,
|
|
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
|
+ Lesser General Public License for more details.
|
|
+
|
|
+ You should have received a copy of the GNU Lesser General Public
|
|
+ License along with the GNU C Library; if not, see
|
|
+ <https://www.gnu.org/licenses/>. */
|
|
+
|
|
+#include "tst-printf-format-f.h"
|
|
+#include "tst-printf-format-skeleton-char.c"
|
|
diff --git a/stdio-common/tst-printf-format-f-double.c b/stdio-common/tst-printf-format-f-double.c
|
|
new file mode 100644
|
|
index 0000000000000000..906ef0b90b9e7d1d
|
|
--- /dev/null
|
|
+++ b/stdio-common/tst-printf-format-f-double.c
|
|
@@ -0,0 +1,20 @@
|
|
+/* Test for formatted 'fprintf' output for double conversions.
|
|
+ Copyright (C) 2024 Free Software Foundation, Inc.
|
|
+ This file is part of the GNU C Library.
|
|
+
|
|
+ The GNU C Library is free software; you can redistribute it and/or
|
|
+ modify it under the terms of the GNU Lesser General Public
|
|
+ License as published by the Free Software Foundation; either
|
|
+ version 2.1 of the License, or (at your option) any later version.
|
|
+
|
|
+ The GNU C Library is distributed in the hope that it will be useful,
|
|
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
|
+ Lesser General Public License for more details.
|
|
+
|
|
+ You should have received a copy of the GNU Lesser General Public
|
|
+ License along with the GNU C Library; if not, see
|
|
+ <https://www.gnu.org/licenses/>. */
|
|
+
|
|
+#include "tst-printf-format-f.h"
|
|
+#include "tst-printf-format-skeleton-double.c"
|
|
diff --git a/stdio-common/tst-printf-format-f-int.c b/stdio-common/tst-printf-format-f-int.c
|
|
new file mode 100644
|
|
index 0000000000000000..92dc0c919771ae26
|
|
--- /dev/null
|
|
+++ b/stdio-common/tst-printf-format-f-int.c
|
|
@@ -0,0 +1,20 @@
|
|
+/* Test for formatted 'fprintf' output for int conversions.
|
|
+ Copyright (C) 2024 Free Software Foundation, Inc.
|
|
+ This file is part of the GNU C Library.
|
|
+
|
|
+ The GNU C Library is free software; you can redistribute it and/or
|
|
+ modify it under the terms of the GNU Lesser General Public
|
|
+ License as published by the Free Software Foundation; either
|
|
+ version 2.1 of the License, or (at your option) any later version.
|
|
+
|
|
+ The GNU C Library is distributed in the hope that it will be useful,
|
|
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
|
+ Lesser General Public License for more details.
|
|
+
|
|
+ You should have received a copy of the GNU Lesser General Public
|
|
+ License along with the GNU C Library; if not, see
|
|
+ <https://www.gnu.org/licenses/>. */
|
|
+
|
|
+#include "tst-printf-format-f.h"
|
|
+#include "tst-printf-format-skeleton-int.c"
|
|
diff --git a/stdio-common/tst-printf-format-f-ldouble.c b/stdio-common/tst-printf-format-f-ldouble.c
|
|
new file mode 100644
|
|
index 0000000000000000..0a0c88d64c873061
|
|
--- /dev/null
|
|
+++ b/stdio-common/tst-printf-format-f-ldouble.c
|
|
@@ -0,0 +1,20 @@
|
|
+/* Test for formatted 'fprintf' output for long double conversions.
|
|
+ Copyright (C) 2024 Free Software Foundation, Inc.
|
|
+ This file is part of the GNU C Library.
|
|
+
|
|
+ The GNU C Library is free software; you can redistribute it and/or
|
|
+ modify it under the terms of the GNU Lesser General Public
|
|
+ License as published by the Free Software Foundation; either
|
|
+ version 2.1 of the License, or (at your option) any later version.
|
|
+
|
|
+ The GNU C Library is distributed in the hope that it will be useful,
|
|
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
|
+ Lesser General Public License for more details.
|
|
+
|
|
+ You should have received a copy of the GNU Lesser General Public
|
|
+ License along with the GNU C Library; if not, see
|
|
+ <https://www.gnu.org/licenses/>. */
|
|
+
|
|
+#include "tst-printf-format-f.h"
|
|
+#include "tst-printf-format-skeleton-ldouble.c"
|
|
diff --git a/stdio-common/tst-printf-format-f-llong.c b/stdio-common/tst-printf-format-f-llong.c
|
|
new file mode 100644
|
|
index 0000000000000000..ceb8d035faaf0a12
|
|
--- /dev/null
|
|
+++ b/stdio-common/tst-printf-format-f-llong.c
|
|
@@ -0,0 +1,20 @@
|
|
+/* Test for formatted 'fprintf' output for long long int conversions.
|
|
+ Copyright (C) 2024 Free Software Foundation, Inc.
|
|
+ This file is part of the GNU C Library.
|
|
+
|
|
+ The GNU C Library is free software; you can redistribute it and/or
|
|
+ modify it under the terms of the GNU Lesser General Public
|
|
+ License as published by the Free Software Foundation; either
|
|
+ version 2.1 of the License, or (at your option) any later version.
|
|
+
|
|
+ The GNU C Library is distributed in the hope that it will be useful,
|
|
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
|
+ Lesser General Public License for more details.
|
|
+
|
|
+ You should have received a copy of the GNU Lesser General Public
|
|
+ License along with the GNU C Library; if not, see
|
|
+ <https://www.gnu.org/licenses/>. */
|
|
+
|
|
+#include "tst-printf-format-f.h"
|
|
+#include "tst-printf-format-skeleton-llong.c"
|
|
diff --git a/stdio-common/tst-printf-format-f-long.c b/stdio-common/tst-printf-format-f-long.c
|
|
new file mode 100644
|
|
index 0000000000000000..a4a5dca5ebd7b3a4
|
|
--- /dev/null
|
|
+++ b/stdio-common/tst-printf-format-f-long.c
|
|
@@ -0,0 +1,20 @@
|
|
+/* Test for formatted 'fprintf' output for long int conversions.
|
|
+ Copyright (C) 2024 Free Software Foundation, Inc.
|
|
+ This file is part of the GNU C Library.
|
|
+
|
|
+ The GNU C Library is free software; you can redistribute it and/or
|
|
+ modify it under the terms of the GNU Lesser General Public
|
|
+ License as published by the Free Software Foundation; either
|
|
+ version 2.1 of the License, or (at your option) any later version.
|
|
+
|
|
+ The GNU C Library is distributed in the hope that it will be useful,
|
|
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
|
+ Lesser General Public License for more details.
|
|
+
|
|
+ You should have received a copy of the GNU Lesser General Public
|
|
+ License along with the GNU C Library; if not, see
|
|
+ <https://www.gnu.org/licenses/>. */
|
|
+
|
|
+#include "tst-printf-format-f.h"
|
|
+#include "tst-printf-format-skeleton-long.c"
|
|
diff --git a/stdio-common/tst-printf-format-f-s.c b/stdio-common/tst-printf-format-f-s.c
|
|
new file mode 100644
|
|
index 0000000000000000..da0e0f8bacab6992
|
|
--- /dev/null
|
|
+++ b/stdio-common/tst-printf-format-f-s.c
|
|
@@ -0,0 +1,20 @@
|
|
+/* Test for formatted 'fprintf' output for the 's' conversion.
|
|
+ Copyright (C) 2024 Free Software Foundation, Inc.
|
|
+ This file is part of the GNU C Library.
|
|
+
|
|
+ The GNU C Library is free software; you can redistribute it and/or
|
|
+ modify it under the terms of the GNU Lesser General Public
|
|
+ License as published by the Free Software Foundation; either
|
|
+ version 2.1 of the License, or (at your option) any later version.
|
|
+
|
|
+ The GNU C Library is distributed in the hope that it will be useful,
|
|
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
|
+ Lesser General Public License for more details.
|
|
+
|
|
+ You should have received a copy of the GNU Lesser General Public
|
|
+ License along with the GNU C Library; if not, see
|
|
+ <https://www.gnu.org/licenses/>. */
|
|
+
|
|
+#include "tst-printf-format-f.h"
|
|
+#include "tst-printf-format-skeleton-s.c"
|
|
diff --git a/stdio-common/tst-printf-format-f-short.c b/stdio-common/tst-printf-format-f-short.c
|
|
new file mode 100644
|
|
index 0000000000000000..3abd134d0aeeef87
|
|
--- /dev/null
|
|
+++ b/stdio-common/tst-printf-format-f-short.c
|
|
@@ -0,0 +1,20 @@
|
|
+/* Test for formatted 'fprintf' output for short int conversions.
|
|
+ Copyright (C) 2024 Free Software Foundation, Inc.
|
|
+ This file is part of the GNU C Library.
|
|
+
|
|
+ The GNU C Library is free software; you can redistribute it and/or
|
|
+ modify it under the terms of the GNU Lesser General Public
|
|
+ License as published by the Free Software Foundation; either
|
|
+ version 2.1 of the License, or (at your option) any later version.
|
|
+
|
|
+ The GNU C Library is distributed in the hope that it will be useful,
|
|
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
|
+ Lesser General Public License for more details.
|
|
+
|
|
+ You should have received a copy of the GNU Lesser General Public
|
|
+ License along with the GNU C Library; if not, see
|
|
+ <https://www.gnu.org/licenses/>. */
|
|
+
|
|
+#include "tst-printf-format-f.h"
|
|
+#include "tst-printf-format-skeleton-short.c"
|
|
diff --git a/stdio-common/tst-printf-format-f-uchar.c b/stdio-common/tst-printf-format-f-uchar.c
|
|
new file mode 100644
|
|
index 0000000000000000..f104cde37b322b60
|
|
--- /dev/null
|
|
+++ b/stdio-common/tst-printf-format-f-uchar.c
|
|
@@ -0,0 +1,20 @@
|
|
+/* Test for formatted 'fprintf' output for unsigned char conversions.
|
|
+ Copyright (C) 2024 Free Software Foundation, Inc.
|
|
+ This file is part of the GNU C Library.
|
|
+
|
|
+ The GNU C Library is free software; you can redistribute it and/or
|
|
+ modify it under the terms of the GNU Lesser General Public
|
|
+ License as published by the Free Software Foundation; either
|
|
+ version 2.1 of the License, or (at your option) any later version.
|
|
+
|
|
+ The GNU C Library is distributed in the hope that it will be useful,
|
|
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
|
+ Lesser General Public License for more details.
|
|
+
|
|
+ You should have received a copy of the GNU Lesser General Public
|
|
+ License along with the GNU C Library; if not, see
|
|
+ <https://www.gnu.org/licenses/>. */
|
|
+
|
|
+#include "tst-printf-format-f.h"
|
|
+#include "tst-printf-format-skeleton-uchar.c"
|
|
diff --git a/stdio-common/tst-printf-format-f-uint.c b/stdio-common/tst-printf-format-f-uint.c
|
|
new file mode 100644
|
|
index 0000000000000000..0e1fdb4b367032a2
|
|
--- /dev/null
|
|
+++ b/stdio-common/tst-printf-format-f-uint.c
|
|
@@ -0,0 +1,20 @@
|
|
+/* Test for formatted 'fprintf' output for unsigned int conversions.
|
|
+ Copyright (C) 2024 Free Software Foundation, Inc.
|
|
+ This file is part of the GNU C Library.
|
|
+
|
|
+ The GNU C Library is free software; you can redistribute it and/or
|
|
+ modify it under the terms of the GNU Lesser General Public
|
|
+ License as published by the Free Software Foundation; either
|
|
+ version 2.1 of the License, or (at your option) any later version.
|
|
+
|
|
+ The GNU C Library is distributed in the hope that it will be useful,
|
|
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
|
+ Lesser General Public License for more details.
|
|
+
|
|
+ You should have received a copy of the GNU Lesser General Public
|
|
+ License along with the GNU C Library; if not, see
|
|
+ <https://www.gnu.org/licenses/>. */
|
|
+
|
|
+#include "tst-printf-format-f.h"
|
|
+#include "tst-printf-format-skeleton-uint.c"
|
|
diff --git a/stdio-common/tst-printf-format-f-ullong.c b/stdio-common/tst-printf-format-f-ullong.c
|
|
new file mode 100644
|
|
index 0000000000000000..b4669fcbb7dd3282
|
|
--- /dev/null
|
|
+++ b/stdio-common/tst-printf-format-f-ullong.c
|
|
@@ -0,0 +1,20 @@
|
|
+/* Test for formatted 'fprintf' output for unsigned long long int conversions.
|
|
+ Copyright (C) 2024 Free Software Foundation, Inc.
|
|
+ This file is part of the GNU C Library.
|
|
+
|
|
+ The GNU C Library is free software; you can redistribute it and/or
|
|
+ modify it under the terms of the GNU Lesser General Public
|
|
+ License as published by the Free Software Foundation; either
|
|
+ version 2.1 of the License, or (at your option) any later version.
|
|
+
|
|
+ The GNU C Library is distributed in the hope that it will be useful,
|
|
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
|
+ Lesser General Public License for more details.
|
|
+
|
|
+ You should have received a copy of the GNU Lesser General Public
|
|
+ License along with the GNU C Library; if not, see
|
|
+ <https://www.gnu.org/licenses/>. */
|
|
+
|
|
+#include "tst-printf-format-f.h"
|
|
+#include "tst-printf-format-skeleton-ullong.c"
|
|
diff --git a/stdio-common/tst-printf-format-f-ulong.c b/stdio-common/tst-printf-format-f-ulong.c
|
|
new file mode 100644
|
|
index 0000000000000000..3f4f900362a153b5
|
|
--- /dev/null
|
|
+++ b/stdio-common/tst-printf-format-f-ulong.c
|
|
@@ -0,0 +1,20 @@
|
|
+/* Test for formatted 'fprintf' output for unsigned long int conversions.
|
|
+ Copyright (C) 2024 Free Software Foundation, Inc.
|
|
+ This file is part of the GNU C Library.
|
|
+
|
|
+ The GNU C Library is free software; you can redistribute it and/or
|
|
+ modify it under the terms of the GNU Lesser General Public
|
|
+ License as published by the Free Software Foundation; either
|
|
+ version 2.1 of the License, or (at your option) any later version.
|
|
+
|
|
+ The GNU C Library is distributed in the hope that it will be useful,
|
|
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
|
+ Lesser General Public License for more details.
|
|
+
|
|
+ You should have received a copy of the GNU Lesser General Public
|
|
+ License along with the GNU C Library; if not, see
|
|
+ <https://www.gnu.org/licenses/>. */
|
|
+
|
|
+#include "tst-printf-format-f.h"
|
|
+#include "tst-printf-format-skeleton-ulong.c"
|
|
diff --git a/stdio-common/tst-printf-format-f-ushort.c b/stdio-common/tst-printf-format-f-ushort.c
|
|
new file mode 100644
|
|
index 0000000000000000..d49c2371403e20a6
|
|
--- /dev/null
|
|
+++ b/stdio-common/tst-printf-format-f-ushort.c
|
|
@@ -0,0 +1,20 @@
|
|
+/* Test for formatted 'fprintf' output for unsigned short int conversions.
|
|
+ Copyright (C) 2024 Free Software Foundation, Inc.
|
|
+ This file is part of the GNU C Library.
|
|
+
|
|
+ The GNU C Library is free software; you can redistribute it and/or
|
|
+ modify it under the terms of the GNU Lesser General Public
|
|
+ License as published by the Free Software Foundation; either
|
|
+ version 2.1 of the License, or (at your option) any later version.
|
|
+
|
|
+ The GNU C Library is distributed in the hope that it will be useful,
|
|
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
|
+ Lesser General Public License for more details.
|
|
+
|
|
+ You should have received a copy of the GNU Lesser General Public
|
|
+ License along with the GNU C Library; if not, see
|
|
+ <https://www.gnu.org/licenses/>. */
|
|
+
|
|
+#include "tst-printf-format-f.h"
|
|
+#include "tst-printf-format-skeleton-ushort.c"
|
|
diff --git a/stdio-common/tst-printf-format-f.h b/stdio-common/tst-printf-format-f.h
|
|
new file mode 100644
|
|
index 0000000000000000..efb3283a032f44a7
|
|
--- /dev/null
|
|
+++ b/stdio-common/tst-printf-format-f.h
|
|
@@ -0,0 +1,29 @@
|
|
+/* Test feature wrapper for formatted 'fprintf' output.
|
|
+ Copyright (C) 2024 Free Software Foundation, Inc.
|
|
+ This file is part of the GNU C Library.
|
|
+
|
|
+ The GNU C Library is free software; you can redistribute it and/or
|
|
+ modify it under the terms of the GNU Lesser General Public
|
|
+ License as published by the Free Software Foundation; either
|
|
+ version 2.1 of the License, or (at your option) any later version.
|
|
+
|
|
+ The GNU C Library is distributed in the hope that it will be useful,
|
|
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
|
+ Lesser General Public License for more details.
|
|
+
|
|
+ You should have received a copy of the GNU Lesser General Public
|
|
+ License along with the GNU C Library; if not, see
|
|
+ <https://www.gnu.org/licenses/>. */
|
|
+
|
|
+#include <stdio.h>
|
|
+
|
|
+#define printf_under_test(...) \
|
|
+({ \
|
|
+ int result; \
|
|
+ \
|
|
+ result = fprintf (stdout, __VA_ARGS__); \
|
|
+ if (result < 0) \
|
|
+ perror ("fprintf"); \
|
|
+ result; \
|
|
+})
|