Ignore link-local IPV6 addresses for AI_ADDRCONFIG (#697149)
This commit is contained in:
parent
817ee79b35
commit
fc9b7c8869
14
glibc-rh697149.patch
Normal file
14
glibc-rh697149.patch
Normal file
@ -0,0 +1,14 @@
|
||||
diff -rup a/sysdeps/unix/sysv/linux/check_pf.c b/sysdeps/unix/sysv/linux/check_pf.c
|
||||
--- a/sysdeps/unix/sysv/linux/check_pf.c 2012-02-16 22:51:17.148797741 -0700
|
||||
+++ b/sysdeps/unix/sysv/linux/check_pf.c 2012-02-17 10:55:26.513139941 -0700
|
||||
@@ -209,7 +209,8 @@ make_request (int fd, pid_t pid)
|
||||
}
|
||||
else
|
||||
{
|
||||
- if (!IN6_IS_ADDR_LOOPBACK (address))
|
||||
+ if (!IN6_IS_ADDR_LOOPBACK (address)
|
||||
+ && !IN6_IS_ADDR_LINKLOCAL (address))
|
||||
seen_ipv6 = true;
|
||||
}
|
||||
}
|
||||
Only in b/sysdeps/x86_64: .dl-trampoline.S.swp
|
12
glibc.spec
12
glibc.spec
@ -28,7 +28,7 @@
|
||||
Summary: The GNU libc libraries
|
||||
Name: glibc
|
||||
Version: %{glibcversion}
|
||||
Release: 19%{?dist}
|
||||
Release: 20%{?dist}
|
||||
# GPLv2+ is used in a bunch of programs, LGPLv2+ is used for libraries.
|
||||
# Things that are linked directly into dynamically linked programs
|
||||
# and shared libraries (e.g. crt files, lib*_nonshared.a) have an additional
|
||||
@ -86,12 +86,16 @@ Patch25: %{name}-rh789209.patch
|
||||
Patch26: %{name}-rh624296.patch
|
||||
# Needs to be sent upstream
|
||||
Patch27: %{name}-rh564528.patch
|
||||
# All three have been sent upstream
|
||||
# Submitted upstream BZ 13604
|
||||
Patch28: %{name}-rh790292.patch
|
||||
# Submitted upstream BZ 13603
|
||||
Patch29: %{name}-rh790298.patch
|
||||
# Submitted upstream BZ 13698
|
||||
Patch30: %{name}-rh791161.patch
|
||||
# Aurelien submitted upstream, Uli has largely ignored
|
||||
Patch31 : %{name}-rh730856.patch
|
||||
# Submitted upstream BZ 12377
|
||||
Patch32 : %{name}-rh697149.patch
|
||||
|
||||
|
||||
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
@ -342,6 +346,7 @@ rm -rf %{glibcportsdir}
|
||||
%patch29 -p1
|
||||
%patch30 -p1
|
||||
%patch31 -p1
|
||||
%patch32 -p1
|
||||
|
||||
# A lot of programs still misuse memcpy when they have to use
|
||||
# memmove. The memcpy implementation below is not tolerant at
|
||||
@ -1194,6 +1199,9 @@ rm -f *.filelist*
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Fri Feb 17 2012 Jeff Law <law@redhat.com> - 2.15-20
|
||||
- Ignore link-local IPV6 addresses for AI_ADDRCONFIG (#697149)
|
||||
|
||||
* Fri Feb 17 2012 Jeff Law <law@redhat.com> - 2.15-19
|
||||
- Fix reply buffer mismanagement in resolver (#730856)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user