Merge branch 'f16'
Conflicts: glibc.spec
This commit is contained in:
commit
f0d2fdc7e8
33
glibc-fdelt.patch
Normal file
33
glibc-fdelt.patch
Normal file
@ -0,0 +1,33 @@
|
||||
commit d4cc29a254db6bd3838aac79d9d0e91cfd467c9d
|
||||
Author: Andreas Schwab <schwab@redhat.com>
|
||||
Date: Fri Dec 2 11:34:28 2011 +0100
|
||||
|
||||
Mark fortified __FD_ELT as extension
|
||||
|
||||
diff --git a/ChangeLog b/ChangeLog
|
||||
index dddb628..e512bbb 100644
|
||||
--- a/ChangeLog
|
||||
+++ b/ChangeLog
|
||||
@@ -1,3 +1,8 @@
|
||||
+2011-12-02 Andreas Schwab <schwab@redhat.com>
|
||||
+
|
||||
+ * misc/bits/select2.h (__FD_ELT): Mark as extension. Add
|
||||
+ parenthesis.
|
||||
+
|
||||
2011-11-29 Andreas Schwab <schwab@redhat.com>
|
||||
|
||||
* locale/weight.h (findidx): Add parameter len.
|
||||
diff --git a/misc/bits/select2.h b/misc/bits/select2.h
|
||||
index 37c4827..a7ce1b4 100644
|
||||
--- a/misc/bits/select2.h
|
||||
+++ b/misc/bits/select2.h
|
||||
@@ -27,7 +27,8 @@ extern unsigned long int __fdelt_warn (unsigned long int __d)
|
||||
__warnattr ("bit outside of fd_set selected");
|
||||
#undef __FD_ELT
|
||||
#define __FD_ELT(d) \
|
||||
- ({ unsigned long int __d = d; \
|
||||
+ __extension__ \
|
||||
+ ({ unsigned long int __d = (d); \
|
||||
(__builtin_constant_p (__d) \
|
||||
? (__d >= __FD_SETSIZE \
|
||||
? __fdelt_warn (__d) : (__d / __NFDBITS)) \
|
13
glibc-rh708455.patch
Normal file
13
glibc-rh708455.patch
Normal file
@ -0,0 +1,13 @@
|
||||
diff --git a/manual/resource.texi b/manual/resource.texi
|
||||
index 0549572..8e3155c 100644
|
||||
--- a/manual/resource.texi
|
||||
+++ b/manual/resource.texi
|
||||
@@ -1607,7 +1607,7 @@ processors and so the call
|
||||
@end smallexample
|
||||
|
||||
@noindent
|
||||
-returns the number of processors which are currently inline (i.e.,
|
||||
+returns the number of processors which are currently online (i.e.,
|
||||
available).
|
||||
|
||||
For these two pieces of information the GNU C library also provides
|
29
glibc-rh750811.patch
Normal file
29
glibc-rh750811.patch
Normal file
@ -0,0 +1,29 @@
|
||||
commit 850fb039cec802072f70ed9763927881bbbf639c
|
||||
Author: Andreas Schwab <schwab@linux-m68k.org>
|
||||
Date: Tue Dec 6 11:10:06 2011 +0100
|
||||
|
||||
Fix a wrong constant in powerpc hypot implementation
|
||||
|
||||
--- a/ChangeLog 2011-12-05 20:28:47.000000000 -0700
|
||||
+++ b/ChangeLog 2011-12-07 13:14:29.619858242 -0700
|
||||
@@ -1,3 +1,7 @@
|
||||
+2011-12-06 Andreas Schwab <schwab@linux-m68k.org>
|
||||
+
|
||||
+ * sysdeps/powerpc/fpu/e_hypot.c (twoM600): Correct value.
|
||||
+
|
||||
2011-12-02 Andreas Schwab <schwab@redhat.com>
|
||||
|
||||
* misc/bits/select2.h (__FD_ELT): Mark as extension. Add
|
||||
diff --git a/sysdeps/powerpc/fpu/e_hypot.c b/sysdeps/powerpc/fpu/e_hypot.c
|
||||
index a8d67d8..3731c58 100644
|
||||
--- a/sysdeps/powerpc/fpu/e_hypot.c
|
||||
+++ b/sysdeps/powerpc/fpu/e_hypot.c
|
||||
@@ -26,7 +26,7 @@ static const double two500 = 3.2733906078961419e+150;
|
||||
static const double two600 = 4.149515568880993e+180;
|
||||
static const double two1022 = 4.49423283715579e+307;
|
||||
static const double twoM500 = 3.054936363499605e-151;
|
||||
-static const double twoM600 = 4.616489308892868e-128;
|
||||
+static const double twoM600 = 2.4099198651028841e-181;
|
||||
static const double pdnum = 2.225073858507201e-308;
|
||||
|
||||
/* __ieee754_hypot(x,y)
|
20
glibc.spec
20
glibc.spec
@ -28,7 +28,7 @@
|
||||
Summary: The GNU libc libraries
|
||||
Name: glibc
|
||||
Version: %{glibcversion}
|
||||
Release: 21%{?dist}
|
||||
Release: 23%{?dist}
|
||||
# GPLv2+ is used in a bunch of programs, LGPLv2+ is used for libraries.
|
||||
# Things that are linked directly into dynamically linked programs
|
||||
# and shared libraries (e.g. crt files, lib*_nonshared.a) have an additional
|
||||
@ -48,6 +48,10 @@ Patch4: %{name}-arenalock.patch
|
||||
Patch5: %{name}-rh757881.patch
|
||||
Patch6: %{name}-rh750858.patch
|
||||
Patch7: %{name}-rh757887.patch
|
||||
Patch8: %{name}-fdelt.patch
|
||||
Patch9: %{name}-rh708455.patch
|
||||
Patch10: %{name}-rh750811.patch
|
||||
Patch11: %{name}-rh758252.patch
|
||||
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
Obsoletes: glibc-profile < 2.4
|
||||
Obsoletes: nss_db
|
||||
@ -272,6 +276,10 @@ rm -rf %{glibcportsdir}
|
||||
%patch5 -p1
|
||||
%patch6 -p1
|
||||
%patch7 -p1
|
||||
%patch8 -p1
|
||||
%patch9 -p1
|
||||
%patch10 -p1
|
||||
%patch11 -p1
|
||||
|
||||
# A lot of programs still misuse memcpy when they have to use
|
||||
# memmove. The memcpy implementation below is not tolerant at
|
||||
@ -1124,6 +1132,16 @@ rm -f *.filelist*
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Wed Dec 7 2011 Jeff Law <law@redhat.com> - 2.14.90-23
|
||||
- Fix a wrong constant in powerpc hypot implementation (#750811)
|
||||
#13534 in python bug database
|
||||
#13472 in glibc bug database
|
||||
- Truncate time values in Linux futimes when falling back to utime
|
||||
|
||||
* Mon Dec 5 2011 Jeff Law <law@redhat.com> - 2.14.90-22
|
||||
- Mark fortified __FD_ELT as extension
|
||||
- Fix typo in manual (#708455)
|
||||
|
||||
* Wed Nov 30 2011 Jeff Law <law@redhat.com> - 2.14.90-21
|
||||
- Don't fail in makedb if SELinux is disabled (#750858)
|
||||
- Fix access after end of search string in regex matcher (#757887)
|
||||
|
Loading…
Reference in New Issue
Block a user