Auto-sync with upstream branch master
Upstream commit: cc47d5c5f53f6d845ac54698ae8929af15662c44 - Linux: Use built-in system call tables - lv_LV locale: Correct the time part of d_t_fmt (swbz#25324) - km_KH locale: Use "%M" instead of "m" in d_t_fmt (swbz#25323) - ldbl-128ibm-compat: Do not mix -mabi=*longdouble and -mlong-double-128 - ldbl-128ibm-compat: Compiler flags for stdio functions - Do not redirect calls to __GI_* symbols, when redirecting to *ieee128 - aarch64: add default memcpy version for kunpeng920 - aarch64: ifunc rename for kunpeng - aarch64: Modify error-shown comments for strcpy - linux: Consolidate sigprocmask - Fix return code for __libc_signal_* functions - nptl: Remove duplicate internal __SIZEOF_PTHREAD_MUTEX_T (swbz#25241)
This commit is contained in:
parent
53b7c46841
commit
ee01264a30
@ -9,32 +9,32 @@ python3 during a transitional phase.
|
||||
Author: Carlos O'Donell <carlos@redhat.com>
|
||||
|
||||
diff --git a/benchtests/scripts/compare_bench.py b/benchtests/scripts/compare_bench.py
|
||||
index c1c438a1c9f0eae6..b7d3d7bcee87969d 100755
|
||||
index a215ebc9bd92ba73..f174161ed3147e03 100755
|
||||
--- a/benchtests/scripts/compare_bench.py
|
||||
+++ b/benchtests/scripts/compare_bench.py
|
||||
@@ -1,4 +1,4 @@
|
||||
-#!/usr/bin/python
|
||||
+#!/usr/bin/python3
|
||||
# Copyright (C) 2015-2019 Free Software Foundation, Inc.
|
||||
# Copyright (C) 2015-2020 Free Software Foundation, Inc.
|
||||
# This file is part of the GNU C Library.
|
||||
#
|
||||
diff --git a/benchtests/scripts/import_bench.py b/benchtests/scripts/import_bench.py
|
||||
index 7a55d19f038e64d4..72e6034243a8c9b6 100644
|
||||
index 08681aafdc200f64..2264da00370f9f02 100644
|
||||
--- a/benchtests/scripts/import_bench.py
|
||||
+++ b/benchtests/scripts/import_bench.py
|
||||
@@ -1,4 +1,4 @@
|
||||
-#!/usr/bin/python
|
||||
+#!/usr/bin/python3
|
||||
# Copyright (C) 2015-2019 Free Software Foundation, Inc.
|
||||
# Copyright (C) 2015-2020 Free Software Foundation, Inc.
|
||||
# This file is part of the GNU C Library.
|
||||
#
|
||||
diff --git a/benchtests/scripts/validate_benchout.py b/benchtests/scripts/validate_benchout.py
|
||||
index 55d07c6bce5b5184..04129f9c26c2874c 100755
|
||||
index 715218aff804baa0..6b4877a67b86b791 100755
|
||||
--- a/benchtests/scripts/validate_benchout.py
|
||||
+++ b/benchtests/scripts/validate_benchout.py
|
||||
@@ -1,4 +1,4 @@
|
||||
-#!/usr/bin/python
|
||||
+#!/usr/bin/python3
|
||||
# Copyright (C) 2014-2019 Free Software Foundation, Inc.
|
||||
# Copyright (C) 2014-2020 Free Software Foundation, Inc.
|
||||
# This file is part of the GNU C Library.
|
||||
#
|
||||
|
20
glibc.spec
20
glibc.spec
@ -1,4 +1,4 @@
|
||||
%define glibcsrcdir glibc-2.30.9000-419-gb8c210bcc7
|
||||
%define glibcsrcdir glibc-2.30.9000-445-gcc47d5c5f5
|
||||
%define glibcversion 2.30.9000
|
||||
# Pre-release tarballs are pulled in from git using a command that is
|
||||
# effectively:
|
||||
@ -87,7 +87,7 @@
|
||||
Summary: The GNU libc libraries
|
||||
Name: glibc
|
||||
Version: %{glibcversion}
|
||||
Release: 27%{?dist}
|
||||
Release: 28%{?dist}
|
||||
|
||||
# In general, GPLv2+ is used by programs, LGPLv2+ is used for
|
||||
# libraries.
|
||||
@ -2041,6 +2041,22 @@ fi
|
||||
%files -f compat-libpthread-nonshared.filelist -n compat-libpthread-nonshared
|
||||
|
||||
%changelog
|
||||
* Thu Jan 02 2020 Florian Weimer <fweimer@redhat.com> - 2.30.9000-28
|
||||
- Auto-sync with upstream branch master,
|
||||
commit cc47d5c5f53f6d845ac54698ae8929af15662c44:
|
||||
- Linux: Use built-in system call tables
|
||||
- lv_LV locale: Correct the time part of d_t_fmt (swbz#25324)
|
||||
- km_KH locale: Use "%M" instead of "m" in d_t_fmt (swbz#25323)
|
||||
- ldbl-128ibm-compat: Do not mix -mabi=*longdouble and -mlong-double-128
|
||||
- ldbl-128ibm-compat: Compiler flags for stdio functions
|
||||
- Do not redirect calls to __GI_* symbols, when redirecting to *ieee128
|
||||
- aarch64: add default memcpy version for kunpeng920
|
||||
- aarch64: ifunc rename for kunpeng
|
||||
- aarch64: Modify error-shown comments for strcpy
|
||||
- linux: Consolidate sigprocmask
|
||||
- Fix return code for __libc_signal_* functions
|
||||
- nptl: Remove duplicate internal __SIZEOF_PTHREAD_MUTEX_T (swbz#25241)
|
||||
|
||||
* Thu Dec 26 2019 Carlos O'Donell <carlos@redhat.com> - 2.30.9000-27
|
||||
- Auto-sync with upstream branch master,
|
||||
commit b8c210bcc74840d24c61d39bde15bea9daf3e271.
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (glibc-2.30.9000-419-gb8c210bcc7.tar.xz) = 92c4eb91b129f7f89875908dcd6898cce77cb0bf0c152132e2a16c3c9449f3cdcdf6d33bcde3e5c6d340ecab0e40be0034dc619c20c18168b7f0ebd34ab45035
|
||||
SHA512 (glibc-2.30.9000-445-gcc47d5c5f5.tar.xz) = dc5dba729ef3651960da0dc0971529f73fd3118d101f7ebec1dd34258c92368d86da963f3e8b7372eddcf0df6258759db8b792a8d8cde5f06dd3cbf733ce43a3
|
||||
|
Loading…
Reference in New Issue
Block a user