Sync with upstream master.

This commit is contained in:
Carlos O'Donell 2015-10-21 15:24:28 -04:00
parent 4d789e132e
commit e61b8f41f2
7 changed files with 90 additions and 280 deletions

View File

@ -2,6 +2,7 @@
# Autogeneries the quilt `series` from the patch order in the spec file.
# We don't use `quilt setup` because it makes a huge mess and doesn't work.
rm -f series.new
extra_args="--fuzz=0"
count=0
# Filter out the patches, and use `_` as our pseudo-IFS to prevent expansion.
for i in `grep '^%patch' glibc.spec | sed -e 's,%patch,,g' -e 's, ,_,g'`; do
@ -14,7 +15,9 @@ for i in `grep '^%patch' glibc.spec | sed -e 's,%patch,,g' -e 's, ,_,g'`; do
args=${elements[@]:1}
# Find the next patch that applies in order and write it out.
# This way we transform the patch # list into a patch file list in order.
grep "Patch${num}: " glibc.spec | sed -e 's,Patch.*: ,,g' -e "s,\$, ${args[@]},g" >> series.new
grep "Patch${num}: " glibc.spec \
| sed -e 's,Patch.*: ,,g' -e "s,\$, ${args[@]} ${extra_args},g" \
>> series.new
((count++))
done
# Double check we processed the correct number of patches.

View File

@ -2369,10 +2369,10 @@ index 5e1506f..1496730 100644
+# define __pthread_cond_timedwait __pthread_cond_timedwait_internal
# include_next <pthread_cond_wait.c>
#endif
diff --git a/sysdeps/unix/sysv/linux/i386/i486/pthread_cond_broadcast.S b/sysdeps/unix/sysv/linux/i386/i486/pthread_cond_broadcast.S
diff --git a/sysdeps/unix/sysv/linux/i386/pthread_cond_broadcast.S b/sysdeps/unix/sysv/linux/i386/pthread_cond_broadcast.S
deleted file mode 100644
index 5ddd5ac..0000000
--- a/sysdeps/unix/sysv/linux/i386/i486/pthread_cond_broadcast.S
--- a/sysdeps/unix/sysv/linux/i386/pthread_cond_broadcast.S
+++ /dev/null
@@ -1,241 +0,0 @@
-/* Copyright (C) 2002-2015 Free Software Foundation, Inc.
@ -2616,10 +2616,10 @@ index 5ddd5ac..0000000
- .size __pthread_cond_broadcast, .-__pthread_cond_broadcast
-versioned_symbol (libpthread, __pthread_cond_broadcast, pthread_cond_broadcast,
- GLIBC_2_3_2)
diff --git a/sysdeps/unix/sysv/linux/i386/i486/pthread_cond_signal.S b/sysdeps/unix/sysv/linux/i386/i486/pthread_cond_signal.S
diff --git a/sysdeps/unix/sysv/linux/i386/pthread_cond_signal.S b/sysdeps/unix/sysv/linux/i386/pthread_cond_signal.S
deleted file mode 100644
index 8f4d937..0000000
--- a/sysdeps/unix/sysv/linux/i386/i486/pthread_cond_signal.S
--- a/sysdeps/unix/sysv/linux/i386/pthread_cond_signal.S
+++ /dev/null
@@ -1,216 +0,0 @@
-/* Copyright (C) 2002-2015 Free Software Foundation, Inc.
@ -2838,10 +2838,10 @@ index 8f4d937..0000000
- .size __pthread_cond_signal, .-__pthread_cond_signal
-versioned_symbol (libpthread, __pthread_cond_signal, pthread_cond_signal,
- GLIBC_2_3_2)
diff --git a/sysdeps/unix/sysv/linux/i386/i486/pthread_cond_timedwait.S b/sysdeps/unix/sysv/linux/i386/i486/pthread_cond_timedwait.S
diff --git a/sysdeps/unix/sysv/linux/i386/pthread_cond_timedwait.S b/sysdeps/unix/sysv/linux/i386/pthread_cond_timedwait.S
deleted file mode 100644
index 130c090..0000000
--- a/sysdeps/unix/sysv/linux/i386/i486/pthread_cond_timedwait.S
--- a/sysdeps/unix/sysv/linux/i386/pthread_cond_timedwait.S
+++ /dev/null
@@ -1,973 +0,0 @@
-/* Copyright (C) 2002-2015 Free Software Foundation, Inc.
@ -3817,10 +3817,10 @@ index 130c090..0000000
-DW.ref.__gcc_personality_v0:
- .long __gcc_personality_v0
-#endif
diff --git a/sysdeps/unix/sysv/linux/i386/i486/pthread_cond_wait.S b/sysdeps/unix/sysv/linux/i386/i486/pthread_cond_wait.S
diff --git a/sysdeps/unix/sysv/linux/i386/pthread_cond_wait.S b/sysdeps/unix/sysv/linux/i386/pthread_cond_wait.S
deleted file mode 100644
index ec3538f..0000000
--- a/sysdeps/unix/sysv/linux/i386/i486/pthread_cond_wait.S
--- a/sysdeps/unix/sysv/linux/i386/pthread_cond_wait.S
+++ /dev/null
@@ -1,641 +0,0 @@
-/* Copyright (C) 2002-2015 Free Software Foundation, Inc.
@ -4464,207 +4464,6 @@ index ec3538f..0000000
-DW.ref.__gcc_personality_v0:
- .long __gcc_personality_v0
-#endif
diff --git a/sysdeps/unix/sysv/linux/i386/i586/pthread_cond_broadcast.S b/sysdeps/unix/sysv/linux/i386/i586/pthread_cond_broadcast.S
deleted file mode 100644
index 9a4006a..0000000
--- a/sysdeps/unix/sysv/linux/i386/i586/pthread_cond_broadcast.S
+++ /dev/null
@@ -1,19 +0,0 @@
-/* Copyright (C) 2003-2015 Free Software Foundation, Inc.
- This file is part of the GNU C Library.
- Contributed by Ulrich Drepper <drepper@redhat.com>, 2003.
-
- The GNU C Library is free software; you can redistribute it and/or
- modify it under the terms of the GNU Lesser General Public
- License as published by the Free Software Foundation; either
- version 2.1 of the License, or (at your option) any later version.
-
- The GNU C Library is distributed in the hope that it will be useful,
- but WITHOUT ANY WARRANTY; without even the implied warranty of
- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
- Lesser General Public License for more details.
-
- You should have received a copy of the GNU Lesser General Public
- License along with the GNU C Library; if not, see
- <http://www.gnu.org/licenses/>. */
-
-#include "../i486/pthread_cond_broadcast.S"
diff --git a/sysdeps/unix/sysv/linux/i386/i586/pthread_cond_signal.S b/sysdeps/unix/sysv/linux/i386/i586/pthread_cond_signal.S
deleted file mode 100644
index 59f93b6..0000000
--- a/sysdeps/unix/sysv/linux/i386/i586/pthread_cond_signal.S
+++ /dev/null
@@ -1,19 +0,0 @@
-/* Copyright (C) 2003-2015 Free Software Foundation, Inc.
- This file is part of the GNU C Library.
- Contributed by Ulrich Drepper <drepper@redhat.com>, 2003.
-
- The GNU C Library is free software; you can redistribute it and/or
- modify it under the terms of the GNU Lesser General Public
- License as published by the Free Software Foundation; either
- version 2.1 of the License, or (at your option) any later version.
-
- The GNU C Library is distributed in the hope that it will be useful,
- but WITHOUT ANY WARRANTY; without even the implied warranty of
- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
- Lesser General Public License for more details.
-
- You should have received a copy of the GNU Lesser General Public
- License along with the GNU C Library; if not, see
- <http://www.gnu.org/licenses/>. */
-
-#include "../i486/pthread_cond_signal.S"
diff --git a/sysdeps/unix/sysv/linux/i386/i586/pthread_cond_timedwait.S b/sysdeps/unix/sysv/linux/i386/i586/pthread_cond_timedwait.S
deleted file mode 100644
index d96af08..0000000
--- a/sysdeps/unix/sysv/linux/i386/i586/pthread_cond_timedwait.S
+++ /dev/null
@@ -1,19 +0,0 @@
-/* Copyright (C) 2003-2015 Free Software Foundation, Inc.
- This file is part of the GNU C Library.
- Contributed by Ulrich Drepper <drepper@redhat.com>, 2003.
-
- The GNU C Library is free software; you can redistribute it and/or
- modify it under the terms of the GNU Lesser General Public
- License as published by the Free Software Foundation; either
- version 2.1 of the License, or (at your option) any later version.
-
- The GNU C Library is distributed in the hope that it will be useful,
- but WITHOUT ANY WARRANTY; without even the implied warranty of
- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
- Lesser General Public License for more details.
-
- You should have received a copy of the GNU Lesser General Public
- License along with the GNU C Library; if not, see
- <http://www.gnu.org/licenses/>. */
-
-#include "../i486/pthread_cond_timedwait.S"
diff --git a/sysdeps/unix/sysv/linux/i386/i586/pthread_cond_wait.S b/sysdeps/unix/sysv/linux/i386/i586/pthread_cond_wait.S
deleted file mode 100644
index 9696972..0000000
--- a/sysdeps/unix/sysv/linux/i386/i586/pthread_cond_wait.S
+++ /dev/null
@@ -1,19 +0,0 @@
-/* Copyright (C) 2003-2015 Free Software Foundation, Inc.
- This file is part of the GNU C Library.
- Contributed by Ulrich Drepper <drepper@redhat.com>, 2003.
-
- The GNU C Library is free software; you can redistribute it and/or
- modify it under the terms of the GNU Lesser General Public
- License as published by the Free Software Foundation; either
- version 2.1 of the License, or (at your option) any later version.
-
- The GNU C Library is distributed in the hope that it will be useful,
- but WITHOUT ANY WARRANTY; without even the implied warranty of
- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
- Lesser General Public License for more details.
-
- You should have received a copy of the GNU Lesser General Public
- License along with the GNU C Library; if not, see
- <http://www.gnu.org/licenses/>. */
-
-#include "../i486/pthread_cond_wait.S"
diff --git a/sysdeps/unix/sysv/linux/i386/i686/pthread_cond_broadcast.S b/sysdeps/unix/sysv/linux/i386/i686/pthread_cond_broadcast.S
deleted file mode 100644
index 9a4006a..0000000
--- a/sysdeps/unix/sysv/linux/i386/i686/pthread_cond_broadcast.S
+++ /dev/null
@@ -1,19 +0,0 @@
-/* Copyright (C) 2003-2015 Free Software Foundation, Inc.
- This file is part of the GNU C Library.
- Contributed by Ulrich Drepper <drepper@redhat.com>, 2003.
-
- The GNU C Library is free software; you can redistribute it and/or
- modify it under the terms of the GNU Lesser General Public
- License as published by the Free Software Foundation; either
- version 2.1 of the License, or (at your option) any later version.
-
- The GNU C Library is distributed in the hope that it will be useful,
- but WITHOUT ANY WARRANTY; without even the implied warranty of
- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
- Lesser General Public License for more details.
-
- You should have received a copy of the GNU Lesser General Public
- License along with the GNU C Library; if not, see
- <http://www.gnu.org/licenses/>. */
-
-#include "../i486/pthread_cond_broadcast.S"
diff --git a/sysdeps/unix/sysv/linux/i386/i686/pthread_cond_signal.S b/sysdeps/unix/sysv/linux/i386/i686/pthread_cond_signal.S
deleted file mode 100644
index 59f93b6..0000000
--- a/sysdeps/unix/sysv/linux/i386/i686/pthread_cond_signal.S
+++ /dev/null
@@ -1,19 +0,0 @@
-/* Copyright (C) 2003-2015 Free Software Foundation, Inc.
- This file is part of the GNU C Library.
- Contributed by Ulrich Drepper <drepper@redhat.com>, 2003.
-
- The GNU C Library is free software; you can redistribute it and/or
- modify it under the terms of the GNU Lesser General Public
- License as published by the Free Software Foundation; either
- version 2.1 of the License, or (at your option) any later version.
-
- The GNU C Library is distributed in the hope that it will be useful,
- but WITHOUT ANY WARRANTY; without even the implied warranty of
- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
- Lesser General Public License for more details.
-
- You should have received a copy of the GNU Lesser General Public
- License along with the GNU C Library; if not, see
- <http://www.gnu.org/licenses/>. */
-
-#include "../i486/pthread_cond_signal.S"
diff --git a/sysdeps/unix/sysv/linux/i386/i686/pthread_cond_timedwait.S b/sysdeps/unix/sysv/linux/i386/i686/pthread_cond_timedwait.S
deleted file mode 100644
index 0e8d7ff..0000000
--- a/sysdeps/unix/sysv/linux/i386/i686/pthread_cond_timedwait.S
+++ /dev/null
@@ -1,20 +0,0 @@
-/* Copyright (C) 2003-2015 Free Software Foundation, Inc.
- This file is part of the GNU C Library.
- Contributed by Ulrich Drepper <drepper@redhat.com>, 2003.
-
- The GNU C Library is free software; you can redistribute it and/or
- modify it under the terms of the GNU Lesser General Public
- License as published by the Free Software Foundation; either
- version 2.1 of the License, or (at your option) any later version.
-
- The GNU C Library is distributed in the hope that it will be useful,
- but WITHOUT ANY WARRANTY; without even the implied warranty of
- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
- Lesser General Public License for more details.
-
- You should have received a copy of the GNU Lesser General Public
- License along with the GNU C Library; if not, see
- <http://www.gnu.org/licenses/>. */
-
-#define HAVE_CMOV 1
-#include "../i486/pthread_cond_timedwait.S"
diff --git a/sysdeps/unix/sysv/linux/i386/i686/pthread_cond_wait.S b/sysdeps/unix/sysv/linux/i386/i686/pthread_cond_wait.S
deleted file mode 100644
index 9696972..0000000
--- a/sysdeps/unix/sysv/linux/i386/i686/pthread_cond_wait.S
+++ /dev/null
@@ -1,19 +0,0 @@
-/* Copyright (C) 2003-2015 Free Software Foundation, Inc.
- This file is part of the GNU C Library.
- Contributed by Ulrich Drepper <drepper@redhat.com>, 2003.
-
- The GNU C Library is free software; you can redistribute it and/or
- modify it under the terms of the GNU Lesser General Public
- License as published by the Free Software Foundation; either
- version 2.1 of the License, or (at your option) any later version.
-
- The GNU C Library is distributed in the hope that it will be useful,
- but WITHOUT ANY WARRANTY; without even the implied warranty of
- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
- Lesser General Public License for more details.
-
- You should have received a copy of the GNU Lesser General Public
- License along with the GNU C Library; if not, see
- <http://www.gnu.org/licenses/>. */
-
-#include "../i486/pthread_cond_wait.S"
diff --git a/sysdeps/unix/sysv/linux/powerpc/bits/pthreadtypes.h b/sysdeps/unix/sysv/linux/powerpc/bits/pthreadtypes.h
index 7cbdb2c..70b65d3 100644
--- a/sysdeps/unix/sysv/linux/powerpc/bits/pthreadtypes.h

View File

@ -1,16 +1,16 @@
Index: glibc-2.22-193-g315267a/resolv/res_hconf.c
Index: glibc-2.22-386-g95e8397/resolv/res_hconf.c
===================================================================
--- glibc-2.22-193-g315267a.orig/resolv/res_hconf.c
+++ glibc-2.22-193-g315267a/resolv/res_hconf.c
@@ -45,6 +45,7 @@
#include "ifreq.h"
--- glibc-2.22-386-g95e8397.orig/resolv/res_hconf.c
+++ glibc-2.22-386-g95e8397/resolv/res_hconf.c
@@ -46,6 +46,7 @@
#include "res_hconf.h"
#include <wchar.h>
#include <atomic.h>
+#include <libc-internal.h>
#if IS_IN (libc)
# define fgets_unlocked __fgets_unlocked
@@ -523,7 +524,16 @@ _res_hconf_trim_domain (char *hostname)
@@ -577,7 +578,16 @@ _res_hconf_trim_domain (char *hostname)
for (i = 0; i < _res_hconf.num_trimdomains; ++i)
{

View File

@ -1,7 +1,8 @@
diff -rup a/elf/dl-load.c b/elf/dl-load.c
--- a/elf/dl-load.c 2012-02-03 10:59:58.917870716 -0700
+++ b/elf/dl-load.c 2012-02-03 11:01:01.796580644 -0700
@@ -880,7 +880,8 @@ _dl_map_object_from_fd (const char *name, int fd, struct filebuf *fbp,
Index: glibc-2.22-386-g95e8397/elf/dl-load.c
===================================================================
--- glibc-2.22-386-g95e8397.orig/elf/dl-load.c
+++ glibc-2.22-386-g95e8397/elf/dl-load.c
@@ -881,7 +881,8 @@ _dl_map_object_from_fd (const char *name
/* Get file information. */
struct r_file_id id;
@ -11,7 +12,7 @@ diff -rup a/elf/dl-load.c b/elf/dl-load.c
{
errstring = N_("cannot stat shared object");
call_lose_errno:
@@ -1130,6 +1130,16 @@ _dl_map_object_from_fd (const char *name
@@ -1076,6 +1077,16 @@ _dl_map_object_from_fd (const char *name
= N_("ELF load command address/offset not properly aligned");
goto call_lose;
}
@ -27,11 +28,11 @@ diff -rup a/elf/dl-load.c b/elf/dl-load.c
+ }
struct loadcmd *c = &loadcmds[nloadcmds++];
c->mapstart = ph->p_vaddr & ~(GLRO(dl_pagesize) - 1);
diff --git a/sysdeps/generic/dl-fileid.h b/sysdeps/generic/dl-fileid.h
index 2cbd21d..9b7f410 100644
--- a/sysdeps/generic/dl-fileid.h
+++ b/sysdeps/generic/dl-fileid.h
c->mapstart = ALIGN_DOWN (ph->p_vaddr, GLRO(dl_pagesize));
Index: glibc-2.22-386-g95e8397/sysdeps/generic/dl-fileid.h
===================================================================
--- glibc-2.22-386-g95e8397.orig/sysdeps/generic/dl-fileid.h
+++ glibc-2.22-386-g95e8397/sysdeps/generic/dl-fileid.h
@@ -29,7 +29,8 @@ struct r_file_id
On error, returns false, with errno set. */
static inline bool
@ -42,10 +43,10 @@ index 2cbd21d..9b7f410 100644
{
return true;
}
diff --git a/sysdeps/posix/dl-fileid.h b/sysdeps/posix/dl-fileid.h
index d0d5436..7115c3b 100644
--- a/sysdeps/posix/dl-fileid.h
+++ b/sysdeps/posix/dl-fileid.h
Index: glibc-2.22-386-g95e8397/sysdeps/posix/dl-fileid.h
===================================================================
--- glibc-2.22-386-g95e8397.orig/sysdeps/posix/dl-fileid.h
+++ glibc-2.22-386-g95e8397/sysdeps/posix/dl-fileid.h
@@ -27,18 +27,16 @@ struct r_file_id
ino64_t ino;
};

View File

@ -1,6 +1,6 @@
%define glibcsrcdir glibc-2.22-193-g315267a
%define glibcsrcdir glibc-2.22-386-g95e8397
%define glibcversion 2.22.90
%define glibcrelease 8%{?dist}
%define glibcrelease 9%{?dist}
# Pre-release tarballs are pulled in from git using a command that is
# effectively:
#
@ -1080,8 +1080,11 @@ chmod 644 $RPM_BUILD_ROOT%{_libdir}/gconv/gconv-modules.cache
##############################################################################
# NPTL <bits/stdio-lock.h> is not usable outside of glibc, so include
# the generic one (#162634)
cp -a bits/stdio-lock.h $RPM_BUILD_ROOT%{_prefix}/include/bits/stdio-lock.h
# the generic one (#162634). This header is required by older gcc builds
# which shared libio. Once we stop supporting building old compilers which
# need shared libio we can remove this.
cp -a sysdeps/generic/stdio-lock.h \
$RPM_BUILD_ROOT%{_prefix}/include/bits/stdio-lock.h
# And <bits/libc-lock.h> needs sanitizing as well.
cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_prefix}/include/bits/libc-lock.h
@ -1848,6 +1851,10 @@ rm -f *.filelist*
%endif
%changelog
* Wed Oct 21 2015 Carlos O'Donell <carlos@redhat.com> - 2.22.90-9
- Auto-sync with upstream master.
- Update new condvar implementation.
* Fri Oct 9 2015 Carlos O'Donell <carlos@redhat.com> - 2.22.90-8
- Remove libbsd.a (#1193168).

90
series
View File

@ -1,45 +1,45 @@
glibc-fedora-nscd.patch -p1
glibc-fedora-ldd.patch -p1
glibc-fedora-ppc-unwind.patch -p1
glibc-rh825061.patch -p1
glibc-arm-hardfloat-3.patch -p1
glibc-rh697421.patch -p1
glibc-fedora-include-bits-ldbl.patch -p1
glibc-fedora-linux-tcsetattr.patch -p1
glibc-rh741105.patch -p1
glibc-fedora-nptl-linklibc.patch -p1
glibc-fedora-localedef.patch -p1
glibc-fedora-i386-tls-direct-seg-refs.patch -p1
glibc-fedora-nis-rh188246.patch -p1
glibc-fedora-manual-dircategory.patch -p1
glibc-rh827510.patch -p1
glibc-fedora-locarchive.patch -p1
glibc-fedora-streams-rh436349.patch -p1
glibc-rh819430.patch -p1
glibc-fedora-localedata-rh61908.patch -p1
glibc-fedora-uname-getrlimit.patch -p1
glibc-fedora-__libc_multiple_libcs.patch -p1
glibc-fedora-elf-ORIGIN.patch -p1
glibc-fedora-elf-init-hidden_undef.patch -p1
glibc-rh952799.patch -p1
glibc-rh1009145.patch -p1
glibc-rh1013801.patch -p1
glibc-rh1070416.patch -p1
glibc-nscd-sysconfig.patch -p1
glibc-aarch64-tls-fixes.patch -p1
glibc-aarch64-workaround-nzcv-clobber-in-tlsdesc.patch -p1
glibc-disable-rwlock-elision.patch -p1
glibc-cs-path.patch -p1
glibc-bench-build.patch -p1
glibc-new-condvar.patch -p1
glibc-rh1238412-remove-duplicate-transliterations.patch -p1
glibc-rh1238412-addition-and-fixes-for-translit_neutral.patch -p1
glibc-rh1238412-update-the-translit-files-to-unicode-7.0.0.patch -p1
glibc-rh1238412-add-translit-rules-for-da-nb-nn-sv-locales.patch -p1
glibc-rh1238412-unicode-8.0.0-update.patch -p1
glibc-res-hconf-gcc5.patch -p1
glibc-ld-ctype-gcc5.patch -p1
glibc-gethnamaddr-gcc5.patch -p1
glibc-dns-host-gcc5.patch -p1
glibc-bug-regex-gcc5.patch -p1
glibc-c-utf8-locale.patch -p1
glibc-fedora-nscd.patch -p1 --fuzz=0
glibc-fedora-ldd.patch -p1 --fuzz=0
glibc-fedora-ppc-unwind.patch -p1 --fuzz=0
glibc-rh825061.patch -p1 --fuzz=0
glibc-arm-hardfloat-3.patch -p1 --fuzz=0
glibc-rh697421.patch -p1 --fuzz=0
glibc-fedora-include-bits-ldbl.patch -p1 --fuzz=0
glibc-fedora-linux-tcsetattr.patch -p1 --fuzz=0
glibc-rh741105.patch --fuzz=0
glibc-fedora-nptl-linklibc.patch -p1 --fuzz=0
glibc-fedora-localedef.patch -p1 --fuzz=0
glibc-fedora-i386-tls-direct-seg-refs.patch -p1 --fuzz=0
glibc-fedora-nis-rh188246.patch -p1 --fuzz=0
glibc-fedora-manual-dircategory.patch -p1 --fuzz=0
glibc-rh827510.patch -p1 --fuzz=0
glibc-fedora-locarchive.patch -p1 --fuzz=0
glibc-fedora-streams-rh436349.patch -p1 --fuzz=0
glibc-rh819430.patch -p1 --fuzz=0
glibc-fedora-localedata-rh61908.patch -p1 --fuzz=0
glibc-fedora-uname-getrlimit.patch -p1 --fuzz=0
glibc-fedora-__libc_multiple_libcs.patch -p1 --fuzz=0
glibc-fedora-elf-ORIGIN.patch -p1 --fuzz=0
glibc-fedora-elf-init-hidden_undef.patch -p1 --fuzz=0
glibc-rh952799.patch -p1 --fuzz=0
glibc-rh1009145.patch -p1 --fuzz=0
glibc-rh1013801.patch -p1 --fuzz=0
glibc-rh1070416.patch -p1 --fuzz=0
glibc-nscd-sysconfig.patch -p1 --fuzz=0
glibc-aarch64-tls-fixes.patch -p1 --fuzz=0
glibc-aarch64-workaround-nzcv-clobber-in-tlsdesc.patch -p1 --fuzz=0
glibc-disable-rwlock-elision.patch -p1 --fuzz=0
glibc-cs-path.patch -p1 --fuzz=0
glibc-bench-build.patch -p1 --fuzz=0
glibc-new-condvar.patch -p1 --fuzz=0
glibc-rh1238412-remove-duplicate-transliterations.patch -p1 --fuzz=0
glibc-rh1238412-addition-and-fixes-for-translit_neutral.patch -p1 --fuzz=0
glibc-rh1238412-update-the-translit-files-to-unicode-7.0.0.patch -p1 --fuzz=0
glibc-rh1238412-add-translit-rules-for-da-nb-nn-sv-locales.patch -p1 --fuzz=0
glibc-rh1238412-unicode-8.0.0-update.patch -p1 --fuzz=0
glibc-res-hconf-gcc5.patch -p1 --fuzz=0
glibc-ld-ctype-gcc5.patch -p1 --fuzz=0
glibc-gethnamaddr-gcc5.patch -p1 --fuzz=0
glibc-dns-host-gcc5.patch -p1 --fuzz=0
glibc-bug-regex-gcc5.patch -p1 --fuzz=0
glibc-c-utf8-locale.patch -p1 --fuzz=0

View File

@ -1 +1 @@
7979311a9559451d849a87eb5da7f630 glibc-2.22-193-g315267a.tar.gz
a5ba3423afe0f919eec002e1747fb01f glibc-2.22-386-g95e8397.tar.gz