Update arm-hardfloat patch
This commit is contained in:
parent
6537aa83a1
commit
e5e2fc3bd7
@ -1,36 +1,29 @@
|
|||||||
diff -rup c/sysdeps/arm/configure.in d/sysdeps/arm/configure.in
|
diff --git a/sysdeps/arm/configure.in b/sysdeps/arm/configure.in
|
||||||
--- c/sysdeps/arm/configure.in 2012-01-08 22:47:04.000000000 -0700
|
index 706add2..f00b798 100644
|
||||||
+++ d/sysdeps/arm/configure.in 2012-05-07 11:55:26.111096072 -0600
|
--- a/sysdeps/arm/configure.in
|
||||||
@@ -18,3 +18,28 @@ EOF
|
+++ b/sysdeps/arm/configure.in
|
||||||
if test $libc_cv_asm_cfi_directive_sections != yes; then
|
@@ -49,3 +49,20 @@ EOF
|
||||||
|
if test $libc_cv_asm_cfi_directive_sections !=3D yes; then
|
||||||
AC_MSG_ERROR([need .cfi_sections in this configuration])
|
AC_MSG_ERROR([need .cfi_sections in this configuration])
|
||||||
fi
|
fi
|
||||||
+
|
+
|
||||||
+AC_CACHE_CHECK([whether the compiler is using the ARM hard-float ABI],
|
|
||||||
+ [libc_cv_arm_pcs_vfp],
|
|
||||||
+ [archcppflag=`echo "" |
|
|
||||||
+ $CC $CFLAGS $CPPFLAGS -E -dM - |
|
|
||||||
+ grep __ARM_PCS_VFP |
|
|
||||||
+ sed -e 's/^#define //' -e 's/ .*//'`
|
|
||||||
+# We check to see if the compiler and flags are
|
+# We check to see if the compiler and flags are
|
||||||
+# selecting the hard-float ABI and if they are then
|
+# selecting the hard-float ABI and if they are then
|
||||||
+# we set libc_cv_arm_pcs_vfp to yes which causes
|
+# we set libc_cv_arm_pcs_vfp to yes which causes
|
||||||
+# HAVE_ARM_PCS_VFP to be defined in config.h and
|
+# HAVE_ARM_PCS_VFP to be defined in config.h and
|
||||||
+ # in include/libc-symbols.h and thus availabile to
|
+# in include/libc-symbols.h and thus available to
|
||||||
+# shlib-versions to select the appropriate name for
|
+# shlib-versions to select the appropriate name for
|
||||||
+# the dynamic linker via %ifdef.
|
+# the dynamic linker via %ifdef.
|
||||||
+ case x$archcppflag in
|
+AC_CACHE_CHECK([whether the compiler is using the ARM hard-float ABI],
|
||||||
+ x__ARM_PCS_VFP)
|
+ [libc_cv_arm_pcs_vfp],
|
||||||
+ libc_cv_arm_pcs_vfp=yes
|
+ [AC_EGREP_CPP(yes,[#ifdef __ARM_PCS_VFP
|
||||||
+ ;;
|
+ yes
|
||||||
+ *)
|
+ #endif
|
||||||
+ libc_cv_arm_pcs_vfp=no
|
+ ], libc_cv_arm_pcs_vfp=3Dyes, libc_cv_arm_pcs_vfp=3Dno)])
|
||||||
+ ;;
|
+if test $libc_cv_arm_pcs_vfp =3D yes; then
|
||||||
+ esac])
|
|
||||||
+if test $libc_cv_arm_pcs_vfp = yes; then
|
|
||||||
+ AC_DEFINE(HAVE_ARM_PCS_VFP)
|
+ AC_DEFINE(HAVE_ARM_PCS_VFP)
|
||||||
+fi
|
+fi
|
||||||
Only in d/sysdeps/arm: configure.in.orig
|
|
||||||
diff -rup c/sysdeps/arm/shlib-versions d/sysdeps/arm/shlib-versions
|
diff -rup c/sysdeps/arm/shlib-versions d/sysdeps/arm/shlib-versions
|
||||||
--- c/sysdeps/arm/shlib-versions 2012-01-08 22:47:04.000000000 -0700
|
--- c/sysdeps/arm/shlib-versions 2012-01-08 22:47:04.000000000 -0700
|
||||||
+++ d/sysdeps/arm/shlib-versions 2012-05-07 11:57:07.739567660 -0600
|
+++ d/sysdeps/arm/shlib-versions 2012-05-07 11:57:07.739567660 -0600
|
||||||
@ -46,3 +39,4 @@ diff -rup c/sysdeps/arm/shlib-versions d/sysdeps/arm/shlib-versions
|
|||||||
+arm.*-.*-linux-gnueabi.* ld=ld-linux.so.3
|
+arm.*-.*-linux-gnueabi.* ld=ld-linux.so.3
|
||||||
+%endif
|
+%endif
|
||||||
arm.*-.*-linux.* ld=ld-linux.so.2
|
arm.*-.*-linux.* ld=ld-linux.so.2
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user