Auto-sync with upstream branch master
Upstream commit: 4eda036f5b897fa8bc20ddd2099b5a6ed4239dc9 - stdlib: Move tst-system to tests-container - support/shell-container.c: Add builtin kill - support/shell-container.c: Add builtin exit - support/shell-container.c: Return 127 if execve fails - Add NEWS entry for CVE-2020-1751 (bug 25423) - posix: Fix system error return value [BZ #25715] - y2038: fix: Add missing libc_hidden_def attribute for some syscall wrappers - Extended Char Intro: Use getwc in example (Bug 25626) - stdio: Add tests for printf multibyte convertion leak [BZ#25691] - stdio: Remove memory leak from multibyte convertion [BZ#25691] - Add NEWS entry for CVE-2020-1752 (bug 25414) - math: Remove inline math tests - Remove __LIBC_INTERNAL_MATH_INLINES - math: Remove mathinline - m68k: Remove mathinline.h - oc_FR locale: Fix spelling of Thursday (bug 25639) - x86: Remove ARCH_CET_LEGACY_BITMAP [BZ #25397] - Fix build with GCC 10 when long double = double. - nscd/cachedumper.c : fix whitespace - Fix nscd/cachedumper.c compile errors - manual: Fix inconsistent declaration of wcsrchr [BZ #24655] - nscd: add cache dumper
This commit is contained in:
parent
c0cdff7e6c
commit
e5688486f8
@ -1,24 +0,0 @@
|
|||||||
Emergency patch for #1778344: A reference to a unique symbol in
|
|
||||||
libstdc++ causes it to be marked as NODELETE (as expected), but the
|
|
||||||
assert is not prepared for that situation.
|
|
||||||
|
|
||||||
diff --git a/elf/dl-open.c b/elf/dl-open.c
|
|
||||||
index df9f29a5e5683bf2..763e90187afaf09a 100644
|
|
||||||
--- a/elf/dl-open.c
|
|
||||||
+++ b/elf/dl-open.c
|
|
||||||
@@ -452,12 +452,9 @@ activate_nodelete (struct link_map *new, int mode)
|
|
||||||
_dl_debug_printf ("activating NODELETE for %s [%lu]\n",
|
|
||||||
imap->l_name, imap->l_ns);
|
|
||||||
|
|
||||||
- /* Only new objects should have set
|
|
||||||
- link_map_nodelete_pending. Existing objects should not
|
|
||||||
- have gained any new dependencies and therefore cannot
|
|
||||||
- reach NODELETE status. */
|
|
||||||
- assert (!imap->l_init_called || imap->l_type != lt_loaded);
|
|
||||||
-
|
|
||||||
+ /* Note that this can also activate NODELETE for objects
|
|
||||||
+ which had already been loaded at the time of the dlopen
|
|
||||||
+ call. */
|
|
||||||
imap->l_nodelete = link_map_nodelete_active;
|
|
||||||
}
|
|
||||||
}
|
|
@ -1,44 +0,0 @@
|
|||||||
Emergency patch for broken utimes/utime functions.
|
|
||||||
|
|
||||||
diff --git a/sysdeps/unix/sysv/linux/utime.c b/sysdeps/unix/sysv/linux/utime.c
|
|
||||||
index 2cd9334a6f1efc36..8665ef26362b9563 100644
|
|
||||||
--- a/sysdeps/unix/sysv/linux/utime.c
|
|
||||||
+++ b/sysdeps/unix/sysv/linux/utime.c
|
|
||||||
@@ -18,6 +18,7 @@
|
|
||||||
|
|
||||||
#include <utime.h>
|
|
||||||
#include <time.h>
|
|
||||||
+#include <fcntl.h>
|
|
||||||
|
|
||||||
int
|
|
||||||
__utime64 (const char *file, const struct __utimbuf64 *times)
|
|
||||||
@@ -32,7 +33,7 @@ __utime64 (const char *file, const struct __utimbuf64 *times)
|
|
||||||
ts64[1].tv_nsec = 0LL;
|
|
||||||
}
|
|
||||||
|
|
||||||
- return __utimensat64_helper (0, file, times ? ts64 : NULL, 0);
|
|
||||||
+ return __utimensat64_helper (AT_FDCWD, file, times ? ts64 : NULL, 0);
|
|
||||||
}
|
|
||||||
|
|
||||||
#if __TIMESIZE != 64
|
|
||||||
diff --git a/sysdeps/unix/sysv/linux/utimes.c b/sysdeps/unix/sysv/linux/utimes.c
|
|
||||||
index 75927b6ec6695c96..a6809876fdd0df51 100644
|
|
||||||
--- a/sysdeps/unix/sysv/linux/utimes.c
|
|
||||||
+++ b/sysdeps/unix/sysv/linux/utimes.c
|
|
||||||
@@ -17,6 +17,7 @@
|
|
||||||
<https://www.gnu.org/licenses/>. */
|
|
||||||
|
|
||||||
#include <time.h>
|
|
||||||
+#include <fcntl.h>
|
|
||||||
|
|
||||||
int
|
|
||||||
__utimes64 (const char *file, const struct __timeval64 tvp[2])
|
|
||||||
@@ -29,7 +30,7 @@ __utimes64 (const char *file, const struct __timeval64 tvp[2])
|
|
||||||
ts64[1] = timeval64_to_timespec64 (tvp[1]);
|
|
||||||
}
|
|
||||||
|
|
||||||
- return __utimensat64_helper (0, file, tvp ? ts64 : NULL, 0);
|
|
||||||
+ return __utimensat64_helper (AT_FDCWD, file, tvp ? ts64 : NULL, 0);
|
|
||||||
}
|
|
||||||
|
|
||||||
#if __TIMESIZE != 64
|
|
30
glibc.spec
30
glibc.spec
@ -1,4 +1,4 @@
|
|||||||
%define glibcsrcdir glibc-2.31.9000-263-g2de7fe6253
|
%define glibcsrcdir glibc-2.31.9000-285-g4eda036f5b
|
||||||
%define glibcversion 2.31.9000
|
%define glibcversion 2.31.9000
|
||||||
# Pre-release tarballs are pulled in from git using a command that is
|
# Pre-release tarballs are pulled in from git using a command that is
|
||||||
# effectively:
|
# effectively:
|
||||||
@ -87,7 +87,7 @@
|
|||||||
Summary: The GNU libc libraries
|
Summary: The GNU libc libraries
|
||||||
Name: glibc
|
Name: glibc
|
||||||
Version: %{glibcversion}
|
Version: %{glibcversion}
|
||||||
Release: 4%{?dist}
|
Release: 5%{?dist}
|
||||||
|
|
||||||
# In general, GPLv2+ is used by programs, LGPLv2+ is used for
|
# In general, GPLv2+ is used by programs, LGPLv2+ is used for
|
||||||
# libraries.
|
# libraries.
|
||||||
@ -2041,6 +2041,32 @@ fi
|
|||||||
%files -f compat-libpthread-nonshared.filelist -n compat-libpthread-nonshared
|
%files -f compat-libpthread-nonshared.filelist -n compat-libpthread-nonshared
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Mar 25 2020 Patsy Franklin <patsy@redhat.com> - 2.31.9000-5
|
||||||
|
- Auto-sync with upstream branch master,
|
||||||
|
commit 4eda036f5b897fa8bc20ddd2099b5a6ed4239dc9.
|
||||||
|
- stdlib: Move tst-system to tests-container
|
||||||
|
- support/shell-container.c: Add builtin kill
|
||||||
|
- support/shell-container.c: Add builtin exit
|
||||||
|
- support/shell-container.c: Return 127 if execve fails
|
||||||
|
- Add NEWS entry for CVE-2020-1751 (bug 25423)
|
||||||
|
- posix: Fix system error return value [BZ #25715]
|
||||||
|
- y2038: fix: Add missing libc_hidden_def attribute for some syscall wrappers
|
||||||
|
- Extended Char Intro: Use getwc in example (Bug 25626)
|
||||||
|
- stdio: Add tests for printf multibyte convertion leak [BZ#25691]
|
||||||
|
- stdio: Remove memory leak from multibyte convertion [BZ#25691]
|
||||||
|
- Add NEWS entry for CVE-2020-1752 (bug 25414)
|
||||||
|
- math: Remove inline math tests
|
||||||
|
- Remove __LIBC_INTERNAL_MATH_INLINES
|
||||||
|
- math: Remove mathinline
|
||||||
|
- m68k: Remove mathinline.h
|
||||||
|
- oc_FR locale: Fix spelling of Thursday (bug 25639)
|
||||||
|
- x86: Remove ARCH_CET_LEGACY_BITMAP [BZ #25397]
|
||||||
|
- Fix build with GCC 10 when long double = double.
|
||||||
|
- nscd/cachedumper.c : fix whitespace
|
||||||
|
- Fix nscd/cachedumper.c compile errors
|
||||||
|
- manual: Fix inconsistent declaration of wcsrchr [BZ #24655]
|
||||||
|
- nscd: add cache dumper
|
||||||
|
|
||||||
* Fri Mar 13 2020 Patsy Franklin <patsy@redhat.com> - 2.31.9000-4
|
* Fri Mar 13 2020 Patsy Franklin <patsy@redhat.com> - 2.31.9000-4
|
||||||
- Auto-sync with upstream branch master,
|
- Auto-sync with upstream branch master,
|
||||||
commit 2de7fe62534b7a6461c633114f03e9dff394f5f7.
|
commit 2de7fe62534b7a6461c633114f03e9dff394f5f7.
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (glibc-2.31.9000-263-g2de7fe6253.tar.xz) = a92adef062b28815e440a965494f1db00d969e236716442c620527869ab10a59bc3636ae579e2ea076041b9c721875e64af326bdaeadf6ae2fd38e07479d007b
|
SHA512 (glibc-2.31.9000-285-g4eda036f5b.tar.xz) = 9992f68741afc08bf2ef7af6fa8361bdb32c8c8cf4265574529d2e4ae15764ca5ea579a5df197433b639dc17b961b7bc62830e33d404248abccafb04fe5fbea9
|
||||||
|
Loading…
Reference in New Issue
Block a user