Prevent erroneous inline optimization of initfini.s on PowerPC64 (#783979)
This commit is contained in:
parent
7b27d27fa9
commit
dd7f54d17d
12
glibc-rh783979.patch
Normal file
12
glibc-rh783979.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
diff -rup a/sysdeps/powerpc/powerpc64/Makefile b/sysdeps/powerpc/powerpc64/Makefile
|
||||||
|
--- a/sysdeps/powerpc/powerpc64/Makefile 2012-02-01 09:34:07.018768021 -0700
|
||||||
|
+++ b/sysdeps/powerpc/powerpc64/Makefile 2012-02-01 09:35:28.813356195 -0700
|
||||||
|
@@ -31,7 +31,7 @@ elide-routines.os += hp-timing
|
||||||
|
ifneq ($(elf),no)
|
||||||
|
# The initfini generation code doesn't work in the presence of -fPIC, so
|
||||||
|
# we use -fpic instead which is much better.
|
||||||
|
-CFLAGS-initfini.s += -fpic -O1
|
||||||
|
+CFLAGS-initfini.s += -fpic -O1 -fno-inline
|
||||||
|
endif
|
||||||
|
CFLAGS-libc-start.c += -fno-asynchronous-unwind-tables
|
||||||
|
endif
|
@ -66,6 +66,7 @@ Patch14: %{name}-rh740682.patch
|
|||||||
Patch15: %{name}-sw13618.patch
|
Patch15: %{name}-sw13618.patch
|
||||||
# Fix bogus sorting code which was copied from dl-deps.
|
# Fix bogus sorting code which was copied from dl-deps.
|
||||||
Patch16: %{name}-sw13618-2.patch
|
Patch16: %{name}-sw13618-2.patch
|
||||||
|
Patch17: %{name}-rh783979.patch
|
||||||
|
|
||||||
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
Obsoletes: glibc-profile < 2.4
|
Obsoletes: glibc-profile < 2.4
|
||||||
@ -300,6 +301,7 @@ rm -rf %{glibcportsdir}
|
|||||||
%patch14 -p1
|
%patch14 -p1
|
||||||
%patch15 -p1
|
%patch15 -p1
|
||||||
%patch16 -p1
|
%patch16 -p1
|
||||||
|
%patch17 -p1
|
||||||
|
|
||||||
# A lot of programs still misuse memcpy when they have to use
|
# A lot of programs still misuse memcpy when they have to use
|
||||||
# memmove. The memcpy implementation below is not tolerant at
|
# memmove. The memcpy implementation below is not tolerant at
|
||||||
@ -1153,6 +1155,7 @@ rm -f *.filelist*
|
|||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
* Wed Feb 1 2012 Jeff Law <law@redhat.com> - 2.15-8
|
* Wed Feb 1 2012 Jeff Law <law@redhat.com> - 2.15-8
|
||||||
|
- Prevent erroneous inline optimization of initfini.s on PowerPC64 (#783979)
|
||||||
- Use upstream variant of fix for 740506.
|
- Use upstream variant of fix for 740506.
|
||||||
|
|
||||||
* Sun Jan 29 2012 Jeff Law <law@redhat.com> - 2.15-7
|
* Sun Jan 29 2012 Jeff Law <law@redhat.com> - 2.15-7
|
||||||
|
Loading…
Reference in New Issue
Block a user