* Thu Feb 7 2013 Carlos O'Donell <carlos@redhat.com> - 2.17-2
- Fix ownership of /usr/lib[64]/audit (#894307). - Support unmarked ARM objects in ld.so.cache and aux cache (#905184).
This commit is contained in:
parent
fb5a5a9b05
commit
db7fd60840
95
glibc-rh905184.patch
Normal file
95
glibc-rh905184.patch
Normal file
@ -0,0 +1,95 @@
|
|||||||
|
#
|
||||||
|
# Red Hat BZ:
|
||||||
|
# https://bugzilla.redhat.com/show_bug.cgi?id=905184
|
||||||
|
#
|
||||||
|
# Sourcware BZ:
|
||||||
|
# http://sourceware.org/bugzilla/show_bug.cgi?id=15006
|
||||||
|
#
|
||||||
|
# Upstream submission:
|
||||||
|
# http://www.sourceware.org/ml/libc-alpha/2013-02/msg00120.html
|
||||||
|
#
|
||||||
|
# ChangeLog
|
||||||
|
#
|
||||||
|
# 2013-02-07 Carlos O'Donell <carlos@redhat.com>
|
||||||
|
#
|
||||||
|
# * sysdeps/generic/ldconfig.h: Define FLAG_ARM_LIBSF.
|
||||||
|
# * elf/cache.c (print_entry): Add FLAG_ARM_LIBSF support.
|
||||||
|
#
|
||||||
|
# ports/ChangeLog.arm
|
||||||
|
#
|
||||||
|
# 2013-02-07 Carlos O'Donell <carlos@redhat.com>
|
||||||
|
#
|
||||||
|
# * sysdeps/unix/sysv/linux/arm/dl-cache.h
|
||||||
|
# [__ARM_PCS_VFP] (_dl_cache_check_flags): Allow plain FLAG_ELF_LIBC6.
|
||||||
|
# [!__ARM_PCS_VFP] (_dl_cache_check_flags): Likewise.
|
||||||
|
# * sysdeps/unix/sysv/linux/arm/readelflib.c (process_elf_file):
|
||||||
|
# Set FLAG_ARM_LIBSF for soft-float ABI otherwise just FLAG_ELF_LIBC6.
|
||||||
|
#
|
||||||
|
diff --git a/elf/cache.c b/elf/cache.c
|
||||||
|
index 9901952..699550b 100644
|
||||||
|
--- a/elf/cache.c
|
||||||
|
+++ b/elf/cache.c
|
||||||
|
@@ -100,6 +100,10 @@ print_entry (const char *lib, int flag, unsigned int osversion,
|
||||||
|
case FLAG_AARCH64_LIB64:
|
||||||
|
fputs (",AArch64", stdout);
|
||||||
|
break;
|
||||||
|
+ /* Uses the ARM soft-float ABI. */
|
||||||
|
+ case FLAG_ARM_LIBSF:
|
||||||
|
+ fputs (",soft-float", stdout);
|
||||||
|
+ break;
|
||||||
|
case 0:
|
||||||
|
break;
|
||||||
|
default:
|
||||||
|
diff --git a/ports/sysdeps/unix/sysv/linux/arm/dl-cache.h b/ports/sysdeps/unix/sysv/linux/arm/dl-cache.h
|
||||||
|
index acc4f28..504feca 100644
|
||||||
|
--- a/ports/sysdeps/unix/sysv/linux/arm/dl-cache.h
|
||||||
|
+++ b/ports/sysdeps/unix/sysv/linux/arm/dl-cache.h
|
||||||
|
@@ -18,12 +18,17 @@
|
||||||
|
|
||||||
|
#include <ldconfig.h>
|
||||||
|
|
||||||
|
+/* In order to support the transition from unmarked objects
|
||||||
|
+ to marked objects we must treat unmarked objects as
|
||||||
|
+ compatible with either FLAG_ARM_LIBHF or FLAG_ARM_LIBSF. */
|
||||||
|
#ifdef __ARM_PCS_VFP
|
||||||
|
# define _dl_cache_check_flags(flags) \
|
||||||
|
- ((flags) == (FLAG_ARM_LIBHF | FLAG_ELF_LIBC6))
|
||||||
|
+ ((flags) == (FLAG_ARM_LIBHF | FLAG_ELF_LIBC6) \
|
||||||
|
+ || (flags) == FLAG_ELF_LIBC6)
|
||||||
|
#else
|
||||||
|
# define _dl_cache_check_flags(flags) \
|
||||||
|
- ((flags) == FLAG_ELF_LIBC6)
|
||||||
|
+ ((flags) == (FLAG_ARM_LIBSF | FLAG_ELF_LIBC6) \
|
||||||
|
+ || (flags) == FLAG_ELF_LIBC6)
|
||||||
|
#endif
|
||||||
|
|
||||||
|
#include_next <dl-cache.h>
|
||||||
|
diff --git a/ports/sysdeps/unix/sysv/linux/arm/readelflib.c b/ports/sysdeps/unix/sysv/linux/arm/readelflib.c
|
||||||
|
index 81e5ccb..3efb613 100644
|
||||||
|
--- a/ports/sysdeps/unix/sysv/linux/arm/readelflib.c
|
||||||
|
+++ b/ports/sysdeps/unix/sysv/linux/arm/readelflib.c
|
||||||
|
@@ -46,6 +46,12 @@ process_elf_file (const char *file_name, const char *lib, int *flag,
|
||||||
|
if (elf32_header->e_flags & EF_ARM_ABI_FLOAT_HARD)
|
||||||
|
*flag = FLAG_ARM_LIBHF|FLAG_ELF_LIBC6;
|
||||||
|
else if (elf32_header->e_flags & EF_ARM_ABI_FLOAT_SOFT)
|
||||||
|
+ *flag = FLAG_ARM_LIBSF|FLAG_ELF_LIBC6;
|
||||||
|
+ else
|
||||||
|
+ /* We must assume the unmarked objects are compatible
|
||||||
|
+ with all ABI variants. Such objects may have been
|
||||||
|
+ generated in a transitional period when the ABI
|
||||||
|
+ tags were not added to all objects. */
|
||||||
|
*flag = FLAG_ELF_LIBC6;
|
||||||
|
}
|
||||||
|
}
|
||||||
|
diff --git a/sysdeps/generic/ldconfig.h b/sysdeps/generic/ldconfig.h
|
||||||
|
index 57a9a46..91190aa 100644
|
||||||
|
--- a/sysdeps/generic/ldconfig.h
|
||||||
|
+++ b/sysdeps/generic/ldconfig.h
|
||||||
|
@@ -36,6 +36,7 @@
|
||||||
|
#define FLAG_X8664_LIBX32 0x0800
|
||||||
|
#define FLAG_ARM_LIBHF 0x0900
|
||||||
|
#define FLAG_AARCH64_LIB64 0x0a00
|
||||||
|
+#define FLAG_ARM_LIBSF 0x0b00
|
||||||
|
|
||||||
|
/* Name of auxiliary cache. */
|
||||||
|
#define _PATH_LDCONFIG_AUX_CACHE "/var/cache/ldconfig/aux-cache"
|
11
glibc.spec
11
glibc.spec
@ -27,7 +27,7 @@
|
|||||||
Summary: The GNU libc libraries
|
Summary: The GNU libc libraries
|
||||||
Name: glibc
|
Name: glibc
|
||||||
Version: %{glibcversion}
|
Version: %{glibcversion}
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
# GPLv2+ is used in a bunch of programs, LGPLv2+ is used for libraries.
|
# GPLv2+ is used in a bunch of programs, LGPLv2+ is used for libraries.
|
||||||
# Things that are linked directly into dynamically linked programs
|
# Things that are linked directly into dynamically linked programs
|
||||||
# and shared libraries (e.g. crt files, lib*_nonshared.a) have an additional
|
# and shared libraries (e.g. crt files, lib*_nonshared.a) have an additional
|
||||||
@ -141,6 +141,9 @@ Patch2026: %{name}-rh841787.patch
|
|||||||
# Upstream BZ 14185
|
# Upstream BZ 14185
|
||||||
Patch2027: %{name}-rh819430.patch
|
Patch2027: %{name}-rh819430.patch
|
||||||
|
|
||||||
|
# Upstream BZ 15006
|
||||||
|
Patch2028: %{name}-rh905184.patch
|
||||||
|
|
||||||
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
Obsoletes: glibc-profile < 2.4
|
Obsoletes: glibc-profile < 2.4
|
||||||
Obsoletes: nss_db
|
Obsoletes: nss_db
|
||||||
@ -398,6 +401,7 @@ package or when debugging this package.
|
|||||||
%patch0032 -p1
|
%patch0032 -p1
|
||||||
%patch0033 -p1
|
%patch0033 -p1
|
||||||
%patch0034 -p1
|
%patch0034 -p1
|
||||||
|
%patch2028 -p1
|
||||||
|
|
||||||
# On powerpc32, hp timing is only available in power4/power6
|
# On powerpc32, hp timing is only available in power4/power6
|
||||||
# libs, not in base, so pre-power4 dynamic linker is incompatible
|
# libs, not in base, so pre-power4 dynamic linker is incompatible
|
||||||
@ -1091,6 +1095,7 @@ rm -f *.filelist*
|
|||||||
|
|
||||||
%files -f rpm.filelist
|
%files -f rpm.filelist
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
|
%dir /usr/%{_lib}/audit
|
||||||
%ifarch %{rtkaioarches}
|
%ifarch %{rtkaioarches}
|
||||||
%dir /%{_lib}/rtkaio
|
%dir /%{_lib}/rtkaio
|
||||||
%endif
|
%endif
|
||||||
@ -1192,6 +1197,10 @@ rm -f *.filelist*
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Feb 7 2013 Carlos O'Donell <carlos@redhat.com> - 2.17-2
|
||||||
|
- Fix ownership of /usr/lib[64]/audit (#894307).
|
||||||
|
- Support unmarked ARM objects in ld.so.cache and aux cache (#905184).
|
||||||
|
|
||||||
* Tue Jan 1 2013 Jeff Law <law@redhat.com> - 2.17-1
|
* Tue Jan 1 2013 Jeff Law <law@redhat.com> - 2.17-1
|
||||||
- Resync with official glibc-2.17 release
|
- Resync with official glibc-2.17 release
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user