Revert "Merge remote-tracking branch 'origin/f16' into f16"

This reverts commit 3e058f4c4c, reversing
changes made to a515186e36.
This commit is contained in:
Jeff Law 2011-11-15 22:03:21 -07:00
parent e5b54e6a82
commit d930a6ebb2
5 changed files with 456 additions and 320 deletions

6
.gitignore vendored
View File

@ -1,3 +1,3 @@
/glibc-2.14-418-gb2ea1df-fedora.tar.xz
/glibc-2.14-418-gb2ea1df.tar.xz
/glibc-ports-2.14-43-gf335e01.tar.xz
/glibc-ports-2.14-25-gd3d9bde.tar.xz
/glibc-2.14-394-g8f3b1ff-fedora.tar.xz
/glibc-2.14-394-g8f3b1ff.tar.xz

File diff suppressed because it is too large Load Diff

View File

@ -0,0 +1,49 @@
From 7327af4c323f6d4f500bf4aaa66a9cac6236772f Mon Sep 17 00:00:00 2001
From: Jim Meyering <meyering@redhat.com>
Date: Wed, 26 Oct 2011 20:08:52 +0200
Subject: [PATCH] Revert "Use leaf function attribute in __THROW"
This reverts commit aa78043a4aafe5db1a1a76d544a833b63b4c5f5c
and the related 49a43d80ec5c97cf6136b1ee2687414773b2d5aa.
This fixes http://bugzilla.redhat.com/747377
---
misc/sys/cdefs.h | 15 +++------------
2 files changed, 3 insertions(+), 14 deletions(-)
diff --git a/misc/sys/cdefs.h b/misc/sys/cdefs.h
index 72073e8..165a94a 100644
--- a/misc/sys/cdefs.h
+++ b/misc/sys/cdefs.h
@@ -38,27 +38,18 @@
#ifdef __GNUC__
-/* All functions, except those with callbacks, are leaf functions. */
-# if __GNUC_PREREQ (4, 6) && !defined _LIBC
-# define __LEAF , __leaf__
-# define __LEAF_ATTR __attribute__ ((__leaf__))
-# else
-# define __LEAF
-# define __LEAF_ATTR
-# endif
-
/* GCC can always grok prototypes. For C++ programs we add throw()
to help it optimize the function calls. But this works only with
gcc 2.8.x and egcs. For gcc 3.2 and up we even mark C functions
as non-throwing using a function attribute since programs can use
the -fexceptions options for C code as well. */
# if !defined __cplusplus && __GNUC_PREREQ (3, 3)
-# define __THROW __attribute__ ((__nothrow__ __LEAF))
-# define __NTH(fct) __attribute__ ((__nothrow__ __LEAF)) fct
+# define __THROW __attribute__ ((__nothrow__))
+# define __NTH(fct) __attribute__ ((__nothrow__)) fct
# else
# if defined __cplusplus && __GNUC_PREREQ (2,8)
# define __THROW throw ()
-# define __NTH(fct) __LEAF_ATTR fct throw ()
+# define __NTH(fct) fct throw ()
# else
# define __THROW
# define __NTH(fct) fct
--
1.7.7.1

View File

@ -1,6 +1,6 @@
%define glibcsrcdir glibc-2.14-418-gb2ea1df
%define glibcsrcdir glibc-2.14-394-g8f3b1ff
%define glibcversion 2.14.90
%define glibcportsdir glibc-ports-2.14-43-gf335e01
%define glibcportsdir glibc-ports-2.14-25-gd3d9bde
### glibc.spec.in follows:
%define run_glibc_tests 1
%define auxarches athlon alphaev6
@ -28,7 +28,7 @@
Summary: The GNU libc libraries
Name: glibc
Version: %{glibcversion}
Release: 15.1
Release: 15
# GPLv2+ is used in a bunch of programs, LGPLv2+ is used for libraries.
# Things that are linked directly into dynamically linked programs
# and shared libraries (e.g. crt files, lib*_nonshared.a) have an additional
@ -42,6 +42,7 @@ Source1: %{?glibc_release_url}%{glibcportsdir}.tar.xz
Source2: %{glibcsrcdir}-fedora.tar.xz
Patch0: %{name}-fedora.patch
Patch1: %{name}-ia64-lib64.patch
Patch2: %{name}-no-leaf-attribute.patch
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
Obsoletes: glibc-profile < 2.4
Obsoletes: nss_db
@ -260,6 +261,7 @@ rm -rf %{glibcportsdir}
%patch1 -p1
%endif
%endif
%patch2 -p1
# A lot of programs still misuse memcpy when they have to use
# memmove. The memcpy implementation below is not tolerant at
@ -1112,21 +1114,13 @@ rm -f *.filelist*
%endif
%changelog
* Tue Nov 8 2011 Andreas Schwab <schwab@redhat.com> - 2.4.90-14
- Update from master
- Fix locking in _IO_flush_all_lockp
- Fix buffer allocation in files initgroups handler
- Don't start AVC thread until credentials are installed
- Don't fail in makedb if SELinux is disabled
- New Linux syscalls process_vm_readv and process_vm_writev
- Unify getent output for initgroups database (BZ#13367)
- Avoid assertion in processes with VM in bad shape (BZ#13276)
- Don't mark memory synchronisation functions as leaf (#747377, BZ#13344)
- Add missing register initialization in x86-64
pthread_cond_timedwait (BZ#13358)
- Correctly NUL-terminate link name in sprof (BZ#13337)
- Fix readlink call in ldconfig's chroot handling (BZ#13335)
- Preserve link time dependencies over relocation dependencies (BZ#12892)
* Wed Oct 26 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.14.90-15
- Rebuilt for glibc bug#747377
* Wed Oct 19 2011 Jim Meyering <meyering@redhat.com> - 2.14.90-14
- Revert the upstream patch that added the leaf attribute, since it
caused gcc -O2 to move code past thread primitives and sometimes
even out of critical sections. See http://bugzilla.redhat.com/747377
* Wed Oct 19 2011 Andreas Schwab <schwab@redhat.com> - 2.14.90-13
- Update from master

View File

@ -1,3 +1,3 @@
bce89b90d75eb65d573c89d231128a45 glibc-2.14-418-gb2ea1df-fedora.tar.xz
a1c214925f0f2dabf4f88bddb1fcf39e glibc-2.14-418-gb2ea1df.tar.xz
b89c04e859de608e0c6b33ab77923527 glibc-ports-2.14-43-gf335e01.tar.xz
6cb0f013d410bf40e1a1d28a5d9f95b9 glibc-2.14-394-g8f3b1ff-fedora.tar.xz
860f193936a67a1fd1e06c2b85912477 glibc-2.14-394-g8f3b1ff.tar.xz
9673adaacae3ac645748827a62876ce9 glibc-ports-2.14-25-gd3d9bde.tar.xz