- Fix AVX checks (#801650)
This commit is contained in:
parent
b113737687
commit
d893fa43b7
@ -4,39 +4,12 @@ Date: Thu Jan 26 07:45:14 2012 -0500
|
|||||||
|
|
||||||
Reset bit_AVX in __cpu_features is OS support is missing
|
Reset bit_AVX in __cpu_features is OS support is missing
|
||||||
|
|
||||||
diff --git a/ChangeLog b/ChangeLog
|
2012-01-26 Ulrich Drepper <drepper@gmail.com>
|
||||||
index a0b355e..1e2284f 100644
|
|
||||||
--- a/ChangeLog
|
|
||||||
+++ b/ChangeLog
|
|
||||||
@@ -1,3 +1,10 @@
|
|
||||||
+2012-01-26 Ulrich Drepper <drepper@gmail.com>
|
|
||||||
+
|
|
||||||
+ [BZ #13583]
|
|
||||||
+ * sysdeps/x86_64/multiarch/init-arch.h: Define bit_OSXSAVE.
|
|
||||||
+ * sysdeps/x86_64/multiarch/init-arch.c (__init_cpu_features): If
|
|
||||||
+ bit_AVX is set also check OSXAVE/XCR0 and reset bit_AVX if necessary.
|
|
||||||
+
|
|
||||||
2012-01-25 Joseph Myers <joseph@codesourcery.com>
|
|
||||||
|
|
||||||
* elf/tst-unique3.cc (gets): Remove declaration.
|
[BZ #13583]
|
||||||
diff --git a/NEWS b/NEWS
|
* sysdeps/x86_64/multiarch/init-arch.h: Define bit_OSXSAVE.
|
||||||
index 5e062af..42e09c1 100644
|
* sysdeps/x86_64/multiarch/init-arch.c (__init_cpu_features): If
|
||||||
--- a/NEWS
|
bit_AVX is set also check OSXAVE/XCR0 and reset bit_AVX if necessary.
|
||||||
+++ b/NEWS
|
|
||||||
@@ -1,4 +1,4 @@
|
|
||||||
-GNU C Library NEWS -- history of user-visible changes. 2012-1-10
|
|
||||||
+GNU C Library NEWS -- history of user-visible changes. 2012-1-26
|
|
||||||
Copyright (C) 1992-2009, 2010, 2011, 2012 Free Software Foundation, Inc.
|
|
||||||
See the end for copying conditions.
|
|
||||||
|
|
||||||
@@ -10,7 +10,7 @@ Version 2.16
|
|
||||||
* The following bugs are resolved with this release:
|
|
||||||
|
|
||||||
13525, 13526, 13527, 13528, 13529, 13531, 13532, 13533, 13547, 13530,
|
|
||||||
- 13551, 13552, 13553, 13555, 13559
|
|
||||||
+ 13551, 13552, 13553, 13555, 13559, 13583
|
|
||||||
|
|
||||||
* ISO C11 support:
|
|
||||||
|
|
||||||
diff --git a/sysdeps/x86_64/multiarch/init-arch.c b/sysdeps/x86_64/multiarch/init-arch.c
|
diff --git a/sysdeps/x86_64/multiarch/init-arch.c b/sysdeps/x86_64/multiarch/init-arch.c
|
||||||
index 65b0ee9..4fabbee 100644
|
index 65b0ee9..4fabbee 100644
|
||||||
|
@ -8,26 +8,19 @@ Date: Thu Jan 26 09:45:54 2012 -0500
|
|||||||
The math routines might since gcc perhaps generates such code.
|
The math routines might since gcc perhaps generates such code.
|
||||||
Introduce bit_YMM_USBALE and use it in the math routines.
|
Introduce bit_YMM_USBALE and use it in the math routines.
|
||||||
|
|
||||||
diff --git a/ChangeLog b/ChangeLog
|
|
||||||
index 1e2284f..b413d27 100644
|
|
||||||
--- a/ChangeLog
|
|
||||||
+++ b/ChangeLog
|
|
||||||
@@ -2,8 +2,17 @@
|
|
||||||
|
|
||||||
[BZ #13583]
|
[BZ #13583]
|
||||||
* sysdeps/x86_64/multiarch/init-arch.h: Define bit_OSXSAVE.
|
* sysdeps/x86_64/multiarch/init-arch.h: Define bit_OSXSAVE.
|
||||||
+ Clean up HAS_* macros.
|
Clean up HAS_* macros.
|
||||||
* sysdeps/x86_64/multiarch/init-arch.c (__init_cpu_features): If
|
* sysdeps/x86_64/multiarch/init-arch.c (__init_cpu_features): If
|
||||||
- bit_AVX is set also check OSXAVE/XCR0 and reset bit_AVX if necessary.
|
bit_AVX is set also check OSXAVE/XCR0 and set bit_YMM_Usable if
|
||||||
+ bit_AVX is set also check OSXAVE/XCR0 and set bit_YMM_Usable if
|
possible.
|
||||||
+ possible.
|
* sysdeps/x86_64/fpu/multiarch/e_atan2.c: Use HAS_YMM_USABLE, not
|
||||||
+ * sysdeps/x86_64/fpu/multiarch/e_atan2.c: Use HAS_YMM_USABLE, not
|
HAS_AVX.
|
||||||
+ HAS_AVX.
|
* sysdeps/x86_64/fpu/multiarch/e_exp.c: Likewise.
|
||||||
+ * sysdeps/x86_64/fpu/multiarch/e_exp.c: Likewise.
|
* sysdeps/x86_64/fpu/multiarch/e_log.c: Likewise.
|
||||||
+ * sysdeps/x86_64/fpu/multiarch/e_log.c: Likewise.
|
* sysdeps/x86_64/fpu/multiarch/s_atan.c: Likewise.
|
||||||
+ * sysdeps/x86_64/fpu/multiarch/s_atan.c: Likewise.
|
* sysdeps/x86_64/fpu/multiarch/s_sin.c: Likewise.
|
||||||
+ * sysdeps/x86_64/fpu/multiarch/s_sin.c: Likewise.
|
* sysdeps/x86_64/fpu/multiarch/s_tan.c: Likewise.
|
||||||
+ * sysdeps/x86_64/fpu/multiarch/s_tan.c: Likewise.
|
|
||||||
|
|
||||||
2012-01-25 Joseph Myers <joseph@codesourcery.com>
|
2012-01-25 Joseph Myers <joseph@codesourcery.com>
|
||||||
|
|
||||||
|
10
glibc.spec
10
glibc.spec
@ -28,7 +28,7 @@
|
|||||||
Summary: The GNU libc libraries
|
Summary: The GNU libc libraries
|
||||||
Name: glibc
|
Name: glibc
|
||||||
Version: %{glibcversion}
|
Version: %{glibcversion}
|
||||||
Release: 26%{?dist}
|
Release: 27%{?dist}
|
||||||
# GPLv2+ is used in a bunch of programs, LGPLv2+ is used for libraries.
|
# GPLv2+ is used in a bunch of programs, LGPLv2+ is used for libraries.
|
||||||
# Things that are linked directly into dynamically linked programs
|
# Things that are linked directly into dynamically linked programs
|
||||||
# and shared libraries (e.g. crt files, lib*_nonshared.a) have an additional
|
# and shared libraries (e.g. crt files, lib*_nonshared.a) have an additional
|
||||||
@ -114,6 +114,9 @@ Patch39 : %{name}-rh758888.patch
|
|||||||
Patch40 : %{name}-rh800224.patch
|
Patch40 : %{name}-rh800224.patch
|
||||||
# From upstream
|
# From upstream
|
||||||
Patch41 : %{name}-rh794797-2.patch
|
Patch41 : %{name}-rh794797-2.patch
|
||||||
|
# From upstream
|
||||||
|
Patch42 : %{name}-rh801650-1.patch
|
||||||
|
Patch43 : %{name}-rh801650-2.patch
|
||||||
|
|
||||||
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
Obsoletes: glibc-profile < 2.4
|
Obsoletes: glibc-profile < 2.4
|
||||||
@ -373,6 +376,8 @@ rm -rf %{glibcportsdir}
|
|||||||
%patch39 -p1
|
%patch39 -p1
|
||||||
%patch40 -p1
|
%patch40 -p1
|
||||||
%patch41 -p1
|
%patch41 -p1
|
||||||
|
%patch42 -p1
|
||||||
|
%patch43 -p1
|
||||||
|
|
||||||
# A lot of programs still misuse memcpy when they have to use
|
# A lot of programs still misuse memcpy when they have to use
|
||||||
# memmove. The memcpy implementation below is not tolerant at
|
# memmove. The memcpy implementation below is not tolerant at
|
||||||
@ -1225,6 +1230,9 @@ rm -f *.filelist*
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Mar 09 2012 Jeff Law <law@redhat.com> - 2.15-27
|
||||||
|
- Fix AVX checks (#801650)
|
||||||
|
|
||||||
* Wed Feb 29 2012 Jeff Law <law@redhat.com> - 2.15-26
|
* Wed Feb 29 2012 Jeff Law <law@redhat.com> - 2.15-26
|
||||||
- Set errno properly in vfprintf (#794797)
|
- Set errno properly in vfprintf (#794797)
|
||||||
- Don't kill application when LD_PROFILE is set. (#800224)
|
- Don't kill application when LD_PROFILE is set. (#800224)
|
||||||
|
Loading…
Reference in New Issue
Block a user