- Resync with master
- Drop local patch for 657588 that is no longer needed. - Drop lotch patch for nss-files-overflow that seems useless. - Repack patchlist.
This commit is contained in:
parent
03545a8efd
commit
d5297ae5f7
2
.gitignore
vendored
2
.gitignore
vendored
@ -77,3 +77,5 @@ glibc-2.14-394-g8f3b1ff
|
||||
/glibc-2.16.90-2af1b328.tar.gz
|
||||
/glibc-2.16.90-1a538b9f-fedora.tar.gz
|
||||
/glibc-2.16.90-1a538b9f.tar.gz
|
||||
/glibc-2.16.90-70e5aee4-fedora.tar.gz
|
||||
/glibc-2.16.90-70e5aee4.tar.gz
|
||||
|
@ -1,25 +0,0 @@
|
||||
From f7001472d8d6ee9c5f83170c850a8a3b3ca0635f Mon Sep 17 00:00:00 2001
|
||||
From: Andreas Schwab <schwab@redhat.com>
|
||||
Date: Fri, 20 Aug 2010 17:04:03 +0200
|
||||
Subject: [PATCH] Fix overflow in nss files parser
|
||||
|
||||
* nss/nss_files/files-XXX.c (internal_getent): Declare linebuflen
|
||||
as size_t.
|
||||
|
||||
---
|
||||
ChangeLog | 3 +++
|
||||
nss/nss_files/files-XXX.c | 4 ++--
|
||||
2 files changed, 5 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/nss/nss_files/files-XXX.c b/nss/nss_files/files-XXX.c
|
||||
--- a/nss/nss_files/files-XXX.c
|
||||
+++ b/nss/nss_files/files-XXX.c
|
||||
@@ -189,7 +189,7 @@ internal_getent (struct STRUCTURE *result,
|
||||
{
|
||||
char *p;
|
||||
struct parser_data *data = (void *) buffer;
|
||||
- int linebuflen = buffer + buflen - data->linebuffer;
|
||||
+ size_t linebuflen = buffer + buflen - data->linebuffer;
|
||||
int parse_result;
|
||||
|
||||
if (buflen < sizeof *data + 2)
|
@ -1,20 +0,0 @@
|
||||
diff -rup a/localedata/locales/zh_CN b/localedata/locales/zh_CN
|
||||
--- a/localedata/locales/zh_CN 2006-07-30 16:19:43.000000000 -0600
|
||||
+++ b/localedata/locales/zh_CN 2012-01-30 21:24:46.905115483 -0700
|
||||
@@ -108,11 +108,11 @@ day "<U661F><U671F><U65E5>";/
|
||||
"<U661F><U671F><U4E94>";/
|
||||
"<U661F><U671F><U516D>"
|
||||
|
||||
-abmon "<U0020><U0031><U6708>";"<U0020><U0032><U6708>";/
|
||||
- "<U0020><U0033><U6708>";"<U0020><U0034><U6708>";/
|
||||
- "<U0020><U0035><U6708>";"<U0020><U0036><U6708>";/
|
||||
- "<U0020><U0037><U6708>";"<U0020><U0038><U6708>";/
|
||||
- "<U0020><U0039><U6708>";"<U0031><U0030><U6708>";/
|
||||
+abmon "<U0031><U6708>";"<U0032><U6708>";/
|
||||
+ "<U0033><U6708>";"<U0034><U6708>";/
|
||||
+ "<U0035><U6708>";"<U0036><U6708>";/
|
||||
+ "<U0037><U6708>";"<U0038><U6708>";/
|
||||
+ "<U0039><U6708>";"<U0031><U0030><U6708>";/
|
||||
"<U0031><U0031><U6708>";"<U0031><U0032><U6708>"
|
||||
|
||||
mon "<U4E00><U6708>";"<U4E8C><U6708>";"<U4E09><U6708>";/
|
22
glibc.spec
22
glibc.spec
@ -1,4 +1,4 @@
|
||||
%define glibcsrcdir glibc-2.16.90-1a538b9f
|
||||
%define glibcsrcdir glibc-2.16.90-70e5aee4
|
||||
%define glibcversion 2.16.90
|
||||
### glibc.spec.in follows:
|
||||
%define run_glibc_tests 1
|
||||
@ -27,7 +27,7 @@
|
||||
Summary: The GNU libc libraries
|
||||
Name: glibc
|
||||
Version: %{glibcversion}
|
||||
Release: 35%{?dist}
|
||||
Release: 36%{?dist}
|
||||
# GPLv2+ is used in a bunch of programs, LGPLv2+ is used for libraries.
|
||||
# Things that are linked directly into dynamically linked programs
|
||||
# and shared libraries (e.g. crt files, lib*_nonshared.a) have an additional
|
||||
@ -64,8 +64,7 @@ Source1: %{glibcsrcdir}-fedora.tar.gz
|
||||
Patch0001: %{name}-fedora-nscd.patch
|
||||
|
||||
Patch0002: %{name}-fedora-regcomp-sw11561.patch
|
||||
|
||||
Patch0003: %{name}-fedora-nss-files-overflow-fix.patch
|
||||
Patch0003: %{name}-fedora-ldd.patch
|
||||
|
||||
Patch0004: %{name}-fedora-ppc-unwind.patch
|
||||
|
||||
@ -83,9 +82,7 @@ Patch0007: %{name}-rh697421.patch
|
||||
|
||||
# Needs to be sent upstream
|
||||
Patch0008: %{name}-rh740682.patch
|
||||
|
||||
# Needs to be sent upstream
|
||||
Patch0009: %{name}-rh657588.patch
|
||||
Patch0009: %{name}-fedora-include-bits-ldbl.patch
|
||||
|
||||
# stap, needs to be sent upstream
|
||||
Patch0010: %{name}-stap-libm.patch
|
||||
@ -118,8 +115,6 @@ Patch0038: %{name}-fedora-localedef.patch
|
||||
Patch0039: %{name}-fedora-getrlimit-PLT.patch
|
||||
Patch0040: %{name}-fedora-i386-tls-direct-seg-refs.patch
|
||||
Patch0041: %{name}-fedora-pt_chown.patch
|
||||
Patch0042: %{name}-fedora-include-bits-ldbl.patch
|
||||
Patch0043: %{name}-fedora-ldd.patch
|
||||
|
||||
#
|
||||
# Patches from upstream
|
||||
@ -418,8 +413,6 @@ package or when debugging this package.
|
||||
%patch0039 -p1
|
||||
%patch0040 -p1
|
||||
%patch0041 -p1
|
||||
%patch0042 -p1
|
||||
%patch0043 -p1
|
||||
|
||||
# On powerpc32, hp timing is only available in power4/power6
|
||||
# libs, not in base, so pre-power4 dynamic linker is incompatible
|
||||
@ -1214,6 +1207,13 @@ rm -f *.filelist*
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Mon Dec 3 2012 Jeff Law <law@redhat.com> - 2.16.90-36
|
||||
- Resync with master
|
||||
- Drop local patch for 657588 that is no longer needed.
|
||||
- Drop lotch patch for nss-files-overflow that seems
|
||||
useless.
|
||||
- Repack patchlist.
|
||||
|
||||
* Fri Nov 30 2012 Jeff Law <law@redhat.com> - 2.16.90-35
|
||||
- Resync with master (#882137).
|
||||
- Remove local patch for strict-aliasing warnings that
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
f55e091ccdae9a29dd183116091ed679 glibc-2.16.90-1a538b9f-fedora.tar.gz
|
||||
37289795583e3897226edf1ad24c261a glibc-2.16.90-1a538b9f.tar.gz
|
||||
9c01e48bb4243efe6eccd816e7778397 glibc-2.16.90-70e5aee4-fedora.tar.gz
|
||||
b916c52cb084837eabb4107e7fb830ca glibc-2.16.90-70e5aee4.tar.gz
|
||||
|
Loading…
Reference in New Issue
Block a user