Auto-sync with upstream branch master
Upstream commit: 2d2d7e1a8f2e62b442ae8978f0a6c17f385575c4 - configure: Allow user override LD, AR, OBJCOPY, and GPROF - math: Suppress -O0 warnings for soft-fp fsqrt [BZ #19444] - sunrpc: Suppress GCC -O1 warning on user2netname [BZ #19444] - locale: Use correct buffer size for utf8_sequence_error [BZ #19444] - Add HWCAP2_SVE_EBF16 from Linux 6.1 to AArch64 bits/hwcap.h - Add _FORTIFY_SOURCE implementation documentation [BZ #28998] - Update copyright dates not handled by scripts/update-copyrights - Update copyright dates with scripts/update-copyrights - Remove trailing whitespace in gmp.h - Remove trailing whitespace - C2x semantics for <tgmath.h> - time: Set daylight to 1 for matching DST/offset change (bug 29951) - Fix ldbl-128 built-in function use - x86: Check minimum/maximum of non_temporal_threshold [BZ #29953] - i686: Regenerate ulps
This commit is contained in:
parent
2ceebf21f1
commit
d000e6b3e6
@ -9,23 +9,28 @@ python3 during a transitional phase.
|
||||
Author: Carlos O'Donell <carlos@redhat.com>
|
||||
|
||||
|
||||
|
||||
diff --git a/benchtests/scripts/compare_bench.py b/benchtests/scripts/compare_bench.py
|
||||
index a85ca3a38be1fdeb..9f1ea9d85f4b833a 100755
|
||||
index 9a91c2649106a740..9f1ea9d85f4b833a 100755
|
||||
--- a/benchtests/scripts/compare_bench.py
|
||||
+++ b/benchtests/scripts/compare_bench.py
|
||||
@@ -1,4 +1,4 @@
|
||||
@@ -1,5 +1,5 @@
|
||||
-#!/usr/bin/python
|
||||
-# Copyright (C) 2015-2023 Free Software Foundation, Inc.
|
||||
+#!/usr/bin/python3
|
||||
# Copyright (C) 2015-2022 Free Software Foundation, Inc.
|
||||
+# Copyright (C) 2015-2022 Free Software Foundation, Inc.
|
||||
# This file is part of the GNU C Library.
|
||||
#
|
||||
# The GNU C Library is free software; you can redistribute it and/or
|
||||
diff --git a/benchtests/scripts/import_bench.py b/benchtests/scripts/import_bench.py
|
||||
index d8bdde7753885a4d..698c4ff81b13f697 100644
|
||||
index 92d9dc4fbaf08382..698c4ff81b13f697 100644
|
||||
--- a/benchtests/scripts/import_bench.py
|
||||
+++ b/benchtests/scripts/import_bench.py
|
||||
@@ -1,4 +1,4 @@
|
||||
@@ -1,5 +1,5 @@
|
||||
-#!/usr/bin/python
|
||||
-# Copyright (C) 2015-2023 Free Software Foundation, Inc.
|
||||
+#!/usr/bin/python3
|
||||
# Copyright (C) 2015-2022 Free Software Foundation, Inc.
|
||||
+# Copyright (C) 2015-2022 Free Software Foundation, Inc.
|
||||
# This file is part of the GNU C Library.
|
||||
#
|
||||
# The GNU C Library is free software; you can redistribute it and/or
|
||||
|
23
glibc.spec
23
glibc.spec
@ -1,4 +1,4 @@
|
||||
%global glibcsrcdir glibc-2.36.9000-415-g5f55b22f4b
|
||||
%global glibcsrcdir glibc-2.36.9000-430-g2d2d7e1a8f
|
||||
%global glibcversion 2.36.9000
|
||||
# Pre-release tarballs are pulled in from git using a command that is
|
||||
# effectively:
|
||||
@ -159,7 +159,7 @@ Version: %{glibcversion}
|
||||
# - It allows using the Release number without the %%dist tag in the dependency
|
||||
# generator to make the generated requires interchangeable between Rawhide
|
||||
# and ELN (.elnYY < .fcXX).
|
||||
%global baserelease 20
|
||||
%global baserelease 21
|
||||
Release: %{baserelease}%{?dist}
|
||||
|
||||
# In general, GPLv2+ is used by programs, LGPLv2+ is used for
|
||||
@ -2193,6 +2193,25 @@ update_gconv_modules_cache ()
|
||||
%files -f compat-libpthread-nonshared.filelist -n compat-libpthread-nonshared
|
||||
|
||||
%changelog
|
||||
* Wed Jan 11 2023 Patsy Griffin <patsy@redhat.com> - 2.36.9000-21
|
||||
- Auto-sync with upstream branch master,
|
||||
commit 2d2d7e1a8f2e62b442ae8978f0a6c17f385575c4.
|
||||
- configure: Allow user override LD, AR, OBJCOPY, and GPROF
|
||||
- math: Suppress -O0 warnings for soft-fp fsqrt [BZ #19444]
|
||||
- sunrpc: Suppress GCC -O1 warning on user2netname [BZ #19444]
|
||||
- locale: Use correct buffer size for utf8_sequence_error [BZ #19444]
|
||||
- Add HWCAP2_SVE_EBF16 from Linux 6.1 to AArch64 bits/hwcap.h
|
||||
- Add _FORTIFY_SOURCE implementation documentation [BZ #28998]
|
||||
- Update copyright dates not handled by scripts/update-copyrights
|
||||
- Update copyright dates with scripts/update-copyrights
|
||||
- Remove trailing whitespace in gmp.h
|
||||
- Remove trailing whitespace
|
||||
- C2x semantics for <tgmath.h>
|
||||
- time: Set daylight to 1 for matching DST/offset change (bug 29951)
|
||||
- Fix ldbl-128 built-in function use
|
||||
- x86: Check minimum/maximum of non_temporal_threshold [BZ #29953]
|
||||
- i686: Regenerate ulps
|
||||
|
||||
* Mon Jan 02 2023 Arjun Shankar <arjun@redhat.com> - 2.36.9000-20
|
||||
- Drop glibc-rh2155825.patch; fix applied upstream, and
|
||||
- Auto-sync with upstream branch master,
|
||||
|
1
sources
1
sources
@ -1 +1,2 @@
|
||||
SHA512 (glibc-2.36.9000-415-g5f55b22f4b.tar.xz) = fba6e81e710b5585c67181a4e5b8dd4617f4c0dbe96c79c88e4adaf47e2919ad4ba4609c32db6d4615ed34493e52e02d74b6489ef2d479a4f5581b12dade5006
|
||||
SHA512 (glibc-2.36.9000-430-g2d2d7e1a8f.tar.xz) = d2736c48c99ffe11972e6cb87d6835ad94abc0f74c328ff6c1f6d4a529da3c2af783c1745c951b1a94bbce5ca4d108755c2556245adfc865a073c22874bb0f0a
|
||||
|
Loading…
Reference in New Issue
Block a user