2.14-3
This commit is contained in:
parent
78124418b9
commit
cecb16f60f
6
.gitignore
vendored
6
.gitignore
vendored
@ -1,3 +1,3 @@
|
||||
/glibc-ports-2.13-35-g8969f4d.tar.xz
|
||||
/glibc-2.14-fedora.tar.xz
|
||||
/glibc-2.14.tar.xz
|
||||
/glibc-2.14-12-g5babac1-fedora.tar.xz
|
||||
/glibc-2.14-12-g5babac1.tar.xz
|
||||
/glibc-ports-2.14.tar.xz
|
||||
|
File diff suppressed because it is too large
Load Diff
@ -1,46 +0,0 @@
|
||||
diff -U0 glibc-2.14/ChangeLog.orig glibc-2.14/ChangeLog
|
||||
diff -up glibc-2.14/sysdeps/s390/s390-64/utf16-utf32-z9.c.orig glibc-2.14/sysdeps/s390/s390-64/utf16-utf32-z9.c
|
||||
--- glibc-2.14/sysdeps/s390/s390-64/utf16-utf32-z9.c.orig 2011-05-31 06:12:33.000000000 +0200
|
||||
+++ glibc-2.14/sysdeps/s390/s390-64/utf16-utf32-z9.c 2011-06-09 14:44:52.000000000 +0200
|
||||
@@ -169,10 +169,7 @@ gconv_end (struct __gconv_step *data)
|
||||
register unsigned long long outlen asm("11") = outend - outptr; \
|
||||
uint64_t cc = 0; \
|
||||
\
|
||||
- asm volatile (".machine push \n\t" \
|
||||
- ".machine \"z9-109\" \n\t" \
|
||||
- "0: " INSTRUCTION " \n\t" \
|
||||
- ".machine pop \n\t" \
|
||||
+ asm volatile ("0: " INSTRUCTION " \n\t" \
|
||||
" jo 0b \n\t" \
|
||||
" ipm %2 \n" \
|
||||
: "+a" (pOutput), "+a" (pInput), "+d" (cc), \
|
||||
diff -up glibc-2.14/sysdeps/s390/s390-64/utf8-utf16-z9.c.orig glibc-2.14/sysdeps/s390/s390-64/utf8-utf16-z9.c
|
||||
--- glibc-2.14/sysdeps/s390/s390-64/utf8-utf16-z9.c.orig 2011-05-31 06:12:33.000000000 +0200
|
||||
+++ glibc-2.14/sysdeps/s390/s390-64/utf8-utf16-z9.c 2011-06-09 14:44:55.000000000 +0200
|
||||
@@ -151,10 +151,7 @@ gconv_end (struct __gconv_step *data)
|
||||
register unsigned long long outlen asm("11") = outend - outptr; \
|
||||
uint64_t cc = 0; \
|
||||
\
|
||||
- asm volatile (".machine push \n\t" \
|
||||
- ".machine \"z9-109\" \n\t" \
|
||||
- "0: " INSTRUCTION " \n\t" \
|
||||
- ".machine pop \n\t" \
|
||||
+ asm volatile ("0: " INSTRUCTION " \n\t" \
|
||||
" jo 0b \n\t" \
|
||||
" ipm %2 \n" \
|
||||
: "+a" (pOutput), "+a" (pInput), "+d" (cc), \
|
||||
diff -up glibc-2.14/sysdeps/s390/s390-64/utf8-utf32-z9.c.orig glibc-2.14/sysdeps/s390/s390-64/utf8-utf32-z9.c
|
||||
--- glibc-2.14/sysdeps/s390/s390-64/utf8-utf32-z9.c.orig 2011-05-31 06:12:33.000000000 +0200
|
||||
+++ glibc-2.14/sysdeps/s390/s390-64/utf8-utf32-z9.c 2011-06-09 14:44:55.000000000 +0200
|
||||
@@ -155,10 +155,7 @@ gconv_end (struct __gconv_step *data)
|
||||
register unsigned long long outlen asm("11") = outend - outptr; \
|
||||
uint64_t cc = 0; \
|
||||
\
|
||||
- asm volatile (".machine push \n\t" \
|
||||
- ".machine \"z9-109\" \n\t" \
|
||||
- "0: " INSTRUCTION " \n\t" \
|
||||
- ".machine pop \n\t" \
|
||||
+ asm volatile ("0: " INSTRUCTION " \n\t" \
|
||||
" jo 0b \n\t" \
|
||||
" ipm %2 \n" \
|
||||
: "+a" (pOutput), "+a" (pInput), "+d" (cc), \
|
20
glibc.spec
20
glibc.spec
@ -1,6 +1,6 @@
|
||||
%define glibcsrcdir glibc-2.14
|
||||
%define glibcsrcdir glibc-2.14-12-g5babac1
|
||||
%define glibcversion 2.14
|
||||
%define glibcportsdir glibc-ports-2.13-35-g8969f4d
|
||||
%define glibcportsdir glibc-ports-2.14
|
||||
### glibc.spec.in follows:
|
||||
%define run_glibc_tests 1
|
||||
%define auxarches athlon alphaev6
|
||||
@ -41,8 +41,6 @@ Source1: %{?glibc_release_url}%{glibcportsdir}.tar.xz
|
||||
Source2: %{glibcsrcdir}-fedora.tar.xz
|
||||
Patch0: %{name}-fedora.patch
|
||||
Patch1: %{name}-ia64-lib64.patch
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=711330
|
||||
Patch2: %{name}-revert-27390476.patch
|
||||
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
Obsoletes: glibc-profile < 2.4
|
||||
Provides: ldconfig
|
||||
@ -259,7 +257,6 @@ rm -rf %{glibcportsdir}
|
||||
%patch1 -p1
|
||||
%endif
|
||||
%endif
|
||||
%patch2 -p1
|
||||
|
||||
# A lot of programs still misuse memcpy when they have to use
|
||||
# memmove. The memcpy implementation below is not tolerant at
|
||||
@ -1054,8 +1051,17 @@ rm -f *.filelist*
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Thu Jun 9 2011 Dan Horák <dan[at]danny.cz> - 2.14-3
|
||||
- revert glibc commit 27390476 as it requires binutils >= 2.21.52.0.1 (#711330)
|
||||
* Mon Jun 21 2011 Andreas Schwab <schwab@redhat.com> - 2.14-3
|
||||
- Update from 2.14 branch
|
||||
- Fix typo in recent resolver change which causes segvs (#710279)
|
||||
- Fix memory leak in getaddrinfo (#712178)
|
||||
- Fix <bits/mqueue2.h> for C++ (BZ#12841)
|
||||
- Assume Intel Core i3/i5/i7 processor if AVX is available
|
||||
- Filter results from gethostbyname4_r according to request flags
|
||||
(#711827)
|
||||
- Repair GB18030 charmap (#712901)
|
||||
- Revert "Use .machine to prevent AS from complaining about z9-109
|
||||
instructions in iconv modules" (#711330)
|
||||
|
||||
* Fri Jun 3 2011 Andreas Schwab <schwab@redhat.com> - 2.14-2
|
||||
- Revert "Handle DNS server failures in case of AF_UNSPEC lookups
|
||||
|
6
sources
6
sources
@ -1,3 +1,3 @@
|
||||
13604bf93e96992ee8c14d76f7a04901 glibc-2.14-fedora.tar.xz
|
||||
8f5f6b09f98d17c630819b4845e31e65 glibc-2.14.tar.xz
|
||||
a300a99da8850731058a6221b5c56368 glibc-ports-2.13-35-g8969f4d.tar.xz
|
||||
c430a5a8a9f762b94e5c1c3b202fe0c1 glibc-2.14-12-g5babac1-fedora.tar.xz
|
||||
96a48cb0acb030c77e224c7748684652 glibc-2.14-12-g5babac1.tar.xz
|
||||
05c85905b43021a81318c3aa81718019 glibc-ports-2.14.tar.xz
|
||||
|
Loading…
Reference in New Issue
Block a user