- Resync with master
- Drop patch for 731228 that is no longer needed.
This commit is contained in:
parent
245f445471
commit
cdd3b0516c
2
.gitignore
vendored
2
.gitignore
vendored
@ -83,3 +83,5 @@ glibc-2.14-394-g8f3b1ff
|
|||||||
/glibc-2.16.90-0136fe2a.tar.gz
|
/glibc-2.16.90-0136fe2a.tar.gz
|
||||||
/glibc-2.16.90-82123268-fedora.tar.gz
|
/glibc-2.16.90-82123268-fedora.tar.gz
|
||||||
/glibc-2.16.90-82123268.tar.gz
|
/glibc-2.16.90-82123268.tar.gz
|
||||||
|
/glibc-2.16.90-67cbf9a2-fedora.tar.gz
|
||||||
|
/glibc-2.16.90-67cbf9a2.tar.gz
|
||||||
|
@ -1,24 +0,0 @@
|
|||||||
From a45bd0d9682db986191b075e64bcacd038af5993 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Andreas Schwab <schwab@redhat.com>
|
|
||||||
Date: Thu, 1 Sep 2011 10:45:00 +0200
|
|
||||||
Subject: [PATCH] Don't treat tls_offset == 1 as forced dynamic
|
|
||||||
|
|
||||||
* include/link.h (FORCED_DYNAMIC_TLS_OFFSET) [NO_TLS_OFFSET == 0]:
|
|
||||||
Change to -1.
|
|
||||||
|
|
||||||
---
|
|
||||||
ChangeLog | 5 +++++
|
|
||||||
include/link.h | 2 +-
|
|
||||||
2 files changed, 6 insertions(+), 1 deletions(-)
|
|
||||||
|
|
||||||
--- a/include/link.h
|
|
||||||
+++ b/include/link.h
|
|
||||||
@@ -289,7 +289,7 @@ struct link_map
|
|
||||||
#endif
|
|
||||||
#ifndef FORCED_DYNAMIC_TLS_OFFSET
|
|
||||||
# if NO_TLS_OFFSET == 0
|
|
||||||
-# define FORCED_DYNAMIC_TLS_OFFSET 1
|
|
||||||
+# define FORCED_DYNAMIC_TLS_OFFSET -1
|
|
||||||
# elif NO_TLS_OFFSET == -1
|
|
||||||
# define FORCED_DYNAMIC_TLS_OFFSET -2
|
|
||||||
# else
|
|
16
glibc.spec
16
glibc.spec
@ -1,4 +1,4 @@
|
|||||||
%define glibcsrcdir glibc-2.16.90-82123268
|
%define glibcsrcdir glibc-2.16.90-67cbf9a2
|
||||||
%define glibcversion 2.16.90
|
%define glibcversion 2.16.90
|
||||||
### glibc.spec.in follows:
|
### glibc.spec.in follows:
|
||||||
%define run_glibc_tests 1
|
%define run_glibc_tests 1
|
||||||
@ -27,7 +27,7 @@
|
|||||||
Summary: The GNU libc libraries
|
Summary: The GNU libc libraries
|
||||||
Name: glibc
|
Name: glibc
|
||||||
Version: %{glibcversion}
|
Version: %{glibcversion}
|
||||||
Release: 37%{?dist}
|
Release: 38%{?dist}
|
||||||
# GPLv2+ is used in a bunch of programs, LGPLv2+ is used for libraries.
|
# GPLv2+ is used in a bunch of programs, LGPLv2+ is used for libraries.
|
||||||
# Things that are linked directly into dynamically linked programs
|
# Things that are linked directly into dynamically linked programs
|
||||||
# and shared libraries (e.g. crt files, lib*_nonshared.a) have an additional
|
# and shared libraries (e.g. crt files, lib*_nonshared.a) have an additional
|
||||||
@ -105,9 +105,9 @@ Patch0025: %{name}-fedora-streams-rh436349.patch
|
|||||||
Patch0028: %{name}-fedora-localedata-rh61908.patch
|
Patch0028: %{name}-fedora-localedata-rh61908.patch
|
||||||
Patch0030: %{name}-fedora-uname-getrlimit.patch
|
Patch0030: %{name}-fedora-uname-getrlimit.patch
|
||||||
Patch0031: %{name}-fedora-__libc_multiple_libcs.patch
|
Patch0031: %{name}-fedora-__libc_multiple_libcs.patch
|
||||||
|
Patch0032: %{name}-fedora-elf-rh737223.patch
|
||||||
Patch0033: %{name}-fedora-elf-ORIGIN.patch
|
Patch0033: %{name}-fedora-elf-ORIGIN.patch
|
||||||
Patch0034: %{name}-fedora-elf-init-hidden_undef.patch
|
Patch0034: %{name}-fedora-elf-init-hidden_undef.patch
|
||||||
Patch0035: %{name}-fedora-elf-rh737223.patch
|
|
||||||
|
|
||||||
#
|
#
|
||||||
# Patches from upstream
|
# Patches from upstream
|
||||||
@ -141,9 +141,6 @@ Patch2026: %{name}-rh841787.patch
|
|||||||
# Upstream BZ 14185
|
# Upstream BZ 14185
|
||||||
Patch2027: %{name}-rh819430.patch
|
Patch2027: %{name}-rh819430.patch
|
||||||
|
|
||||||
# Upstream BZ 14898
|
|
||||||
Patch2032: %{name}-fedora-tls-offset-rh731228.patch
|
|
||||||
|
|
||||||
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
Obsoletes: glibc-profile < 2.4
|
Obsoletes: glibc-profile < 2.4
|
||||||
Obsoletes: nss_db
|
Obsoletes: nss_db
|
||||||
@ -398,10 +395,9 @@ package or when debugging this package.
|
|||||||
%patch0029 -p1
|
%patch0029 -p1
|
||||||
%patch0030 -p1
|
%patch0030 -p1
|
||||||
%patch0031 -p1
|
%patch0031 -p1
|
||||||
%patch2032 -p1
|
%patch0032 -p1
|
||||||
%patch0033 -p1
|
%patch0033 -p1
|
||||||
%patch0034 -p1
|
%patch0034 -p1
|
||||||
%patch0035 -p1
|
|
||||||
|
|
||||||
# On powerpc32, hp timing is only available in power4/power6
|
# On powerpc32, hp timing is only available in power4/power6
|
||||||
# libs, not in base, so pre-power4 dynamic linker is incompatible
|
# libs, not in base, so pre-power4 dynamic linker is incompatible
|
||||||
@ -1196,6 +1192,10 @@ rm -f *.filelist*
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Dec 7 2012 Jeff Law <law@redhat.com> - 2.16.90-38
|
||||||
|
- Resync with master
|
||||||
|
- Drop patch for 731228 that is no longer needed.
|
||||||
|
|
||||||
* Thu Dec 6 2012 Jeff Law <law@redhat.com> - 2.16.90-37
|
* Thu Dec 6 2012 Jeff Law <law@redhat.com> - 2.16.90-37
|
||||||
- Resync with master
|
- Resync with master
|
||||||
- Patch for 697421 has been submitted upstream.
|
- Patch for 697421 has been submitted upstream.
|
||||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
|||||||
72080e31d4830a3b574d8cdba5f51247 glibc-2.16.90-82123268-fedora.tar.gz
|
3e66af62520bb199b7c3e7652a06c765 glibc-2.16.90-67cbf9a2-fedora.tar.gz
|
||||||
62a798bec5cc01e83d690476a8e002d7 glibc-2.16.90-82123268.tar.gz
|
da81b82b447cdd5b3f1685741171f7ed glibc-2.16.90-67cbf9a2.tar.gz
|
||||||
|
Loading…
Reference in New Issue
Block a user