- Remove broken patch for 816647.
This commit is contained in:
parent
7e2e80de95
commit
cd9aa54a17
@ -1,118 +0,0 @@
|
||||
2012-09-20 Jeff Law <law@redhat.com>
|
||||
|
||||
[BZ #14594]
|
||||
* iconv/gconv_cache.c (find_module): Demangle function pointer
|
||||
before testing it.
|
||||
* iconv/gconv_db.c (free_derivation): Likewise.
|
||||
(__gconv_release_step, gen_steps, increment_counter): Likewise.
|
||||
|
||||
diff --git a/iconv/gconv_cache.c b/iconv/gconv_cache.c
|
||||
index 90b6cff..9e23708 100644
|
||||
--- a/iconv/gconv_cache.c
|
||||
+++ b/iconv/gconv_cache.c
|
||||
@@ -1,5 +1,5 @@
|
||||
/* Cache handling for iconv modules.
|
||||
- Copyright (C) 2001, 2002, 2003, 2005, 2007 Free Software Foundation, Inc.
|
||||
+ Copyright (C) 2001-2003, 2005, 2007, 2012 Free Software Foundation, Inc.
|
||||
This file is part of the GNU C Library.
|
||||
Contributed by Ulrich Drepper <drepper@cygnus.com>, 2001.
|
||||
|
||||
@@ -206,13 +206,13 @@ find_module (const char *directory, const char *filename,
|
||||
result->__btowc_fct = NULL;
|
||||
result->__data = NULL;
|
||||
|
||||
- /* Call the init function. */
|
||||
- if (result->__init_fct != NULL)
|
||||
- {
|
||||
- __gconv_init_fct init_fct = result->__init_fct;
|
||||
+ __gconv_init_fct init_fct = result->__init_fct;
|
||||
#ifdef PTR_DEMANGLE
|
||||
- PTR_DEMANGLE (init_fct);
|
||||
+ PTR_DEMANGLE (init_fct);
|
||||
#endif
|
||||
+ /* Call the init function. */
|
||||
+ if (init_fct != NULL)
|
||||
+ {
|
||||
status = DL_CALL_FCT (init_fct, (result));
|
||||
|
||||
#ifdef PTR_MANGLE
|
||||
diff --git a/iconv/gconv_db.c b/iconv/gconv_db.c
|
||||
index 01015e8..7f91c7d 100644
|
||||
--- a/iconv/gconv_db.c
|
||||
+++ b/iconv/gconv_db.c
|
||||
@@ -179,16 +179,17 @@ free_derivation (void *p)
|
||||
size_t cnt;
|
||||
|
||||
for (cnt = 0; cnt < deriv->nsteps; ++cnt)
|
||||
- if (deriv->steps[cnt].__counter > 0
|
||||
- && deriv->steps[cnt].__end_fct != NULL)
|
||||
+ if (deriv->steps[cnt].__counter > 0)
|
||||
{
|
||||
- assert (deriv->steps[cnt].__shlib_handle != NULL);
|
||||
-
|
||||
__gconv_end_fct end_fct = deriv->steps[cnt].__end_fct;
|
||||
#ifdef PTR_DEMANGLE
|
||||
PTR_DEMANGLE (end_fct);
|
||||
#endif
|
||||
- DL_CALL_FCT (end_fct, (&deriv->steps[cnt]));
|
||||
+ if (end_fct != NULL)
|
||||
+ {
|
||||
+ assert (deriv->steps[cnt].__shlib_handle != NULL);
|
||||
+ DL_CALL_FCT (end_fct, (&deriv->steps[cnt]));
|
||||
+ }
|
||||
}
|
||||
|
||||
/* Free the name strings. */
|
||||
@@ -211,15 +212,15 @@ __gconv_release_step (struct __gconv_step *step)
|
||||
/* Skip builtin modules; they are not reference counted. */
|
||||
if (step->__shlib_handle != NULL && --step->__counter == 0)
|
||||
{
|
||||
+ __gconv_end_fct end_fct = step->__end_fct;
|
||||
+#ifdef PTR_DEMANGLE
|
||||
+ PTR_DEMANGLE (end_fct);
|
||||
+#endif
|
||||
/* Call the destructor. */
|
||||
- if (step->__end_fct != NULL)
|
||||
+ if (end_fct != NULL)
|
||||
{
|
||||
assert (step->__shlib_handle != NULL);
|
||||
|
||||
- __gconv_end_fct end_fct = step->__end_fct;
|
||||
-#ifdef PTR_DEMANGLE
|
||||
- PTR_DEMANGLE (end_fct);
|
||||
-#endif
|
||||
DL_CALL_FCT (end_fct, (step));
|
||||
}
|
||||
|
||||
@@ -293,13 +294,13 @@ gen_steps (struct derivation_step *best, const char *toset,
|
||||
|
||||
/* Call the init function. */
|
||||
__gconv_init_fct init_fct = result[step_cnt].__init_fct;
|
||||
+# ifdef PTR_DEMANGLE
|
||||
+ PTR_DEMANGLE (init_fct);
|
||||
+# endif
|
||||
if (init_fct != NULL)
|
||||
{
|
||||
assert (result[step_cnt].__shlib_handle != NULL);
|
||||
|
||||
-# ifdef PTR_DEMANGLE
|
||||
- PTR_DEMANGLE (init_fct);
|
||||
-# endif
|
||||
status = DL_CALL_FCT (init_fct, (&result[step_cnt]));
|
||||
|
||||
if (__builtin_expect (status, __GCONV_OK) != __GCONV_OK)
|
||||
@@ -393,11 +394,11 @@ increment_counter (struct __gconv_step *steps, size_t nsteps)
|
||||
|
||||
/* Call the init function. */
|
||||
__gconv_init_fct init_fct = step->__init_fct;
|
||||
- if (init_fct != NULL)
|
||||
- {
|
||||
#ifdef PTR_DEMANGLE
|
||||
- PTR_DEMANGLE (init_fct);
|
||||
+ PTR_DEMANGLE (init_fct);
|
||||
#endif
|
||||
+ if (init_fct != NULL)
|
||||
+ {
|
||||
DL_CALL_FCT (init_fct, (step));
|
||||
|
||||
#ifdef PTR_MANGLE
|
11
glibc.spec
11
glibc.spec
@ -27,7 +27,7 @@
|
||||
Summary: The GNU libc libraries
|
||||
Name: glibc
|
||||
Version: %{glibcversion}
|
||||
Release: 13%{?dist}
|
||||
Release: 14%{?dist}
|
||||
# GPLv2+ is used in a bunch of programs, LGPLv2+ is used for libraries.
|
||||
# Things that are linked directly into dynamically linked programs
|
||||
# and shared libraries (e.g. crt files, lib*_nonshared.a) have an additional
|
||||
@ -137,11 +137,6 @@ Patch0065: %{name}-fedora-tls-offset-rh731228.patch
|
||||
Patch0066: %{name}-fedora-uname-getrlimit.patch
|
||||
Patch0067: %{name}-fedora-vfprintf-sw6530.patch
|
||||
|
||||
|
||||
# Reverting an upstream patch. Once upstream fixes the problem
|
||||
# Remove this patch and resync.
|
||||
Patch0069: %{name}-rh858274.patch
|
||||
|
||||
#
|
||||
# Patches from upstream
|
||||
#
|
||||
@ -490,7 +485,6 @@ package or when debugging this package.
|
||||
%patch0066 -p1
|
||||
%patch0067 -p1
|
||||
%patch2068 -p1
|
||||
%patch0069 -p1
|
||||
|
||||
# On powerpc32, hp timing is only available in power4/power6
|
||||
# libs, not in base, so pre-power4 dynamic linker is incompatible
|
||||
@ -1285,6 +1279,9 @@ rm -f *.filelist*
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Fri Sep 21 2012 Jeff Law <law@redhat.com> - 2.16.90-14
|
||||
- Revert patch for 816647, it's blatently broken.
|
||||
|
||||
* Fri Sep 21 2012 Siddhesh Poyarekar <siddhesh@redhat.com> - 2.16.90-13
|
||||
- Bring back byteswap-16.h (#859268).
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user