Related: #1324623
Add missing definitions to the crypt-glibc/Makefile, so that the cryptographic tests can be built.
This commit is contained in:
parent
2c005c98da
commit
b8b6a436e9
@ -10,7 +10,7 @@ Index: b/crypt-glibc/Makefile
|
|||||||
===================================================================
|
===================================================================
|
||||||
--- /dev/null
|
--- /dev/null
|
||||||
+++ b/crypt-glibc/Makefile
|
+++ b/crypt-glibc/Makefile
|
||||||
@@ -0,0 +1,51 @@
|
@@ -0,0 +1,60 @@
|
||||||
+# Build libcrypt against internal cryptographic algorithms.
|
+# Build libcrypt against internal cryptographic algorithms.
|
||||||
+# Copyright (C) 1996-2016 Free Software Foundation, Inc.
|
+# Copyright (C) 1996-2016 Free Software Foundation, Inc.
|
||||||
+# This file is part of the GNU C Library.
|
+# This file is part of the GNU C Library.
|
||||||
@ -57,6 +57,15 @@ Index: b/crypt-glibc/Makefile
|
|||||||
+
|
+
|
||||||
+include ../Rules
|
+include ../Rules
|
||||||
+
|
+
|
||||||
|
+md5-routines := md5 $(filter md5%,$(libcrypt-sysdep_routines))
|
||||||
|
+sha256-routines := sha256 $(filter sha256%,$(libcrypt-sysdep_routines))
|
||||||
|
+sha512-routines := sha512 $(filter sha512%,$(libcrypt-sysdep_routines))
|
||||||
|
+
|
||||||
|
+$(objpfx)md5test: $(patsubst %, $(objpfx)%.o,$(md5-routines))
|
||||||
|
+$(objpfx)md5test-giant: $(patsubst %, $(objpfx)%.o,$(md5-routines))
|
||||||
|
+$(objpfx)sha256test: $(patsubst %, $(objpfx)%.o,$(sha256-routines))
|
||||||
|
+$(objpfx)sha512test: $(patsubst %, $(objpfx)%.o,$(sha512-routines))
|
||||||
|
+
|
||||||
+ifeq (yes,$(build-shared))
|
+ifeq (yes,$(build-shared))
|
||||||
+$(addprefix $(objpfx),$(tests)): $(objpfx)libcrypt.so
|
+$(addprefix $(objpfx),$(tests)): $(objpfx)libcrypt.so
|
||||||
+else
|
+else
|
||||||
|
Loading…
Reference in New Issue
Block a user