Auto-sync with upstream branch master
Upstream commit: 648279f4af423c4783ec1dfa63cb7b46a7640217 - Drop glibc-warning-fix.patch. Microbenchmark code fixed upstream. - powerpc: Use generic wcscpy optimization - powerpc: Use generic wcschr optimization - powerpc: Use generic wcsrchr optimization - aarch64: thunderx2 memcpy implementation cleanup and streamlining - resolv: Remove support for RES_USE_INET6 and the inet6 option - resolv: Remove RES_INSECURE1, RES_INSECURE2
This commit is contained in:
parent
e4dacdad3d
commit
b797613532
@ -1,25 +0,0 @@
|
|||||||
Temporary work around to fix compiler warning for set but not used
|
|
||||||
'res' variable.
|
|
||||||
|
|
||||||
e.g.
|
|
||||||
BUILDSTDERR: bench-malloc-simple.c: In function 'bench':
|
|
||||||
BUILDSTDERR: bench-malloc-simple.c:89:17: error: variable 'res' set but not used [-Werror=unused-but-set-variable]
|
|
||||||
BUILDSTDERR: 89 | unsigned long res;
|
|
||||||
BUILDSTDERR: | ^~~
|
|
||||||
BUILDSTDERR: cc1: all warnings being treated as errors
|
|
||||||
|
|
||||||
Affects aarch64, armv7hl, and s390x.
|
|
||||||
|
|
||||||
diff --git a/benchtests/bench-malloc-simple.c b/benchtests/bench-malloc-simple.c
|
|
||||||
index 83203ff3187654a1..e449dd5a2e351278 100644
|
|
||||||
--- a/benchtests/bench-malloc-simple.c
|
|
||||||
+++ b/benchtests/bench-malloc-simple.c
|
|
||||||
@@ -90,6 +90,8 @@ bench (unsigned long size)
|
|
||||||
|
|
||||||
TIMING_INIT (res);
|
|
||||||
|
|
||||||
+ (void) res;
|
|
||||||
+
|
|
||||||
for (int t = 0; t <= 3; t++)
|
|
||||||
for (int i = 0; i < NUM_ALLOCS; i++)
|
|
||||||
{
|
|
16
glibc.spec
16
glibc.spec
@ -1,4 +1,4 @@
|
|||||||
%define glibcsrcdir glibc-2.29.9000-176-g8260f23616
|
%define glibcsrcdir glibc-2.29.9000-189-g648279f4af
|
||||||
%define glibcversion 2.29.9000
|
%define glibcversion 2.29.9000
|
||||||
# Pre-release tarballs are pulled in from git using a command that is
|
# Pre-release tarballs are pulled in from git using a command that is
|
||||||
# effectively:
|
# effectively:
|
||||||
@ -87,7 +87,7 @@
|
|||||||
Summary: The GNU libc libraries
|
Summary: The GNU libc libraries
|
||||||
Name: glibc
|
Name: glibc
|
||||||
Version: %{glibcversion}
|
Version: %{glibcversion}
|
||||||
Release: 10%{?dist}
|
Release: 11%{?dist}
|
||||||
|
|
||||||
# In general, GPLv2+ is used by programs, LGPLv2+ is used for
|
# In general, GPLv2+ is used by programs, LGPLv2+ is used for
|
||||||
# libraries.
|
# libraries.
|
||||||
@ -156,7 +156,6 @@ Patch17: glibc-cs-path.patch
|
|||||||
Patch18: glibc-c-utf8-locale.patch
|
Patch18: glibc-c-utf8-locale.patch
|
||||||
Patch23: glibc-python3.patch
|
Patch23: glibc-python3.patch
|
||||||
Patch28: glibc-rh1615608.patch
|
Patch28: glibc-rh1615608.patch
|
||||||
Patch30: glibc-warning-fix.patch
|
|
||||||
|
|
||||||
# In progress upstream submission for nsswitch.conf changes:
|
# In progress upstream submission for nsswitch.conf changes:
|
||||||
# https://www.sourceware.org/ml/libc-alpha/2019-03/msg00425.html
|
# https://www.sourceware.org/ml/libc-alpha/2019-03/msg00425.html
|
||||||
@ -1896,6 +1895,17 @@ fi
|
|||||||
%files -f compat-libpthread-nonshared.filelist -n compat-libpthread-nonshared
|
%files -f compat-libpthread-nonshared.filelist -n compat-libpthread-nonshared
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Apr 09 2019 Carlos O'Donell <carlos@redhat.com> - 2.29.9000-11
|
||||||
|
- Drop glibc-warning-fix.patch. Microbenchmark code fixed upstream.
|
||||||
|
- Auto-sync with upstream branch master,
|
||||||
|
commit 648279f4af423c4783ec1dfa63cb7b46a7640217:
|
||||||
|
- powerpc: Use generic wcscpy optimization
|
||||||
|
- powerpc: Use generic wcschr optimization
|
||||||
|
- powerpc: Use generic wcsrchr optimization
|
||||||
|
- aarch64: thunderx2 memcpy implementation cleanup and streamlining
|
||||||
|
- resolv: Remove support for RES_USE_INET6 and the inet6 option
|
||||||
|
- resolv: Remove RES_INSECURE1, RES_INSECURE2
|
||||||
|
|
||||||
* Thu Apr 04 2019 Arjun Shankar <arjun@redhat.com> - 2.29.9000-10
|
* Thu Apr 04 2019 Arjun Shankar <arjun@redhat.com> - 2.29.9000-10
|
||||||
- Auto-sync with upstream branch master,
|
- Auto-sync with upstream branch master,
|
||||||
commit 8260f23616c1a2a4e609f989a195fba7690a42ca:
|
commit 8260f23616c1a2a4e609f989a195fba7690a42ca:
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (glibc-2.29.9000-176-g8260f23616.tar.xz) = 62e691eddb773ebedea61d3cddfa6afadd0e98055dd46e794bcec5cd07aa010379b94bdce9a363940a2d1e68c1beaa16ee05e517df01862bfb6fac707fff1605
|
SHA512 (glibc-2.29.9000-189-g648279f4af.tar.xz) = 5540f7922cd9829b1f5b8b021ac156e5a2e4b95c4712b9ab4d9ec9578941ff078b945af0a454e35b48e57bb25f322cfc28b42086a4f56ea224da4a87cb84e759
|
||||||
|
Loading…
Reference in New Issue
Block a user