* Fri Sep 28 2012 Jeff Law <law@redhat.com> - 2.16.90-18
- Resync with upstream sources. - Drop fedora-cdefs-gnuc.patch, it's not needed anymore. - Drop fedora-gai-rfc1918.patch, it's upstream now. - Drop fedora-localedata-no_NO.patch, it was supposed to be temporary -- that was back in 2003. This should have been sorted out long ago. We'll just have to deal with the fallout. - Drop fedora-vfprintf-sw6530.patch, it's upstream now. - Drop rh769421.patch; Siddhesh has fixed this properly with 552960.
This commit is contained in:
parent
cdb17b58a8
commit
b33c1d2300
4
.gitignore
vendored
4
.gitignore
vendored
@ -46,3 +46,7 @@ glibc-2.14-394-g8f3b1ff
|
||||
/glibc-2.16.90-97bc38d7.tar.gz
|
||||
/glibc-2.16.90-f6a2737f-fedora.tar.gz
|
||||
/glibc-2.16.90-f6a2737f.tar.gz
|
||||
/glibc-2.16.90-8cf6a02e-fedora.tar.gz
|
||||
/glibc-2.16.90-8cf6a02e.tar.gz
|
||||
/glibc-2.16.90-715a900c-fedora.tar.gz
|
||||
/glibc-2.16.90-715a900c.tar.gz
|
||||
|
@ -1,39 +0,0 @@
|
||||
diff -Nrup a/misc/sys/cdefs.h b/misc/sys/cdefs.h
|
||||
--- a/misc/sys/cdefs.h 2012-06-05 07:42:49.000000000 -0600
|
||||
+++ b/misc/sys/cdefs.h 2012-06-07 12:15:21.808318708 -0600
|
||||
@@ -142,7 +142,10 @@
|
||||
#define __bos0(ptr) __builtin_object_size (ptr, 0)
|
||||
#define __fortify_function __extern_always_inline __attribute_artificial__
|
||||
|
||||
-#if __GNUC_PREREQ (4,3)
|
||||
+#if __GNUC_PREREQ (4,3) \
|
||||
+ || (defined __GNUC_RH_RELEASE__ && __GNUC__ == 4 \
|
||||
+ && __GNUC_MINOR__ == 1 && __GNUC_PATCHLEVEL__ == 2 \
|
||||
+ && __GNUC_RH_RELEASE__ >= 31)
|
||||
# define __warndecl(name, msg) \
|
||||
extern void name (void) __attribute__((__warning__ (msg)))
|
||||
# define __warnattr(msg) __attribute__((__warning__ (msg)))
|
||||
@@ -320,7 +323,10 @@
|
||||
|
||||
/* GCC 4.3 and above with -std=c99 or -std=gnu99 implements ISO C99
|
||||
inline semantics, unless -fgnu89-inline is used. */
|
||||
-#if !defined __cplusplus || __GNUC_PREREQ (4,3)
|
||||
+#if !defined __cplusplus || __GNUC_PREREQ (4,3) \
|
||||
+ || (defined __GNUC_RH_RELEASE__ && __GNUC__ == 4 \
|
||||
+ && __GNUC_MINOR__ == 1 && __GNUC_PATCHLEVEL__ == 2 \
|
||||
+ && __GNUC_RH_RELEASE__ >= 31)
|
||||
# if defined __GNUC_STDC_INLINE__ || defined __cplusplus
|
||||
# define __extern_inline extern __inline __attribute__ ((__gnu_inline__))
|
||||
# define __extern_always_inline \
|
||||
@@ -333,7 +339,10 @@
|
||||
|
||||
/* GCC 4.3 and above allow passing all anonymous arguments of an
|
||||
__extern_always_inline function to some other vararg function. */
|
||||
-#if __GNUC_PREREQ (4,3)
|
||||
+#if __GNUC_PREREQ (4,3) \
|
||||
+ || (defined __GNUC_RH_RELEASE__ && __GNUC__ == 4 \
|
||||
+ && __GNUC_MINOR__ == 1 && __GNUC_PATCHLEVEL__ == 2 \
|
||||
+ && __GNUC_RH_RELEASE__ >= 31)
|
||||
# define __va_arg_pack() __builtin_va_arg_pack ()
|
||||
# define __va_arg_pack_len() __builtin_va_arg_pack_len ()
|
||||
#endif
|
@ -1,54 +0,0 @@
|
||||
From 1080954fbcf54814875eb988673004d25a1655cf Mon Sep 17 00:00:00 2001
|
||||
From: Ulrich Drepper <drepper@redhat.com>
|
||||
Date: Tue, 6 Apr 2010 12:27:58 +0200
|
||||
Subject: [PATCH] Assign global scope to RFC 1918 addresses
|
||||
|
||||
* sysdeps/posix/getaddrinfo.c (default_scopes): Assign global
|
||||
scope to RFC 1918 addresses.
|
||||
* posix/gai.conf: Document difference from RFC 3484.
|
||||
|
||||
---
|
||||
ChangeLog | 6 ++++++
|
||||
posix/gai.conf | 6 ++++--
|
||||
sysdeps/posix/getaddrinfo.c | 2 ++
|
||||
3 files changed, 12 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/posix/gai.conf b/posix/gai.conf
|
||||
index 195287e..bd40684 100644
|
||||
--- a/posix/gai.conf
|
||||
+++ b/posix/gai.conf
|
||||
@@ -41,7 +41,7 @@
|
||||
#
|
||||
# precedence <mask> <value>
|
||||
# Add another rule to the RFC 3484 precedence table. See section 2.1
|
||||
-# and 10.3 in RFC 3484. The default is:
|
||||
+# and 10.3 in RFC 3484. The RFC requires:
|
||||
#
|
||||
#precedence ::1/128 50
|
||||
#precedence ::/0 40
|
||||
@@ -58,7 +58,7 @@
|
||||
# Add another rule to the RFC 3484 scope table for IPv4 addresses.
|
||||
# By default the scope IDs described in section 3.2 in RFC 3484 are
|
||||
# used. Changing these defaults should hardly ever be necessary.
|
||||
-# The defaults are equivalent to:
|
||||
+# The definitions in RFC 1918 are equivalent to:
|
||||
#
|
||||
#scopev4 ::ffff:169.254.0.0/112 2
|
||||
#scopev4 ::ffff:127.0.0.0/104 2
|
||||
diff --git a/sysdeps/posix/getaddrinfo.c b/sysdeps/posix/getaddrinfo.c
|
||||
index 2e0c724..3eb5971 100644
|
||||
--- a/sysdeps/posix/getaddrinfo.c
|
||||
+++ b/sysdeps/posix/getaddrinfo.c
|
||||
@@ -1099,10 +1099,12 @@ static const struct scopeentry
|
||||
/* Link-local addresses: scope 2. */
|
||||
{ { { 169, 254, 0, 0 } }, htonl_c (0xffff0000), 2 },
|
||||
{ { { 127, 0, 0, 0 } }, htonl_c (0xff000000), 2 },
|
||||
+#if 0
|
||||
/* Site-local addresses: scope 5. */
|
||||
{ { { 10, 0, 0, 0 } }, htonl_c (0xff000000), 5 },
|
||||
{ { { 172, 16, 0, 0 } }, htonl_c (0xfff00000), 5 },
|
||||
{ { { 192, 168, 0, 0 } }, htonl_c (0xffff0000), 5 },
|
||||
+#endif
|
||||
/* Default: scope 14. */
|
||||
{ { { 0, 0, 0, 0 } }, htonl_c (0x00000000), 14 }
|
||||
};
|
@ -1,102 +0,0 @@
|
||||
* Mon Dec 1 2003 Jakub Jelinek <jakub@redhat.com> 2.3.3-1
|
||||
- for the time being, include both nb_NO* and no_NO* as locales
|
||||
so that the distribution can catch up with the no_NO->nb_NO
|
||||
transition
|
||||
|
||||
diff -Nrup a/intl/locale.alias b/intl/locale.alias
|
||||
--- a/intl/locale.alias 2012-06-05 07:42:49.000000000 -0600
|
||||
+++ b/intl/locale.alias 2012-06-07 12:15:21.583319548 -0600
|
||||
@@ -56,8 +56,6 @@ korean ko_KR.eucKR
|
||||
korean.euc ko_KR.eucKR
|
||||
ko_KR ko_KR.eucKR
|
||||
lithuanian lt_LT.ISO-8859-13
|
||||
-no_NO nb_NO.ISO-8859-1
|
||||
-no_NO.ISO-8859-1 nb_NO.ISO-8859-1
|
||||
norwegian nb_NO.ISO-8859-1
|
||||
nynorsk nn_NO.ISO-8859-1
|
||||
polish pl_PL.ISO-8859-2
|
||||
diff -Nrup a/localedata/SUPPORTED b/localedata/SUPPORTED
|
||||
--- a/localedata/SUPPORTED 2012-06-05 07:42:49.000000000 -0600
|
||||
+++ b/localedata/SUPPORTED 2012-06-07 12:15:21.805318719 -0600
|
||||
@@ -320,6 +320,8 @@ nl_NL/ISO-8859-1 \
|
||||
nl_NL@euro/ISO-8859-15 \
|
||||
nn_NO.UTF-8/UTF-8 \
|
||||
nn_NO/ISO-8859-1 \
|
||||
+no_NO.UTF-8/UTF-8 \
|
||||
+no_NO/ISO-8859-1 \
|
||||
nr_ZA/UTF-8 \
|
||||
nso_ZA/UTF-8 \
|
||||
oc_FR.UTF-8/UTF-8 \
|
||||
diff -Nrup a/localedata/locales/no_NO b/localedata/locales/no_NO
|
||||
--- a/localedata/locales/no_NO 1969-12-31 17:00:00.000000000 -0700
|
||||
+++ b/localedata/locales/no_NO 2012-06-07 12:15:21.806318715 -0600
|
||||
@@ -0,0 +1,69 @@
|
||||
+escape_char /
|
||||
+comment_char %
|
||||
+
|
||||
+% Norwegian language locale for Norway
|
||||
+% Source: Norsk Standardiseringsforbund
|
||||
+% Address: University Library,
|
||||
+% Drammensveien 41, N-9242 Oslo, Norge
|
||||
+% Contact: Kolbjoern Aamboe
|
||||
+% Tel: +47 - 22859109
|
||||
+% Fax: +47 - 22434497
|
||||
+% Email: kolbjorn.aambo@usit.uio.no
|
||||
+% Language: no
|
||||
+% Territory: NO
|
||||
+% Revision: 4.3
|
||||
+% Date: 1996-10-15
|
||||
+% Application: general
|
||||
+% Users: general
|
||||
+% Repertoiremap: mnemonic.ds
|
||||
+% Charset: ISO-8859-1
|
||||
+% Distribution and use is free, also
|
||||
+% for commercial purposes.
|
||||
+
|
||||
+LC_IDENTIFICATION
|
||||
+copy "nb_NO"
|
||||
+END LC_IDENTIFICATION
|
||||
+
|
||||
+LC_COLLATE
|
||||
+copy "nb_NO"
|
||||
+END LC_COLLATE
|
||||
+
|
||||
+LC_CTYPE
|
||||
+copy "nb_NO"
|
||||
+END LC_CTYPE
|
||||
+
|
||||
+LC_MONETARY
|
||||
+copy "nb_NO"
|
||||
+END LC_MONETARY
|
||||
+
|
||||
+LC_NUMERIC
|
||||
+copy "nb_NO"
|
||||
+END LC_NUMERIC
|
||||
+
|
||||
+LC_TIME
|
||||
+copy "nb_NO"
|
||||
+END LC_TIME
|
||||
+
|
||||
+LC_MESSAGES
|
||||
+copy "nb_NO"
|
||||
+END LC_MESSAGES
|
||||
+
|
||||
+LC_PAPER
|
||||
+copy "nb_NO"
|
||||
+END LC_PAPER
|
||||
+
|
||||
+LC_TELEPHONE
|
||||
+copy "nb_NO"
|
||||
+END LC_TELEPHONE
|
||||
+
|
||||
+LC_MEASUREMENT
|
||||
+copy "nb_NO"
|
||||
+END LC_MEASUREMENT
|
||||
+
|
||||
+LC_NAME
|
||||
+copy "nb_NO"
|
||||
+END LC_NAME
|
||||
+
|
||||
+LC_ADDRESS
|
||||
+copy "nb_NO"
|
||||
+END LC_ADDRESS
|
@ -1,62 +0,0 @@
|
||||
From 8a34866d978e4281d69104372056ba0211d1373a Mon Sep 17 00:00:00 2001
|
||||
From: Andreas Schwab <schwab@redhat.com>
|
||||
Date: Tue, 31 Aug 2010 12:20:05 +0200
|
||||
Subject: [PATCH] Don't parse %s format argument as multibyte string
|
||||
|
||||
[BZ #6530]
|
||||
* stdio-common/vfprintf.c (process_string_arg): Revert 2000-07-22
|
||||
change.
|
||||
|
||||
---
|
||||
ChangeLog | 4 ++++
|
||||
stdio-common/vfprintf.c | 40 ++++------------------------------------
|
||||
2 files changed, 8 insertions(+), 36 deletions(-)
|
||||
|
||||
--- a/stdio-common/vfprintf.c
|
||||
+++ b/stdio-common/vfprintf.c
|
||||
@@ -1168,42 +1168,9 @@ vfprintf (FILE *s, const CHAR_T *format, va_list ap)
|
||||
else if (!is_long && spec != L_('S')) \
|
||||
{ \
|
||||
if (prec != -1) \
|
||||
- { \
|
||||
- /* Search for the end of the string, but don't search past \
|
||||
- the length (in bytes) specified by the precision. Also \
|
||||
- don't use incomplete characters. */ \
|
||||
- if (_NL_CURRENT_WORD (LC_CTYPE, _NL_CTYPE_MB_CUR_MAX) == 1) \
|
||||
- len = __strnlen (string, prec); \
|
||||
- else \
|
||||
- { \
|
||||
- /* In case we have a multibyte character set the \
|
||||
- situation is more complicated. We must not copy \
|
||||
- bytes at the end which form an incomplete character. */\
|
||||
- size_t ignore_size = (unsigned) prec > 1024 ? 1024 : prec;\
|
||||
- wchar_t ignore[ignore_size]; \
|
||||
- const char *str2 = string; \
|
||||
- const char *strend = string + prec; \
|
||||
- if (strend < string) \
|
||||
- strend = (const char *) UINTPTR_MAX; \
|
||||
- \
|
||||
- mbstate_t ps; \
|
||||
- memset (&ps, '\0', sizeof (ps)); \
|
||||
- \
|
||||
- while (str2 != NULL && str2 < strend) \
|
||||
- if (__mbsnrtowcs (ignore, &str2, strend - str2, \
|
||||
- ignore_size, &ps) == (size_t) -1) \
|
||||
- { \
|
||||
- /* Conversion function has set errno. */ \
|
||||
- done = -1; \
|
||||
- goto all_done; \
|
||||
- } \
|
||||
- \
|
||||
- if (str2 == NULL) \
|
||||
- len = strlen (string); \
|
||||
- else \
|
||||
- len = str2 - string - (ps.__count & 7); \
|
||||
- } \
|
||||
- } \
|
||||
+ /* Search for the end of the string, but don't search past \
|
||||
+ the length (in bytes) specified by the precision. */ \
|
||||
+ len = __strnlen (string, prec); \
|
||||
else \
|
||||
len = strlen (string); \
|
||||
} \
|
@ -1,217 +0,0 @@
|
||||
diff -Nrup c/nptl/sysdeps/unix/sysv/linux/i386/i486/pthread_cond_wait.S d/nptl/sysdeps/unix/sysv/linux/i386/i486/pthread_cond_wait.S
|
||||
--- c/nptl/sysdeps/unix/sysv/linux/i386/i486/pthread_cond_wait.S 2012-05-20 23:58:20.732670548 -0600
|
||||
+++ d/nptl/sysdeps/unix/sysv/linux/i386/i486/pthread_cond_wait.S 2012-05-20 23:58:52.667518135 -0600
|
||||
@@ -137,7 +137,6 @@ __pthread_cond_wait:
|
||||
cmpl $PI_BIT, %eax
|
||||
jne 18f
|
||||
|
||||
-90:
|
||||
movl $(FUTEX_WAIT_REQUEUE_PI|FUTEX_PRIVATE_FLAG), %ecx
|
||||
movl %ebp, %edx
|
||||
xorl %esi, %esi
|
||||
@@ -151,9 +150,6 @@ __pthread_cond_wait:
|
||||
sete 16(%esp)
|
||||
je 19f
|
||||
|
||||
- cmpl $-EAGAIN, %eax
|
||||
- je 91f
|
||||
-
|
||||
/* Normal and PI futexes dont mix. Use normal futex functions only
|
||||
if the kernel does not support the PI futex functions. */
|
||||
cmpl $-ENOSYS, %eax
|
||||
@@ -398,78 +394,6 @@ __pthread_cond_wait:
|
||||
#endif
|
||||
call __lll_unlock_wake
|
||||
jmp 11b
|
||||
-
|
||||
-91:
|
||||
-.LcleanupSTART2:
|
||||
- /* FUTEX_WAIT_REQUEUE_PI returned EAGAIN. We need to
|
||||
- call it again. */
|
||||
-
|
||||
- /* Get internal lock. */
|
||||
- movl $1, %edx
|
||||
- xorl %eax, %eax
|
||||
- LOCK
|
||||
-#if cond_lock == 0
|
||||
- cmpxchgl %edx, (%ebx)
|
||||
-#else
|
||||
- cmpxchgl %edx, cond_lock(%ebx)
|
||||
-#endif
|
||||
- jz 92f
|
||||
-
|
||||
-#if cond_lock == 0
|
||||
- movl %ebx, %edx
|
||||
-#else
|
||||
- leal cond_lock(%ebx), %edx
|
||||
-#endif
|
||||
-#if (LLL_SHARED-LLL_PRIVATE) > 255
|
||||
- xorl %ecx, %ecx
|
||||
-#endif
|
||||
- cmpl $-1, dep_mutex(%ebx)
|
||||
- setne %cl
|
||||
- subl $1, %ecx
|
||||
- andl $(LLL_SHARED-LLL_PRIVATE), %ecx
|
||||
-#if LLL_PRIVATE != 0
|
||||
- addl $LLL_PRIVATE, %ecx
|
||||
-#endif
|
||||
- call __lll_lock_wait
|
||||
-
|
||||
-92:
|
||||
- /* Increment the cond_futex value again, so it can be used as a new
|
||||
- expected value. */
|
||||
- addl $1, cond_futex(%ebx)
|
||||
- movl cond_futex(%ebx), %ebp
|
||||
-
|
||||
- /* Unlock. */
|
||||
- LOCK
|
||||
-#if cond_lock == 0
|
||||
- subl $1, (%ebx)
|
||||
-#else
|
||||
- subl $1, cond_lock(%ebx)
|
||||
-#endif
|
||||
- je 93f
|
||||
-#if cond_lock == 0
|
||||
- movl %ebx, %eax
|
||||
-#else
|
||||
- leal cond_lock(%ebx), %eax
|
||||
-#endif
|
||||
-#if (LLL_SHARED-LLL_PRIVATE) > 255
|
||||
- xorl %ecx, %ecx
|
||||
-#endif
|
||||
- cmpl $-1, dep_mutex(%ebx)
|
||||
- setne %cl
|
||||
- subl $1, %ecx
|
||||
- andl $(LLL_SHARED-LLL_PRIVATE), %ecx
|
||||
-#if LLL_PRIVATE != 0
|
||||
- addl $LLL_PRIVATE, %ecx
|
||||
-#endif
|
||||
- call __lll_unlock_wake
|
||||
-
|
||||
-93:
|
||||
- /* Set the rest of SYS_futex args for FUTEX_WAIT_REQUEUE_PI. */
|
||||
- xorl %ecx, %ecx
|
||||
- movl dep_mutex(%ebx), %edi
|
||||
- jmp 90b
|
||||
-.LcleanupEND2:
|
||||
-
|
||||
.size __pthread_cond_wait, .-__pthread_cond_wait
|
||||
versioned_symbol (libpthread, __pthread_cond_wait, pthread_cond_wait,
|
||||
GLIBC_2_3_2)
|
||||
@@ -642,10 +566,6 @@ __condvar_w_cleanup:
|
||||
.long .LcleanupEND-.Lsub_cond_futex
|
||||
.long __condvar_w_cleanup-.LSTARTCODE
|
||||
.uleb128 0
|
||||
- .long .LcleanupSTART2-.LSTARTCODE
|
||||
- .long .LcleanupEND2-.LcleanupSTART2
|
||||
- .long __condvar_w_cleanup-.LSTARTCODE
|
||||
- .uleb128 0
|
||||
.long .LcallUR-.LSTARTCODE
|
||||
.long .LENDCODE-.LcallUR
|
||||
.long 0
|
||||
diff -Nrup c/nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S d/nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S
|
||||
--- c/nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S 2012-05-20 23:58:20.736670528 -0600
|
||||
+++ d/nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S 2012-05-21 00:01:39.870720001 -0600
|
||||
@@ -136,14 +136,11 @@ __pthread_cond_wait:
|
||||
cmpl $PI_BIT, %eax
|
||||
jne 61f
|
||||
|
||||
-90:
|
||||
movl $(FUTEX_WAIT_REQUEUE_PI|FUTEX_PRIVATE_FLAG), %esi
|
||||
movl $SYS_futex, %eax
|
||||
syscall
|
||||
|
||||
movl $1, %r8d
|
||||
- cmpq $-EAGAIN, %rax
|
||||
- je 91f
|
||||
#ifdef __ASSUME_REQUEUE_PI
|
||||
jmp 62f
|
||||
#else
|
||||
@@ -331,69 +328,6 @@ __pthread_cond_wait:
|
||||
13: movq %r10, %rax
|
||||
jmp 14b
|
||||
|
||||
-91:
|
||||
-.LcleanupSTART2:
|
||||
- /* FUTEX_WAIT_REQUEUE_PI returned EAGAIN. We need to
|
||||
- call it again. */
|
||||
- movq 8(%rsp), %rdi
|
||||
-
|
||||
- /* Get internal lock. */
|
||||
- movl $1, %esi
|
||||
- xorl %eax, %eax
|
||||
- LOCK
|
||||
-#if cond_lock == 0
|
||||
- cmpxchgl %esi, (%rdi)
|
||||
-#else
|
||||
- cmpxchgl %esi, cond_lock(%rdi)
|
||||
-#endif
|
||||
- jz 92f
|
||||
-
|
||||
-#if cond_lock != 0
|
||||
- addq $cond_lock, %rdi
|
||||
-#endif
|
||||
- LP_OP(cmp) $-1, dep_mutex-cond_lock(%rdi)
|
||||
- movl $LLL_PRIVATE, %eax
|
||||
- movl $LLL_SHARED, %esi
|
||||
- cmovne %eax, %esi
|
||||
- callq __lll_lock_wait
|
||||
-#if cond_lock != 0
|
||||
- subq $cond_lock, %rdi
|
||||
-#endif
|
||||
-92:
|
||||
- /* Increment the cond_futex value again, so it can be used as a new
|
||||
- expected value. */
|
||||
- incl cond_futex(%rdi)
|
||||
- movl cond_futex(%rdi), %edx
|
||||
-
|
||||
- /* Release internal lock. */
|
||||
- LOCK
|
||||
-#if cond_lock == 0
|
||||
- decl (%rdi)
|
||||
-#else
|
||||
- decl cond_lock(%rdi)
|
||||
-#endif
|
||||
- jz 93f
|
||||
-
|
||||
-#if cond_lock != 0
|
||||
- addq $cond_lock, %rdi
|
||||
-#endif
|
||||
- LP_OP(cmp) $-1, dep_mutex-cond_lock(%rdi)
|
||||
- movl $LLL_PRIVATE, %eax
|
||||
- movl $LLL_SHARED, %esi
|
||||
- cmovne %eax, %esi
|
||||
- /* The call preserves %rdx. */
|
||||
- callq __lll_unlock_wake
|
||||
-#if cond_lock != 0
|
||||
- subq $cond_lock, %rdi
|
||||
-#endif
|
||||
-93:
|
||||
- /* Set the rest of SYS_futex args for FUTEX_WAIT_REQUEUE_PI. */
|
||||
- xorq %r10, %r10
|
||||
- mov dep_mutex(%rdi), %R8_LP
|
||||
- leaq cond_futex(%rdi), %rdi
|
||||
- jmp 90b
|
||||
-.LcleanupEND2:
|
||||
-
|
||||
.size __pthread_cond_wait, .-__pthread_cond_wait
|
||||
versioned_symbol (libpthread, __pthread_cond_wait, pthread_cond_wait,
|
||||
GLIBC_2_3_2)
|
||||
@@ -546,15 +480,11 @@ __condvar_cleanup1:
|
||||
.uleb128 .LcleanupSTART-.LSTARTCODE
|
||||
.uleb128 .LcleanupEND-.LcleanupSTART
|
||||
.uleb128 __condvar_cleanup1-.LSTARTCODE
|
||||
- .uleb128 0
|
||||
- .uleb128 .LcleanupSTART2-.LSTARTCODE
|
||||
- .uleb128 .LcleanupEND2-.LcleanupSTART2
|
||||
- .uleb128 __condvar_cleanup1-.LSTARTCODE
|
||||
- .uleb128 0
|
||||
+ .uleb128 0
|
||||
.uleb128 .LcallUR-.LSTARTCODE
|
||||
.uleb128 .LENDCODE-.LcallUR
|
||||
.uleb128 0
|
||||
- .uleb128 0
|
||||
+ .uleb128 0
|
||||
.Lcstend:
|
||||
|
||||
|
31
glibc.spec
31
glibc.spec
@ -1,4 +1,4 @@
|
||||
%define glibcsrcdir glibc-2.16.90-f6a2737f
|
||||
%define glibcsrcdir glibc-2.16.90-715a900c
|
||||
%define glibcversion 2.16.90
|
||||
### glibc.spec.in follows:
|
||||
%define run_glibc_tests 1
|
||||
@ -27,7 +27,7 @@
|
||||
Summary: The GNU libc libraries
|
||||
Name: glibc
|
||||
Version: %{glibcversion}
|
||||
Release: 17%{?dist}
|
||||
Release: 18%{?dist}
|
||||
# GPLv2+ is used in a bunch of programs, LGPLv2+ is used for libraries.
|
||||
# Things that are linked directly into dynamically linked programs
|
||||
# and shared libraries (e.g. crt files, lib*_nonshared.a) have an additional
|
||||
@ -61,11 +61,6 @@ Source1: %{glibcsrcdir}-fedora.tar.gz
|
||||
# Is this still necessary, if so, it needs to go upstream
|
||||
Patch0001: %{name}-stap.patch
|
||||
|
||||
# Reverting an upstream patch. I don't think this has been discussed
|
||||
# upstream yet.
|
||||
# rh552960 now does this and adds a real fix.
|
||||
# Patch0002: %{name}-rh769421.patch
|
||||
|
||||
# Not likely to be accepted upstream
|
||||
Patch0003: %{name}-rh787201.patch
|
||||
|
||||
@ -101,7 +96,6 @@ Patch0029: %{name}-rh841318.patch
|
||||
# dropped.
|
||||
|
||||
Patch0031: %{name}-fedora-__libc_multiple_libcs.patch
|
||||
Patch0032: %{name}-fedora-cdefs-gnuc.patch
|
||||
Patch0033: %{name}-fedora-elf-ORIGIN.patch
|
||||
Patch0034: %{name}-fedora-elf-init-hidden_undef.patch
|
||||
Patch0035: %{name}-fedora-elf-rh737223.patch
|
||||
@ -114,7 +108,6 @@ Patch0043: %{name}-fedora-ldd.patch
|
||||
Patch0044: %{name}-fedora-linux-tcsetattr.patch
|
||||
Patch0045: %{name}-fedora-locale-euro.patch
|
||||
Patch0046: %{name}-fedora-localedata-locales-fixes.patch
|
||||
Patch0047: %{name}-fedora-localedata-no_NO.patch
|
||||
Patch0048: %{name}-fedora-localedata-rh61908.patch
|
||||
Patch0049: %{name}-fedora-localedef.patch
|
||||
Patch0050: %{name}-fedora-locarchive.patch
|
||||
@ -133,7 +126,6 @@ Patch0063: %{name}-fedora-test-debug-gnuc-compat.patch
|
||||
Patch0064: %{name}-fedora-test-debug-gnuc-hack.patch
|
||||
Patch0065: %{name}-fedora-tls-offset-rh731228.patch
|
||||
Patch0066: %{name}-fedora-uname-getrlimit.patch
|
||||
Patch0067: %{name}-fedora-vfprintf-sw6530.patch
|
||||
|
||||
# Reverting an upstream patch. Once upstream fixes the problem
|
||||
# Remove this patch and resync.
|
||||
@ -193,9 +185,6 @@ Patch2027: %{name}-rh819430.patch
|
||||
# See http://sourceware.org/ml/libc-alpha/2012-06/msg00074.html
|
||||
Patch2028: %{name}-rh767693-2.patch
|
||||
|
||||
# Upstream BZ 11438
|
||||
Patch2037: %{name}-fedora-gai-rfc1918.patch
|
||||
|
||||
# Upstream BZ 14417
|
||||
Patch2070: %{name}-rh552960.patch
|
||||
|
||||
@ -423,7 +412,6 @@ package or when debugging this package.
|
||||
%setup -q -n %{glibcsrcdir} -b1
|
||||
|
||||
%patch0001 -E -p1
|
||||
#%patch0002 -p1
|
||||
%patch0003 -p1
|
||||
%patch0004 -p1
|
||||
%patch0005 -p1
|
||||
@ -452,12 +440,10 @@ package or when debugging this package.
|
||||
%patch2028 -p1
|
||||
%patch0029 -p1
|
||||
%patch0031 -p1
|
||||
%patch0032 -p1
|
||||
%patch0033 -p1
|
||||
%patch0034 -p1
|
||||
%patch0035 -p1
|
||||
%patch0036 -p1
|
||||
%patch2037 -p1
|
||||
%patch0038 -p1
|
||||
%patch0039 -p1
|
||||
%patch0040 -p1
|
||||
@ -466,7 +452,6 @@ package or when debugging this package.
|
||||
%patch0044 -p1
|
||||
%patch0045 -p1
|
||||
%patch0046 -p1
|
||||
%patch0047 -p1
|
||||
%patch0048 -p1
|
||||
%patch0049 -p1
|
||||
%patch0050 -p1
|
||||
@ -485,7 +470,6 @@ package or when debugging this package.
|
||||
%patch0064 -p1
|
||||
%patch0065 -p1
|
||||
%patch0066 -p1
|
||||
%patch0067 -p1
|
||||
%patch0069 -p1
|
||||
%patch2070 -p1
|
||||
|
||||
@ -1282,6 +1266,17 @@ rm -f *.filelist*
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Fri Sep 28 2012 Jeff Law <law@redhat.com> - 2.16.90-18
|
||||
- Resync with upstream sources.
|
||||
- Drop fedora-cdefs-gnuc.patch, it's not needed anymore.
|
||||
- Drop fedora-gai-rfc1918.patch, it's upstream now.
|
||||
- Drop fedora-localedata-no_NO.patch, it was supposed to be
|
||||
temporary -- that was back in 2003. This should have been
|
||||
sorted out long ago. We'll just have to deal with the
|
||||
fallout.
|
||||
- Drop fedora-vfprintf-sw6530.patch, it's upstream now.
|
||||
- Drop rh769421.patch; Siddhesh has fixed this properly with 552960.
|
||||
|
||||
* Fri Sep 28 2012 Siddhesh Poyarekar <siddhesh@redhat.com> - 2.16.90-17
|
||||
- Release mutex before going back to wait for PI mutexes (#552960).
|
||||
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
cc7dff606fcb498b2da9bcdcb37d98ed glibc-2.16.90-f6a2737f-fedora.tar.gz
|
||||
6a90565046e9ec8d0f139e170824722c glibc-2.16.90-f6a2737f.tar.gz
|
||||
f3d2d76b578442702e4d5ad29e08f401 glibc-2.16.90-715a900c-fedora.tar.gz
|
||||
e2cdc7aff2f1a7eaa5a6d91c32029858 glibc-2.16.90-715a900c.tar.gz
|
||||
|
Loading…
Reference in New Issue
Block a user