Auto-sync with upstream branch master
Upstream commit: 734c60ebb607086ad6d67b2544d6b7baba72a652 - login: Move libutil into libc - login: Rework hidden prototypes for __setutent, __utmpname, __endutent - login: Hidden prototypes for _getpt, __ptsname_r, grantpt, unlockpt - nptl_db: Re-use the ELF-to-abilist converter for ABI checking - Add RFC 8335 Definitions from Linux 5.13 - nss: Fix NSS_DECLARE_MODULE_FUNCTIONS handling of _nss_*_endnetgrent - s390x: Update math: redirect roundeven function - posix: Add _Fork [BZ #4737]
This commit is contained in:
parent
d7e27f5895
commit
afd298e6eb
@ -1,74 +0,0 @@
|
||||
Emergency backport of a submitted upstream patch.
|
||||
|
||||
From: Stefan Liebler via Libc-alpha <libc-alpha@sourceware.org>
|
||||
Subject: [PATCH] s390x: Update math: redirect roundeven function
|
||||
To: libc-alpha@sourceware.org
|
||||
Cc: Stefan Liebler <stli@linux.ibm.com>
|
||||
Date: Mon, 28 Jun 2021 13:01:07 +0200 (4 hours, 41 minutes, 28 seconds ago)
|
||||
Message-Id: <20210628110107.4039211-1-stli@linux.ibm.com>
|
||||
Reply-To: Stefan Liebler <stli@linux.ibm.com>
|
||||
|
||||
After recent commit
|
||||
447954a206837b5f153869cfeeeab44631c3fac9
|
||||
"math: redirect roundeven function", building on
|
||||
s390x fails with:
|
||||
Error: symbol `__roundevenl' is already defined
|
||||
|
||||
Similar to aarch64/riscv fix, this patch redirects target
|
||||
specific functions for s390x:
|
||||
commit 3213ed770cbc5821920d16caa93c85e92dd7b9f6
|
||||
"Update math: redirect roundeven function"
|
||||
---
|
||||
sysdeps/s390/fpu/s_roundeven.c | 2 +-
|
||||
sysdeps/s390/fpu/s_roundevenf.c | 1 +
|
||||
sysdeps/s390/fpu/s_roundevenl.c | 1 +
|
||||
3 files changed, 3 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/sysdeps/s390/fpu/s_roundeven.c b/sysdeps/s390/fpu/s_roundeven.c
|
||||
index 40b07e054b..0773adfed0 100644
|
||||
--- a/sysdeps/s390/fpu/s_roundeven.c
|
||||
+++ b/sysdeps/s390/fpu/s_roundeven.c
|
||||
@@ -18,6 +18,7 @@
|
||||
<https://www.gnu.org/licenses/>. */
|
||||
|
||||
#ifdef HAVE_S390_MIN_Z196_ZARCH_ASM_SUPPORT
|
||||
+# define NO_MATH_REDIRECT
|
||||
# include <math.h>
|
||||
# include <libm-alias-double.h>
|
||||
|
||||
@@ -31,7 +32,6 @@ __roundeven (double x)
|
||||
__asm__ ("fidbra %0,4,%1,4" : "=f" (y) : "f" (x));
|
||||
return y;
|
||||
}
|
||||
-hidden_def (__roundeven)
|
||||
libm_alias_double (__roundeven, roundeven)
|
||||
|
||||
#else
|
||||
diff --git a/sysdeps/s390/fpu/s_roundevenf.c b/sysdeps/s390/fpu/s_roundevenf.c
|
||||
index d2fbf3d2b6..289785bc4a 100644
|
||||
--- a/sysdeps/s390/fpu/s_roundevenf.c
|
||||
+++ b/sysdeps/s390/fpu/s_roundevenf.c
|
||||
@@ -18,6 +18,7 @@
|
||||
<https://www.gnu.org/licenses/>. */
|
||||
|
||||
#ifdef HAVE_S390_MIN_Z196_ZARCH_ASM_SUPPORT
|
||||
+# define NO_MATH_REDIRECT
|
||||
# include <math.h>
|
||||
# include <libm-alias-float.h>
|
||||
|
||||
diff --git a/sysdeps/s390/fpu/s_roundevenl.c b/sysdeps/s390/fpu/s_roundevenl.c
|
||||
index 29ab7a8616..94b6459ab4 100644
|
||||
--- a/sysdeps/s390/fpu/s_roundevenl.c
|
||||
+++ b/sysdeps/s390/fpu/s_roundevenl.c
|
||||
@@ -18,6 +18,7 @@
|
||||
<https://www.gnu.org/licenses/>. */
|
||||
|
||||
#ifdef HAVE_S390_MIN_Z196_ZARCH_ASM_SUPPORT
|
||||
+# define NO_MATH_REDIRECT
|
||||
# include <math.h>
|
||||
# include <math_private.h>
|
||||
# include <libm-alias-ldouble.h>
|
||||
--
|
||||
|
||||
2.31.1
|
||||
|
21
glibc.spec
21
glibc.spec
@ -1,4 +1,4 @@
|
||||
%define glibcsrcdir glibc-2.33.9000-826-gdd45734e32
|
||||
%define glibcsrcdir glibc-2.33.9000-834-g734c60ebb6
|
||||
%define glibcversion 2.33.9000
|
||||
# Pre-release tarballs are pulled in from git using a command that is
|
||||
# effectively:
|
||||
@ -111,7 +111,7 @@
|
||||
Summary: The GNU libc libraries
|
||||
Name: glibc
|
||||
Version: %{glibcversion}
|
||||
Release: 34%{?dist}
|
||||
Release: 35%{?dist}
|
||||
|
||||
# In general, GPLv2+ is used by programs, LGPLv2+ is used for
|
||||
# libraries.
|
||||
@ -190,7 +190,6 @@ Patch23: glibc-python3.patch
|
||||
Patch29: glibc-fedora-nsswitch.patch
|
||||
Patch30: glibc-deprecated-selinux-makedb.patch
|
||||
Patch31: glibc-deprecated-selinux-nscd.patch
|
||||
Patch32: glibc-s390x-roundeven.patch
|
||||
|
||||
##############################################################################
|
||||
# Continued list of core "glibc" package information:
|
||||
@ -1650,7 +1649,7 @@ done
|
||||
###############################################################################
|
||||
|
||||
# Static libraries that land in glibc-devel, not glibc-static.
|
||||
devel_static_library_pattern='/lib\(\(c\|nldbl\|mvec\)_nonshared\|g\|ieee\|mcheck\|pthread\|dl\|rt\)\.a$'
|
||||
devel_static_library_pattern='/lib\(\(c\|nldbl\|mvec\)_nonshared\|g\|ieee\|mcheck\|pthread\|dl\|rt\|util\)\.a$'
|
||||
# Static libraries neither in glibc-devel nor in glibc-static.
|
||||
other_static_library_pattern='/libpthread_nonshared\.a'
|
||||
|
||||
@ -2208,6 +2207,20 @@ fi
|
||||
%files -f compat-libpthread-nonshared.filelist -n compat-libpthread-nonshared
|
||||
|
||||
%changelog
|
||||
* Wed Jun 30 2021 Florian Weimer <fweimer@redhat.com> - 2.33.9000-35
|
||||
- Drop glibc-s390x-roundeven.patch, applied upstream.
|
||||
- Move libutil.a into glibc-devel.
|
||||
- Auto-sync with upstream branch master,
|
||||
commit 734c60ebb607086ad6d67b2544d6b7baba72a652:
|
||||
- login: Move libutil into libc
|
||||
- login: Rework hidden prototypes for __setutent, __utmpname, __endutent
|
||||
- login: Hidden prototypes for _getpt, __ptsname_r, grantpt, unlockpt
|
||||
- nptl_db: Re-use the ELF-to-abilist converter for ABI checking
|
||||
- Add RFC 8335 Definitions from Linux 5.13
|
||||
- nss: Fix NSS_DECLARE_MODULE_FUNCTIONS handling of _nss_*_endnetgrent
|
||||
- s390x: Update math: redirect roundeven function
|
||||
- posix: Add _Fork [BZ #4737]
|
||||
|
||||
* Mon Jun 28 2021 Florian Weimer <fweimer@redhat.com> - 2.33.9000-34
|
||||
- Move librt.a to glibc-devel (#1977058)
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (glibc-2.33.9000-826-gdd45734e32.tar.xz) = aa8f50f32659e34e50405dfa788f3c5007819ba8649f646cba0df55e424e48afcb28410d488ef3f675d19aebc7b621c0fef742da64d4c2084c6dbfb99dbb81dd
|
||||
SHA512 (glibc-2.33.9000-834-g734c60ebb6.tar.xz) = f46a04d81ed78ed704969f2f920e4441e0ca7a4b78229528c54a7065a35a8566a40a0105478714ffe3a7d8072883b8efd4fa4cf1987874e185dec7e21bb87a04
|
||||
|
Loading…
Reference in New Issue
Block a user