- Resync with upstream sources.
- Don't use distinct patches for 770869, 787201 and 688948 as they all modify stuff under fedora/ - Repack patchlist
This commit is contained in:
parent
178231ee78
commit
a7ee17d411
2
.gitignore
vendored
2
.gitignore
vendored
@ -62,3 +62,5 @@ glibc-2.14-394-g8f3b1ff
|
|||||||
/glibc-2.16.90-2a0e2669.tar.gz
|
/glibc-2.16.90-2a0e2669.tar.gz
|
||||||
/glibc-2.16.90-d6cffd3e-fedora.tar.gz
|
/glibc-2.16.90-d6cffd3e-fedora.tar.gz
|
||||||
/glibc-2.16.90-d6cffd3e.tar.gz
|
/glibc-2.16.90-d6cffd3e.tar.gz
|
||||||
|
/glibc-2.16.90-8f861542-fedora.tar.gz
|
||||||
|
/glibc-2.16.90-8f861542.tar.gz
|
||||||
|
@ -1,37 +0,0 @@
|
|||||||
diff -rNup a/fedora/glibc_post_upgrade.c b/fedora/glibc_post_upgrade.c
|
|
||||||
--- a/fedora/glibc_post_upgrade.c 2011-10-19 05:04:41.000000000 -0600
|
|
||||||
+++ b/fedora/glibc_post_upgrade.c 2012-02-06 11:02:03.236713830 -0700
|
|
||||||
@@ -60,6 +60,7 @@ is_ia64 (void)
|
|
||||||
int
|
|
||||||
main (void)
|
|
||||||
{
|
|
||||||
+ struct stat statbuf;
|
|
||||||
char initpath[256];
|
|
||||||
|
|
||||||
char buffer[4096];
|
|
||||||
@@ -170,12 +171,24 @@ main (void)
|
|
||||||
|| ((!!access ("/dev/initctl", F_OK))
|
|
||||||
^ !access ("/sbin/initctl", X_OK)))
|
|
||||||
_exit (0);
|
|
||||||
+
|
|
||||||
/* Check if we are not inside of some chroot, because we'd just
|
|
||||||
- timeout and leave /etc/initrunlvl. */
|
|
||||||
+ timeout and leave /etc/initrunlvl.
|
|
||||||
+
|
|
||||||
+ On more modern systems this test is not sufficient to detect
|
|
||||||
+ if we're in a chroot. */
|
|
||||||
if (readlink ("/proc/1/exe", initpath, 256) <= 0 ||
|
|
||||||
readlink ("/proc/1/root", initpath, 256) <= 0)
|
|
||||||
_exit (0);
|
|
||||||
|
|
||||||
+ /* Here's another well known way to detect chroot, at least on an
|
|
||||||
+ ext and xfs filesystems and assuming nothing mounted on the chroot's
|
|
||||||
+ root. */
|
|
||||||
+ if (stat ("/", &statbuf) != 0
|
|
||||||
+ || (statbuf.st_ino != 2
|
|
||||||
+ && statbuf.st_ino != 128))
|
|
||||||
+ _exit (0);
|
|
||||||
+
|
|
||||||
if (check_elf ("/proc/1/exe"))
|
|
||||||
verbose_exec (116, "/sbin/telinit", "/sbin/telinit", "u");
|
|
||||||
|
|
@ -1,23 +0,0 @@
|
|||||||
diff -rup a/fedora/nscd.service b/fedora/nscd.service
|
|
||||||
--- a/fedora/nscd.service 2011-10-19 05:04:41.000000000 -0600
|
|
||||||
+++ b/fedora/nscd.service 2012-02-03 13:40:37.070063851 -0700
|
|
||||||
@@ -3,16 +3,15 @@ Description=Name Service Cache Daemon
|
|
||||||
After=syslog.target
|
|
||||||
|
|
||||||
[Service]
|
|
||||||
-Type=forking
|
|
||||||
EnvironmentFile=-/etc/sysconfig/nscd
|
|
||||||
-ExecStart=/usr/sbin/nscd $NSCD_OPTIONS
|
|
||||||
+ExecStart=/usr/sbin/nscd --foreground $NSCD_OPTIONS
|
|
||||||
ExecStop=/usr/sbin/nscd --shutdown
|
|
||||||
ExecReload=/usr/sbin/nscd -i passwd
|
|
||||||
ExecReload=/usr/sbin/nscd -i group
|
|
||||||
ExecReload=/usr/sbin/nscd -i hosts
|
|
||||||
-ExecReload=/usr/sbin/nscd -i service
|
|
||||||
+ExecReload=/usr/sbin/nscd -i services
|
|
||||||
+ExecReload=/usr/sbin/nscd -i netgroup
|
|
||||||
Restart=always
|
|
||||||
-PIDFile=/run/nscd/nscd.pid
|
|
||||||
|
|
||||||
[Install]
|
|
||||||
WantedBy=multi-user.target
|
|
@ -1,12 +0,0 @@
|
|||||||
diff -rup a/fedora/glibc.spec.in b/fedora/glibc.spec.in
|
|
||||||
--- a/fedora/glibc.spec.in 2011-10-19 05:04:41.000000000 -0600
|
|
||||||
+++ b/fedora/glibc.spec.in 2012-02-03 09:26:36.669828253 -0700
|
|
||||||
@@ -316,7 +316,7 @@ GCC="gcc -m64"
|
|
||||||
GXX="g++ -m64"
|
|
||||||
%endif
|
|
||||||
%ifarch ppc64
|
|
||||||
-BuildFlags="-mno-minimal-toc"
|
|
||||||
+BuildFlags=
|
|
||||||
GCC="gcc -m64"
|
|
||||||
GXX="g++ -m64"
|
|
||||||
%endif
|
|
31
glibc.spec
31
glibc.spec
@ -1,4 +1,4 @@
|
|||||||
%define glibcsrcdir glibc-2.16.90-d6cffd3e
|
%define glibcsrcdir glibc-2.16.90-8f861542
|
||||||
%define glibcversion 2.16.90
|
%define glibcversion 2.16.90
|
||||||
### glibc.spec.in follows:
|
### glibc.spec.in follows:
|
||||||
%define run_glibc_tests 1
|
%define run_glibc_tests 1
|
||||||
@ -27,7 +27,7 @@
|
|||||||
Summary: The GNU libc libraries
|
Summary: The GNU libc libraries
|
||||||
Name: glibc
|
Name: glibc
|
||||||
Version: %{glibcversion}
|
Version: %{glibcversion}
|
||||||
Release: 26%{?dist}
|
Release: 27%{?dist}
|
||||||
# GPLv2+ is used in a bunch of programs, LGPLv2+ is used for libraries.
|
# GPLv2+ is used in a bunch of programs, LGPLv2+ is used for libraries.
|
||||||
# Things that are linked directly into dynamically linked programs
|
# Things that are linked directly into dynamically linked programs
|
||||||
# and shared libraries (e.g. crt files, lib*_nonshared.a) have an additional
|
# and shared libraries (e.g. crt files, lib*_nonshared.a) have an additional
|
||||||
@ -65,11 +65,9 @@ Patch0001: %{name}-fedora-nscd.patch
|
|||||||
|
|
||||||
Patch0002: %{name}-fedora-regcomp-sw11561.patch
|
Patch0002: %{name}-fedora-regcomp-sw11561.patch
|
||||||
|
|
||||||
# Not likely to be accepted upstream
|
Patch0003: %{name}-fedora-nss-files-overflow-fix.patch
|
||||||
Patch0003: %{name}-rh787201.patch
|
|
||||||
|
|
||||||
# Not necessary to send upstream, fedora specific
|
Patch0004: %{name}-fedora-ppc-unwind.patch
|
||||||
Patch0004: %{name}-rh688948.patch
|
|
||||||
|
|
||||||
# Build info files in the source tree, then move to the build
|
# Build info files in the source tree, then move to the build
|
||||||
# tree so that they're identical for multilib builds
|
# tree so that they're identical for multilib builds
|
||||||
@ -92,6 +90,8 @@ Patch0009: %{name}-rh657588.patch
|
|||||||
# stap, needs to be sent upstream
|
# stap, needs to be sent upstream
|
||||||
Patch0010: %{name}-stap-libm.patch
|
Patch0010: %{name}-stap-libm.patch
|
||||||
|
|
||||||
|
Patch0014: %{name}-fedora-nptl-linklibc.patch
|
||||||
|
|
||||||
# Needs to be sent upstream
|
# Needs to be sent upstream
|
||||||
Patch0029: %{name}-rh841318.patch
|
Patch0029: %{name}-rh841318.patch
|
||||||
|
|
||||||
@ -122,10 +122,7 @@ Patch0049: %{name}-fedora-localedef.patch
|
|||||||
Patch0050: %{name}-fedora-locarchive.patch
|
Patch0050: %{name}-fedora-locarchive.patch
|
||||||
Patch0051: %{name}-fedora-manual-dircategory.patch
|
Patch0051: %{name}-fedora-manual-dircategory.patch
|
||||||
Patch0052: %{name}-fedora-nis-rh188246.patch
|
Patch0052: %{name}-fedora-nis-rh188246.patch
|
||||||
Patch0053: %{name}-fedora-nptl-linklibc.patch
|
Patch0053: %{name}-fedora-strict-aliasing.patch
|
||||||
Patch0054: %{name}-fedora-ppc-unwind.patch
|
|
||||||
Patch0055: %{name}-fedora-nss-files-overflow-fix.patch
|
|
||||||
Patch0056: %{name}-fedora-strict-aliasing.patch
|
|
||||||
|
|
||||||
#
|
#
|
||||||
# Patches from upstream
|
# Patches from upstream
|
||||||
@ -144,7 +141,6 @@ Patch2011: %{name}-rh757881.patch
|
|||||||
Patch2012: %{name}-rh730856.patch
|
Patch2012: %{name}-rh730856.patch
|
||||||
|
|
||||||
Patch2013: %{name}-rh741105.patch
|
Patch2013: %{name}-rh741105.patch
|
||||||
Patch2014: %{name}-rh770869.patch
|
|
||||||
Patch2015: %{name}-rh770439.patch
|
Patch2015: %{name}-rh770439.patch
|
||||||
Patch2016: %{name}-rh789209.patch
|
Patch2016: %{name}-rh789209.patch
|
||||||
Patch2017: %{name}-rh691912.patch
|
Patch2017: %{name}-rh691912.patch
|
||||||
@ -417,7 +413,7 @@ package or when debugging this package.
|
|||||||
%patch2011 -p1
|
%patch2011 -p1
|
||||||
%patch2012 -p1
|
%patch2012 -p1
|
||||||
%patch2013 -p1
|
%patch2013 -p1
|
||||||
%patch2014 -p1
|
%patch0014 -p1
|
||||||
%patch2015 -p1
|
%patch2015 -p1
|
||||||
%patch2016 -p1
|
%patch2016 -p1
|
||||||
%patch2017 -p1
|
%patch2017 -p1
|
||||||
@ -457,9 +453,6 @@ package or when debugging this package.
|
|||||||
%patch0051 -p1
|
%patch0051 -p1
|
||||||
%patch0052 -p1
|
%patch0052 -p1
|
||||||
%patch0053 -p1
|
%patch0053 -p1
|
||||||
%patch0054 -p1
|
|
||||||
%patch0055 -p1
|
|
||||||
%patch0056 -p1
|
|
||||||
|
|
||||||
# On powerpc32, hp timing is only available in power4/power6
|
# On powerpc32, hp timing is only available in power4/power6
|
||||||
# libs, not in base, so pre-power4 dynamic linker is incompatible
|
# libs, not in base, so pre-power4 dynamic linker is incompatible
|
||||||
@ -513,7 +506,7 @@ GCC="gcc -m64"
|
|||||||
GXX="g++ -m64"
|
GXX="g++ -m64"
|
||||||
%endif
|
%endif
|
||||||
%ifarch %{power64}
|
%ifarch %{power64}
|
||||||
BuildFlags="-mno-minimal-toc"
|
BuildFlags=""
|
||||||
GCC="gcc -m64"
|
GCC="gcc -m64"
|
||||||
GXX="g++ -m64"
|
GXX="g++ -m64"
|
||||||
%endif
|
%endif
|
||||||
@ -1254,6 +1247,12 @@ rm -f *.filelist*
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Nov 5 2012 Jeff Law <law@redhat.com> - 2.16.90-27
|
||||||
|
- Resync with upstream sources.
|
||||||
|
- Don't use distinct patches for 770869, 787201 and 688948
|
||||||
|
as they all modify stuff under fedora/
|
||||||
|
- Repack patchlist
|
||||||
|
|
||||||
* Thu Nov 1 2012 Jeff Law <law@redhat.com> - 2.16.90-26
|
* Thu Nov 1 2012 Jeff Law <law@redhat.com> - 2.16.90-26
|
||||||
- Resync with upstream sources (#872336)
|
- Resync with upstream sources (#872336)
|
||||||
|
|
||||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
|||||||
b79acdfe563ca4cadea129ec13287e3c glibc-2.16.90-d6cffd3e-fedora.tar.gz
|
c2cea9476c166a9619eba7f314e1b103 glibc-2.16.90-8f861542-fedora.tar.gz
|
||||||
3459d69cade97a354cafb60a030a95e7 glibc-2.16.90-d6cffd3e.tar.gz
|
df7068d3cc72dce07a6d5f17e0c73f4a glibc-2.16.90-8f861542.tar.gz
|
||||||
|
Loading…
Reference in New Issue
Block a user