Rework handling of asynchronous unwind tables compiler flag
This commit drops an overridden -fasynchronous-unwind-tables flag, which had no effect. We compile all of glibc with -fno-asynchronous-unwind-tables, so we can drop glibc-fedora-ppc-unwind.patch.
This commit is contained in:
parent
eb3d3880c8
commit
a4f378196e
@ -1,20 +0,0 @@
|
|||||||
glibc-2.3.3-1478-g37582bc
|
|
||||||
|
|
||||||
* Thu Nov 30 2006 Jakub Jelinek <jakub@redhat.com> 2.5.90-9
|
|
||||||
- on ppc64 build __libc_start_main without unwind info,
|
|
||||||
as it breaks MD_FROB_UPDATE_CONTEXT (#217729, #217775; in the
|
|
||||||
future that could be fixable just by providing .cfi_undefined r2
|
|
||||||
in __libc_start_main instead)
|
|
||||||
|
|
||||||
diff -Nrup a/sysdeps/powerpc/powerpc64/Makefile b/sysdeps/powerpc/powerpc64/Makefile
|
|
||||||
--- a/sysdeps/powerpc/powerpc64/Makefile 2012-06-05 07:42:49.000000000 -0600
|
|
||||||
+++ b/sysdeps/powerpc/powerpc64/Makefile 2012-06-07 12:15:21.828318633 -0600
|
|
||||||
@@ -35,6 +35,8 @@ CFLAGS-rtld-memmove.os = $(no-special-re
|
|
||||||
CFLAGS-rtld-memchr.os = $(no-special-regs)
|
|
||||||
CFLAGS-rtld-strnlen.os = $(no-special-regs)
|
|
||||||
|
|
||||||
+CFLAGS-libc-start.c += -fno-asynchronous-unwind-tables
|
|
||||||
+
|
|
||||||
ifeq ($(subdir),elf)
|
|
||||||
# help gcc inline asm code from dl-machine.h
|
|
||||||
+cflags += -finline-limit=2000
|
|
@ -178,8 +178,6 @@ Source11: SUPPORTED
|
|||||||
# change this.
|
# change this.
|
||||||
Patch0001: glibc-fedora-nscd.patch
|
Patch0001: glibc-fedora-nscd.patch
|
||||||
|
|
||||||
Patch0004: glibc-fedora-ppc-unwind.patch
|
|
||||||
|
|
||||||
# Build info files in the source tree, then move to the build
|
# Build info files in the source tree, then move to the build
|
||||||
# tree so that they're identical for multilib builds
|
# tree so that they're identical for multilib builds
|
||||||
Patch0005: glibc-rh825061.patch
|
Patch0005: glibc-rh825061.patch
|
||||||
@ -724,7 +722,6 @@ microbenchmark tests on the system.
|
|||||||
|
|
||||||
# Patch order matters.
|
# Patch order matters.
|
||||||
%patch0001 -p1
|
%patch0001 -p1
|
||||||
%patch0004 -p1
|
|
||||||
%patch0005 -p1
|
%patch0005 -p1
|
||||||
%patch2007 -p1
|
%patch2007 -p1
|
||||||
%patch0009 -p1
|
%patch0009 -p1
|
||||||
@ -888,7 +885,6 @@ BuildFlags="-march=mips64r2 -mabi=64 -mrelax-pic-calls"
|
|||||||
##############################################################################
|
##############################################################################
|
||||||
# %%build - Generic options.
|
# %%build - Generic options.
|
||||||
##############################################################################
|
##############################################################################
|
||||||
BuildFlags="$BuildFlags -fasynchronous-unwind-tables"
|
|
||||||
EnableKernel="--enable-kernel=%{enablekernel}"
|
EnableKernel="--enable-kernel=%{enablekernel}"
|
||||||
# Save the used compiler and options into the file "Gcc" for use later
|
# Save the used compiler and options into the file "Gcc" for use later
|
||||||
# by %%install.
|
# by %%install.
|
||||||
|
Loading…
Reference in New Issue
Block a user