Add glibc-rpcgen subpackage, until the replacement is packaged (#1531540)

This commit is contained in:
Florian Weimer 2018-01-08 16:46:16 +01:00
parent 1042b5d52a
commit a281128660
2 changed files with 53 additions and 2 deletions

22
glibc-rpcgen.patch Normal file
View File

@ -0,0 +1,22 @@
Enable rpcgen unconditionally even if Sun RPC is disabled.
rpcgen will be installed into the glibc-rpcgen subpackage.
diff --git a/sunrpc/Makefile b/sunrpc/Makefile
index 8f2a3c8213e3564e..69be5c119bf5ff85 100644
--- a/sunrpc/Makefile
+++ b/sunrpc/Makefile
@@ -85,14 +85,12 @@ shared-only-routines = $(routines)
endif
endif
-ifeq ($(link-obsolete-rpc),yes)
install-bin := rpcgen
rpcgen-objs = rpc_main.o rpc_hout.o rpc_cout.o rpc_parse.o \
rpc_scan.o rpc_util.o rpc_svcout.o rpc_clntout.o \
rpc_tblout.o rpc_sample.o
extra-objs = $(rpcgen-objs) $(addprefix cross-,$(rpcgen-objs))
others += rpcgen
-endif
tests = tst-xdrmem tst-xdrmem2 test-rpcent tst-udp-error tst-udp-timeout \
tst-udp-nonblocking

View File

@ -1,6 +1,6 @@
%define glibcsrcdir glibc-2.26.9000-1095-g579396ee08 %define glibcsrcdir glibc-2.26.9000-1095-g579396ee08
%define glibcversion 2.26.9000 %define glibcversion 2.26.9000
%define glibcrelease 36%{?dist} %define glibcrelease 37%{?dist}
# Pre-release tarballs are pulled in from git using a command that is # Pre-release tarballs are pulled in from git using a command that is
# effectively: # effectively:
# #
@ -170,6 +170,7 @@ Patch0024: glibc-fedora-locarchive.patch
Patch0025: glibc-fedora-streams-rh436349.patch Patch0025: glibc-fedora-streams-rh436349.patch
Patch0028: glibc-fedora-localedata-rh61908.patch Patch0028: glibc-fedora-localedata-rh61908.patch
Patch0031: glibc-fedora-__libc_multiple_libcs.patch Patch0031: glibc-fedora-__libc_multiple_libcs.patch
Patch32: glibc-rpcgen.patch
# Allow applications to call pthread_atfork without libpthread.so. # Allow applications to call pthread_atfork without libpthread.so.
Patch0046: glibc-rh1013801.patch Patch0046: glibc-rh1013801.patch
@ -358,6 +359,19 @@ hashing.
%postun -n libcrypt %postun -n libcrypt
/sbin/ldconfig /sbin/ldconfig
######################################################################
# rpcgen subpackage
######################################################################
%package rpcgen
Summary: rpcgen compiler for Sun RPC protocol descriptions (glibc variant)
Provides: rpcgen
Provides: /usr/bin/rpcgen
%description rpcgen
This package provides the rpcgen program, for compiled .x protocol
description files into C source code.
############################################################################## ##############################################################################
# glibc "devel" sub-package # glibc "devel" sub-package
############################################################################## ##############################################################################
@ -725,6 +739,7 @@ microbenchmark tests on the system.
%patch2027 -p1 %patch2027 -p1
%patch0028 -p1 %patch0028 -p1
%patch0031 -p1 %patch0031 -p1
%patch32 -p1
%patch0046 -p1 %patch0046 -p1
%patch2031 -p1 %patch2031 -p1
%patch0047 -p1 %patch0047 -p1
@ -1261,6 +1276,8 @@ rm -f $RPM_BUILD_ROOT%{_prefix}/lib/debug%{_libdir}/*_p.a
# - Contains the list of flies for the common subpackage. # - Contains the list of flies for the common subpackage.
# * utils.filelist # * utils.filelist
# - Contains the list of files for the utils subpackage. # - Contains the list of files for the utils subpackage.
# * rpcgen.filelist
# - Contains the list of files for the rpcgen subpackage.
# * nscd.filelist # * nscd.filelist
# - Contains the list of files for the nscd subpackage. # - Contains the list of files for the nscd subpackage.
# * devel.filelist # * devel.filelist
@ -1315,7 +1332,7 @@ rm -f $RPM_BUILD_ROOT%{_prefix}/lib/debug%{_libdir}/*_p.a
-e '\,.*/share/i18n/charmaps/.*,d' \ -e '\,.*/share/i18n/charmaps/.*,d' \
-e '\,/etc/\(localtime\|nsswitch.conf\|ld\.so\.conf\|ld\.so\.cache\|default\|rpc\|gai\.conf\),d' \ -e '\,/etc/\(localtime\|nsswitch.conf\|ld\.so\.conf\|ld\.so\.cache\|default\|rpc\|gai\.conf\),d' \
-e '\,/%{_lib}/lib\(pcprofile\|memusage\)\.so,d' \ -e '\,/%{_lib}/lib\(pcprofile\|memusage\)\.so,d' \
-e '\,bin/\(memusage\|mtrace\|xtrace\|pcprofiledump\),d' -e '\,bin/\(memusage\|mtrace\|xtrace\|pcprofiledump\|rpcgen\),d'
} | sort > rpm.filelist } | sort > rpm.filelist
touch common.filelist touch common.filelist
@ -1430,6 +1447,11 @@ cat > utils.filelist <<EOF
%{_prefix}/bin/xtrace %{_prefix}/bin/xtrace
EOF EOF
# rpcgen subpackage file list
cat > rpcgen.filelist <<EOF
%{_prefix}/bin/rpcgen
EOF
# Move the NSS-related files to the NSS subpackages. Be careful not # Move the NSS-related files to the NSS subpackages. Be careful not
# to pick up .debug files, and the -devel symbolic links. # to pick up .debug files, and the -devel symbolic links.
for module in db nis nisplus compat hesiod files dns; do for module in db nis nisplus compat hesiod files dns; do
@ -1565,6 +1587,7 @@ find_debuginfo_args='--strict-build-id -g'
find_debuginfo_args="$find_debuginfo_args \ find_debuginfo_args="$find_debuginfo_args \
-l common.filelist \ -l common.filelist \
-l utils.filelist \ -l utils.filelist \
-l rpcgen.filelist \
-l nscd.filelist \ -l nscd.filelist \
-p '.*/(sbin|libexec)/.*' \ -p '.*/(sbin|libexec)/.*' \
-o debuginfocommon.filelist \ -o debuginfocommon.filelist \
@ -1978,6 +2001,9 @@ fi
%files -f utils.filelist utils %files -f utils.filelist utils
%defattr(-,root,root) %defattr(-,root,root)
%files -f rpcgen.filelist rpcgen
%defattr(-,root,root)
%files -f nscd.filelist -n nscd %files -f nscd.filelist -n nscd
%defattr(-,root,root) %defattr(-,root,root)
%config(noreplace) /etc/nscd.conf %config(noreplace) /etc/nscd.conf
@ -2027,6 +2053,9 @@ fi
%endif %endif
%changelog %changelog
* Mon Jan 8 2018 Florian Weimer <fweimer@redhat.com> - 2.26.9000-37
- Add glibc-rpcgen subpackage, until the replacement is packaged (#1531540)
* Mon Jan 08 2018 Florian Weimer <fweimer@redhat.com> - 2.26.9000-36 * Mon Jan 08 2018 Florian Weimer <fweimer@redhat.com> - 2.26.9000-36
- Auto-sync with upstream branch master, - Auto-sync with upstream branch master,
commit 579396ee082565ab5f42ff166a264891223b7b82: commit 579396ee082565ab5f42ff166a264891223b7b82: