Defuzz patch
This commit is contained in:
parent
fb633eaa14
commit
a0c4aeb2e1
@ -13,8 +13,9 @@ Subject: [PATCH] Avoid strict-aliasing issues
|
|||||||
sysdeps/powerpc/powerpc64/elf/Makefile | 2 ++
|
sysdeps/powerpc/powerpc64/elf/Makefile | 2 ++
|
||||||
7 files changed, 13 insertions(+), 0 deletions(-)
|
7 files changed, 13 insertions(+), 0 deletions(-)
|
||||||
|
|
||||||
--- a/elf/Makefile 2012-06-05 07:42:49.000000000 -0600
|
diff -Nrup a/elf/Makefile b/elf/Makefile
|
||||||
+++ b/elf/Makefile 2012-06-07 12:15:21.572319589 -0600
|
--- a/elf/Makefile 2012-08-13 13:12:18.000000000 -0600
|
||||||
|
+++ b/elf/Makefile 2012-08-20 13:34:00.070089702 -0600
|
||||||
@@ -50,6 +50,7 @@ include ../Makeconfig
|
@@ -50,6 +50,7 @@ include ../Makeconfig
|
||||||
ifeq ($(unwind-find-fde),yes)
|
ifeq ($(unwind-find-fde),yes)
|
||||||
routines += unwind-dw2-fde-glibc
|
routines += unwind-dw2-fde-glibc
|
||||||
@ -23,8 +24,9 @@ Subject: [PATCH] Avoid strict-aliasing issues
|
|||||||
endif
|
endif
|
||||||
|
|
||||||
before-compile = $(objpfx)trusted-dirs.h
|
before-compile = $(objpfx)trusted-dirs.h
|
||||||
--- a/inet/Makefile 2012-06-05 07:42:49.000000000 -0600
|
diff -Nrup a/inet/Makefile b/inet/Makefile
|
||||||
+++ b/inet/Makefile 2012-06-07 12:15:21.582319552 -0600
|
--- a/inet/Makefile 2012-08-13 13:12:18.000000000 -0600
|
||||||
|
+++ b/inet/Makefile 2012-08-20 13:34:00.099089572 -0600
|
||||||
@@ -54,6 +54,8 @@ tests := htontest test_ifindex tst-ntoa
|
@@ -54,6 +54,8 @@ tests := htontest test_ifindex tst-ntoa
|
||||||
|
|
||||||
include ../Rules
|
include ../Rules
|
||||||
@ -34,8 +36,9 @@ Subject: [PATCH] Avoid strict-aliasing issues
|
|||||||
ifeq ($(have-thread-library),yes)
|
ifeq ($(have-thread-library),yes)
|
||||||
|
|
||||||
CFLAGS-gethstbyad_r.c = -DUSE_NSCD=1 -fexceptions
|
CFLAGS-gethstbyad_r.c = -DUSE_NSCD=1 -fexceptions
|
||||||
--- a/nis/Makefile 2012-06-05 07:42:49.000000000 -0600
|
diff -Nrup a/nis/Makefile b/nis/Makefile
|
||||||
+++ b/nis/Makefile 2012-06-07 12:15:21.810318702 -0600
|
--- a/nis/Makefile 2012-08-13 13:12:18.000000000 -0600
|
||||||
|
+++ b/nis/Makefile 2012-08-20 13:34:01.338084016 -0600
|
||||||
@@ -71,6 +71,8 @@ libnss_nisplus-inhibit-o = $(filter-out
|
@@ -71,6 +71,8 @@ libnss_nisplus-inhibit-o = $(filter-out
|
||||||
|
|
||||||
include ../Rules
|
include ../Rules
|
||||||
@ -45,8 +48,9 @@ Subject: [PATCH] Avoid strict-aliasing issues
|
|||||||
|
|
||||||
$(objpfx)libnss_compat.so: $(objpfx)libnsl.so$(libnsl.so-version)
|
$(objpfx)libnss_compat.so: $(objpfx)libnsl.so$(libnsl.so-version)
|
||||||
$(objpfx)libnss_nis.so: $(objpfx)libnsl.so$(libnsl.so-version) \
|
$(objpfx)libnss_nis.so: $(objpfx)libnsl.so$(libnsl.so-version) \
|
||||||
--- a/nss/Makefile 2012-06-05 07:42:49.000000000 -0600
|
diff -Nrup a/nss/Makefile b/nss/Makefile
|
||||||
+++ b/nss/Makefile 2012-06-07 12:15:21.819318667 -0600
|
--- a/nss/Makefile 2012-08-13 13:12:18.000000000 -0600
|
||||||
|
+++ b/nss/Makefile 2012-08-20 13:34:01.491083332 -0600
|
||||||
@@ -101,6 +101,7 @@ $(libnss_db-dbs:%=$(objpfx)%.c): $(objpf
|
@@ -101,6 +101,7 @@ $(libnss_db-dbs:%=$(objpfx)%.c): $(objpf
|
||||||
echo '#include "$<"') > $@.new
|
echo '#include "$<"') > $@.new
|
||||||
mv -f $@.new $@
|
mv -f $@.new $@
|
||||||
@ -55,8 +59,9 @@ Subject: [PATCH] Avoid strict-aliasing issues
|
|||||||
|
|
||||||
$(objpfx)makedb: $(makedb-modules:%=$(objpfx)%.o)
|
$(objpfx)makedb: $(makedb-modules:%=$(objpfx)%.o)
|
||||||
|
|
||||||
--- a/resolv/Makefile 2012-06-05 07:42:49.000000000 -0600
|
diff -Nrup a/resolv/Makefile b/resolv/Makefile
|
||||||
+++ b/resolv/Makefile 2012-06-07 12:15:21.822318657 -0600
|
--- a/resolv/Makefile 2012-08-13 13:12:18.000000000 -0600
|
||||||
|
+++ b/resolv/Makefile 2012-08-20 13:34:01.492083327 -0600
|
||||||
@@ -80,6 +80,7 @@ ifeq (yes,$(have-ssp))
|
@@ -80,6 +80,7 @@ ifeq (yes,$(have-ssp))
|
||||||
CFLAGS-libresolv += -fstack-protector
|
CFLAGS-libresolv += -fstack-protector
|
||||||
endif
|
endif
|
||||||
@ -65,8 +70,9 @@ Subject: [PATCH] Avoid strict-aliasing issues
|
|||||||
|
|
||||||
# The BIND code elicits some harmless warnings.
|
# The BIND code elicits some harmless warnings.
|
||||||
+cflags += -Wno-strict-prototypes -Wno-write-strings
|
+cflags += -Wno-strict-prototypes -Wno-write-strings
|
||||||
--- a/sunrpc/Makefile 2012-06-05 07:42:49.000000000 -0600
|
diff -Nrup a/sunrpc/Makefile b/sunrpc/Makefile
|
||||||
+++ b/sunrpc/Makefile 2012-06-07 12:15:21.825318645 -0600
|
--- a/sunrpc/Makefile 2012-08-13 13:12:18.000000000 -0600
|
||||||
|
+++ b/sunrpc/Makefile 2012-08-20 13:34:01.495083314 -0600
|
||||||
@@ -150,6 +150,10 @@ sunrpc-CPPFLAGS = -D_RPC_THREAD_SAFE_
|
@@ -150,6 +150,10 @@ sunrpc-CPPFLAGS = -D_RPC_THREAD_SAFE_
|
||||||
CPPFLAGS += $(sunrpc-CPPFLAGS)
|
CPPFLAGS += $(sunrpc-CPPFLAGS)
|
||||||
BUILD_CPPFLAGS += $(sunrpc-CPPFLAGS)
|
BUILD_CPPFLAGS += $(sunrpc-CPPFLAGS)
|
||||||
@ -78,11 +84,12 @@ Subject: [PATCH] Avoid strict-aliasing issues
|
|||||||
$(objpfx)tst-getmyaddr: $(common-objpfx)linkobj/libc.so
|
$(objpfx)tst-getmyaddr: $(common-objpfx)linkobj/libc.so
|
||||||
$(objpfx)tst-xdrmem: $(common-objpfx)linkobj/libc.so
|
$(objpfx)tst-xdrmem: $(common-objpfx)linkobj/libc.so
|
||||||
$(objpfx)tst-xdrmem2: $(common-objpfx)linkobj/libc.so
|
$(objpfx)tst-xdrmem2: $(common-objpfx)linkobj/libc.so
|
||||||
--- a/sysdeps/powerpc/powerpc64/Makefile 2012-06-05 07:42:49.000000000 -0600
|
diff -Nrup a/sysdeps/powerpc/powerpc64/Makefile b/sysdeps/powerpc/powerpc64/Makefile
|
||||||
+++ b/sysdeps/powerpc/powerpc64/Makefile 2012-06-07 12:15:21.828318633 -0600
|
--- a/sysdeps/powerpc/powerpc64/Makefile 2012-08-20 13:33:29.453227506 -0600
|
||||||
@@ -35,6 +35,8 @@ CFLAGS-rtld-memmove.os = $(no-special-re
|
+++ b/sysdeps/powerpc/powerpc64/Makefile 2012-08-20 13:34:01.496083309 -0600
|
||||||
CFLAGS-rtld-memchr.os = $(no-special-regs)
|
@@ -37,6 +37,8 @@ CFLAGS-rtld-strnlen.os = $(no-special-re
|
||||||
CFLAGS-rtld-strnlen.os = $(no-special-regs)
|
|
||||||
|
CFLAGS-libc-start.c += -fno-asynchronous-unwind-tables
|
||||||
|
|
||||||
+CFLAGS-gmon-start.c += -fno-strict-aliasing
|
+CFLAGS-gmon-start.c += -fno-strict-aliasing
|
||||||
+
|
+
|
||||||
|
Loading…
Reference in New Issue
Block a user