Fix gettext version check to accommodate snapshot builds in rawhide

If the gettext snapshots are deemed official upstream,
glibc-gettext-snapshot-versioncheck.patch will be posted upstream.
This commit is contained in:
Siddhesh Poyarekar 2022-03-08 20:24:19 +05:30
parent 2b9524042d
commit 93272df772
2 changed files with 49 additions and 1 deletions

View File

@ -0,0 +1,43 @@
commit e3f322fa0f85c7db60cb4eadfd97337964df1c4d
Author: Siddhesh Poyarekar <siddhesh@sourceware.org>
Date: Tue Mar 8 11:22:44 2022 +0530
configure: Allow gettext snapshots
Gettext snapshots may have a yyyy-mm-dd version number, so account for
that.
Signed-off-by: Siddhesh Poyarekar <siddhesh@sourceware.org>
diff --git a/configure b/configure
index 8e5bee775a..b31703557d 100755
--- a/configure
+++ b/configure
@@ -5011,10 +5011,10 @@ else
# Found it, now check the version.
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking version of $MSGFMT" >&5
$as_echo_n "checking version of $MSGFMT... " >&6; }
- ac_prog_version=`$MSGFMT --version 2>&1 | sed -n 's/^.*GNU gettext.* \([0-9]*\.[0-9.]*\).*$/\1/p'`
+ ac_prog_version=`$MSGFMT --version 2>&1 | sed -n 's/^.*GNU gettext.* \(\([0-9]*\.[0-9.]*\)\|\([0-9]*-[0-9]*-[0-9]*\)\).*$/\1/p'`
case $ac_prog_version in
'') ac_prog_version="v. ?.??, bad"; ac_verc_fail=yes;;
- 0.10.3[6-9]* | 0.10.[4-9][0-9]* | 0.1[1-9]* | 0.[2-9][0-9]* | [1-9].*)
+ 0.10.3[6-9]* | 0.10.[4-9][0-9]* | 0.1[1-9]* | 0.[2-9][0-9]* | [1-9].* | [0-9]*-[0-9]*-[0-9]*)
ac_prog_version="$ac_prog_version, ok"; ac_verc_fail=no;;
*) ac_prog_version="$ac_prog_version, bad"; ac_verc_fail=yes;;
diff --git a/configure.ac b/configure.ac
index 87f67d25ec..2f39f7e2d1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1040,8 +1040,8 @@ AC_CHECK_PROG_VER(MAKE, gnumake gmake make, --version,
[[4-9].* | [1-9][0-9]*], critic_missing="$critic_missing make")
AC_CHECK_PROG_VER(MSGFMT, gnumsgfmt gmsgfmt msgfmt, --version,
- [GNU gettext.* \([0-9]*\.[0-9.]*\)],
- [0.10.3[6-9]* | 0.10.[4-9][0-9]* | 0.1[1-9]* | 0.[2-9][0-9]* | [1-9].*],
+ [GNU gettext.* \(\([0-9]*\.[0-9.]*\)\|\([0-9]*-[0-9]*-[0-9]*\)\)],
+ [0.10.3[6-9]* | 0.10.[4-9][0-9]* | 0.1[1-9]* | 0.[2-9][0-9]* | [1-9].* | [0-9]*-[0-9]*-[0-9]*],
MSGFMT=: aux_missing="$aux_missing msgfmt")
AC_CHECK_PROG_VER(MAKEINFO, makeinfo, --version,
[GNU texinfo.* \([0-9][0-9.]*\)],

View File

@ -152,7 +152,7 @@ end}
Summary: The GNU libc libraries
Name: glibc
Version: %{glibcversion}
Release: 7%{?dist}
Release: 8%{?dist}
# In general, GPLv2+ is used by programs, LGPLv2+ is used for
# libraries.
@ -228,6 +228,8 @@ Patch30: glibc-deprecated-selinux-makedb.patch
# Temporary until gcc is patched to have -mlong-double-64 override
# -mabi=ibmlongdouble instead of conflict with it.
Patch99: glibc-temp-ibmldbl64.patch
# Temporary until gettext snapshot versioning is resolved, see #2061646.
Patch100: glibc-gettext-snapshot-versioncheck.patch
##############################################################################
# Continued list of core "glibc" package information:
@ -2174,6 +2176,9 @@ update_gconv_modules_cache ()
%files -f compat-libpthread-nonshared.filelist -n compat-libpthread-nonshared
%changelog
* Tue Mar 08 2022 Siddhesh Poyarekar <siddhesh@redhat.com> - 2.35.9000-8
- Fix version check to accommodate gettext snapshot builds in rawhide.
* Tue Mar 01 2022 Carlos O'Donell <carlos@redhat.com> - 2.35.9000-7
- Auto-sync with upstream branch master,
commit 2bbc694df279020a6620096d31c1e05c93966f9b: