2.11.90-7

This commit is contained in:
Andreas Schwab 2010-01-11 15:35:32 +00:00
parent e7298f2636
commit 930f8bac49
5 changed files with 130 additions and 62 deletions

View File

@ -1,2 +1,2 @@
glibc-2.11-100-g33780b6-fedora.tar.bz2
glibc-2.11-100-g33780b6.tar.bz2
glibc-2.11-100-g33780b6-fedora.tar.bz2

View File

@ -1,6 +1,17 @@
--- glibc-2.11-100-g33780b6/ChangeLog
+++ glibc-2.11.90-5/ChangeLog
@@ -1549,6 +1549,11 @@ d2009-10-30 Ulrich Drepper <drepper@redhat.com>
+++ glibc-2.11.90-7/ChangeLog
@@ -1,3 +1,10 @@
+2010-01-11 Andreas Schwab <schwab@redhat.com>
+
+ * io/fcntl.h: Only include <bits/stat.h> once.
+ * io/sys/stat.h: Likewise.
+
+ * bits/confname.h: Add missing comma, remove trailing commas.
+
2010-01-10 Ulrich Drepper <drepper@redhat.com>
* sysdeps/unix/sysv/linux/bits/sigaction.h: SA_RESTART, SA_NODEFER,
@@ -1549,6 +1556,11 @@ d2009-10-30 Ulrich Drepper <drepper@redhat.com>
* sysdeps/generic/ldsodefs.h (struct rtld_global): The map element in
the unique symbol hash table should not be const.
@ -12,7 +23,7 @@
2009-07-21 Ulrich Drepper <drepper@redhat.com>
* sysdeps/x86_64/multiarch/strstr.c: Minor cleanups. Remove
@@ -1814,6 +1819,11 @@ d2009-10-30 Ulrich Drepper <drepper@redhat.com>
@@ -1814,6 +1826,11 @@ d2009-10-30 Ulrich Drepper <drepper@redhat.com>
out common code into new function get_common_indeces. Determine
extended family and model for Intel processors.
@ -24,7 +35,7 @@
2009-06-26 Ulrich Drepper <drepper@redhat.com>
* resolv/resolv.h: Define RES_SNGLKUPREOP.
@@ -10507,6 +10517,10 @@ d2009-10-30 Ulrich Drepper <drepper@redhat.com>
@@ -10507,6 +10524,10 @@ d2009-10-30 Ulrich Drepper <drepper@redhat.com>
[BZ #4368]
* stdlib/stdlib.h: Remove obsolete part of comment for realpath.
@ -35,7 +46,7 @@
2007-04-16 Ulrich Drepper <drepper@redhat.com>
[BZ #4364]
@@ -11764,6 +11778,15 @@ d2009-10-30 Ulrich Drepper <drepper@redhat.com>
@@ -11764,6 +11785,15 @@ d2009-10-30 Ulrich Drepper <drepper@redhat.com>
separators also if no non-zero digits found.
* stdlib/Makefile (tests): Add tst-strtod3.
@ -52,7 +63,7 @@
[BZ #3632]
--- glibc-2.11-100-g33780b6/ChangeLog.15
+++ glibc-2.11.90-5/ChangeLog.15
+++ glibc-2.11.90-7/ChangeLog.15
@@ -477,6 +477,14 @@
2004-11-26 Jakub Jelinek <jakub@redhat.com>
@ -119,7 +130,7 @@
* scripts/extract-abilist.awk: If `lastversion' variable defined, omit
--- glibc-2.11-100-g33780b6/ChangeLog.16
+++ glibc-2.11.90-5/ChangeLog.16
+++ glibc-2.11.90-7/ChangeLog.16
@@ -2042,6 +2042,9 @@
(__MATHDECL_2): Use __REDIRECT_NTH instead of __REDIRECT
followed by __THROW.
@ -174,7 +185,7 @@
[BZ #1137]
--- glibc-2.11-100-g33780b6/Makeconfig
+++ glibc-2.11.90-5/Makeconfig
+++ glibc-2.11.90-7/Makeconfig
@@ -780,12 +780,12 @@ endif
# The assembler can generate debug information too.
ifndef ASFLAGS
@ -191,8 +202,33 @@
ifndef BUILD_CC
BUILD_CC = $(CC)
--- glibc-2.11-100-g33780b6/bits/confname.h
+++ glibc-2.11.90-7/bits/confname.h
@@ -527,7 +527,7 @@ enum
_SC_THREAD_ROBUST_PRIO_INHERIT,
#define _SC_THREAD_ROBUST_PRIO_INHERIT _SC_THREAD_ROBUST_PRIO_INHERIT
- _SC_THREAD_ROBUST_PRIO_PROTECT,
+ _SC_THREAD_ROBUST_PRIO_PROTECT
#define _SC_THREAD_ROBUST_PRIO_PROTECT _SC_THREAD_ROBUST_PRIO_PROTECT
};
@@ -667,11 +667,11 @@ enum
#define _CS_POSIX_V7_LPBIG_OFFBIG_LDFLAGS _CS_POSIX_V7_LPBIG_OFFBIG_LDFLAGS
_CS_POSIX_V7_LPBIG_OFFBIG_LIBS,
#define _CS_POSIX_V7_LPBIG_OFFBIG_LIBS _CS_POSIX_V7_LPBIG_OFFBIG_LIBS
- _CS_POSIX_V7_LPBIG_OFFBIG_LINTFLAGS
+ _CS_POSIX_V7_LPBIG_OFFBIG_LINTFLAGS,
#define _CS_POSIX_V7_LPBIG_OFFBIG_LINTFLAGS _CS_POSIX_V7_LPBIG_OFFBIG_LINTFLAGS
_CS_V6_ENV,
#define _CS_V6_ENV _CS_V6_ENV
- _CS_V7_ENV,
+ _CS_V7_ENV
#define _CS_V7_ENV _CS_V7_ENV
};
--- glibc-2.11-100-g33780b6/csu/Makefile
+++ glibc-2.11.90-5/csu/Makefile
+++ glibc-2.11.90-7/csu/Makefile
@@ -93,7 +93,8 @@ omit-deps += $(crtstuff)
$(crtstuff:%=$(objpfx)%.o): %.o: %.S $(objpfx)defs.h
$(compile.S) -g0 $(ASFLAGS-.os) -o $@
@ -204,7 +240,7 @@
vpath initfini.c $(sysdirs)
--- glibc-2.11-100-g33780b6/csu/elf-init.c
+++ glibc-2.11.90-5/csu/elf-init.c
+++ glibc-2.11.90-7/csu/elf-init.c
@@ -63,6 +63,23 @@ extern void (*__init_array_end []) (int, char **, char **)
extern void (*__fini_array_start []) (void) attribute_hidden;
extern void (*__fini_array_end []) (void) attribute_hidden;
@ -230,7 +266,7 @@
/* These function symbols are provided for the .init/.fini section entry
points automagically by the linker. */
--- glibc-2.11-100-g33780b6/debug/tst-chk1.c
+++ glibc-2.11.90-5/debug/tst-chk1.c
+++ glibc-2.11.90-7/debug/tst-chk1.c
@@ -17,6 +17,9 @@
Software Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
02111-1307 USA. */
@ -260,7 +296,7 @@
# else
# define O 1
--- glibc-2.11-100-g33780b6/elf/ldconfig.c
+++ glibc-2.11.90-5/elf/ldconfig.c
+++ glibc-2.11.90-7/elf/ldconfig.c
@@ -1020,17 +1020,19 @@ search_dirs (void)
@ -343,7 +379,7 @@
if (! opt_ignore_aux_cache)
--- glibc-2.11-100-g33780b6/elf/tst-stackguard1.c
+++ glibc-2.11.90-5/elf/tst-stackguard1.c
+++ glibc-2.11.90-7/elf/tst-stackguard1.c
@@ -160,17 +160,21 @@ do_test (void)
the 16 runs, something is very wrong. */
int ndifferences = 0;
@ -369,15 +405,15 @@
puts ("stack guard canaries are not randomized enough");
puts ("nor equal to the default canary value");
--- glibc-2.11-100-g33780b6/include/bits/stdlib-ldbl.h
+++ glibc-2.11.90-5/include/bits/stdlib-ldbl.h
+++ glibc-2.11.90-7/include/bits/stdlib-ldbl.h
@@ -0,0 +1 @@
+#include <stdlib/bits/stdlib-ldbl.h>
--- glibc-2.11-100-g33780b6/include/bits/wchar-ldbl.h
+++ glibc-2.11.90-5/include/bits/wchar-ldbl.h
+++ glibc-2.11.90-7/include/bits/wchar-ldbl.h
@@ -0,0 +1 @@
+#include <wcsmbs/bits/wchar-ldbl.h>
--- glibc-2.11-100-g33780b6/include/features.h
+++ glibc-2.11.90-5/include/features.h
+++ glibc-2.11.90-7/include/features.h
@@ -304,8 +304,13 @@
#endif
@ -395,7 +431,7 @@
# else
# define __USE_FORTIFY_LEVEL 1
--- glibc-2.11-100-g33780b6/intl/locale.alias
+++ glibc-2.11.90-5/intl/locale.alias
+++ glibc-2.11.90-7/intl/locale.alias
@@ -57,8 +57,6 @@ korean ko_KR.eucKR
korean.euc ko_KR.eucKR
ko_KR ko_KR.eucKR
@ -405,8 +441,36 @@
norwegian nb_NO.ISO-8859-1
nynorsk nn_NO.ISO-8859-1
polish pl_PL.ISO-8859-2
--- glibc-2.11-100-g33780b6/io/fcntl.h
+++ glibc-2.11.90-7/io/fcntl.h
@@ -38,7 +38,10 @@ __BEGIN_DECLS
# include <bits/types.h> /* For __mode_t and __dev_t. */
# define __need_timespec
# include <time.h>
-# include <bits/stat.h>
+# ifndef __bits_stat_h_included
+# include <bits/stat.h>
+# define __bits_stat_h_included
+# endif
# define S_IFMT __S_IFMT
# define S_IFDIR __S_IFDIR
--- glibc-2.11-100-g33780b6/io/sys/stat.h
+++ glibc-2.11.90-7/io/sys/stat.h
@@ -104,7 +104,10 @@ typedef __blksize_t blksize_t;
__BEGIN_DECLS
-#include <bits/stat.h>
+#ifndef __bits_stat_h_included
+# include <bits/stat.h>
+# define __bits_stat_h_included
+#endif
#if defined __USE_BSD || defined __USE_MISC || defined __USE_XOPEN
# define S_IFMT __S_IFMT
--- glibc-2.11-100-g33780b6/libio/stdio.h
+++ glibc-2.11.90-5/libio/stdio.h
+++ glibc-2.11.90-7/libio/stdio.h
@@ -165,10 +165,12 @@ typedef _G_fpos64_t fpos64_t;
extern struct _IO_FILE *stdin; /* Standard input stream. */
extern struct _IO_FILE *stdout; /* Standard output stream. */
@ -421,7 +485,7 @@
__BEGIN_NAMESPACE_STD
/* Remove file FILENAME. */
--- glibc-2.11-100-g33780b6/locale/iso-4217.def
+++ glibc-2.11.90-5/locale/iso-4217.def
+++ glibc-2.11.90-7/locale/iso-4217.def
@@ -8,6 +8,7 @@
*
* !!! The list has to be sorted !!!
@ -514,7 +578,7 @@
DEFINE_INT_CURR("QAR") /* Qatar Rial */
DEFINE_INT_CURR("ROL") /* Romanian Leu */
--- glibc-2.11-100-g33780b6/locale/programs/locarchive.c
+++ glibc-2.11.90-5/locale/programs/locarchive.c
+++ glibc-2.11.90-7/locale/programs/locarchive.c
@@ -241,9 +241,9 @@ oldlocrecentcmp (const void *a, const void *b)
/* forward decls for below */
static uint32_t add_locale (struct locarhandle *ah, const char *name,
@ -547,7 +611,7 @@
const char *oldname, uint32_t *locrec_offset_p)
{
--- glibc-2.11-100-g33780b6/localedata/Makefile
+++ glibc-2.11.90-5/localedata/Makefile
+++ glibc-2.11.90-7/localedata/Makefile
@@ -225,6 +225,7 @@ $(INSTALL-SUPPORTED-LOCALES): install-locales-dir
echo -n '...'; \
input=`echo $$locale | sed 's/\([^.]*\)[^@]*\(.*\)/\1\2/'`; \
@ -557,7 +621,7 @@
$(addprefix --prefix=,$(install_root)) $$locale; \
echo ' done'; \
--- glibc-2.11-100-g33780b6/localedata/SUPPORTED
+++ glibc-2.11.90-5/localedata/SUPPORTED
+++ glibc-2.11.90-7/localedata/SUPPORTED
@@ -84,6 +84,7 @@ cy_GB.UTF-8/UTF-8 \
cy_GB/ISO-8859-14 \
da_DK.UTF-8/UTF-8 \
@ -600,7 +664,7 @@
te_IN/UTF-8 \
tg_TJ.UTF-8/UTF-8 \
--- glibc-2.11-100-g33780b6/localedata/locales/cy_GB
+++ glibc-2.11.90-5/localedata/locales/cy_GB
+++ glibc-2.11.90-7/localedata/locales/cy_GB
@@ -248,8 +248,11 @@ mon "<U0049><U006F><U006E><U0061><U0077><U0072>";/
d_t_fmt "<U0044><U0079><U0064><U0064><U0020><U0025><U0041><U0020><U0025><U0064><U0020><U006d><U0069><U0073><U0020><U0025><U0042><U0020><U0025><U0059><U0020><U0025><U0054><U0020><U0025><U005A>"
d_fmt "<U0025><U0064><U002E><U0025><U006D><U002E><U0025><U0079>"
@ -616,7 +680,7 @@
LC_MESSAGES
--- glibc-2.11-100-g33780b6/localedata/locales/en_GB
+++ glibc-2.11.90-5/localedata/locales/en_GB
+++ glibc-2.11.90-7/localedata/locales/en_GB
@@ -116,8 +116,8 @@ mon "<U004A><U0061><U006E><U0075><U0061><U0072><U0079>";/
d_t_fmt "<U0025><U0061><U0020><U0025><U0064><U0020><U0025><U0062><U0020><U0025><U0059><U0020><U0025><U0054><U0020><U0025><U005A>"
d_fmt "<U0025><U0064><U002F><U0025><U006D><U002F><U0025><U0079>"
@ -629,7 +693,7 @@
<U0020><U0025><U0048><U003A><U0025><U004D><U003A><U0025><U0053><U0020>/
<U0025><U005A><U0020><U0025><U0059>"
--- glibc-2.11-100-g33780b6/localedata/locales/no_NO
+++ glibc-2.11.90-5/localedata/locales/no_NO
+++ glibc-2.11.90-7/localedata/locales/no_NO
@@ -0,0 +1,69 @@
+escape_char /
+comment_char %
@ -701,7 +765,7 @@
+copy "nb_NO"
+END LC_ADDRESS
--- glibc-2.11-100-g33780b6/localedata/locales/zh_TW
+++ glibc-2.11.90-5/localedata/locales/zh_TW
+++ glibc-2.11.90-7/localedata/locales/zh_TW
@@ -1,7 +1,7 @@
comment_char %
escape_char /
@ -730,7 +794,7 @@
date "2000-08-02"
%
--- glibc-2.11-100-g33780b6/malloc/mcheck.c
+++ glibc-2.11.90-5/malloc/mcheck.c
+++ glibc-2.11.90-7/malloc/mcheck.c
@@ -24,9 +24,25 @@
# include <mcheck.h>
# include <stdint.h>
@ -807,7 +871,7 @@
old_free_hook = __free_hook;
__free_hook = freehook;
--- glibc-2.11-100-g33780b6/manual/libc.texinfo
+++ glibc-2.11.90-5/manual/libc.texinfo
+++ glibc-2.11.90-7/manual/libc.texinfo
@@ -5,7 +5,7 @@
@c setchapternewpage odd
@ -818,7 +882,7 @@
* Libc: (libc). C library.
@end direntry
--- glibc-2.11-100-g33780b6/misc/sys/cdefs.h
+++ glibc-2.11.90-5/misc/sys/cdefs.h
+++ glibc-2.11.90-7/misc/sys/cdefs.h
@@ -132,7 +132,10 @@
#define __bos(ptr) __builtin_object_size (ptr, __USE_FORTIFY_LEVEL > 1)
#define __bos0(ptr) __builtin_object_size (ptr, 0)
@ -863,7 +927,7 @@
# define __va_arg_pack_len() __builtin_va_arg_pack_len ()
#endif
--- glibc-2.11-100-g33780b6/nis/nss
+++ glibc-2.11.90-5/nis/nss
+++ glibc-2.11.90-7/nis/nss
@@ -25,4 +25,4 @@
# memory with every getXXent() call. Otherwise each getXXent() call
# might result into a network communication with the server to get
@ -871,7 +935,7 @@
-#SETENT_BATCH_READ=TRUE
+SETENT_BATCH_READ=TRUE
--- glibc-2.11-100-g33780b6/nptl/ChangeLog
+++ glibc-2.11.90-5/nptl/ChangeLog
+++ glibc-2.11.90-7/nptl/ChangeLog
@@ -3807,6 +3807,15 @@
Use __sigfillset. Document that sigfillset does the right thing wrt
to SIGSETXID.
@ -913,7 +977,7 @@
* tst-cancel17.c (do_test): Check if aio_cancel failed.
--- glibc-2.11-100-g33780b6/nptl/Makefile
+++ glibc-2.11.90-5/nptl/Makefile
+++ glibc-2.11.90-7/nptl/Makefile
@@ -339,7 +339,8 @@ endif
extra-objs += $(crti-objs) $(crtn-objs)
omit-deps += crti crtn
@ -947,7 +1011,7 @@
$(addprefix $(objpfx),$(tests) $(test-srcs)): $(objpfx)libpthread.a
endif
--- glibc-2.11-100-g33780b6/nptl/sysdeps/unix/sysv/linux/bits/posix_opt.h
+++ glibc-2.11.90-5/nptl/sysdeps/unix/sysv/linux/bits/posix_opt.h
+++ glibc-2.11.90-7/nptl/sysdeps/unix/sysv/linux/bits/posix_opt.h
@@ -189,4 +189,7 @@
/* Typed memory objects are not available. */
#define _POSIX_TYPED_MEMORY_OBJECTS -1
@ -957,7 +1021,7 @@
+
#endif /* bits/posix_opt.h */
--- glibc-2.11-100-g33780b6/nptl/sysdeps/unix/sysv/linux/kernel-features.h
+++ glibc-2.11.90-5/nptl/sysdeps/unix/sysv/linux/kernel-features.h
+++ glibc-2.11.90-7/nptl/sysdeps/unix/sysv/linux/kernel-features.h
@@ -0,0 +1,6 @@
+#include_next <kernel-features.h>
+
@ -966,7 +1030,7 @@
+# define __ASSUME_CLONE_THREAD_FLAGS 1
+#endif
--- glibc-2.11-100-g33780b6/nptl/tst-stackguard1.c
+++ glibc-2.11.90-5/nptl/tst-stackguard1.c
+++ glibc-2.11.90-7/nptl/tst-stackguard1.c
@@ -190,17 +190,21 @@ do_test (void)
the 16 runs, something is very wrong. */
int ndifferences = 0;
@ -992,7 +1056,7 @@
puts ("stack guard canaries are not randomized enough");
puts ("nor equal to the default canary value");
--- glibc-2.11-100-g33780b6/nscd/nscd.conf
+++ glibc-2.11.90-5/nscd/nscd.conf
+++ glibc-2.11.90-7/nscd/nscd.conf
@@ -33,7 +33,7 @@
# logfile /var/log/nscd.log
# threads 4
@ -1003,7 +1067,7 @@
debug-level 0
# reload-count 5
--- glibc-2.11-100-g33780b6/nscd/nscd.init
+++ glibc-2.11.90-5/nscd/nscd.init
+++ glibc-2.11.90-7/nscd/nscd.init
@@ -9,6 +9,7 @@
# slow naming services like NIS, NIS+, LDAP, or hesiod.
# processname: /usr/sbin/nscd
@ -1076,7 +1140,7 @@
*)
echo $"Usage: $0 {start|stop|status|restart|reload|condrestart}"
--- glibc-2.11-100-g33780b6/posix/Makefile
+++ glibc-2.11.90-5/posix/Makefile
+++ glibc-2.11.90-7/posix/Makefile
@@ -303,15 +303,8 @@ $(inst_libexecdir)/getconf: $(inst_bindir)/getconf \
mv -f $@/$$spec.new $@/$$spec; \
done < $(objpfx)getconf.speclist
@ -1098,7 +1162,7 @@
+ > $@.new
mv -f $@.new $@
--- glibc-2.11-100-g33780b6/posix/getconf.speclist.h
+++ glibc-2.11.90-5/posix/getconf.speclist.h
+++ glibc-2.11.90-7/posix/getconf.speclist.h
@@ -0,0 +1,39 @@
+#include <unistd.h>
+const char *START_OF_STRINGS =
@ -1140,7 +1204,7 @@
+#endif
+"";
--- glibc-2.11-100-g33780b6/streams/Makefile
+++ glibc-2.11.90-5/streams/Makefile
+++ glibc-2.11.90-7/streams/Makefile
@@ -21,7 +21,7 @@
#
subdir := streams
@ -1151,7 +1215,7 @@
include ../Rules
--- glibc-2.11-100-g33780b6/sysdeps/generic/dl-cache.h
+++ glibc-2.11.90-5/sysdeps/generic/dl-cache.h
+++ glibc-2.11.90-7/sysdeps/generic/dl-cache.h
@@ -36,6 +36,14 @@
# define add_system_dir(dir) add_dir (dir)
#endif
@ -1168,7 +1232,7 @@
/* libc5 and glibc 2.0/2.1 use the same format. For glibc 2.2 another
--- glibc-2.11-100-g33780b6/sysdeps/i386/Makefile
+++ glibc-2.11.90-5/sysdeps/i386/Makefile
+++ glibc-2.11.90-7/sysdeps/i386/Makefile
@@ -2,6 +2,8 @@
# Every i386 port in use uses gas syntax (I think).
asm-CPPFLAGS += -DGAS_SYNTAX
@ -1194,7 +1258,7 @@
ifeq ($(subdir),elf)
--- glibc-2.11-100-g33780b6/sysdeps/ia64/Makefile
+++ glibc-2.11.90-5/sysdeps/ia64/Makefile
+++ glibc-2.11.90-7/sysdeps/ia64/Makefile
@@ -12,8 +12,8 @@ elide-routines.os += hp-timing
ifeq (yes,$(build-shared))
@ -1207,7 +1271,7 @@
endif
--- glibc-2.11-100-g33780b6/sysdeps/ia64/ia64libgcc.S
+++ glibc-2.11.90-5/sysdeps/ia64/ia64libgcc.S
+++ glibc-2.11.90-7/sysdeps/ia64/ia64libgcc.S
@@ -1,350 +0,0 @@
-/* From the Intel IA-64 Optimization Guide, choose the minimum latency
- alternative. */
@ -1560,7 +1624,7 @@
-
-#endif
--- glibc-2.11-100-g33780b6/sysdeps/ia64/libgcc-compat.c
+++ glibc-2.11.90-5/sysdeps/ia64/libgcc-compat.c
+++ glibc-2.11.90-7/sysdeps/ia64/libgcc-compat.c
@@ -0,0 +1,84 @@
+/* pre-.hidden libgcc compatibility
+ Copyright (C) 2002 Free Software Foundation, Inc.
@ -1647,7 +1711,7 @@
+
+#endif
--- glibc-2.11-100-g33780b6/sysdeps/powerpc/powerpc64/Makefile
+++ glibc-2.11.90-5/sysdeps/powerpc/powerpc64/Makefile
+++ glibc-2.11.90-7/sysdeps/powerpc/powerpc64/Makefile
@@ -30,6 +30,7 @@ ifneq ($(elf),no)
# we use -fpic instead which is much better.
CFLAGS-initfini.s += -fpic -O1
@ -1657,7 +1721,7 @@
ifeq ($(subdir),elf)
--- glibc-2.11-100-g33780b6/sysdeps/unix/nice.c
+++ glibc-2.11.90-5/sysdeps/unix/nice.c
+++ glibc-2.11.90-7/sysdeps/unix/nice.c
@@ -42,7 +42,12 @@ nice (int incr)
__set_errno (save);
}
@ -1673,7 +1737,7 @@
{
if (errno == EACCES)
--- glibc-2.11-100-g33780b6/sysdeps/unix/sysv/linux/check_pf.c
+++ glibc-2.11.90-5/sysdeps/unix/sysv/linux/check_pf.c
+++ glibc-2.11.90-7/sysdeps/unix/sysv/linux/check_pf.c
@@ -27,13 +27,10 @@
#include <unistd.h>
#include <sys/socket.h>
@ -1690,7 +1754,7 @@
#ifndef IFA_F_HOMEADDRESS
# define IFA_F_HOMEADDRESS 0
--- glibc-2.11-100-g33780b6/sysdeps/unix/sysv/linux/dl-osinfo.h
+++ glibc-2.11.90-5/sysdeps/unix/sysv/linux/dl-osinfo.h
+++ glibc-2.11.90-7/sysdeps/unix/sysv/linux/dl-osinfo.h
@@ -17,10 +17,13 @@
Software Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
02111-1307 USA. */
@ -1739,7 +1803,7 @@
else
#endif
--- glibc-2.11-100-g33780b6/sysdeps/unix/sysv/linux/futimesat.c
+++ glibc-2.11.90-5/sysdeps/unix/sysv/linux/futimesat.c
+++ glibc-2.11.90-7/sysdeps/unix/sysv/linux/futimesat.c
@@ -37,14 +37,14 @@ futimesat (fd, file, tvp)
{
int result;
@ -1783,7 +1847,7 @@
size_t filelen = strlen (file);
if (__builtin_expect (filelen == 0, 0))
--- glibc-2.11-100-g33780b6/sysdeps/unix/sysv/linux/i386/dl-cache.h
+++ glibc-2.11.90-5/sysdeps/unix/sysv/linux/i386/dl-cache.h
+++ glibc-2.11.90-7/sysdeps/unix/sysv/linux/i386/dl-cache.h
@@ -0,0 +1,59 @@
+/* Support for reading /etc/ld.so.cache files written by Linux ldconfig.
+ Copyright (C) 2004 Free Software Foundation, Inc.
@ -1845,7 +1909,7 @@
+
+#include_next <dl-cache.h>
--- glibc-2.11-100-g33780b6/sysdeps/unix/sysv/linux/ia64/dl-cache.h
+++ glibc-2.11.90-5/sysdeps/unix/sysv/linux/ia64/dl-cache.h
+++ glibc-2.11.90-7/sysdeps/unix/sysv/linux/ia64/dl-cache.h
@@ -22,4 +22,31 @@
#define _dl_cache_check_flags(flags) \
((flags) == _DL_CACHE_DEFAULT_ID)
@ -1879,7 +1943,7 @@
+
#include_next <dl-cache.h>
--- glibc-2.11-100-g33780b6/sysdeps/unix/sysv/linux/ia64/dl-procinfo.c
+++ glibc-2.11.90-5/sysdeps/unix/sysv/linux/ia64/dl-procinfo.c
+++ glibc-2.11.90-7/sysdeps/unix/sysv/linux/ia64/dl-procinfo.c
@@ -0,0 +1,5 @@
+#ifdef IS_IN_ldconfig
+#include <sysdeps/i386/dl-procinfo.c>
@ -1887,7 +1951,7 @@
+#include <sysdeps/generic/dl-procinfo.c>
+#endif
--- glibc-2.11-100-g33780b6/sysdeps/unix/sysv/linux/ia64/dl-procinfo.h
+++ glibc-2.11.90-5/sysdeps/unix/sysv/linux/ia64/dl-procinfo.h
+++ glibc-2.11.90-7/sysdeps/unix/sysv/linux/ia64/dl-procinfo.h
@@ -0,0 +1,5 @@
+#ifdef IS_IN_ldconfig
+#include <sysdeps/unix/sysv/linux/i386/dl-procinfo.h>
@ -1895,12 +1959,12 @@
+#include <sysdeps/generic/dl-procinfo.h>
+#endif
--- glibc-2.11-100-g33780b6/sysdeps/unix/sysv/linux/ia64/ldd-rewrite.sed
+++ glibc-2.11.90-5/sysdeps/unix/sysv/linux/ia64/ldd-rewrite.sed
+++ glibc-2.11.90-7/sysdeps/unix/sysv/linux/ia64/ldd-rewrite.sed
@@ -1 +1 @@
-s_^\(RTLDLIST=\)\([^ ]*\)-ia64\(\.so\.[0-9.]*\)[ ]*$_\1"\2-ia64\3 \2\3"_
+s_^\(RTLDLIST=\)\([^ ]*\)-ia64\(\.so\.[0-9.]*\)[ ]*$_\1"\2-ia64\3 /emul/ia32-linux\2\3"_
--- glibc-2.11-100-g33780b6/sysdeps/unix/sysv/linux/netlinkaccess.h
+++ glibc-2.11.90-5/sysdeps/unix/sysv/linux/netlinkaccess.h
+++ glibc-2.11.90-7/sysdeps/unix/sysv/linux/netlinkaccess.h
@@ -25,6 +25,24 @@
#include <kernel-features.h>
@ -1927,7 +1991,7 @@
struct netlink_res
{
--- glibc-2.11-100-g33780b6/sysdeps/unix/sysv/linux/paths.h
+++ glibc-2.11.90-5/sysdeps/unix/sysv/linux/paths.h
+++ glibc-2.11.90-7/sysdeps/unix/sysv/linux/paths.h
@@ -62,7 +62,7 @@
#define _PATH_TTY "/dev/tty"
#define _PATH_UNIX "/boot/vmlinux"
@ -1938,7 +2002,7 @@
/* Provide trailing slash, since mostly used for building pathnames. */
--- glibc-2.11-100-g33780b6/sysdeps/unix/sysv/linux/tcsetattr.c
+++ glibc-2.11.90-5/sysdeps/unix/sysv/linux/tcsetattr.c
+++ glibc-2.11.90-7/sysdeps/unix/sysv/linux/tcsetattr.c
@@ -49,6 +49,7 @@ tcsetattr (fd, optional_actions, termios_p)
{
struct __kernel_termios k_termios;
@ -1985,7 +2049,7 @@
}
libc_hidden_def (tcsetattr)
--- glibc-2.11-100-g33780b6/timezone/zic.c
+++ glibc-2.11.90-5/timezone/zic.c
+++ glibc-2.11.90-7/timezone/zic.c
@@ -1921,7 +1921,7 @@ const int zonecount;
if (stdrp != NULL && stdrp->r_hiyear == 2037)
return;

View File

@ -24,7 +24,7 @@
Summary: The GNU libc libraries
Name: glibc
Version: %{glibcversion}
Release: 6
Release: 7
# GPLv2+ is used in a bunch of programs, LGPLv2+ is used for libraries.
# Things that are linked directly into dynamically linked programs
# and shared libraries (e.g. crt files, lib*_nonshared.a) have an additional
@ -1033,6 +1033,9 @@ rm -f *.filelist*
%endif
%changelog
* Mon Jan 11 2010 Andreas Schwab <schwab@redhat.com> - 2.11.90-7
- Fix build failure.
* Mon Jan 11 2010 Andreas Schwab <schwab@redhat.com> - 2.11.90-6
- Update from master.
- POSIX conformance fixes (BZ#11125).

View File

@ -38,3 +38,4 @@ glibc-2_11_90-3:HEAD:glibc-2.11.90-3.src.rpm:1259590502
glibc-2_11_90-4:HEAD:glibc-2.11.90-4.src.rpm:1260808586
glibc-2_11_90-5:HEAD:glibc-2.11.90-5.src.rpm:1262613598
glibc-2_11_90-6:HEAD:glibc-2.11.90-6.src.rpm:1263202828
glibc-2_11_90-7:HEAD:glibc-2.11.90-7.src.rpm:1263223934

View File

@ -1,2 +1,2 @@
05468492e46d2d7dc32adad73d7fa45e glibc-2.11-100-g33780b6-fedora.tar.bz2
2855dd7f96cba8d4d067625b6537300e glibc-2.11-100-g33780b6.tar.bz2
e463d9ec3563aa1681d00dc57e954ffa glibc-2.11-100-g33780b6-fedora.tar.bz2