2.10.90-23

This commit is contained in:
Andreas Schwab 2009-09-21 10:39:33 +00:00
parent 26aeed088c
commit 91d8fccb67
5 changed files with 73 additions and 71 deletions

View File

@ -1,2 +1,2 @@
glibc-2.10-335-g02bf610-fedora.tar.bz2
glibc-2.10-335-g02bf610.tar.bz2
glibc-2.10-340-gae0f0db-fedora.tar.bz2
glibc-2.10-340-gae0f0db.tar.bz2

View File

@ -1,6 +1,6 @@
--- glibc-2.10-335-g02bf610/ChangeLog
--- glibc-2.10-340-gae0f0db/ChangeLog
+++ glibc-2.10.90-22/ChangeLog
@@ -596,6 +596,11 @@
@@ -625,6 +625,11 @@
* sysdeps/generic/ldsodefs.h (struct rtld_global): The map element in
the unique symbol hash table should not be const.
@ -12,7 +12,7 @@
2009-07-21 Ulrich Drepper <drepper@redhat.com>
* sysdeps/x86_64/multiarch/strstr.c: Minor cleanups. Remove
@@ -861,6 +866,11 @@
@@ -890,6 +895,11 @@
out common code into new function get_common_indeces. Determine
extended family and model for Intel processors.
@ -24,7 +24,7 @@
2009-06-26 Ulrich Drepper <drepper@redhat.com>
* resolv/resolv.h: Define RES_SNGLKUPREOP.
@@ -9259,6 +9269,13 @@
@@ -9288,6 +9298,13 @@
* include/sys/cdefs.h: Redefine __nonnull so that test for
incorrect parameters in the libc code itself are not omitted.
@ -38,7 +38,7 @@
2007-05-09 Jakub Jelinek <jakub@redhat.com>
* sysdeps/ia64/fpu/fraiseexcpt.c (feraiseexcept): Don't raise overflow
@@ -9554,6 +9571,10 @@
@@ -9583,6 +9600,10 @@
[BZ #4368]
* stdlib/stdlib.h: Remove obsolete part of comment for realpath.
@ -49,7 +49,7 @@
2007-04-16 Ulrich Drepper <drepper@redhat.com>
[BZ #4364]
@@ -10811,6 +10832,15 @@
@@ -10840,6 +10861,15 @@
separators also if no non-zero digits found.
* stdlib/Makefile (tests): Add tst-strtod3.
@ -65,7 +65,7 @@
2006-12-09 Ulrich Drepper <drepper@redhat.com>
[BZ #3632]
--- glibc-2.10-335-g02bf610/ChangeLog.15
--- glibc-2.10-340-gae0f0db/ChangeLog.15
+++ glibc-2.10.90-22/ChangeLog.15
@@ -477,6 +477,14 @@
@ -132,7 +132,7 @@
2004-08-30 Roland McGrath <roland@frob.com>
* scripts/extract-abilist.awk: If `lastversion' variable defined, omit
--- glibc-2.10-335-g02bf610/ChangeLog.16
--- glibc-2.10-340-gae0f0db/ChangeLog.16
+++ glibc-2.10.90-22/ChangeLog.16
@@ -171,6 +171,11 @@
[BZ #2611]
@ -305,7 +305,7 @@
2005-02-10 Roland McGrath <roland@redhat.com>
[BZ #157]
--- glibc-2.10-335-g02bf610/Makeconfig
--- glibc-2.10-340-gae0f0db/Makeconfig
+++ glibc-2.10.90-22/Makeconfig
@@ -780,12 +780,12 @@ endif
# The assembler can generate debug information too.
@ -323,7 +323,7 @@
ifndef BUILD_CC
BUILD_CC = $(CC)
--- glibc-2.10-335-g02bf610/csu/Makefile
--- glibc-2.10-340-gae0f0db/csu/Makefile
+++ glibc-2.10.90-22/csu/Makefile
@@ -93,7 +93,8 @@ omit-deps += $(crtstuff)
$(crtstuff:%=$(objpfx)%.o): %.o: %.S $(objpfx)defs.h
@ -335,7 +335,7 @@
vpath initfini.c $(sysdirs)
--- glibc-2.10-335-g02bf610/csu/elf-init.c
--- glibc-2.10-340-gae0f0db/csu/elf-init.c
+++ glibc-2.10.90-22/csu/elf-init.c
@@ -63,6 +63,23 @@ extern void (*__init_array_end []) (int, char **, char **)
extern void (*__fini_array_start []) (void) attribute_hidden;
@ -361,7 +361,7 @@
/* These function symbols are provided for the .init/.fini section entry
points automagically by the linker. */
--- glibc-2.10-335-g02bf610/debug/tst-chk1.c
--- glibc-2.10-340-gae0f0db/debug/tst-chk1.c
+++ glibc-2.10.90-22/debug/tst-chk1.c
@@ -17,6 +17,9 @@
Software Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
@ -391,7 +391,7 @@
# define O 0
# else
# define O 1
--- glibc-2.10-335-g02bf610/elf/ldconfig.c
--- glibc-2.10-340-gae0f0db/elf/ldconfig.c
+++ glibc-2.10.90-22/elf/ldconfig.c
@@ -1020,17 +1020,19 @@ search_dirs (void)
@ -474,7 +474,7 @@
}
if (! opt_ignore_aux_cache)
--- glibc-2.10-335-g02bf610/elf/tst-stackguard1.c
--- glibc-2.10-340-gae0f0db/elf/tst-stackguard1.c
+++ glibc-2.10.90-22/elf/tst-stackguard1.c
@@ -160,17 +160,21 @@ do_test (void)
the 16 runs, something is very wrong. */
@ -500,15 +500,15 @@
{
puts ("stack guard canaries are not randomized enough");
puts ("nor equal to the default canary value");
--- glibc-2.10-335-g02bf610/include/bits/stdlib-ldbl.h
--- glibc-2.10-340-gae0f0db/include/bits/stdlib-ldbl.h
+++ glibc-2.10.90-22/include/bits/stdlib-ldbl.h
@@ -0,0 +1 @@
+#include <stdlib/bits/stdlib-ldbl.h>
--- glibc-2.10-335-g02bf610/include/bits/wchar-ldbl.h
--- glibc-2.10-340-gae0f0db/include/bits/wchar-ldbl.h
+++ glibc-2.10.90-22/include/bits/wchar-ldbl.h
@@ -0,0 +1 @@
+#include <wcsmbs/bits/wchar-ldbl.h>
--- glibc-2.10-335-g02bf610/include/features.h
--- glibc-2.10-340-gae0f0db/include/features.h
+++ glibc-2.10.90-22/include/features.h
@@ -299,8 +299,13 @@
#endif
@ -526,7 +526,7 @@
# define __USE_FORTIFY_LEVEL 2
# else
# define __USE_FORTIFY_LEVEL 1
--- glibc-2.10-335-g02bf610/intl/locale.alias
--- glibc-2.10-340-gae0f0db/intl/locale.alias
+++ glibc-2.10.90-22/intl/locale.alias
@@ -57,8 +57,6 @@ korean ko_KR.eucKR
korean.euc ko_KR.eucKR
@ -537,7 +537,7 @@
norwegian nb_NO.ISO-8859-1
nynorsk nn_NO.ISO-8859-1
polish pl_PL.ISO-8859-2
--- glibc-2.10-335-g02bf610/libio/stdio.h
--- glibc-2.10-340-gae0f0db/libio/stdio.h
+++ glibc-2.10.90-22/libio/stdio.h
@@ -145,10 +145,12 @@ typedef _G_fpos64_t fpos64_t;
extern struct _IO_FILE *stdin; /* Standard input stream. */
@ -552,7 +552,7 @@
__BEGIN_NAMESPACE_STD
/* Remove file FILENAME. */
--- glibc-2.10-335-g02bf610/locale/iso-4217.def
--- glibc-2.10-340-gae0f0db/locale/iso-4217.def
+++ glibc-2.10.90-22/locale/iso-4217.def
@@ -8,6 +8,7 @@
*
@ -645,7 +645,7 @@
DEFINE_INT_CURR("PYG") /* Paraguay Guarani */
DEFINE_INT_CURR("QAR") /* Qatar Rial */
DEFINE_INT_CURR("ROL") /* Romanian Leu */
--- glibc-2.10-335-g02bf610/locale/programs/locarchive.c
--- glibc-2.10-340-gae0f0db/locale/programs/locarchive.c
+++ glibc-2.10.90-22/locale/programs/locarchive.c
@@ -241,9 +241,9 @@ oldlocrecentcmp (const void *a, const void *b)
/* forward decls for below */
@ -678,7 +678,7 @@
add_alias (struct locarhandle *ah, const char *alias, bool replace,
const char *oldname, uint32_t *locrec_offset_p)
{
--- glibc-2.10-335-g02bf610/localedata/Makefile
--- glibc-2.10-340-gae0f0db/localedata/Makefile
+++ glibc-2.10.90-22/localedata/Makefile
@@ -225,6 +225,7 @@ $(INSTALL-SUPPORTED-LOCALES): install-locales-dir
echo -n '...'; \
@ -688,7 +688,7 @@
-i locales/$$input -c -f charmaps/$$charset \
$(addprefix --prefix=,$(install_root)) $$locale; \
echo ' done'; \
--- glibc-2.10-335-g02bf610/localedata/SUPPORTED
--- glibc-2.10-340-gae0f0db/localedata/SUPPORTED
+++ glibc-2.10.90-22/localedata/SUPPORTED
@@ -84,6 +84,7 @@ cy_GB.UTF-8/UTF-8 \
cy_GB/ISO-8859-14 \
@ -731,7 +731,7 @@
ta_IN/UTF-8 \
te_IN/UTF-8 \
tg_TJ.UTF-8/UTF-8 \
--- glibc-2.10-335-g02bf610/localedata/locales/cy_GB
--- glibc-2.10-340-gae0f0db/localedata/locales/cy_GB
+++ glibc-2.10.90-22/localedata/locales/cy_GB
@@ -248,8 +248,11 @@ mon "<U0049><U006F><U006E><U0061><U0077><U0072>";/
d_t_fmt "<U0044><U0079><U0064><U0064><U0020><U0025><U0041><U0020><U0025><U0064><U0020><U006d><U0069><U0073><U0020><U0025><U0042><U0020><U0025><U0059><U0020><U0025><U0054><U0020><U0025><U005A>"
@ -747,7 +747,7 @@
END LC_TIME
LC_MESSAGES
--- glibc-2.10-335-g02bf610/localedata/locales/en_GB
--- glibc-2.10-340-gae0f0db/localedata/locales/en_GB
+++ glibc-2.10.90-22/localedata/locales/en_GB
@@ -116,8 +116,8 @@ mon "<U004A><U0061><U006E><U0075><U0061><U0072><U0079>";/
d_t_fmt "<U0025><U0061><U0020><U0025><U0064><U0020><U0025><U0062><U0020><U0025><U0059><U0020><U0025><U0054><U0020><U0025><U005A>"
@ -760,7 +760,7 @@
date_fmt "<U0025><U0061><U0020><U0025><U0062><U0020><U0025><U0065>/
<U0020><U0025><U0048><U003A><U0025><U004D><U003A><U0025><U0053><U0020>/
<U0025><U005A><U0020><U0025><U0059>"
--- glibc-2.10-335-g02bf610/localedata/locales/no_NO
--- glibc-2.10-340-gae0f0db/localedata/locales/no_NO
+++ glibc-2.10.90-22/localedata/locales/no_NO
@@ -0,0 +1,69 @@
+escape_char /
@ -832,7 +832,7 @@
+LC_ADDRESS
+copy "nb_NO"
+END LC_ADDRESS
--- glibc-2.10-335-g02bf610/localedata/locales/zh_TW
--- glibc-2.10-340-gae0f0db/localedata/locales/zh_TW
+++ glibc-2.10.90-22/localedata/locales/zh_TW
@@ -1,7 +1,7 @@
comment_char %
@ -861,7 +861,7 @@
revision "0.2"
date "2000-08-02"
%
--- glibc-2.10-335-g02bf610/malloc/mcheck.c
--- glibc-2.10-340-gae0f0db/malloc/mcheck.c
+++ glibc-2.10.90-22/malloc/mcheck.c
@@ -24,9 +24,25 @@
# include <mcheck.h>
@ -938,7 +938,7 @@
old_free_hook = __free_hook;
__free_hook = freehook;
--- glibc-2.10-335-g02bf610/manual/libc.texinfo
--- glibc-2.10-340-gae0f0db/manual/libc.texinfo
+++ glibc-2.10.90-22/manual/libc.texinfo
@@ -5,7 +5,7 @@
@c setchapternewpage odd
@ -949,7 +949,7 @@
@direntry
* Libc: (libc). C library.
@end direntry
--- glibc-2.10-335-g02bf610/misc/sys/cdefs.h
--- glibc-2.10-340-gae0f0db/misc/sys/cdefs.h
+++ glibc-2.10.90-22/misc/sys/cdefs.h
@@ -132,7 +132,10 @@
#define __bos(ptr) __builtin_object_size (ptr, __USE_FORTIFY_LEVEL > 1)
@ -994,7 +994,7 @@
# define __va_arg_pack() __builtin_va_arg_pack ()
# define __va_arg_pack_len() __builtin_va_arg_pack_len ()
#endif
--- glibc-2.10-335-g02bf610/nis/nss
--- glibc-2.10-340-gae0f0db/nis/nss
+++ glibc-2.10.90-22/nis/nss
@@ -25,4 +25,4 @@
# memory with every getXXent() call. Otherwise each getXXent() call
@ -1002,7 +1002,7 @@
# the next entry.
-#SETENT_BATCH_READ=TRUE
+SETENT_BATCH_READ=TRUE
--- glibc-2.10-335-g02bf610/nptl/ChangeLog
--- glibc-2.10-340-gae0f0db/nptl/ChangeLog
+++ glibc-2.10.90-22/nptl/ChangeLog
@@ -3717,6 +3717,15 @@
Use __sigfillset. Document that sigfillset does the right thing wrt
@ -1044,7 +1044,7 @@
2003-07-25 Jakub Jelinek <jakub@redhat.com>
* tst-cancel17.c (do_test): Check if aio_cancel failed.
--- glibc-2.10-335-g02bf610/nptl/Makefile
--- glibc-2.10-340-gae0f0db/nptl/Makefile
+++ glibc-2.10.90-22/nptl/Makefile
@@ -339,7 +339,8 @@ endif
extra-objs += $(crti-objs) $(crtn-objs)
@ -1078,7 +1078,7 @@
else
$(addprefix $(objpfx),$(tests) $(test-srcs)): $(objpfx)libpthread.a
endif
--- glibc-2.10-335-g02bf610/nptl/sysdeps/unix/sysv/linux/bits/posix_opt.h
--- glibc-2.10-340-gae0f0db/nptl/sysdeps/unix/sysv/linux/bits/posix_opt.h
+++ glibc-2.10.90-22/nptl/sysdeps/unix/sysv/linux/bits/posix_opt.h
@@ -189,4 +189,7 @@
/* Typed memory objects are not available. */
@ -1088,7 +1088,7 @@
+#define _XOPEN_STREAMS -1
+
#endif /* bits/posix_opt.h */
--- glibc-2.10-335-g02bf610/nptl/sysdeps/unix/sysv/linux/kernel-features.h
--- glibc-2.10-340-gae0f0db/nptl/sysdeps/unix/sysv/linux/kernel-features.h
+++ glibc-2.10.90-22/nptl/sysdeps/unix/sysv/linux/kernel-features.h
@@ -0,0 +1,6 @@
+#include_next <kernel-features.h>
@ -1097,7 +1097,7 @@
+#ifndef __ASSUME_CLONE_THREAD_FLAGS
+# define __ASSUME_CLONE_THREAD_FLAGS 1
+#endif
--- glibc-2.10-335-g02bf610/nptl/tst-stackguard1.c
--- glibc-2.10-340-gae0f0db/nptl/tst-stackguard1.c
+++ glibc-2.10.90-22/nptl/tst-stackguard1.c
@@ -190,17 +190,21 @@ do_test (void)
the 16 runs, something is very wrong. */
@ -1123,7 +1123,7 @@
{
puts ("stack guard canaries are not randomized enough");
puts ("nor equal to the default canary value");
--- glibc-2.10-335-g02bf610/nscd/nscd.conf
--- glibc-2.10-340-gae0f0db/nscd/nscd.conf
+++ glibc-2.10.90-22/nscd/nscd.conf
@@ -33,7 +33,7 @@
# logfile /var/log/nscd.log
@ -1134,7 +1134,7 @@
# stat-user somebody
debug-level 0
# reload-count 5
--- glibc-2.10-335-g02bf610/nscd/nscd.init
--- glibc-2.10-340-gae0f0db/nscd/nscd.init
+++ glibc-2.10.90-22/nscd/nscd.init
@@ -9,6 +9,7 @@
# slow naming services like NIS, NIS+, LDAP, or hesiod.
@ -1207,7 +1207,7 @@
;;
*)
echo $"Usage: $0 {start|stop|status|restart|reload|condrestart}"
--- glibc-2.10-335-g02bf610/posix/Makefile
--- glibc-2.10-340-gae0f0db/posix/Makefile
+++ glibc-2.10.90-22/posix/Makefile
@@ -302,15 +302,8 @@ $(inst_libexecdir)/getconf: $(inst_bindir)/getconf \
mv -f $@/$$spec.new $@/$$spec; \
@ -1229,7 +1229,7 @@
+ | sed -n -e '/START_OF_STRINGS/,$${/\(POSIX_V[67]\|_XBS5\)_/{s/^[^"]*"//;s/".*$$//;p}}' \
+ > $@.new
mv -f $@.new $@
--- glibc-2.10-335-g02bf610/posix/getconf.speclist.h
--- glibc-2.10-340-gae0f0db/posix/getconf.speclist.h
+++ glibc-2.10.90-22/posix/getconf.speclist.h
@@ -0,0 +1,39 @@
+#include <unistd.h>
@ -1271,7 +1271,7 @@
+"XBS5_LPBIG_OFFBIG"
+#endif
+"";
--- glibc-2.10-335-g02bf610/streams/Makefile
--- glibc-2.10-340-gae0f0db/streams/Makefile
+++ glibc-2.10.90-22/streams/Makefile
@@ -21,7 +21,7 @@
#
@ -1282,7 +1282,7 @@
routines = isastream getmsg getpmsg putmsg putpmsg fattach fdetach
include ../Rules
--- glibc-2.10-335-g02bf610/sysdeps/generic/dl-cache.h
--- glibc-2.10-340-gae0f0db/sysdeps/generic/dl-cache.h
+++ glibc-2.10.90-22/sysdeps/generic/dl-cache.h
@@ -36,6 +36,14 @@
# define add_system_dir(dir) add_dir (dir)
@ -1299,7 +1299,7 @@
#define CACHEMAGIC "ld.so-1.7.0"
/* libc5 and glibc 2.0/2.1 use the same format. For glibc 2.2 another
--- glibc-2.10-335-g02bf610/sysdeps/i386/Makefile
--- glibc-2.10-340-gae0f0db/sysdeps/i386/Makefile
+++ glibc-2.10.90-22/sysdeps/i386/Makefile
@@ -2,6 +2,8 @@
# Every i386 port in use uses gas syntax (I think).
@ -1325,7 +1325,7 @@
endif
ifeq ($(subdir),elf)
--- glibc-2.10-335-g02bf610/sysdeps/ia64/Makefile
--- glibc-2.10-340-gae0f0db/sysdeps/ia64/Makefile
+++ glibc-2.10.90-22/sysdeps/ia64/Makefile
@@ -12,8 +12,8 @@ elide-routines.os += hp-timing
@ -1338,7 +1338,7 @@
endif
endif
--- glibc-2.10-335-g02bf610/sysdeps/ia64/ia64libgcc.S
--- glibc-2.10-340-gae0f0db/sysdeps/ia64/ia64libgcc.S
+++ glibc-2.10.90-22/sysdeps/ia64/ia64libgcc.S
@@ -1,350 +0,0 @@
-/* From the Intel IA-64 Optimization Guide, choose the minimum latency
@ -1691,7 +1691,7 @@
- .symver ___multi3, __multi3@GLIBC_2.2
-
-#endif
--- glibc-2.10-335-g02bf610/sysdeps/ia64/libgcc-compat.c
--- glibc-2.10-340-gae0f0db/sysdeps/ia64/libgcc-compat.c
+++ glibc-2.10.90-22/sysdeps/ia64/libgcc-compat.c
@@ -0,0 +1,84 @@
+/* pre-.hidden libgcc compatibility
@ -1778,7 +1778,7 @@
+symbol_version (INTUSE (__multi3), __multi3, GLIBC_2.2);
+
+#endif
--- glibc-2.10-335-g02bf610/sysdeps/powerpc/powerpc64/Makefile
--- glibc-2.10-340-gae0f0db/sysdeps/powerpc/powerpc64/Makefile
+++ glibc-2.10.90-22/sysdeps/powerpc/powerpc64/Makefile
@@ -30,6 +30,7 @@ ifneq ($(elf),no)
# we use -fpic instead which is much better.
@ -1788,7 +1788,7 @@
endif
ifeq ($(subdir),elf)
--- glibc-2.10-335-g02bf610/sysdeps/unix/nice.c
--- glibc-2.10-340-gae0f0db/sysdeps/unix/nice.c
+++ glibc-2.10.90-22/sysdeps/unix/nice.c
@@ -42,7 +42,12 @@ nice (int incr)
__set_errno (save);
@ -1804,7 +1804,7 @@
if (result == -1)
{
if (errno == EACCES)
--- glibc-2.10-335-g02bf610/sysdeps/unix/sysv/linux/check_pf.c
--- glibc-2.10-340-gae0f0db/sysdeps/unix/sysv/linux/check_pf.c
+++ glibc-2.10.90-22/sysdeps/unix/sysv/linux/check_pf.c
@@ -27,13 +27,10 @@
#include <unistd.h>
@ -1821,7 +1821,7 @@
#ifndef IFA_F_HOMEADDRESS
# define IFA_F_HOMEADDRESS 0
--- glibc-2.10-335-g02bf610/sysdeps/unix/sysv/linux/dl-osinfo.h
--- glibc-2.10-340-gae0f0db/sysdeps/unix/sysv/linux/dl-osinfo.h
+++ glibc-2.10.90-22/sysdeps/unix/sysv/linux/dl-osinfo.h
@@ -17,10 +17,13 @@
Software Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
@ -1870,7 +1870,7 @@
}
else
#endif
--- glibc-2.10-335-g02bf610/sysdeps/unix/sysv/linux/futimesat.c
--- glibc-2.10-340-gae0f0db/sysdeps/unix/sysv/linux/futimesat.c
+++ glibc-2.10.90-22/sysdeps/unix/sysv/linux/futimesat.c
@@ -37,14 +37,14 @@ futimesat (fd, file, tvp)
{
@ -1914,7 +1914,7 @@
{
size_t filelen = strlen (file);
static const char procfd[] = "/proc/self/fd/%d/%s";
--- glibc-2.10-335-g02bf610/sysdeps/unix/sysv/linux/i386/clone.S
--- glibc-2.10-340-gae0f0db/sysdeps/unix/sysv/linux/i386/clone.S
+++ glibc-2.10.90-22/sysdeps/unix/sysv/linux/i386/clone.S
@@ -120,9 +120,6 @@ L(pseudo_end):
ret
@ -1934,7 +1934,7 @@
cfi_startproc
PSEUDO_END (BP_SYM (__clone))
--- glibc-2.10-335-g02bf610/sysdeps/unix/sysv/linux/i386/dl-cache.h
--- glibc-2.10-340-gae0f0db/sysdeps/unix/sysv/linux/i386/dl-cache.h
+++ glibc-2.10.90-22/sysdeps/unix/sysv/linux/i386/dl-cache.h
@@ -0,0 +1,59 @@
+/* Support for reading /etc/ld.so.cache files written by Linux ldconfig.
@ -1996,7 +1996,7 @@
+ } while (0)
+
+#include_next <dl-cache.h>
--- glibc-2.10-335-g02bf610/sysdeps/unix/sysv/linux/ia64/dl-cache.h
--- glibc-2.10-340-gae0f0db/sysdeps/unix/sysv/linux/ia64/dl-cache.h
+++ glibc-2.10.90-22/sysdeps/unix/sysv/linux/ia64/dl-cache.h
@@ -22,4 +22,31 @@
#define _dl_cache_check_flags(flags) \
@ -2030,7 +2030,7 @@
+ } while (0)
+
#include_next <dl-cache.h>
--- glibc-2.10-335-g02bf610/sysdeps/unix/sysv/linux/ia64/dl-procinfo.c
--- glibc-2.10-340-gae0f0db/sysdeps/unix/sysv/linux/ia64/dl-procinfo.c
+++ glibc-2.10.90-22/sysdeps/unix/sysv/linux/ia64/dl-procinfo.c
@@ -0,0 +1,5 @@
+#ifdef IS_IN_ldconfig
@ -2038,7 +2038,7 @@
+#else
+#include <sysdeps/generic/dl-procinfo.c>
+#endif
--- glibc-2.10-335-g02bf610/sysdeps/unix/sysv/linux/ia64/dl-procinfo.h
--- glibc-2.10-340-gae0f0db/sysdeps/unix/sysv/linux/ia64/dl-procinfo.h
+++ glibc-2.10.90-22/sysdeps/unix/sysv/linux/ia64/dl-procinfo.h
@@ -0,0 +1,5 @@
+#ifdef IS_IN_ldconfig
@ -2046,12 +2046,12 @@
+#else
+#include <sysdeps/generic/dl-procinfo.h>
+#endif
--- glibc-2.10-335-g02bf610/sysdeps/unix/sysv/linux/ia64/ldd-rewrite.sed
--- glibc-2.10-340-gae0f0db/sysdeps/unix/sysv/linux/ia64/ldd-rewrite.sed
+++ glibc-2.10.90-22/sysdeps/unix/sysv/linux/ia64/ldd-rewrite.sed
@@ -1 +1 @@
-s_^\(RTLDLIST=\)\([^ ]*\)-ia64\(\.so\.[0-9.]*\)[ ]*$_\1"\2-ia64\3 \2\3"_
+s_^\(RTLDLIST=\)\([^ ]*\)-ia64\(\.so\.[0-9.]*\)[ ]*$_\1"\2-ia64\3 /emul/ia32-linux\2\3"_
--- glibc-2.10-335-g02bf610/sysdeps/unix/sysv/linux/netlinkaccess.h
--- glibc-2.10-340-gae0f0db/sysdeps/unix/sysv/linux/netlinkaccess.h
+++ glibc-2.10.90-22/sysdeps/unix/sysv/linux/netlinkaccess.h
@@ -25,6 +25,24 @@
@ -2078,7 +2078,7 @@
struct netlink_res
{
--- glibc-2.10-335-g02bf610/sysdeps/unix/sysv/linux/paths.h
--- glibc-2.10-340-gae0f0db/sysdeps/unix/sysv/linux/paths.h
+++ glibc-2.10.90-22/sysdeps/unix/sysv/linux/paths.h
@@ -62,7 +62,7 @@
#define _PATH_TTY "/dev/tty"
@ -2089,7 +2089,7 @@
#define _PATH_WTMP "/var/log/wtmp"
/* Provide trailing slash, since mostly used for building pathnames. */
--- glibc-2.10-335-g02bf610/sysdeps/unix/sysv/linux/tcsetattr.c
--- glibc-2.10-340-gae0f0db/sysdeps/unix/sysv/linux/tcsetattr.c
+++ glibc-2.10.90-22/sysdeps/unix/sysv/linux/tcsetattr.c
@@ -49,6 +49,7 @@ tcsetattr (fd, optional_actions, termios_p)
{
@ -2136,7 +2136,7 @@
+ return retval;
}
libc_hidden_def (tcsetattr)
--- glibc-2.10-335-g02bf610/sysdeps/unix/sysv/linux/x86_64/clone.S
--- glibc-2.10-340-gae0f0db/sysdeps/unix/sysv/linux/x86_64/clone.S
+++ glibc-2.10.90-22/sysdeps/unix/sysv/linux/x86_64/clone.S
@@ -89,9 +89,6 @@ L(pseudo_end):
ret
@ -2156,7 +2156,7 @@
cfi_startproc;
PSEUDO_END (BP_SYM (__clone))
--- glibc-2.10-335-g02bf610/timezone/zic.c
--- glibc-2.10-340-gae0f0db/timezone/zic.c
+++ glibc-2.10.90-22/timezone/zic.c
@@ -1921,7 +1921,7 @@ const int zonecount;
if (stdrp != NULL && stdrp->r_hiyear == 2037)

View File

@ -1,4 +1,4 @@
%define glibcsrcdir glibc-2.10-335-g02bf610
%define glibcsrcdir glibc-2.10-340-gae0f0db
%define glibcversion 2.10.90
### glibc.spec.in follows:
%define run_glibc_tests 1
@ -24,7 +24,7 @@
Summary: The GNU libc libraries
Name: glibc
Version: %{glibcversion}
Release: 22
Release: 23
# GPLv2+ is used in a bunch of programs, LGPLv2+ is used for libraries.
# Things that are linked directly into dynamically linked programs
# and shared libraries (e.g. crt files, lib*_nonshared.a) have an additional
@ -542,9 +542,8 @@ rm -f $RPM_BUILD_ROOT%{_prefix}/lib/debug%{_prefix}/%{_lib}/*_p.a
# rquota.x and rquota.h are now provided by quota
rm -f $RPM_BUILD_ROOT%{_prefix}/include/rpcsvc/rquota.[hx]
# Hardlink identical locale files together
# Create archive of locale files
%ifnarch %{auxarches}
gcc -O2 -o build-%{nptl_target_cpu}-linuxnptl/hardlink fedora/hardlink.c
olddir=`pwd`
pushd ${RPM_BUILD_ROOT}%{_prefix}/lib/locale
rm locale-archive || :
@ -558,7 +557,6 @@ $olddir/build-%{nptl_target_cpu}-linuxnptl/elf/ld.so \
rm -rf *_*
mv locale-archive{,.tmpl}
popd
#build-%{nptl_target_cpu}-linuxnptl/hardlink -vc $RPM_BUILD_ROOT%{_prefix}/lib/locale
%endif
rm -f ${RPM_BUILD_ROOT}/%{_lib}/libnss1-*
@ -1031,6 +1029,9 @@ rm -f *.filelist*
%endif
%changelog
* Mon Sep 21 2009 Andreas Schwab <schwab@redhat.com> - 2.10.90-23
- Update from master.
* Mon Sep 14 2009 Andreas Schwab <schwab@redhat.com> - 2.10.90-22
- Update from master.
- Fix endless loop in localedef.

View File

@ -30,3 +30,4 @@ glibc-2_10_90-19:HEAD:glibc-2.10.90-19.src.rpm:1251889856
glibc-2_10_90-20:HEAD:glibc-2.10.90-20.src.rpm:1251969190
glibc-2_10_90-21:HEAD:glibc-2.10.90-21.src.rpm:1252314102
glibc-2_10_90-22:HEAD:glibc-2.10.90-22.src.rpm:1252930886
glibc-2_10_90-23:HEAD:glibc-2.10.90-23.src.rpm:1253528881

View File

@ -1,2 +1,2 @@
7cf85b26787ff05f8f286ba49ce6cfd3 glibc-2.10-335-g02bf610-fedora.tar.bz2
f886b8d4e1f0d30bc6ae0039cd7e93b0 glibc-2.10-335-g02bf610.tar.bz2
c28c9d6bc56e7603f240324a481f761c glibc-2.10-340-gae0f0db-fedora.tar.bz2
ca11781e7b849d0f4a317f1e5b78f0dc glibc-2.10-340-gae0f0db.tar.bz2