Remove downstream-only workaround patches for ppc64le, gettext
This commit is contained in:
parent
37b89add0a
commit
9050623a8c
@ -1,43 +0,0 @@
|
||||
commit e3f322fa0f85c7db60cb4eadfd97337964df1c4d
|
||||
Author: Siddhesh Poyarekar <siddhesh@sourceware.org>
|
||||
Date: Tue Mar 8 11:22:44 2022 +0530
|
||||
|
||||
configure: Allow gettext snapshots
|
||||
|
||||
Gettext snapshots may have a yyyy-mm-dd version number, so account for
|
||||
that.
|
||||
|
||||
Signed-off-by: Siddhesh Poyarekar <siddhesh@sourceware.org>
|
||||
|
||||
diff --git a/configure b/configure
|
||||
index 8e5bee775a..b31703557d 100755
|
||||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -5011,10 +5011,10 @@ else
|
||||
# Found it, now check the version.
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking version of $MSGFMT" >&5
|
||||
$as_echo_n "checking version of $MSGFMT... " >&6; }
|
||||
- ac_prog_version=`$MSGFMT --version 2>&1 | sed -n 's/^.*GNU gettext.* \([0-9]*\.[0-9.]*\).*$/\1/p'`
|
||||
+ ac_prog_version=`$MSGFMT --version 2>&1 | sed -n 's/^.*GNU gettext.* \(\([0-9]*\.[0-9.]*\)\|\([0-9]*-[0-9]*-[0-9]*\)\).*$/\1/p'`
|
||||
case $ac_prog_version in
|
||||
'') ac_prog_version="v. ?.??, bad"; ac_verc_fail=yes;;
|
||||
- 0.10.3[6-9]* | 0.10.[4-9][0-9]* | 0.1[1-9]* | 0.[2-9][0-9]* | [1-9].*)
|
||||
+ 0.10.3[6-9]* | 0.10.[4-9][0-9]* | 0.1[1-9]* | 0.[2-9][0-9]* | [1-9].* | [0-9]*-[0-9]*-[0-9]*)
|
||||
ac_prog_version="$ac_prog_version, ok"; ac_verc_fail=no;;
|
||||
*) ac_prog_version="$ac_prog_version, bad"; ac_verc_fail=yes;;
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 87f67d25ec..2f39f7e2d1 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -1040,8 +1040,8 @@ AC_CHECK_PROG_VER(MAKE, gnumake gmake make, --version,
|
||||
[[4-9].* | [1-9][0-9]*], critic_missing="$critic_missing make")
|
||||
|
||||
AC_CHECK_PROG_VER(MSGFMT, gnumsgfmt gmsgfmt msgfmt, --version,
|
||||
- [GNU gettext.* \([0-9]*\.[0-9.]*\)],
|
||||
- [0.10.3[6-9]* | 0.10.[4-9][0-9]* | 0.1[1-9]* | 0.[2-9][0-9]* | [1-9].*],
|
||||
+ [GNU gettext.* \(\([0-9]*\.[0-9.]*\)\|\([0-9]*-[0-9]*-[0-9]*\)\)],
|
||||
+ [0.10.3[6-9]* | 0.10.[4-9][0-9]* | 0.1[1-9]* | 0.[2-9][0-9]* | [1-9].* | [0-9]*-[0-9]*-[0-9]*],
|
||||
MSGFMT=: aux_missing="$aux_missing msgfmt")
|
||||
AC_CHECK_PROG_VER(MAKEINFO, makeinfo, --version,
|
||||
[GNU texinfo.* \([0-9][0-9.]*\)],
|
@ -1,40 +0,0 @@
|
||||
Temporary workaround until this GCC bug is fixed:
|
||||
|
||||
-mlong-double-64 should override a previous -mabi=ibmlongdouble
|
||||
<https://gcc.gnu.org/bugzilla/show_bug.cgi?id=104208>
|
||||
|
||||
diff --git a/sysdeps/ieee754/ldbl-opt/Makefile b/sysdeps/ieee754/ldbl-opt/Makefile
|
||||
index 1d01846476..0e06abf9f1 100644
|
||||
--- a/sysdeps/ieee754/ldbl-opt/Makefile
|
||||
+++ b/sysdeps/ieee754/ldbl-opt/Makefile
|
||||
@@ -186,8 +186,8 @@ CFLAGS-nldbl-y0.c = -fno-builtin-y0l
|
||||
CFLAGS-nldbl-y1.c = -fno-builtin-y1l
|
||||
CFLAGS-nldbl-yn.c = -fno-builtin-ynl
|
||||
|
||||
-tests += test-narrow-macros-ldbl-64 test-nldbl-redirect \
|
||||
- test-redirection-ldbl-64
|
||||
+#tests += test-narrow-macros-ldbl-64 test-nldbl-redirect \
|
||||
+# test-redirection-ldbl-64
|
||||
CFLAGS-test-narrow-macros-ldbl-64.c += -mlong-double-64
|
||||
CFLAGS-test-nldbl-redirect.c += -mlong-double-64
|
||||
CFLAGS-test-redirection-ldbl-64.c += -mlong-double-64
|
||||
@@ -198,7 +198,7 @@ endif
|
||||
|
||||
# Tests for argp.h functions (reusing the relevant tests from argp/)
|
||||
ifeq ($(subdir),argp)
|
||||
-tests-internal += tst-nldbl-argp
|
||||
+#tests-internal += tst-nldbl-argp
|
||||
|
||||
$(objpfx)tst-nldbl-argp.c: tst-ldbl-argp.c
|
||||
cp $< $@
|
||||
@@ -209,8 +209,8 @@ endif
|
||||
# Tests for err.h and error.h functions (reusing the relevant tests from
|
||||
# misc/).
|
||||
ifeq ($(subdir), misc)
|
||||
-tests-internal += tst-nldbl-warn
|
||||
-tests-internal += tst-nldbl-error
|
||||
+#tests-internal += tst-nldbl-warn
|
||||
+#tests-internal += tst-nldbl-error
|
||||
|
||||
$(objpfx)tst-nldbl-warn.c: tst-ldbl-warn.c
|
||||
cp $< $@
|
@ -224,12 +224,6 @@ Patch17: glibc-cs-path.patch
|
||||
Patch23: glibc-python3.patch
|
||||
Patch30: glibc-deprecated-selinux-makedb.patch
|
||||
|
||||
# Temporary until gcc is patched to have -mlong-double-64 override
|
||||
# -mabi=ibmlongdouble instead of conflict with it.
|
||||
Patch99: glibc-temp-ibmldbl64.patch
|
||||
# Temporary until gettext snapshot versioning is resolved, see #2061646.
|
||||
Patch100: glibc-gettext-snapshot-versioncheck.patch
|
||||
|
||||
##############################################################################
|
||||
# Continued list of core "glibc" package information:
|
||||
##############################################################################
|
||||
|
Loading…
Reference in New Issue
Block a user