- Delay setting DECIDED field in locale file structure until
we have read the file's data (#827510).
This commit is contained in:
parent
ebc13c27b8
commit
8b98471a2c
27
glibc-rh827510.patch
Normal file
27
glibc-rh827510.patch
Normal file
@ -0,0 +1,27 @@
|
||||
2012-06-14 Jeff Law <law@redhat.com>
|
||||
|
||||
|
||||
* locale/loadlocale.c (_nl_load_locale): Delay setting
|
||||
file->decided until we have successfully loaded the file's
|
||||
data.
|
||||
|
||||
diff --git a/locale/loadlocale.c b/locale/loadlocale.c
|
||||
index e3fa187..9fd9216 100644
|
||||
--- a/locale/loadlocale.c
|
||||
+++ b/locale/loadlocale.c
|
||||
@@ -169,7 +169,6 @@ _nl_load_locale (struct loaded_l10nfile *file, int category)
|
||||
int save_err;
|
||||
int alloc = ld_mapped;
|
||||
|
||||
- file->decided = 1;
|
||||
file->data = NULL;
|
||||
|
||||
fd = open_not_cancel_2 (file->filename, O_RDONLY | O_CLOEXEC);
|
||||
@@ -278,6 +277,7 @@ _nl_load_locale (struct loaded_l10nfile *file, int category)
|
||||
newdata->alloc = alloc;
|
||||
|
||||
file->data = newdata;
|
||||
+ file->decided = 1;
|
||||
}
|
||||
|
||||
void
|
23
glibc.spec
23
glibc.spec
@ -28,7 +28,7 @@
|
||||
Summary: The GNU libc libraries
|
||||
Name: glibc
|
||||
Version: %{glibcversion}
|
||||
Release: 12%{?dist}
|
||||
Release: 13%{?dist}
|
||||
# GPLv2+ is used in a bunch of programs, LGPLv2+ is used for libraries.
|
||||
# Things that are linked directly into dynamically linked programs
|
||||
# and shared libraries (e.g. crt files, lib*_nonshared.a) have an additional
|
||||
@ -100,7 +100,7 @@ Patch0032: %{name}-rh825061.patch
|
||||
|
||||
# Horrible hack, never to be upstreamed. Can go away once the world
|
||||
# has been rebuilt to use the new ld.so path.
|
||||
Patch0061: %{name}-arm-hardfloat-3.patch
|
||||
Patch0036: %{name}-arm-hardfloat-3.patch
|
||||
|
||||
#
|
||||
# Patches from upstream
|
||||
@ -174,6 +174,9 @@ Patch2034: %{name}-rh823905.patch
|
||||
# See http://sourceware.org/ml/libc-alpha/2012-06/msg00074.html
|
||||
Patch2035: %{name}-rh767693-2.patch
|
||||
|
||||
# Upstream BZ 14247
|
||||
Patch2037: %{name}-rh827510.patch
|
||||
|
||||
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
Obsoletes: glibc-profile < 2.4
|
||||
Obsoletes: nss_db
|
||||
@ -431,8 +434,8 @@ rm -rf %{glibcportsdir}
|
||||
%patch2033 -p1
|
||||
%patch2034 -p1
|
||||
%patch2035 -p1
|
||||
|
||||
%patch0061 -p1
|
||||
%patch0036 -p1
|
||||
%patch2037 -p1
|
||||
|
||||
# On powerpc32, hp timing is only available in power4/power6
|
||||
# libs, not in base, so pre-power4 dynamic linker is incompatible
|
||||
@ -1315,13 +1318,17 @@ rm -f *.filelist*
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Mon Jun 14 2012 Jeff Law <law@redhat.com> - 2.15.90-13
|
||||
- Delay setting DECIDED field in locale file structure until
|
||||
we have read the file's data (#827510).
|
||||
|
||||
* Mon Jun 11 2012 Dennis Gilmore <dennis@ausil.us> - 2.15.90-12
|
||||
- actually apply the arm linker hack
|
||||
- actually apply the arm linker hack
|
||||
|
||||
* Mon Jun 11 2012 Dennis Gilmore <dennis@ausil.us> - 2.15.90-11
|
||||
- only deal with the arm linker compat hack on armhfp arches
|
||||
- armsfp arches do not have a linker change
|
||||
- Backward compat hack for armhf binaries.
|
||||
- only deal with the arm linker compat hack on armhfp arches
|
||||
- armsfp arches do not have a linker change
|
||||
- Backward compat hack for armhf binaries.
|
||||
|
||||
* Thu Jun 7 2012 Jeff Law <law@redhat.com> - 2.15.90-10
|
||||
- Fix parsing of /etc/sysconfig/clock when ZONE has spaces. (#828291)
|
||||
|
Loading…
Reference in New Issue
Block a user