Auto-sync with upstream branch master
Upstream commit: b1caa144c74678097cada5a54eda2996bb459d8f - Update mips libm-test-ulps - Update alpha libm-test-ulps - Update ia64 libm-test-ulps - Update sparc libm-test-ulps - Update arm libm-test-ulps - Update aarch64 libm-test-ulps - Updates to the shn_MM locale [BZ #25532] - powerpc: Update ULPs and xfail more ibm128 outputs - i386: Remove build support for GCC older than GCC 6 - oc_FR locale: Fix spelling of April (bug 25639) - Update hppa libm-test-ulps - y2038: linux: Provide __mq_timedreceive_time64 implementation - y2038: linux: Provide __mq_timedsend_time64 implementation - y2038: include: Move struct __timespec64 definition to a separate file - malloc: ensure set_max_fast never stores zero [BZ #25733] - powerpc64le: enforce non-specific long double in .gnu.attributes section - powerpc64le: workaround ieee long double / _Float128 stdc++ bug - powerpc64le: Enforce -mabi=ibmlongdouble when -mfloat128 used - powerpc64le/multiarch: don't generate strong aliases for fmaf128-ppc64 - ldbl-128ibm: simplify iscanonical.h - i386: Disable check_consistency for GCC 5 and above [BZ #25788] - Add IPPROTO_ETHERNET and IPPROTO_MPTCP from Linux 5.6 to netinet/in.h. - Update syscall lists for Linux 5.6. - elf: Implement DT_AUDIT, DT_DEPAUDIT support [BZ #24943] - elf: Simplify handling of lists of audit strings - support: Change xgetline to return 0 on EOF - nptl: Remove x86_64 cancellation assembly implementations [BZ #25765] - aarch64: update bits/hwcap.h - Add tests for Safe-Linking - S390: Regenerate ULPs. - sysv/alpha: Use generic __timeval32 and helpers - linux: Use long time_t for wait4/getrusage - resource: Add a __rusage64 struct - linux: Use long time_t __getitimer/__setitimer - sysv: Define __KERNEL_OLD_TIMEVAL_MATCHES_TIMEVAL64 - math: Add inputs that yield larger errors for float type (x86_64)
This commit is contained in:
parent
1479bc1a28
commit
89e19f3b9e
@ -30,11 +30,11 @@ This patch needs to go upstream to get cleaned up, but has always involed
|
||||
analysis of the GNU/Hurd parts of the change and that stalled out, but
|
||||
perhaps with build-many-glibcs we can now test these changes more easily.
|
||||
|
||||
Index: b/elf/dl-init.c
|
||||
===================================================================
|
||||
diff --git a/elf/dl-init.c b/elf/dl-init.c
|
||||
index 1234611a1c89532e..abd1913fb8de9caf 100644
|
||||
--- a/elf/dl-init.c
|
||||
+++ b/elf/dl-init.c
|
||||
@@ -119,8 +119,6 @@ _dl_init (struct link_map *main_map, int
|
||||
@@ -114,8 +114,6 @@ _dl_init (struct link_map *main_map, int argc, char **argv, char **env)
|
||||
while (i-- > 0)
|
||||
call_init (main_map->l_initfini[i], argc, argv, env);
|
||||
|
||||
@ -43,11 +43,11 @@ Index: b/elf/dl-init.c
|
||||
_dl_starting_up = 0;
|
||||
-#endif
|
||||
}
|
||||
Index: b/elf/dl-support.c
|
||||
===================================================================
|
||||
diff --git a/elf/dl-support.c b/elf/dl-support.c
|
||||
index 7704c101c5a543a1..ffa235c78df8481f 100644
|
||||
--- a/elf/dl-support.c
|
||||
+++ b/elf/dl-support.c
|
||||
@@ -117,10 +117,8 @@ struct r_scope_elem _dl_initial_searchli
|
||||
@@ -120,10 +120,8 @@ struct r_scope_elem _dl_initial_searchlist =
|
||||
.r_nlist = 1,
|
||||
};
|
||||
|
||||
@ -58,19 +58,19 @@ Index: b/elf/dl-support.c
|
||||
|
||||
/* Random data provided by the kernel. */
|
||||
void *_dl_random;
|
||||
Index: b/elf/rtld.c
|
||||
===================================================================
|
||||
diff --git a/elf/rtld.c b/elf/rtld.c
|
||||
index b2ea21c98b89831e..f3c37875f4f4dba7 100644
|
||||
--- a/elf/rtld.c
|
||||
+++ b/elf/rtld.c
|
||||
@@ -214,7 +214,6 @@ audit_list_iter_next (struct audit_list_
|
||||
return iter->previous->name;
|
||||
@@ -298,7 +298,6 @@ audit_list_next (struct audit_list *list)
|
||||
}
|
||||
}
|
||||
|
||||
-#ifndef HAVE_INLINED_SYSCALLS
|
||||
/* Set nonzero during loading and initialization of executable and
|
||||
libraries, cleared before the executable's entry point runs. This
|
||||
must not be initialized to nonzero, because the unused dynamic
|
||||
@@ -224,7 +223,6 @@ audit_list_iter_next (struct audit_list_
|
||||
@@ -308,7 +307,6 @@ audit_list_next (struct audit_list *list)
|
||||
never be called. */
|
||||
int _dl_starting_up = 0;
|
||||
rtld_hidden_def (_dl_starting_up)
|
||||
@ -78,9 +78,9 @@ Index: b/elf/rtld.c
|
||||
|
||||
/* This is the structure which defines all variables global to ld.so
|
||||
(except those which cannot be added for some reason). */
|
||||
@@ -898,10 +896,8 @@ dl_main (const ElfW(Phdr) *phdr,
|
||||
@@ -1155,10 +1153,8 @@ dl_main (const ElfW(Phdr) *phdr,
|
||||
/* Process the environment variable which control the behaviour. */
|
||||
process_envvars (&mode);
|
||||
process_envvars (&mode, &audit_list);
|
||||
|
||||
-#ifndef HAVE_INLINED_SYSCALLS
|
||||
/* Set up a flag which tells we are just starting. */
|
||||
|
44
glibc.spec
44
glibc.spec
@ -1,4 +1,4 @@
|
||||
%define glibcsrcdir glibc-2.31.9000-307-g49c3c37651
|
||||
%define glibcsrcdir glibc-2.31.9000-343-gb1caa144c7
|
||||
%define glibcversion 2.31.9000
|
||||
# Pre-release tarballs are pulled in from git using a command that is
|
||||
# effectively:
|
||||
@ -87,7 +87,7 @@
|
||||
Summary: The GNU libc libraries
|
||||
Name: glibc
|
||||
Version: %{glibcversion}
|
||||
Release: 6%{?dist}
|
||||
Release: 7%{?dist}
|
||||
|
||||
# In general, GPLv2+ is used by programs, LGPLv2+ is used for
|
||||
# libraries.
|
||||
@ -2041,6 +2041,46 @@ fi
|
||||
%files -f compat-libpthread-nonshared.filelist -n compat-libpthread-nonshared
|
||||
|
||||
%changelog
|
||||
* Wed Apr 08 2020 Carlos O'Donell <carlos@redhat.com> - 2.31.9000-7
|
||||
- Auto-sync with upstream branch master,
|
||||
commit b1caa144c74678097cada5a54eda2996bb459d8f.
|
||||
- Update mips libm-test-ulps
|
||||
- Update alpha libm-test-ulps
|
||||
- Update ia64 libm-test-ulps
|
||||
- Update sparc libm-test-ulps
|
||||
- Update arm libm-test-ulps
|
||||
- Update aarch64 libm-test-ulps
|
||||
- Updates to the shn_MM locale [BZ #25532]
|
||||
- powerpc: Update ULPs and xfail more ibm128 outputs
|
||||
- i386: Remove build support for GCC older than GCC 6
|
||||
- oc_FR locale: Fix spelling of April (bug 25639)
|
||||
- Update hppa libm-test-ulps
|
||||
- y2038: linux: Provide __mq_timedreceive_time64 implementation
|
||||
- y2038: linux: Provide __mq_timedsend_time64 implementation
|
||||
- y2038: include: Move struct __timespec64 definition to a separate file
|
||||
- malloc: ensure set_max_fast never stores zero [BZ #25733]
|
||||
- powerpc64le: enforce non-specific long double in .gnu.attributes section
|
||||
- powerpc64le: workaround ieee long double / _Float128 stdc++ bug
|
||||
- powerpc64le: Enforce -mabi=ibmlongdouble when -mfloat128 used
|
||||
- powerpc64le/multiarch: don't generate strong aliases for fmaf128-ppc64
|
||||
- ldbl-128ibm: simplify iscanonical.h
|
||||
- i386: Disable check_consistency for GCC 5 and above [BZ #25788]
|
||||
- Add IPPROTO_ETHERNET and IPPROTO_MPTCP from Linux 5.6 to netinet/in.h.
|
||||
- Update syscall lists for Linux 5.6.
|
||||
- elf: Implement DT_AUDIT, DT_DEPAUDIT support [BZ #24943]
|
||||
- elf: Simplify handling of lists of audit strings
|
||||
- support: Change xgetline to return 0 on EOF
|
||||
- nptl: Remove x86_64 cancellation assembly implementations [BZ #25765]
|
||||
- aarch64: update bits/hwcap.h
|
||||
- Add tests for Safe-Linking
|
||||
- S390: Regenerate ULPs.
|
||||
- sysv/alpha: Use generic __timeval32 and helpers
|
||||
- linux: Use long time_t for wait4/getrusage
|
||||
- resource: Add a __rusage64 struct
|
||||
- linux: Use long time_t __getitimer/__setitimer
|
||||
- sysv: Define __KERNEL_OLD_TIMEVAL_MATCHES_TIMEVAL64
|
||||
- math: Add inputs that yield larger errors for float type (x86_64)
|
||||
|
||||
* Tue Mar 31 2020 DJ Delorie <dj@redhat.com> - 2.31.9000-6
|
||||
- Auto-sync with upstream branch master,
|
||||
commit 49c3c37651e2d2ec4ff8ce21252bbbc08a9d6639.
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (glibc-2.31.9000-307-g49c3c37651.tar.xz) = aa773018a1ca197dd180e5e25b5f151edb4993768a7726fe611df1962b4dbf0b9d5971b8cb01d260c7c327cb5439223d31cc8d9f41319fb461ed09a784e65744
|
||||
SHA512 (glibc-2.31.9000-343-gb1caa144c7.tar.xz) = 54a6efde23d0663679d0ab5e9821248196a4552ad08eaab73511bd410d3df7754a294b6c617b947dfee969be89abc31ad8f309fdab582b23b2c9f76ec2ac25d2
|
||||
|
Loading…
Reference in New Issue
Block a user