Auto-sync with upstream branch master
Upstream commit: f278835f594740f5913001430641cf1da4878670 - Drop glibc-deprecated-selinux-makedb.patch. Upstream has been ported to new libselinux. - makedb: fix build with libselinux >= 3.1 (Bug 26233) - tst-sprintf-errno: Update Hurd message output - Use C11 atomics instead of atomic_decrement(_val) - Use C11 atomics instead atomic_add(_zero) - mktime: improve heuristic for ca-1986 Indiana DST - Assume HAVE_TZSET in time/mktime.c - elf: Fix hwcaps string size overestimation - errlist: add missing entry for EDEADLOCK (bug 29545) - Do not define static_assert or thread_local in headers for C2x - malloc: Use C11 atomics rather than atomic_exchange_and_add - Add NEWS entry for CVE-2022-39046 - elf: Rename _dl_sort_maps parameter from skip to force_first - scripts/dso-ordering-test.py: Generate program run-time dependencies - math: x86: Use prefix for FP_INIT_ROUNDMODE - scripts/build-many-glibcs.py: Use https:// for sourceware.org Git clones - debug: test for more required cacellation points (BZ# 29274) - elf.h: Remove duplicate definition of VER_FLG_WEAK - syslog: Remove extra whitespace between timestamp and message (BZ#29544) - LoongArch: Add soft float support. - elf: Restore how vDSO dependency is printed with LD_TRACE_LOADED_OBJECTS (BZ #29539) - nptl: x86_64: Use same code for CURRENT_STACK_FRAME and stackinfo_get_sp
This commit is contained in:
parent
8e2d77f734
commit
885b520a6d
@ -1,20 +0,0 @@
|
||||
This is necessary to get things building again after libselinux changes.
|
||||
A proper fix is under discussion upstream:
|
||||
|
||||
<https://sourceware.org/pipermail/libc-alpha/2020-July/116504.html>
|
||||
|
||||
diff --git a/nss/makedb.c b/nss/makedb.c
|
||||
index 8e389a1683747cf1..9d81aed57d384a22 100644
|
||||
--- a/nss/makedb.c
|
||||
+++ b/nss/makedb.c
|
||||
@@ -17,6 +17,10 @@
|
||||
License along with the GNU C Library; if not, see
|
||||
<https://www.gnu.org/licenses/>. */
|
||||
|
||||
+/* This file uses deprecated declarations from libselinux. */
|
||||
+#include <libc-diag.h>
|
||||
+DIAG_IGNORE_NEEDS_COMMENT (4.9, "-Wdeprecated-declarations");
|
||||
+
|
||||
#include <argp.h>
|
||||
#include <assert.h>
|
||||
#include <ctype.h>
|
32
glibc.spec
32
glibc.spec
@ -1,4 +1,4 @@
|
||||
%global glibcsrcdir glibc-2.36.9000-95-gc7509d49c4
|
||||
%global glibcsrcdir glibc-2.36.9000-116-gf278835f59
|
||||
%global glibcversion 2.36.9000
|
||||
# Pre-release tarballs are pulled in from git using a command that is
|
||||
# effectively:
|
||||
@ -159,7 +159,7 @@ Version: %{glibcversion}
|
||||
# - It allows using the Release number without the %%dist tag in the dependency
|
||||
# generator to make the generated requires interchangeable between Rawhide
|
||||
# and ELN (.elnYY < .fcXX).
|
||||
%global baserelease 5
|
||||
%global baserelease 6
|
||||
Release: %{baserelease}%{?dist}
|
||||
|
||||
# In general, GPLv2+ is used by programs, LGPLv2+ is used for
|
||||
@ -230,7 +230,6 @@ Patch9: glibc-rh827510.patch
|
||||
Patch13: glibc-fedora-localedata-rh61908.patch
|
||||
Patch17: glibc-cs-path.patch
|
||||
Patch23: glibc-python3.patch
|
||||
Patch30: glibc-deprecated-selinux-makedb.patch
|
||||
|
||||
##############################################################################
|
||||
# Continued list of core "glibc" package information:
|
||||
@ -2185,6 +2184,33 @@ update_gconv_modules_cache ()
|
||||
%files -f compat-libpthread-nonshared.filelist -n compat-libpthread-nonshared
|
||||
|
||||
%changelog
|
||||
* Tue Sep 13 2022 Florian Weimer <fweimer@redhat.com> - 2.36.9000-6
|
||||
- Drop glibc-deprecated-selinux-makedb.patch. Upstream has been ported
|
||||
to new libselinux.
|
||||
- Auto-sync with upstream branch master,
|
||||
commit f278835f594740f5913001430641cf1da4878670:
|
||||
- makedb: fix build with libselinux >= 3.1 (Bug 26233)
|
||||
- tst-sprintf-errno: Update Hurd message output
|
||||
- Use C11 atomics instead of atomic_decrement(_val)
|
||||
- Use C11 atomics instead atomic_add(_zero)
|
||||
- mktime: improve heuristic for ca-1986 Indiana DST
|
||||
- Assume HAVE_TZSET in time/mktime.c
|
||||
- elf: Fix hwcaps string size overestimation
|
||||
- errlist: add missing entry for EDEADLOCK (bug 29545)
|
||||
- Do not define static_assert or thread_local in headers for C2x
|
||||
- malloc: Use C11 atomics rather than atomic_exchange_and_add
|
||||
- Add NEWS entry for CVE-2022-39046
|
||||
- elf: Rename _dl_sort_maps parameter from skip to force_first
|
||||
- scripts/dso-ordering-test.py: Generate program run-time dependencies
|
||||
- math: x86: Use prefix for FP_INIT_ROUNDMODE
|
||||
- scripts/build-many-glibcs.py: Use https:// for sourceware.org Git clones
|
||||
- debug: test for more required cacellation points (BZ# 29274)
|
||||
- elf.h: Remove duplicate definition of VER_FLG_WEAK
|
||||
- syslog: Remove extra whitespace between timestamp and message (BZ#29544)
|
||||
- LoongArch: Add soft float support.
|
||||
- elf: Restore how vDSO dependency is printed with LD_TRACE_LOADED_OBJECTS (BZ #29539)
|
||||
- nptl: x86_64: Use same code for CURRENT_STACK_FRAME and stackinfo_get_sp
|
||||
|
||||
* Mon Sep 05 2022 Arjun Shankar <arjun@redhat.com> - 2.36.9000-5
|
||||
- Co-Authored-By: Benjamin Herrenschmidt <benh@amazon.com>
|
||||
- Retain .gnu_debuglink section in libc.so.6 (#2090744)
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (glibc-2.36.9000-95-gc7509d49c4.tar.xz) = 5fa125bb6b892dccfe73488a9b69961cf4a39cb0d470e50a1ef235bf59a8013f680fdffb3647e0a02be9bc58e30fac0c14619179b457c2674084305f42657a60
|
||||
SHA512 (glibc-2.36.9000-116-gf278835f59.tar.xz) = 001b3d66c26cbe06d34a22c5299b8049afb2604407f70fd2d3c0a654b65e74b860465dc299a4e1fbf89dd94b9a6517895f20fc28b8e76c525c55ed2e18d1099f
|
||||
|
Loading…
Reference in New Issue
Block a user