Resolves: #1462820
- Drop glibc-Disable-buf-NULL-in-login-tst-ptsname.c, applied upstream. - Auto-sync with upstream master, commit 37e9dc814636915afb88d0779e5e897e90e7b8c0, fixing: - CVE-2017-1000366: Avoid large allocas in the dynamic linker (#1462820) - wait3 namespace (swbz#21625) - S390: Sync ptrace.h with kernel (swbz#21539) - Another x86 sys/ucontext.h namespace issue (swbz#21457) - siginterrupt namespace (swbz#21597) - Signal stack namespace (swbz#21584) - Define struct rusage in sys/wait.h when required (swbz#21575) - S390: Fix build with gcc configured with --enable-default-pie (swbz#21537) - Update timezone code from tzcode 2017b - nptl: Invert the mmap/mprotect logic on allocated stacks (swbz#18988) - PowerPC64 ELFv2 PPC64_OPT_LOCALENTRY - Make copy of <bits/std_abs.h> from GCC (swbz#21573) - localedata: ce_RU: update weekdays from CLDR (swbz#21207) - localedata: Remove trailing spaces (swbz#20275) - XPG4 bsd_signal namespace (swbz#21552) - Correct collation rules for Malayalam (swbz#19922, swbz#19919) - waitid namespace (swbz#21561) - Condition signal.h inclusion in sys/wait.h (swbz#21560) - ld.so: Consolidate 2 strtouls into _dl_strtoul (swbz#21528) - tst-timezone race (swbz#14096) - Define SIG_HOLD for XPG4 (swbz#21538) - struct sigaltstack namespace (swbz#21517) - sigevent namespace (swbz#21543) - Add shim header for bits/syscall.h (swbz#21514) - namespace issues in sys/ucontext.h (swbz#21457) - posix: Implement preadv2 and pwritev2 - Various float128 and tunables improvements
This commit is contained in:
parent
f35d7503ab
commit
87bc7c9489
@ -1,17 +0,0 @@
|
||||
Author: Arjun Shankar <arjun.is@lostca.se>
|
||||
Date: Wed May 31 14:09:46 2017 +0200
|
||||
|
||||
Disable buf=NULL in login/tst-ptsname.c
|
||||
|
||||
Index: b/login/tst-ptsname.c
|
||||
===================================================================
|
||||
--- a/login/tst-ptsname.c
|
||||
+++ b/login/tst-ptsname.c
|
||||
@@ -70,7 +70,6 @@ do_test (void)
|
||||
if (fd != -1)
|
||||
{
|
||||
result |= do_single_test (fd, buf, sizeof (buf), 0);
|
||||
- result |= do_single_test (fd, NULL, sizeof (buf), EINVAL);
|
||||
result |= do_single_test (fd, buf, 1, ERANGE);
|
||||
close (fd);
|
||||
}
|
@ -21,10 +21,11 @@
|
||||
# elf/rtld.c | 4 ----
|
||||
# 4 files changed, 7 insertions(+), 10 deletions(-)
|
||||
#
|
||||
diff -urN glibc-2.20-205-ga39208b/elf/dl-init.c glibc-2.20-205-ga39208b.mod/elf/dl-init.c
|
||||
--- glibc-2.20-205-ga39208b/elf/dl-init.c 2014-11-21 16:08:32.744913590 -0500
|
||||
+++ glibc-2.20-205-ga39208b.mod/elf/dl-init.c 2014-11-21 16:09:42.485708197 -0500
|
||||
@@ -119,8 +119,6 @@
|
||||
Index: b/elf/dl-init.c
|
||||
===================================================================
|
||||
--- a/elf/dl-init.c
|
||||
+++ b/elf/dl-init.c
|
||||
@@ -119,8 +119,6 @@ _dl_init (struct link_map *main_map, int
|
||||
while (i-- > 0)
|
||||
call_init (main_map->l_initfini[i], argc, argv, env);
|
||||
|
||||
@ -33,10 +34,11 @@ diff -urN glibc-2.20-205-ga39208b/elf/dl-init.c glibc-2.20-205-ga39208b.mod/elf/
|
||||
_dl_starting_up = 0;
|
||||
-#endif
|
||||
}
|
||||
diff -urN glibc-2.20-205-ga39208b/elf/dl-support.c glibc-2.20-205-ga39208b.mod/elf/dl-support.c
|
||||
--- glibc-2.20-205-ga39208b/elf/dl-support.c 2014-11-19 14:35:03.000000000 -0500
|
||||
+++ glibc-2.20-205-ga39208b.mod/elf/dl-support.c 2014-11-21 16:09:54.829671843 -0500
|
||||
@@ -118,10 +118,8 @@
|
||||
Index: b/elf/dl-support.c
|
||||
===================================================================
|
||||
--- a/elf/dl-support.c
|
||||
+++ b/elf/dl-support.c
|
||||
@@ -117,10 +117,8 @@ struct r_scope_elem _dl_initial_searchli
|
||||
.r_nlist = 1,
|
||||
};
|
||||
|
||||
@ -47,18 +49,19 @@ diff -urN glibc-2.20-205-ga39208b/elf/dl-support.c glibc-2.20-205-ga39208b.mod/e
|
||||
|
||||
/* Random data provided by the kernel. */
|
||||
void *_dl_random;
|
||||
diff -urN glibc-2.20-205-ga39208b/elf/rtld.c glibc-2.20-205-ga39208b.mod/elf/rtld.c
|
||||
--- glibc-2.20-205-ga39208b/elf/rtld.c 2014-11-21 16:08:32.745913587 -0500
|
||||
+++ glibc-2.20-205-ga39208b.mod/elf/rtld.c 2014-11-21 16:09:05.614816785 -0500
|
||||
@@ -107,7 +107,6 @@
|
||||
struct audit_list *next;
|
||||
} *audit_list;
|
||||
Index: b/elf/rtld.c
|
||||
===================================================================
|
||||
--- a/elf/rtld.c
|
||||
+++ b/elf/rtld.c
|
||||
@@ -214,7 +214,6 @@ audit_list_iter_next (struct audit_list_
|
||||
return iter->previous->name;
|
||||
}
|
||||
|
||||
-#ifndef HAVE_INLINED_SYSCALLS
|
||||
/* Set nonzero during loading and initialization of executable and
|
||||
libraries, cleared before the executable's entry point runs. This
|
||||
must not be initialized to nonzero, because the unused dynamic
|
||||
@@ -117,7 +116,6 @@
|
||||
@@ -224,7 +223,6 @@ audit_list_iter_next (struct audit_list_
|
||||
never be called. */
|
||||
int _dl_starting_up = 0;
|
||||
rtld_hidden_def (_dl_starting_up)
|
||||
@ -66,7 +69,7 @@ diff -urN glibc-2.20-205-ga39208b/elf/rtld.c glibc-2.20-205-ga39208b.mod/elf/rtl
|
||||
|
||||
/* This is the structure which defines all variables global to ld.so
|
||||
(except those which cannot be added for some reason). */
|
||||
@@ -776,10 +774,8 @@
|
||||
@@ -898,10 +896,8 @@ dl_main (const ElfW(Phdr) *phdr,
|
||||
/* Process the environment variable which control the behaviour. */
|
||||
process_envvars (&mode);
|
||||
|
||||
|
43
glibc.spec
43
glibc.spec
@ -1,6 +1,6 @@
|
||||
%define glibcsrcdir glibc-2.25-378-gcfa9bb6
|
||||
%define glibcsrcdir glibc-2.25-518-g37e9dc8
|
||||
%define glibcversion 2.25.90
|
||||
%define glibcrelease 6%{?dist}
|
||||
%define glibcrelease 7%{?dist}
|
||||
# Pre-release tarballs are pulled in from git using a command that is
|
||||
# effectively:
|
||||
#
|
||||
@ -295,12 +295,6 @@ Patch2037: glibc-rh1315108.patch
|
||||
# sln implemented by ldconfig, to conserve disk space.
|
||||
Patch2112: glibc-rh1315476-2.patch
|
||||
|
||||
# Disable the NULL buffer test in login/tst-ptsname.c. It leads to a build
|
||||
# failure during 'make check'. A solution is being discussed at:
|
||||
# * [v1] https://sourceware.org/ml/libc-alpha/2017-05/msg00726.html
|
||||
# * [v2] https://sourceware.org/ml/libc-alpha/2017-05/msg00835.html
|
||||
Patch2200: glibc-Disable-buf-NULL-in-login-tst-ptsname.c
|
||||
|
||||
##############################################################################
|
||||
# End of glibc patches.
|
||||
##############################################################################
|
||||
@ -869,7 +863,6 @@ microbenchmark tests on the system.
|
||||
%patch2037 -p1
|
||||
%patch2112 -p1
|
||||
%patch0061 -p1
|
||||
%patch2200 -p1
|
||||
|
||||
##############################################################################
|
||||
# %%prep - Additional prep required...
|
||||
@ -2275,6 +2268,38 @@ rm -f *.filelist*
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Mon Jun 19 2017 Florian Weimer <fweimer@redhat.com> - 2.25.90-7
|
||||
- Drop glibc-Disable-buf-NULL-in-login-tst-ptsname.c, applied upstream.
|
||||
- Auto-sync with upstream master,
|
||||
commit 37e9dc814636915afb88d0779e5e897e90e7b8c0, fixing:
|
||||
- CVE-2017-1000366: Avoid large allocas in the dynamic linker (#1462820)
|
||||
- wait3 namespace (swbz#21625)
|
||||
- S390: Sync ptrace.h with kernel (swbz#21539)
|
||||
- Another x86 sys/ucontext.h namespace issue (swbz#21457)
|
||||
- siginterrupt namespace (swbz#21597)
|
||||
- Signal stack namespace (swbz#21584)
|
||||
- Define struct rusage in sys/wait.h when required (swbz#21575)
|
||||
- S390: Fix build with gcc configured with --enable-default-pie (swbz#21537)
|
||||
- Update timezone code from tzcode 2017b
|
||||
- nptl: Invert the mmap/mprotect logic on allocated stacks (swbz#18988)
|
||||
- PowerPC64 ELFv2 PPC64_OPT_LOCALENTRY
|
||||
- Make copy of <bits/std_abs.h> from GCC (swbz#21573)
|
||||
- localedata: ce_RU: update weekdays from CLDR (swbz#21207)
|
||||
- localedata: Remove trailing spaces (swbz#20275)
|
||||
- XPG4 bsd_signal namespace (swbz#21552)
|
||||
- Correct collation rules for Malayalam (swbz#19922, swbz#19919)
|
||||
- waitid namespace (swbz#21561)
|
||||
- Condition signal.h inclusion in sys/wait.h (swbz#21560)
|
||||
- ld.so: Consolidate 2 strtouls into _dl_strtoul (swbz#21528)
|
||||
- tst-timezone race (swbz#14096)
|
||||
- Define SIG_HOLD for XPG4 (swbz#21538)
|
||||
- struct sigaltstack namespace (swbz#21517)
|
||||
- sigevent namespace (swbz#21543)
|
||||
- Add shim header for bits/syscall.h (swbz#21514)
|
||||
- namespace issues in sys/ucontext.h (swbz#21457)
|
||||
- posix: Implement preadv2 and pwritev2
|
||||
- Various float128 and tunables improvements
|
||||
|
||||
* Tue Jun 06 2017 Stephen Gallagher <sgallagh@redhat.com> - 2.25.90-6
|
||||
- Reduce libcrypt-nss dependency to 'Suggests:'
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (glibc-2.25-378-gcfa9bb6.tar.gz) = e9f602a31e4f62b48ec2f947a8cca0709291b4d9e0fbbcc9e974ad0a004280e554ab42be3949343ac65b29a5ea845e42deaac8b83aedc678c80ac4e3bb7bbcd9
|
||||
SHA512 (glibc-2.25-518-g37e9dc8.tar.gz) = d4f38afaefda493f5229be268ce06fde88bde22d3e266ffe954abe650824e78123631f2263e6bcf0bee050f21a9504cbf07be4b47c40907286fc3e92bc8fb43f
|
||||
|
Loading…
Reference in New Issue
Block a user