- Resync with upstream sources.

This commit is contained in:
Jeff Law 2012-08-30 09:47:02 -06:00
parent df41626e91
commit 7f32dad8b0
4 changed files with 24 additions and 24 deletions

2
.gitignore vendored
View File

@ -38,3 +38,5 @@ glibc-2.14-394-g8f3b1ff
/glibc-2.16.90-42443a47.tar.gz
/glibc-2.16.90-07e51550-fedora.tar.gz
/glibc-2.16.90-07e51550.tar.gz
/glibc-2.16.90-d22e28b0-fedora.tar.gz
/glibc-2.16.90-d22e28b0.tar.gz

View File

@ -12,10 +12,9 @@ Subject: [PATCH] Avoid strict-aliasing issues
sunrpc/Makefile | 4 ++++
sysdeps/powerpc/powerpc64/elf/Makefile | 2 ++
7 files changed, 13 insertions(+), 0 deletions(-)
diff -Nrup a/elf/Makefile b/elf/Makefile
--- a/elf/Makefile 2012-08-13 13:12:18.000000000 -0600
+++ b/elf/Makefile 2012-08-20 13:34:00.070089702 -0600
--- a/elf/Makefile 2012-08-29 07:45:37.000000000 -0600
+++ b/elf/Makefile 2012-08-30 09:42:41.980592920 -0600
@@ -50,6 +50,7 @@ include ../Makeconfig
ifeq ($(unwind-find-fde),yes)
routines += unwind-dw2-fde-glibc
@ -25,8 +24,8 @@ diff -Nrup a/elf/Makefile b/elf/Makefile
before-compile = $(objpfx)trusted-dirs.h
diff -Nrup a/inet/Makefile b/inet/Makefile
--- a/inet/Makefile 2012-08-13 13:12:18.000000000 -0600
+++ b/inet/Makefile 2012-08-20 13:34:00.099089572 -0600
--- a/inet/Makefile 2012-08-29 07:45:37.000000000 -0600
+++ b/inet/Makefile 2012-08-30 09:42:41.981592916 -0600
@@ -54,6 +54,8 @@ tests := htontest test_ifindex tst-ntoa
include ../Rules
@ -35,10 +34,10 @@ diff -Nrup a/inet/Makefile b/inet/Makefile
+
ifeq ($(have-thread-library),yes)
CFLAGS-gethstbyad_r.c = -DUSE_NSCD=1 -fexceptions
CFLAGS-gethstbyad_r.c = -fexceptions
diff -Nrup a/nis/Makefile b/nis/Makefile
--- a/nis/Makefile 2012-08-13 13:12:18.000000000 -0600
+++ b/nis/Makefile 2012-08-20 13:34:01.338084016 -0600
--- a/nis/Makefile 2012-08-29 07:45:37.000000000 -0600
+++ b/nis/Makefile 2012-08-30 09:42:41.982592912 -0600
@@ -71,6 +71,8 @@ libnss_nisplus-inhibit-o = $(filter-out
include ../Rules
@ -49,8 +48,8 @@ diff -Nrup a/nis/Makefile b/nis/Makefile
$(objpfx)libnss_compat.so: $(objpfx)libnsl.so$(libnsl.so-version)
$(objpfx)libnss_nis.so: $(objpfx)libnsl.so$(libnsl.so-version) \
diff -Nrup a/nss/Makefile b/nss/Makefile
--- a/nss/Makefile 2012-08-13 13:12:18.000000000 -0600
+++ b/nss/Makefile 2012-08-20 13:34:01.491083332 -0600
--- a/nss/Makefile 2012-08-29 07:45:37.000000000 -0600
+++ b/nss/Makefile 2012-08-30 09:42:42.021592753 -0600
@@ -101,6 +101,7 @@ $(libnss_db-dbs:%=$(objpfx)%.c): $(objpf
echo '#include "$<"') > $@.new
mv -f $@.new $@
@ -60,8 +59,8 @@ diff -Nrup a/nss/Makefile b/nss/Makefile
$(objpfx)makedb: $(makedb-modules:%=$(objpfx)%.o)
diff -Nrup a/resolv/Makefile b/resolv/Makefile
--- a/resolv/Makefile 2012-08-13 13:12:18.000000000 -0600
+++ b/resolv/Makefile 2012-08-20 13:34:01.492083327 -0600
--- a/resolv/Makefile 2012-08-29 07:45:37.000000000 -0600
+++ b/resolv/Makefile 2012-08-30 09:42:42.023592745 -0600
@@ -80,6 +80,7 @@ ifeq (yes,$(have-ssp))
CFLAGS-libresolv += -fstack-protector
endif
@ -71,8 +70,8 @@ diff -Nrup a/resolv/Makefile b/resolv/Makefile
# The BIND code elicits some harmless warnings.
+cflags += -Wno-strict-prototypes -Wno-write-strings
diff -Nrup a/sunrpc/Makefile b/sunrpc/Makefile
--- a/sunrpc/Makefile 2012-08-13 13:12:18.000000000 -0600
+++ b/sunrpc/Makefile 2012-08-20 13:34:01.495083314 -0600
--- a/sunrpc/Makefile 2012-08-29 07:45:37.000000000 -0600
+++ b/sunrpc/Makefile 2012-08-30 09:42:42.024592741 -0600
@@ -150,6 +150,10 @@ sunrpc-CPPFLAGS = -D_RPC_THREAD_SAFE_
CPPFLAGS += $(sunrpc-CPPFLAGS)
BUILD_CPPFLAGS += $(sunrpc-CPPFLAGS)
@ -85,8 +84,8 @@ diff -Nrup a/sunrpc/Makefile b/sunrpc/Makefile
$(objpfx)tst-xdrmem: $(common-objpfx)linkobj/libc.so
$(objpfx)tst-xdrmem2: $(common-objpfx)linkobj/libc.so
diff -Nrup a/sysdeps/powerpc/powerpc64/Makefile b/sysdeps/powerpc/powerpc64/Makefile
--- a/sysdeps/powerpc/powerpc64/Makefile 2012-08-20 13:33:29.453227506 -0600
+++ b/sysdeps/powerpc/powerpc64/Makefile 2012-08-20 13:34:01.496083309 -0600
--- a/sysdeps/powerpc/powerpc64/Makefile 2012-08-30 09:42:17.872692135 -0600
+++ b/sysdeps/powerpc/powerpc64/Makefile 2012-08-30 09:42:42.024592741 -0600
@@ -37,6 +37,8 @@ CFLAGS-rtld-strnlen.os = $(no-special-re
CFLAGS-libc-start.c += -fno-asynchronous-unwind-tables

View File

@ -1,4 +1,4 @@
%define glibcsrcdir glibc-2.16.90-07e51550
%define glibcsrcdir glibc-2.16.90-d22e28b0
%define glibcversion 2.16.90
### glibc.spec.in follows:
%define run_glibc_tests 1
@ -27,7 +27,7 @@
Summary: The GNU libc libraries
Name: glibc
Version: %{glibcversion}
Release: 6%{?dist}
Release: 7%{?dist}
# GPLv2+ is used in a bunch of programs, LGPLv2+ is used for libraries.
# Things that are linked directly into dynamically linked programs
# and shared libraries (e.g. crt files, lib*_nonshared.a) have an additional
@ -193,9 +193,6 @@ Patch2027: %{name}-rh819430.patch
# See http://sourceware.org/ml/libc-alpha/2012-06/msg00074.html
Patch2028: %{name}-rh767693-2.patch
# Upstream BZ 14459
Patch2030: %{name}-rh847718.patch
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
Obsoletes: glibc-profile < 2.4
Obsoletes: nss_db
@ -445,7 +442,6 @@ package or when debugging this package.
%patch2027 -p1
%patch2028 -p1
%patch0029 -p1
%patch2030 -p1
%patch0031 -p1
%patch0032 -p1
%patch0033 -p1
@ -1347,6 +1343,9 @@ rm -f *.filelist*
%endif
%changelog
* Thu Aug 30 2012 Jeff Law <law@redhat.com> - 2.16.90-7
- Resync with upstream sources.
* Wed Aug 22 2012 Jeff Law <law@redhat.com> - 2.16.90-6
- Resync with upstream sources.

View File

@ -1,2 +1,2 @@
61718ecdef90d014c301a6cbc2062527 glibc-2.16.90-07e51550-fedora.tar.gz
5a2b32d28a10adb244018cefed23d849 glibc-2.16.90-07e51550.tar.gz
f81342d0a3e556572bbc17531d2cb145 glibc-2.16.90-d22e28b0-fedora.tar.gz
871bb4d23e5eb725bee350632a033bee glibc-2.16.90-d22e28b0.tar.gz