auto-import changelog data from glibc-2.3.3-29.src.rpm
Thu May 20 2004 Jakub Jelinek <jakub@redhat.com> 2.3.3-29 - use lib64 instead of lib on ia64 if %{_lib} is defined to lib64
This commit is contained in:
parent
b335e4b243
commit
7cbfe8c1d2
92
glibc-ia64-lib64.patch
Normal file
92
glibc-ia64-lib64.patch
Normal file
@ -0,0 +1,92 @@
|
|||||||
|
2004-05-14 Jakub Jelinek <jakub@redhat.com>
|
||||||
|
|
||||||
|
* sysdeps/unix/sysv/linux/configure.in: Use */lib64 even for ia64.
|
||||||
|
* sysdeps/unix/sysv/linux/configure: Rebuilt.
|
||||||
|
* sysdeps/unix/sysv/linux/ia64/dl-procinfo.c: New file.
|
||||||
|
* sysdeps/unix/sysv/linux/ia64/dl-procinfo.h: New file.
|
||||||
|
* sysdeps/unix/sysv/linux/ia64/ldd-rewrite.sed: Change /lib64/ld*
|
||||||
|
into /lib/ld*. Add LD_LIBRARY_VERSION.
|
||||||
|
* sysdeps/unix/sysv/linux/ia64/ldconfig.h
|
||||||
|
(SYSDEP_KNOWN_INTERPRETER_NAMES): Add /lib64/ld-linux-ia64.so.2.
|
||||||
|
* sysdeps/unix/sysv/linux/ia64/dl-cache.h: Include sparc-linux
|
||||||
|
dl-cache.h instead of generic dl-cache.h.
|
||||||
|
|
||||||
|
--- libc/sysdeps/unix/sysv/linux/configure.jj 2003-03-23 03:10:04.000000000 +0100
|
||||||
|
+++ libc/sysdeps/unix/sysv/linux/configure 2004-05-14 15:54:35.669802684 +0200
|
||||||
|
@@ -225,7 +225,7 @@ case "$prefix" in
|
||||||
|
# 64-bit libraries on bi-arch platforms go in /lib64 instead of /lib
|
||||||
|
case $machine in
|
||||||
|
sparc/sparc64 | x86_64 | powerpc/powerpc64 | s390/s390-64 | \
|
||||||
|
- mips/mips64/n64/* )
|
||||||
|
+ mips/mips64/n64/* | ia64 )
|
||||||
|
libc_cv_slibdir="/lib64"
|
||||||
|
if test "$libdir" = '${exec_prefix}/lib'; then
|
||||||
|
libdir='${exec_prefix}/lib64';
|
||||||
|
--- libc/sysdeps/unix/sysv/linux/configure.in.jj 2003-03-23 03:10:04.000000000 +0100
|
||||||
|
+++ libc/sysdeps/unix/sysv/linux/configure.in 2004-05-14 15:53:44.355998785 +0200
|
||||||
|
@@ -158,7 +158,7 @@ case "$prefix" in
|
||||||
|
# 64-bit libraries on bi-arch platforms go in /lib64 instead of /lib
|
||||||
|
case $machine in
|
||||||
|
sparc/sparc64 | x86_64 | powerpc/powerpc64 | s390/s390-64 | \
|
||||||
|
- mips/mips64/n64/* )
|
||||||
|
+ mips/mips64/n64/* | ia64 )
|
||||||
|
libc_cv_slibdir="/lib64"
|
||||||
|
if test "$libdir" = '${exec_prefix}/lib'; then
|
||||||
|
libdir='${exec_prefix}/lib64';
|
||||||
|
--- libc/sysdeps/unix/sysv/linux/ia64/dl-procinfo.c.jj 2004-05-14 15:42:09.307560515 +0200
|
||||||
|
+++ libc/sysdeps/unix/sysv/linux/ia64/dl-procinfo.c 2003-09-30 00:23:24.000000000 +0200
|
||||||
|
@@ -0,0 +1,5 @@
|
||||||
|
+#ifdef IS_IN_ldconfig
|
||||||
|
+#include <sysdeps/i386/dl-procinfo.c>
|
||||||
|
+#else
|
||||||
|
+#include <sysdeps/generic/dl-procinfo.c>
|
||||||
|
+#endif
|
||||||
|
--- libc/sysdeps/unix/sysv/linux/ia64/ldd-rewrite.sed.jj 2002-01-17 07:49:28.000000000 +0100
|
||||||
|
+++ libc/sysdeps/unix/sysv/linux/ia64/ldd-rewrite.sed 2004-05-14 16:21:03.041325040 +0200
|
||||||
|
@@ -1 +1,4 @@
|
||||||
|
-s_^\(RTLDLIST=\)\([^ ]*\)-ia64\(\.so\.[0-9.]*\)[ ]*$_\1"\2-ia64\3 \2\3"_
|
||||||
|
+/LD_TRACE_LOADED_OBJECTS=1/a\
|
||||||
|
+add_env="$add_env LD_LIBRARY_VERSION=\\$verify_out"
|
||||||
|
+s_^\(RTLDLIST=\)/lib64/ld\([^ ]*\)-ia64\(\.so\.[0-9.]*\)[ ]*$_\1"/lib/ld\2-ia64\3 /lib/ld\2\3"_
|
||||||
|
+s_^\(RTLDLIST=\)\([^"][^ ]*\)-ia64\(\.so\.[0-9.]*\)[ ]*$_\1"\2-ia64\3 \2\3"_
|
||||||
|
--- libc/sysdeps/unix/sysv/linux/ia64/ldconfig.h.jj 2001-07-06 06:56:17.000000000 +0200
|
||||||
|
+++ libc/sysdeps/unix/sysv/linux/ia64/ldconfig.h 2004-05-14 15:45:40.103783087 +0200
|
||||||
|
@@ -1,4 +1,4 @@
|
||||||
|
-/* Copyright (C) 2001 Free Software Foundation, Inc.
|
||||||
|
+/* Copyright (C) 2001, 2004 Free Software Foundation, Inc.
|
||||||
|
This file is part of the GNU C Library.
|
||||||
|
|
||||||
|
The GNU C Library is free software; you can redistribute it and/or
|
||||||
|
@@ -19,7 +19,8 @@
|
||||||
|
#include <sysdeps/generic/ldconfig.h>
|
||||||
|
|
||||||
|
#define SYSDEP_KNOWN_INTERPRETER_NAMES \
|
||||||
|
- { "/lib/ld-linux.so.2", FLAG_ELF_LIBC6 },
|
||||||
|
+ { "/lib/ld-linux.so.2", FLAG_ELF_LIBC6 }, \
|
||||||
|
+ { "/lib64/ld-linux-ia64.so.2", FLAG_ELF_LIBC6 },
|
||||||
|
#define SYSDEP_KNOWN_LIBRARY_NAMES \
|
||||||
|
{ "libc.so.6", FLAG_ELF_LIBC6 }, \
|
||||||
|
{ "libm.so.6", FLAG_ELF_LIBC6 },
|
||||||
|
--- libc/sysdeps/unix/sysv/linux/ia64/dl-cache.h.jj 2001-07-06 06:56:17.000000000 +0200
|
||||||
|
+++ libc/sysdeps/unix/sysv/linux/ia64/dl-cache.h 2004-05-14 15:41:11.658891907 +0200
|
||||||
|
@@ -1,5 +1,5 @@
|
||||||
|
/* Support for reading /etc/ld.so.cache files written by Linux ldconfig.
|
||||||
|
- Copyright (C) 2000 Free Software Foundation, Inc.
|
||||||
|
+ Copyright (C) 2000, 2004 Free Software Foundation, Inc.
|
||||||
|
This file is part of the GNU C Library.
|
||||||
|
|
||||||
|
The GNU C Library is free software; you can redistribute it and/or
|
||||||
|
@@ -22,4 +22,4 @@
|
||||||
|
#define _dl_cache_check_flags(flags) \
|
||||||
|
((flags) == _DL_CACHE_DEFAULT_ID)
|
||||||
|
|
||||||
|
-#include_next <dl-cache.h>
|
||||||
|
+#include <sysdeps/unix/sysv/linux/sparc/dl-cache.h>
|
||||||
|
--- libc/sysdeps/unix/sysv/linux/ia64/dl-procinfo.h.jj 2004-05-14 15:42:13.018895395 +0200
|
||||||
|
+++ libc/sysdeps/unix/sysv/linux/ia64/dl-procinfo.h 2003-07-23 00:06:23.000000000 +0200
|
||||||
|
@@ -0,0 +1,5 @@
|
||||||
|
+#ifdef IS_IN_ldconfig
|
||||||
|
+#include <sysdeps/unix/sysv/linux/i386/dl-procinfo.h>
|
||||||
|
+#else
|
||||||
|
+#include <sysdeps/generic/dl-procinfo.h>
|
||||||
|
+#endif
|
24
glibc.spec
24
glibc.spec
@ -1,4 +1,4 @@
|
|||||||
%define glibcrelease 28
|
%define glibcrelease 29
|
||||||
%define auxarches i586 i686 athlon sparcv9 alphaev6
|
%define auxarches i586 i686 athlon sparcv9 alphaev6
|
||||||
%define prelinkarches noarch
|
%define prelinkarches noarch
|
||||||
%define nptlarches i686 athlon x86_64 ia64 s390 s390x sparcv9 ppc ppc64
|
%define nptlarches i686 athlon x86_64 ia64 s390 s390x sparcv9 ppc ppc64
|
||||||
@ -19,6 +19,7 @@ Patch0: %{name}-redhat.patch
|
|||||||
Patch1: %{name}-nptl-check.patch
|
Patch1: %{name}-nptl-check.patch
|
||||||
Patch2: %{name}-ppc-assume.patch
|
Patch2: %{name}-ppc-assume.patch
|
||||||
Patch3: %{name}-execstack-disable.patch
|
Patch3: %{name}-execstack-disable.patch
|
||||||
|
Patch4: %{name}-ia64-lib64.patch
|
||||||
Buildroot: %{_tmppath}/glibc-%{PACKAGE_VERSION}-root
|
Buildroot: %{_tmppath}/glibc-%{PACKAGE_VERSION}-root
|
||||||
Obsoletes: zoneinfo, libc-static, libc-devel, libc-profile, libc-headers,
|
Obsoletes: zoneinfo, libc-static, libc-devel, libc-profile, libc-headers,
|
||||||
Obsoletes: linuxthreads, gencat, locale, ldconfig, locale-ja
|
Obsoletes: linuxthreads, gencat, locale, ldconfig, locale-ja
|
||||||
@ -250,6 +251,11 @@ gcc*\ 3.2.3*)
|
|||||||
%patch3 -p1
|
%patch3 -p1
|
||||||
;; esac ;;
|
;; esac ;;
|
||||||
esac
|
esac
|
||||||
|
%ifarch ia64
|
||||||
|
%if "%{_lib}" == "lib64"
|
||||||
|
%patch4 -p1
|
||||||
|
%endif
|
||||||
|
%endif
|
||||||
|
|
||||||
# Hack till glibc-kernheaders get updated, argh
|
# Hack till glibc-kernheaders get updated, argh
|
||||||
mkdir asm
|
mkdir asm
|
||||||
@ -889,6 +895,13 @@ gzip -9n documentation/ChangeLog*
|
|||||||
mkdir -p $RPM_BUILD_ROOT/lib
|
mkdir -p $RPM_BUILD_ROOT/lib
|
||||||
ln -sf /%{_lib}/ld64.so.1 $RPM_BUILD_ROOT/lib/ld64.so.1
|
ln -sf /%{_lib}/ld64.so.1 $RPM_BUILD_ROOT/lib/ld64.so.1
|
||||||
%endif
|
%endif
|
||||||
|
%ifarch ia64
|
||||||
|
%if "%{_lib}" == "lib64"
|
||||||
|
# Compatibility symlink
|
||||||
|
mkdir -p $RPM_BUILD_ROOT/lib
|
||||||
|
ln -sf /%{_lib}/ld-linux-ia64.so.2 $RPM_BUILD_ROOT/lib/ld-linux-ia64.so.2
|
||||||
|
%endif
|
||||||
|
%endif
|
||||||
|
|
||||||
# Increase timeouts
|
# Increase timeouts
|
||||||
perl -pi -e 's/alarm \(TIMEOUT\)/alarm (TIMEOUT * 15 * '$numprocs' < 600 ? TIMEOUT * 15 * '$numprocs' : 600)/' \
|
perl -pi -e 's/alarm \(TIMEOUT\)/alarm (TIMEOUT * 15 * '$numprocs' < 600 ? TIMEOUT * 15 * '$numprocs' : 600)/' \
|
||||||
@ -1138,6 +1151,12 @@ rm -f *.filelist*
|
|||||||
%dir /lib
|
%dir /lib
|
||||||
/lib/ld64.so.1
|
/lib/ld64.so.1
|
||||||
%endif
|
%endif
|
||||||
|
%ifarch ia64
|
||||||
|
%if "%{_lib}" == "lib64"
|
||||||
|
%dir /lib
|
||||||
|
/lib/ld-linux-ia64.so.2
|
||||||
|
%endif
|
||||||
|
%endif
|
||||||
%verify(not md5 size mtime) %config(noreplace) /etc/localtime
|
%verify(not md5 size mtime) %config(noreplace) /etc/localtime
|
||||||
%verify(not md5 size mtime) %config(noreplace) /etc/nsswitch.conf
|
%verify(not md5 size mtime) %config(noreplace) /etc/nsswitch.conf
|
||||||
%verify(not md5 size mtime) %config(noreplace) /etc/ld.so.conf
|
%verify(not md5 size mtime) %config(noreplace) /etc/ld.so.conf
|
||||||
@ -1200,6 +1219,9 @@ rm -f *.filelist*
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu May 20 2004 Jakub Jelinek <jakub@redhat.com> 2.3.3-29
|
||||||
|
- use lib64 instead of lib on ia64 if %%{_lib} is defined to lib64
|
||||||
|
|
||||||
* Wed May 19 2004 Jakub Jelinek <jakub@redhat.com> 2.3.3-28
|
* Wed May 19 2004 Jakub Jelinek <jakub@redhat.com> 2.3.3-28
|
||||||
- update from CVS
|
- update from CVS
|
||||||
- FUTEX_REQUEUE fixes (#115349)
|
- FUTEX_REQUEUE fixes (#115349)
|
||||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
|||||||
7150ae0b37ccf073578042439a3743cb glibc-2.3.3-200405190641.tar.bz2
|
c42954fc4781aba8f06173d16a44f177 glibc-2.3.3-200405190641.tar.bz2
|
||||||
e096b8747b7de5763feef13ceb59eb44 glibc-redhat-200405190641.tar.bz2
|
8ce365b84504c105551ba5f5835e1d63 glibc-redhat-200405190641.tar.bz2
|
||||||
|
Loading…
Reference in New Issue
Block a user