2.10.90-17

This commit is contained in:
roland 2009-08-27 21:02:58 +00:00
parent b47019aa11
commit 79e4f027f9
5 changed files with 87 additions and 84 deletions

View File

@ -1,2 +1,2 @@
glibc-2.10-312-g2df4be8-fedora.tar.bz2
glibc-2.10-312-g2df4be8.tar.bz2
glibc-2.10-312-g2df4be8-fedora.tar.bz2

View File

@ -1,5 +1,5 @@
--- glibc-2.10-312-g2df4be8/ChangeLog
+++ glibc-2.10.90-15/ChangeLog
+++ glibc-2.10.90-17/ChangeLog
@@ -497,6 +497,11 @@
* sysdeps/generic/ldsodefs.h (struct rtld_global): The map element in
the unique symbol hash table should not be const.
@ -66,7 +66,7 @@
[BZ #3632]
--- glibc-2.10-312-g2df4be8/ChangeLog.15
+++ glibc-2.10.90-15/ChangeLog.15
+++ glibc-2.10.90-17/ChangeLog.15
@@ -477,6 +477,14 @@
2004-11-26 Jakub Jelinek <jakub@redhat.com>
@ -133,7 +133,7 @@
* scripts/extract-abilist.awk: If `lastversion' variable defined, omit
--- glibc-2.10-312-g2df4be8/ChangeLog.16
+++ glibc-2.10.90-15/ChangeLog.16
+++ glibc-2.10.90-17/ChangeLog.16
@@ -171,6 +171,11 @@
[BZ #2611]
* stdio-common/renameat.c (renameat): Fix typo.
@ -306,7 +306,7 @@
[BZ #157]
--- glibc-2.10-312-g2df4be8/Makeconfig
+++ glibc-2.10.90-15/Makeconfig
+++ glibc-2.10.90-17/Makeconfig
@@ -780,12 +780,12 @@ endif
# The assembler can generate debug information too.
ifndef ASFLAGS
@ -324,7 +324,7 @@
ifndef BUILD_CC
BUILD_CC = $(CC)
--- glibc-2.10-312-g2df4be8/csu/Makefile
+++ glibc-2.10.90-15/csu/Makefile
+++ glibc-2.10.90-17/csu/Makefile
@@ -93,7 +93,8 @@ omit-deps += $(crtstuff)
$(crtstuff:%=$(objpfx)%.o): %.o: %.S $(objpfx)defs.h
$(compile.S) -g0 $(ASFLAGS-.os) -o $@
@ -336,8 +336,8 @@
vpath initfini.c $(sysdirs)
--- glibc-2.10-312-g2df4be8/csu/elf-init.c
+++ glibc-2.10.90-15/csu/elf-init.c
@@ -63,6 +63,23 @@ extern void (*__init_array_end []) (int, char **, char **)
+++ glibc-2.10.90-17/csu/elf-init.c
@@ -63,6 +63,23 @@ extern void (*__init_array_end []) (int,
extern void (*__fini_array_start []) (void) attribute_hidden;
extern void (*__fini_array_end []) (void) attribute_hidden;
@ -362,7 +362,7 @@
/* These function symbols are provided for the .init/.fini section entry
points automagically by the linker. */
--- glibc-2.10-312-g2df4be8/debug/tst-chk1.c
+++ glibc-2.10.90-15/debug/tst-chk1.c
+++ glibc-2.10.90-17/debug/tst-chk1.c
@@ -17,6 +17,9 @@
Software Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
02111-1307 USA. */
@ -392,7 +392,7 @@
# else
# define O 1
--- glibc-2.10-312-g2df4be8/elf/ldconfig.c
+++ glibc-2.10.90-15/elf/ldconfig.c
+++ glibc-2.10.90-17/elf/ldconfig.c
@@ -1020,17 +1020,19 @@ search_dirs (void)
@ -415,7 +415,7 @@
if (do_chroot && opt_chroot)
{
@@ -1091,7 +1093,14 @@ parse_conf (const char *filename, bool do_chroot)
@@ -1091,7 +1093,14 @@ parse_conf (const char *filename, bool d
cp += 8;
while ((dir = strsep (&cp, " \t")) != NULL)
if (dir[0] != '\0')
@ -431,7 +431,7 @@
}
else if (!strncasecmp (cp, "hwcap", 5) && isblank (cp[5]))
{
@@ -1154,7 +1163,7 @@ parse_conf (const char *filename, bool do_chroot)
@@ -1154,7 +1163,7 @@ parse_conf (const char *filename, bool d
config files to read. */
static void
parse_conf_include (const char *config_file, unsigned int lineno,
@ -440,7 +440,7 @@
{
if (opt_chroot && pattern[0] != '/')
error (EXIT_FAILURE, 0,
@@ -1184,7 +1193,7 @@ parse_conf_include (const char *config_file, unsigned int lineno,
@@ -1184,7 +1193,7 @@ parse_conf_include (const char *config_f
{
case 0:
for (size_t i = 0; i < gl.gl_pathc; ++i)
@ -475,7 +475,7 @@
if (! opt_ignore_aux_cache)
--- glibc-2.10-312-g2df4be8/elf/tst-stackguard1.c
+++ glibc-2.10.90-15/elf/tst-stackguard1.c
+++ glibc-2.10.90-17/elf/tst-stackguard1.c
@@ -160,17 +160,21 @@ do_test (void)
the 16 runs, something is very wrong. */
int ndifferences = 0;
@ -501,15 +501,15 @@
puts ("stack guard canaries are not randomized enough");
puts ("nor equal to the default canary value");
--- glibc-2.10-312-g2df4be8/include/bits/stdlib-ldbl.h
+++ glibc-2.10.90-15/include/bits/stdlib-ldbl.h
+++ glibc-2.10.90-17/include/bits/stdlib-ldbl.h
@@ -0,0 +1 @@
+#include <stdlib/bits/stdlib-ldbl.h>
--- glibc-2.10-312-g2df4be8/include/bits/wchar-ldbl.h
+++ glibc-2.10.90-15/include/bits/wchar-ldbl.h
+++ glibc-2.10.90-17/include/bits/wchar-ldbl.h
@@ -0,0 +1 @@
+#include <wcsmbs/bits/wchar-ldbl.h>
--- glibc-2.10-312-g2df4be8/include/features.h
+++ glibc-2.10.90-15/include/features.h
+++ glibc-2.10.90-17/include/features.h
@@ -299,8 +299,13 @@
#endif
@ -527,7 +527,7 @@
# else
# define __USE_FORTIFY_LEVEL 1
--- glibc-2.10-312-g2df4be8/intl/locale.alias
+++ glibc-2.10.90-15/intl/locale.alias
+++ glibc-2.10.90-17/intl/locale.alias
@@ -57,8 +57,6 @@ korean ko_KR.eucKR
korean.euc ko_KR.eucKR
ko_KR ko_KR.eucKR
@ -538,7 +538,7 @@
nynorsk nn_NO.ISO-8859-1
polish pl_PL.ISO-8859-2
--- glibc-2.10-312-g2df4be8/libio/stdio.h
+++ glibc-2.10.90-15/libio/stdio.h
+++ glibc-2.10.90-17/libio/stdio.h
@@ -145,10 +145,12 @@ typedef _G_fpos64_t fpos64_t;
extern struct _IO_FILE *stdin; /* Standard input stream. */
extern struct _IO_FILE *stdout; /* Standard output stream. */
@ -553,7 +553,7 @@
__BEGIN_NAMESPACE_STD
/* Remove file FILENAME. */
--- glibc-2.10-312-g2df4be8/locale/iso-4217.def
+++ glibc-2.10.90-15/locale/iso-4217.def
+++ glibc-2.10.90-17/locale/iso-4217.def
@@ -8,6 +8,7 @@
*
* !!! The list has to be sorted !!!
@ -562,7 +562,7 @@
DEFINE_INT_CURR("AED") /* United Arab Emirates Dirham */
DEFINE_INT_CURR("AFN") /* Afghanistan Afgani */
DEFINE_INT_CURR("ALL") /* Albanian Lek */
@@ -15,12 +16,14 @@ DEFINE_INT_CURR("AMD") /* Armenia Dram */
@@ -15,12 +16,14 @@ DEFINE_INT_CURR("AMD") /* Armenia Dram
DEFINE_INT_CURR("ANG") /* Netherlands Antilles */
DEFINE_INT_CURR("AOA") /* Angolan Kwanza */
DEFINE_INT_CURR("ARS") /* Argentine Peso */
@ -577,7 +577,7 @@
DEFINE_INT_CURR("BGN") /* Bulgarian Lev */
DEFINE_INT_CURR("BHD") /* Bahraini Dinar */
DEFINE_INT_CURR("BIF") /* Burundi Franc */
@@ -44,6 +47,7 @@ DEFINE_INT_CURR("CUP") /* Cuban Peso */
@@ -44,6 +47,7 @@ DEFINE_INT_CURR("CUP") /* Cuban Peso *
DEFINE_INT_CURR("CVE") /* Cape Verde Escudo */
DEFINE_INT_CURR("CYP") /* Cypriot Pound */
DEFINE_INT_CURR("CZK") /* Czech Koruna */
@ -585,7 +585,7 @@
DEFINE_INT_CURR("DJF") /* Djibouti Franc */
DEFINE_INT_CURR("DKK") /* Danish Krone (Faroe Islands, Greenland) */
DEFINE_INT_CURR("DOP") /* Dominican Republic */
@@ -51,16 +55,20 @@ DEFINE_INT_CURR("DZD") /* Algerian Dinar */
@@ -51,16 +55,20 @@ DEFINE_INT_CURR("DZD") /* Algerian Dina
DEFINE_INT_CURR("EEK") /* Estonian Kroon */
DEFINE_INT_CURR("EGP") /* Egyptian Pound */
DEFINE_INT_CURR("ERN") /* Eritrean Nakfa */
@ -606,7 +606,7 @@
DEFINE_INT_CURR("GTQ") /* Guatemala Quetzal */
DEFINE_INT_CURR("GYD") /* Guyana Dollar */
DEFINE_INT_CURR("HKD") /* Hong Kong Dollar */
@@ -69,12 +77,14 @@ DEFINE_INT_CURR("HRK") /* Croatia Kuna */
@@ -69,12 +77,14 @@ DEFINE_INT_CURR("HRK") /* Croatia Kuna
DEFINE_INT_CURR("HTG") /* Haiti Gourde */
DEFINE_INT_CURR("HUF") /* Hungarian Forint */
DEFINE_INT_CURR("IDR") /* Indonesia Rupiah */
@ -621,7 +621,7 @@
DEFINE_INT_CURR("JEP") /* Jersey Pound */
DEFINE_INT_CURR("JMD") /* Jamaican Dollar */
DEFINE_INT_CURR("JOD") /* Jordanian Dinar */
@@ -94,6 +104,7 @@ DEFINE_INT_CURR("LKR") /* Sri Lankan Rupee */
@@ -94,6 +104,7 @@ DEFINE_INT_CURR("LKR") /* Sri Lankan Ru
DEFINE_INT_CURR("LRD") /* Liberian Dollar */
DEFINE_INT_CURR("LSL") /* Lesotho Maloti */
DEFINE_INT_CURR("LTL") /* Lithuanian Litas */
@ -629,7 +629,7 @@
DEFINE_INT_CURR("LVL") /* Latvia Lat */
DEFINE_INT_CURR("LYD") /* Libyan Arab Jamahiriya Dinar */
DEFINE_INT_CURR("MAD") /* Moroccan Dirham */
@@ -114,6 +125,7 @@ DEFINE_INT_CURR("MZM") /* Mozambique Metical */
@@ -114,6 +125,7 @@ DEFINE_INT_CURR("MZM") /* Mozambique Me
DEFINE_INT_CURR("NAD") /* Namibia Dollar */
DEFINE_INT_CURR("NGN") /* Nigeria Naira */
DEFINE_INT_CURR("NIO") /* Nicaragua Cordoba Oro */
@ -637,7 +637,7 @@
DEFINE_INT_CURR("NOK") /* Norwegian Krone */
DEFINE_INT_CURR("NPR") /* Nepalese Rupee */
DEFINE_INT_CURR("NZD") /* New Zealand Dollar */
@@ -124,6 +136,7 @@ DEFINE_INT_CURR("PGK") /* Papau New Guinea Kina */
@@ -124,6 +136,7 @@ DEFINE_INT_CURR("PGK") /* Papau New Gui
DEFINE_INT_CURR("PHP") /* Philippines Peso */
DEFINE_INT_CURR("PKR") /* Pakistan Rupee */
DEFINE_INT_CURR("PLN") /* Polish Zloty */
@ -646,8 +646,8 @@
DEFINE_INT_CURR("QAR") /* Qatar Rial */
DEFINE_INT_CURR("ROL") /* Romanian Leu */
--- glibc-2.10-312-g2df4be8/locale/programs/locarchive.c
+++ glibc-2.10.90-15/locale/programs/locarchive.c
@@ -241,9 +241,9 @@ oldlocrecentcmp (const void *a, const void *b)
+++ glibc-2.10.90-17/locale/programs/locarchive.c
@@ -241,9 +241,9 @@ oldlocrecentcmp (const void *a, const vo
/* forward decls for below */
static uint32_t add_locale (struct locarhandle *ah, const char *name,
locale_data_t data, bool replace);
@ -679,8 +679,8 @@
const char *oldname, uint32_t *locrec_offset_p)
{
--- glibc-2.10-312-g2df4be8/localedata/Makefile
+++ glibc-2.10.90-15/localedata/Makefile
@@ -225,6 +225,7 @@ $(INSTALL-SUPPORTED-LOCALES): install-locales-dir
+++ glibc-2.10.90-17/localedata/Makefile
@@ -225,6 +225,7 @@ $(INSTALL-SUPPORTED-LOCALES): install-lo
echo -n '...'; \
input=`echo $$locale | sed 's/\([^.]*\)[^@]*\(.*\)/\1\2/'`; \
$(LOCALEDEF) --alias-file=../intl/locale.alias \
@ -689,7 +689,7 @@
$(addprefix --prefix=,$(install_root)) $$locale; \
echo ' done'; \
--- glibc-2.10-312-g2df4be8/localedata/SUPPORTED
+++ glibc-2.10.90-15/localedata/SUPPORTED
+++ glibc-2.10.90-17/localedata/SUPPORTED
@@ -84,6 +84,7 @@ cy_GB.UTF-8/UTF-8 \
cy_GB/ISO-8859-14 \
da_DK.UTF-8/UTF-8 \
@ -732,8 +732,8 @@
te_IN/UTF-8 \
tg_TJ.UTF-8/UTF-8 \
--- glibc-2.10-312-g2df4be8/localedata/locales/cy_GB
+++ glibc-2.10.90-15/localedata/locales/cy_GB
@@ -248,8 +248,11 @@ mon "<U0049><U006F><U006E><U0061><U0077><U0072>";/
+++ glibc-2.10.90-17/localedata/locales/cy_GB
@@ -248,8 +248,11 @@ mon "<U0049><U006F><U006E><U0061
d_t_fmt "<U0044><U0079><U0064><U0064><U0020><U0025><U0041><U0020><U0025><U0064><U0020><U006d><U0069><U0073><U0020><U0025><U0042><U0020><U0025><U0059><U0020><U0025><U0054><U0020><U0025><U005A>"
d_fmt "<U0025><U0064><U002E><U0025><U006D><U002E><U0025><U0079>"
t_fmt "<U0025><U0054>"
@ -748,8 +748,8 @@
LC_MESSAGES
--- glibc-2.10-312-g2df4be8/localedata/locales/en_GB
+++ glibc-2.10.90-15/localedata/locales/en_GB
@@ -116,8 +116,8 @@ mon "<U004A><U0061><U006E><U0075><U0061><U0072><U0079>";/
+++ glibc-2.10.90-17/localedata/locales/en_GB
@@ -116,8 +116,8 @@ mon "<U004A><U0061><U006E><U0075
d_t_fmt "<U0025><U0061><U0020><U0025><U0064><U0020><U0025><U0062><U0020><U0025><U0059><U0020><U0025><U0054><U0020><U0025><U005A>"
d_fmt "<U0025><U0064><U002F><U0025><U006D><U002F><U0025><U0079>"
t_fmt "<U0025><U0054>"
@ -761,7 +761,7 @@
<U0020><U0025><U0048><U003A><U0025><U004D><U003A><U0025><U0053><U0020>/
<U0025><U005A><U0020><U0025><U0059>"
--- glibc-2.10-312-g2df4be8/localedata/locales/no_NO
+++ glibc-2.10.90-15/localedata/locales/no_NO
+++ glibc-2.10.90-17/localedata/locales/no_NO
@@ -0,0 +1,69 @@
+escape_char /
+comment_char %
@ -833,7 +833,7 @@
+copy "nb_NO"
+END LC_ADDRESS
--- glibc-2.10-312-g2df4be8/localedata/locales/zh_TW
+++ glibc-2.10.90-15/localedata/locales/zh_TW
+++ glibc-2.10.90-17/localedata/locales/zh_TW
@@ -1,7 +1,7 @@
comment_char %
escape_char /
@ -862,7 +862,7 @@
date "2000-08-02"
%
--- glibc-2.10-312-g2df4be8/malloc/mcheck.c
+++ glibc-2.10.90-15/malloc/mcheck.c
+++ glibc-2.10.90-17/malloc/mcheck.c
@@ -24,9 +24,25 @@
# include <mcheck.h>
# include <stdint.h>
@ -889,7 +889,7 @@
/* Old hook values. */
static void (*old_free_hook) (__ptr_t ptr, __const __ptr_t);
static __ptr_t (*old_malloc_hook) (__malloc_size_t size, const __ptr_t);
@@ -197,7 +213,7 @@ freehook (__ptr_t ptr, const __ptr_t caller)
@@ -197,7 +213,7 @@ freehook (__ptr_t ptr, const __ptr_t cal
if (old_free_hook != NULL)
(*old_free_hook) (ptr, caller);
else
@ -898,7 +898,7 @@
__free_hook = freehook;
}
@@ -214,7 +230,7 @@ mallochook (__malloc_size_t size, const __ptr_t caller)
@@ -214,7 +230,7 @@ mallochook (__malloc_size_t size, const
hdr = (struct hdr *) (*old_malloc_hook) (sizeof (struct hdr) + size + 1,
caller);
else
@ -907,7 +907,7 @@
__malloc_hook = mallochook;
if (hdr == NULL)
return NULL;
@@ -245,7 +261,7 @@ memalignhook (__malloc_size_t alignment, __malloc_size_t size,
@@ -245,7 +261,7 @@ memalignhook (__malloc_size_t alignment,
if (old_memalign_hook != NULL)
block = (*old_memalign_hook) (alignment, slop + size + 1, caller);
else
@ -916,7 +916,7 @@
__memalign_hook = memalignhook;
if (block == NULL)
return NULL;
@@ -300,8 +316,8 @@ reallochook (__ptr_t ptr, __malloc_size_t size, const __ptr_t caller)
@@ -300,8 +316,8 @@ reallochook (__ptr_t ptr, __malloc_size_
sizeof (struct hdr) + size + 1,
caller);
else
@ -939,7 +939,7 @@
old_free_hook = __free_hook;
__free_hook = freehook;
--- glibc-2.10-312-g2df4be8/manual/libc.texinfo
+++ glibc-2.10.90-15/manual/libc.texinfo
+++ glibc-2.10.90-17/manual/libc.texinfo
@@ -5,7 +5,7 @@
@c setchapternewpage odd
@ -950,7 +950,7 @@
* Libc: (libc). C library.
@end direntry
--- glibc-2.10-312-g2df4be8/misc/sys/cdefs.h
+++ glibc-2.10.90-15/misc/sys/cdefs.h
+++ glibc-2.10.90-17/misc/sys/cdefs.h
@@ -132,7 +132,10 @@
#define __bos(ptr) __builtin_object_size (ptr, __USE_FORTIFY_LEVEL > 1)
#define __bos0(ptr) __builtin_object_size (ptr, 0)
@ -995,7 +995,7 @@
# define __va_arg_pack_len() __builtin_va_arg_pack_len ()
#endif
--- glibc-2.10-312-g2df4be8/nis/nss
+++ glibc-2.10.90-15/nis/nss
+++ glibc-2.10.90-17/nis/nss
@@ -25,4 +25,4 @@
# memory with every getXXent() call. Otherwise each getXXent() call
# might result into a network communication with the server to get
@ -1003,7 +1003,7 @@
-#SETENT_BATCH_READ=TRUE
+SETENT_BATCH_READ=TRUE
--- glibc-2.10-312-g2df4be8/nptl/ChangeLog
+++ glibc-2.10.90-15/nptl/ChangeLog
+++ glibc-2.10.90-17/nptl/ChangeLog
@@ -3700,6 +3700,15 @@
Use __sigfillset. Document that sigfillset does the right thing wrt
to SIGSETXID.
@ -1045,7 +1045,7 @@
* tst-cancel17.c (do_test): Check if aio_cancel failed.
--- glibc-2.10-312-g2df4be8/nptl/Makefile
+++ glibc-2.10.90-15/nptl/Makefile
+++ glibc-2.10.90-17/nptl/Makefile
@@ -339,7 +339,8 @@ endif
extra-objs += $(crti-objs) $(crtn-objs)
omit-deps += crti crtn
@ -1079,7 +1079,7 @@
$(addprefix $(objpfx),$(tests) $(test-srcs)): $(objpfx)libpthread.a
endif
--- glibc-2.10-312-g2df4be8/nptl/sysdeps/unix/sysv/linux/bits/posix_opt.h
+++ glibc-2.10.90-15/nptl/sysdeps/unix/sysv/linux/bits/posix_opt.h
+++ glibc-2.10.90-17/nptl/sysdeps/unix/sysv/linux/bits/posix_opt.h
@@ -189,4 +189,7 @@
/* Typed memory objects are not available. */
#define _POSIX_TYPED_MEMORY_OBJECTS -1
@ -1089,7 +1089,7 @@
+
#endif /* bits/posix_opt.h */
--- glibc-2.10-312-g2df4be8/nptl/sysdeps/unix/sysv/linux/kernel-features.h
+++ glibc-2.10.90-15/nptl/sysdeps/unix/sysv/linux/kernel-features.h
+++ glibc-2.10.90-17/nptl/sysdeps/unix/sysv/linux/kernel-features.h
@@ -0,0 +1,6 @@
+#include_next <kernel-features.h>
+
@ -1098,7 +1098,7 @@
+# define __ASSUME_CLONE_THREAD_FLAGS 1
+#endif
--- glibc-2.10-312-g2df4be8/nptl/tst-stackguard1.c
+++ glibc-2.10.90-15/nptl/tst-stackguard1.c
+++ glibc-2.10.90-17/nptl/tst-stackguard1.c
@@ -190,17 +190,21 @@ do_test (void)
the 16 runs, something is very wrong. */
int ndifferences = 0;
@ -1124,7 +1124,7 @@
puts ("stack guard canaries are not randomized enough");
puts ("nor equal to the default canary value");
--- glibc-2.10-312-g2df4be8/nscd/nscd.conf
+++ glibc-2.10.90-15/nscd/nscd.conf
+++ glibc-2.10.90-17/nscd/nscd.conf
@@ -33,7 +33,7 @@
# logfile /var/log/nscd.log
# threads 4
@ -1135,7 +1135,7 @@
debug-level 0
# reload-count 5
--- glibc-2.10-312-g2df4be8/nscd/nscd.init
+++ glibc-2.10.90-15/nscd/nscd.init
+++ glibc-2.10.90-17/nscd/nscd.init
@@ -9,6 +9,7 @@
# slow naming services like NIS, NIS+, LDAP, or hesiod.
# processname: /usr/sbin/nscd
@ -1193,8 +1193,8 @@
*)
echo $"Usage: $0 {start|stop|status|restart|reload|condrestart}"
--- glibc-2.10-312-g2df4be8/posix/Makefile
+++ glibc-2.10.90-15/posix/Makefile
@@ -302,15 +302,8 @@ $(inst_libexecdir)/getconf: $(inst_bindir)/getconf \
+++ glibc-2.10.90-17/posix/Makefile
@@ -302,15 +302,8 @@ $(inst_libexecdir)/getconf: $(inst_bindi
mv -f $@/$$spec.new $@/$$spec; \
done < $(objpfx)getconf.speclist
@ -1215,7 +1215,7 @@
+ > $@.new
mv -f $@.new $@
--- glibc-2.10-312-g2df4be8/posix/getconf.speclist.h
+++ glibc-2.10.90-15/posix/getconf.speclist.h
+++ glibc-2.10.90-17/posix/getconf.speclist.h
@@ -0,0 +1,39 @@
+#include <unistd.h>
+const char *START_OF_STRINGS =
@ -1257,7 +1257,7 @@
+#endif
+"";
--- glibc-2.10-312-g2df4be8/streams/Makefile
+++ glibc-2.10.90-15/streams/Makefile
+++ glibc-2.10.90-17/streams/Makefile
@@ -21,7 +21,7 @@
#
subdir := streams
@ -1268,7 +1268,7 @@
include ../Rules
--- glibc-2.10-312-g2df4be8/sysdeps/generic/dl-cache.h
+++ glibc-2.10.90-15/sysdeps/generic/dl-cache.h
+++ glibc-2.10.90-17/sysdeps/generic/dl-cache.h
@@ -36,6 +36,14 @@
# define add_system_dir(dir) add_dir (dir)
#endif
@ -1285,7 +1285,7 @@
/* libc5 and glibc 2.0/2.1 use the same format. For glibc 2.2 another
--- glibc-2.10-312-g2df4be8/sysdeps/i386/Makefile
+++ glibc-2.10.90-15/sysdeps/i386/Makefile
+++ glibc-2.10.90-17/sysdeps/i386/Makefile
@@ -2,6 +2,8 @@
# Every i386 port in use uses gas syntax (I think).
asm-CPPFLAGS += -DGAS_SYNTAX
@ -1311,7 +1311,7 @@
ifeq ($(subdir),elf)
--- glibc-2.10-312-g2df4be8/sysdeps/ia64/Makefile
+++ glibc-2.10.90-15/sysdeps/ia64/Makefile
+++ glibc-2.10.90-17/sysdeps/ia64/Makefile
@@ -12,8 +12,8 @@ elide-routines.os += hp-timing
ifeq (yes,$(build-shared))
@ -1324,7 +1324,7 @@
endif
--- glibc-2.10-312-g2df4be8/sysdeps/ia64/ia64libgcc.S
+++ glibc-2.10.90-15/sysdeps/ia64/ia64libgcc.S
+++ glibc-2.10.90-17/sysdeps/ia64/ia64libgcc.S
@@ -1,350 +0,0 @@
-/* From the Intel IA-64 Optimization Guide, choose the minimum latency
- alternative. */
@ -1677,7 +1677,7 @@
-
-#endif
--- glibc-2.10-312-g2df4be8/sysdeps/ia64/libgcc-compat.c
+++ glibc-2.10.90-15/sysdeps/ia64/libgcc-compat.c
+++ glibc-2.10.90-17/sysdeps/ia64/libgcc-compat.c
@@ -0,0 +1,84 @@
+/* pre-.hidden libgcc compatibility
+ Copyright (C) 2002 Free Software Foundation, Inc.
@ -1764,7 +1764,7 @@
+
+#endif
--- glibc-2.10-312-g2df4be8/sysdeps/powerpc/powerpc64/Makefile
+++ glibc-2.10.90-15/sysdeps/powerpc/powerpc64/Makefile
+++ glibc-2.10.90-17/sysdeps/powerpc/powerpc64/Makefile
@@ -30,6 +30,7 @@ ifneq ($(elf),no)
# we use -fpic instead which is much better.
CFLAGS-initfini.s += -fpic -O1
@ -1774,7 +1774,7 @@
ifeq ($(subdir),elf)
--- glibc-2.10-312-g2df4be8/sysdeps/unix/nice.c
+++ glibc-2.10.90-15/sysdeps/unix/nice.c
+++ glibc-2.10.90-17/sysdeps/unix/nice.c
@@ -42,7 +42,12 @@ nice (int incr)
__set_errno (save);
}
@ -1790,7 +1790,7 @@
{
if (errno == EACCES)
--- glibc-2.10-312-g2df4be8/sysdeps/unix/sysv/linux/check_pf.c
+++ glibc-2.10.90-15/sysdeps/unix/sysv/linux/check_pf.c
+++ glibc-2.10.90-17/sysdeps/unix/sysv/linux/check_pf.c
@@ -27,13 +27,10 @@
#include <unistd.h>
#include <sys/socket.h>
@ -1807,7 +1807,7 @@
#ifndef IFA_F_HOMEADDRESS
# define IFA_F_HOMEADDRESS 0
--- glibc-2.10-312-g2df4be8/sysdeps/unix/sysv/linux/dl-osinfo.h
+++ glibc-2.10.90-15/sysdeps/unix/sysv/linux/dl-osinfo.h
+++ glibc-2.10.90-17/sysdeps/unix/sysv/linux/dl-osinfo.h
@@ -17,10 +17,13 @@
Software Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
02111-1307 USA. */
@ -1822,7 +1822,7 @@
#ifndef MIN
# define MIN(a,b) (((a)<(b))?(a):(b))
@@ -80,6 +83,32 @@ _dl_setup_stack_chk_guard (void *dl_random)
@@ -80,6 +83,32 @@ _dl_setup_stack_chk_guard (void *dl_rand
unsigned char *p = (unsigned char *) &ret;
p[sizeof (ret) - 1] = 255;
p[sizeof (ret) - 2] = '\n';
@ -1856,7 +1856,7 @@
else
#endif
--- glibc-2.10-312-g2df4be8/sysdeps/unix/sysv/linux/futimesat.c
+++ glibc-2.10.90-15/sysdeps/unix/sysv/linux/futimesat.c
+++ glibc-2.10.90-17/sysdeps/unix/sysv/linux/futimesat.c
@@ -37,14 +37,14 @@ futimesat (fd, file, tvp)
{
int result;
@ -1900,7 +1900,7 @@
size_t filelen = strlen (file);
static const char procfd[] = "/proc/self/fd/%d/%s";
--- glibc-2.10-312-g2df4be8/sysdeps/unix/sysv/linux/i386/clone.S
+++ glibc-2.10.90-15/sysdeps/unix/sysv/linux/i386/clone.S
+++ glibc-2.10.90-17/sysdeps/unix/sysv/linux/i386/clone.S
@@ -120,9 +120,6 @@ L(pseudo_end):
ret
@ -1920,7 +1920,7 @@
cfi_startproc
PSEUDO_END (BP_SYM (__clone))
--- glibc-2.10-312-g2df4be8/sysdeps/unix/sysv/linux/i386/dl-cache.h
+++ glibc-2.10.90-15/sysdeps/unix/sysv/linux/i386/dl-cache.h
+++ glibc-2.10.90-17/sysdeps/unix/sysv/linux/i386/dl-cache.h
@@ -0,0 +1,59 @@
+/* Support for reading /etc/ld.so.cache files written by Linux ldconfig.
+ Copyright (C) 2004 Free Software Foundation, Inc.
@ -1982,7 +1982,7 @@
+
+#include_next <dl-cache.h>
--- glibc-2.10-312-g2df4be8/sysdeps/unix/sysv/linux/ia64/dl-cache.h
+++ glibc-2.10.90-15/sysdeps/unix/sysv/linux/ia64/dl-cache.h
+++ glibc-2.10.90-17/sysdeps/unix/sysv/linux/ia64/dl-cache.h
@@ -22,4 +22,31 @@
#define _dl_cache_check_flags(flags) \
((flags) == _DL_CACHE_DEFAULT_ID)
@ -2016,7 +2016,7 @@
+
#include_next <dl-cache.h>
--- glibc-2.10-312-g2df4be8/sysdeps/unix/sysv/linux/ia64/dl-procinfo.c
+++ glibc-2.10.90-15/sysdeps/unix/sysv/linux/ia64/dl-procinfo.c
+++ glibc-2.10.90-17/sysdeps/unix/sysv/linux/ia64/dl-procinfo.c
@@ -0,0 +1,5 @@
+#ifdef IS_IN_ldconfig
+#include <sysdeps/i386/dl-procinfo.c>
@ -2024,7 +2024,7 @@
+#include <sysdeps/generic/dl-procinfo.c>
+#endif
--- glibc-2.10-312-g2df4be8/sysdeps/unix/sysv/linux/ia64/dl-procinfo.h
+++ glibc-2.10.90-15/sysdeps/unix/sysv/linux/ia64/dl-procinfo.h
+++ glibc-2.10.90-17/sysdeps/unix/sysv/linux/ia64/dl-procinfo.h
@@ -0,0 +1,5 @@
+#ifdef IS_IN_ldconfig
+#include <sysdeps/unix/sysv/linux/i386/dl-procinfo.h>
@ -2032,12 +2032,12 @@
+#include <sysdeps/generic/dl-procinfo.h>
+#endif
--- glibc-2.10-312-g2df4be8/sysdeps/unix/sysv/linux/ia64/ldd-rewrite.sed
+++ glibc-2.10.90-15/sysdeps/unix/sysv/linux/ia64/ldd-rewrite.sed
+++ glibc-2.10.90-17/sysdeps/unix/sysv/linux/ia64/ldd-rewrite.sed
@@ -1 +1 @@
-s_^\(RTLDLIST=\)\([^ ]*\)-ia64\(\.so\.[0-9.]*\)[ ]*$_\1"\2-ia64\3 \2\3"_
+s_^\(RTLDLIST=\)\([^ ]*\)-ia64\(\.so\.[0-9.]*\)[ ]*$_\1"\2-ia64\3 /emul/ia32-linux\2\3"_
--- glibc-2.10-312-g2df4be8/sysdeps/unix/sysv/linux/netlinkaccess.h
+++ glibc-2.10.90-15/sysdeps/unix/sysv/linux/netlinkaccess.h
+++ glibc-2.10.90-17/sysdeps/unix/sysv/linux/netlinkaccess.h
@@ -25,6 +25,24 @@
#include <kernel-features.h>
@ -2064,7 +2064,7 @@
struct netlink_res
{
--- glibc-2.10-312-g2df4be8/sysdeps/unix/sysv/linux/paths.h
+++ glibc-2.10.90-15/sysdeps/unix/sysv/linux/paths.h
+++ glibc-2.10.90-17/sysdeps/unix/sysv/linux/paths.h
@@ -62,7 +62,7 @@
#define _PATH_TTY "/dev/tty"
#define _PATH_UNIX "/boot/vmlinux"
@ -2075,8 +2075,8 @@
/* Provide trailing slash, since mostly used for building pathnames. */
--- glibc-2.10-312-g2df4be8/sysdeps/unix/sysv/linux/tcsetattr.c
+++ glibc-2.10.90-15/sysdeps/unix/sysv/linux/tcsetattr.c
@@ -49,6 +49,7 @@ tcsetattr (fd, optional_actions, termios_p)
+++ glibc-2.10.90-17/sysdeps/unix/sysv/linux/tcsetattr.c
@@ -49,6 +49,7 @@ tcsetattr (fd, optional_actions, termios
{
struct __kernel_termios k_termios;
unsigned long int cmd;
@ -2084,7 +2084,7 @@
switch (optional_actions)
{
@@ -80,6 +81,35 @@ tcsetattr (fd, optional_actions, termios_p)
@@ -80,6 +81,35 @@ tcsetattr (fd, optional_actions, termios
memcpy (&k_termios.c_cc[0], &termios_p->c_cc[0],
__KERNEL_NCCS * sizeof (cc_t));
@ -2122,7 +2122,7 @@
}
libc_hidden_def (tcsetattr)
--- glibc-2.10-312-g2df4be8/sysdeps/unix/sysv/linux/x86_64/clone.S
+++ glibc-2.10.90-15/sysdeps/unix/sysv/linux/x86_64/clone.S
+++ glibc-2.10.90-17/sysdeps/unix/sysv/linux/x86_64/clone.S
@@ -89,9 +89,6 @@ L(pseudo_end):
ret
@ -2142,7 +2142,7 @@
cfi_startproc;
PSEUDO_END (BP_SYM (__clone))
--- glibc-2.10-312-g2df4be8/timezone/zic.c
+++ glibc-2.10.90-15/timezone/zic.c
+++ glibc-2.10.90-17/timezone/zic.c
@@ -1921,7 +1921,7 @@ const int zonecount;
if (stdrp != NULL && stdrp->r_hiyear == 2037)
return;

View File

@ -24,7 +24,7 @@
Summary: The GNU libc libraries
Name: glibc
Version: %{glibcversion}
Release: 16
Release: 17
# GPLv2+ is used in a bunch of programs, LGPLv2+ is used for libraries.
# Things that are linked directly into dynamically linked programs
# and shared libraries (e.g. crt files, lib*_nonshared.a) have an additional
@ -1028,8 +1028,10 @@ rm -f *.filelist*
%endif
%changelog
* Wed Aug 26 2009 Andreas Schwab <schwab@redhat.com> - 2.10.90-16
* Thu Aug 27 2009 Roland McGrath <roland@redhat.com> - 2.10.90-17
- Update from master.
* Wed Aug 26 2009 Andreas Schwab <schwab@redhat.com> - 2.10.90-16
- handle AVX saving on x86-64 in interrupted symbol lookups (#519081).
* Mon Aug 24 2009 Andreas Schwab <schwab@redhat.com> - 2.10.90-15

View File

@ -24,3 +24,4 @@ glibc-2_10_90-13:HEAD:glibc-2.10.90-13.src.rpm:1249897909
glibc-2_10_90-14:HEAD:glibc-2.10.90-14.src.rpm:1250516718
glibc-2_10_90-15:HEAD:glibc-2.10.90-15.src.rpm:1251105646
glibc-2_10_90-16:HEAD:glibc-2.10.90-16.src.rpm:1251288654
glibc-2_10_90-17:HEAD:glibc-2.10.90-17.src.rpm:1251406917

View File

@ -1,2 +1,2 @@
9f7f51058bd40cf84a870dd04e4198ec glibc-2.10-312-g2df4be8-fedora.tar.bz2
e9d285d54d60e73798293d32abdabcf7 glibc-2.10-312-g2df4be8.tar.bz2
8dd0742bf8c3a90a22197c3e054c3271 glibc-2.10-312-g2df4be8-fedora.tar.bz2