Remove workaround for valgrind bug (#1600034)
This commit is contained in:
parent
fde5e92317
commit
723de53164
@ -1,32 +0,0 @@
|
||||
This patch is similar to glibc-asflags.patch and is needed to change
|
||||
the ld.so linker flags. It is needed to work around this valgrind
|
||||
bug: https://bugzilla.redhat.com/show_bug.cgi?id=1600034
|
||||
|
||||
diff --git a/Makeconfig b/Makeconfig
|
||||
index 92e76d6200bbcd5b..376181c8ff06dea7 100644
|
||||
--- a/Makeconfig
|
||||
+++ b/Makeconfig
|
||||
@@ -363,12 +363,12 @@ endif
|
||||
ifeq (yesyes,$(build-shared)$(have-z-combreloc))
|
||||
combreloc-LDFLAGS = -Wl,-z,combreloc
|
||||
LDFLAGS.so += $(combreloc-LDFLAGS)
|
||||
-LDFLAGS-rtld += $(combreloc-LDFLAGS)
|
||||
+override LDFLAGS-rtld += $(combreloc-LDFLAGS)
|
||||
endif
|
||||
|
||||
relro-LDFLAGS = -Wl,-z,relro
|
||||
LDFLAGS.so += $(relro-LDFLAGS)
|
||||
-LDFLAGS-rtld += $(relro-LDFLAGS)
|
||||
+override LDFLAGS-rtld += $(relro-LDFLAGS)
|
||||
|
||||
ifeq (yes,$(have-hash-style))
|
||||
# For the time being we unconditionally use 'both'. At some time we
|
||||
@@ -376,7 +376,7 @@ ifeq (yes,$(have-hash-style))
|
||||
# with --hash-style=gnu only.
|
||||
hashstyle-LDFLAGS = -Wl,--hash-style=both
|
||||
LDFLAGS.so += $(hashstyle-LDFLAGS)
|
||||
-LDFLAGS-rtld += $(hashstyle-LDFLAGS)
|
||||
+override LDFLAGS-rtld += $(hashstyle-LDFLAGS)
|
||||
endif
|
||||
|
||||
ifeq (yes,$(enable-static-pie))
|
17
glibc.spec
17
glibc.spec
@ -1,6 +1,6 @@
|
||||
%define glibcsrcdir glibc-2.28.9000-104-gff6b24501f
|
||||
%define glibcversion 2.28.9000
|
||||
%define glibcrelease 3%{?dist}
|
||||
%define glibcrelease 4%{?dist}
|
||||
# Pre-release tarballs are pulled in from git using a command that is
|
||||
# effectively:
|
||||
#
|
||||
@ -157,7 +157,6 @@ Patch16: glibc-nscd-sysconfig.patch
|
||||
Patch17: glibc-cs-path.patch
|
||||
Patch18: glibc-c-utf8-locale.patch
|
||||
Patch23: glibc-python3.patch
|
||||
Patch26: glibc-ldflags.patch
|
||||
Patch28: glibc-rh1615608.patch
|
||||
|
||||
##############################################################################
|
||||
@ -779,16 +778,7 @@ rpm_inherit_flags \
|
||||
# assembler code. Needs to be passed to make; not preserved by
|
||||
# configure.
|
||||
%define glibc_make_flags_as ASFLAGS="-g -Wa,--generate-missing-build-notes=yes"
|
||||
%define glibc_make_flags %{glibc_make_flags_as} %{glibc_make_flags_ld}
|
||||
|
||||
# valgrind reports false positives if ld.so is linked with -z
|
||||
# separate-code (the default) on i686, so we work around that here.
|
||||
# See <https://bugzilla.redhat.com/show_bug.cgi?id=1600034>.
|
||||
%ifarch %{ix86}
|
||||
%define glibc_make_flags_ld LDFLAGS-rtld="-Wl,-z,noseparate-code"
|
||||
%else
|
||||
%define glibc_make_flags_ld %{nil}
|
||||
%endif
|
||||
%define glibc_make_flags %{glibc_make_flags_as}
|
||||
|
||||
##############################################################################
|
||||
# %%build - Generic options.
|
||||
@ -1874,6 +1864,9 @@ fi
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Wed Aug 29 2018 Florian Weimer <fweimer@redhat.com> - 2.28.9000-4
|
||||
- Remove workaround for valgrind bug (#1600034)
|
||||
|
||||
* Wed Aug 29 2018 Florian Weimer <fweimer@redhat.com> - 2.28.9000-3
|
||||
- Auto-sync with upstream branch master,
|
||||
commit ff6b24501f70da7d6375d6f5929262b9509db39e.
|
||||
|
Loading…
Reference in New Issue
Block a user