Remove the glibc-rpcgen subpackage
An rpcgen subpackage is now built by rpcsvc-proto.
This commit is contained in:
parent
36e8658036
commit
6a5972a529
@ -1,22 +0,0 @@
|
||||
Enable rpcgen unconditionally even if Sun RPC is disabled.
|
||||
rpcgen will be installed into the glibc-rpcgen subpackage.
|
||||
|
||||
diff --git a/sunrpc/Makefile b/sunrpc/Makefile
|
||||
index 8f2a3c8213e3564e..69be5c119bf5ff85 100644
|
||||
--- a/sunrpc/Makefile
|
||||
+++ b/sunrpc/Makefile
|
||||
@@ -85,14 +85,12 @@ shared-only-routines = $(routines)
|
||||
endif
|
||||
endif
|
||||
|
||||
-ifeq ($(link-obsolete-rpc),yes)
|
||||
install-bin := rpcgen
|
||||
rpcgen-objs = rpc_main.o rpc_hout.o rpc_cout.o rpc_parse.o \
|
||||
rpc_scan.o rpc_util.o rpc_svcout.o rpc_clntout.o \
|
||||
rpc_tblout.o rpc_sample.o
|
||||
extra-objs = $(rpcgen-objs) $(addprefix cross-,$(rpcgen-objs))
|
||||
others += rpcgen
|
||||
-endif
|
||||
|
||||
tests = tst-xdrmem tst-xdrmem2 test-rpcent tst-udp-error tst-udp-timeout \
|
||||
tst-udp-nonblocking
|
29
glibc.spec
29
glibc.spec
@ -171,7 +171,6 @@ Patch0024: glibc-fedora-locarchive.patch
|
||||
Patch0025: glibc-fedora-streams-rh436349.patch
|
||||
Patch0028: glibc-fedora-localedata-rh61908.patch
|
||||
Patch0031: glibc-fedora-__libc_multiple_libcs.patch
|
||||
Patch32: glibc-rpcgen.patch
|
||||
|
||||
# Allow applications to call pthread_atfork without libpthread.so.
|
||||
Patch0046: glibc-rh1013801.patch
|
||||
@ -387,19 +386,6 @@ applications should use libnsl2 instead to gain IPv6 support.
|
||||
%postun -n libnsl
|
||||
/sbin/ldconfig
|
||||
|
||||
######################################################################
|
||||
# rpcgen subpackage
|
||||
######################################################################
|
||||
|
||||
%package rpcgen
|
||||
Summary: rpcgen compiler for Sun RPC protocol descriptions (glibc variant)
|
||||
Provides: rpcgen
|
||||
Provides: /usr/bin/rpcgen
|
||||
|
||||
%description rpcgen
|
||||
This package provides the rpcgen program, for compiled .x protocol
|
||||
description files into C source code.
|
||||
|
||||
##############################################################################
|
||||
# glibc "devel" sub-package
|
||||
##############################################################################
|
||||
@ -752,7 +738,6 @@ microbenchmark tests on the system.
|
||||
%patch2027 -p1
|
||||
%patch0028 -p1
|
||||
%patch0031 -p1
|
||||
%patch32 -p1
|
||||
%patch0046 -p1
|
||||
%patch2031 -p1
|
||||
%patch0047 -p1
|
||||
@ -1270,8 +1255,6 @@ rm -f $RPM_BUILD_ROOT%{_prefix}/lib/debug%{_libdir}/*_p.a
|
||||
# - Contains the list of flies for the common subpackage.
|
||||
# * utils.filelist
|
||||
# - Contains the list of files for the utils subpackage.
|
||||
# * rpcgen.filelist
|
||||
# - Contains the list of files for the rpcgen subpackage.
|
||||
# * nscd.filelist
|
||||
# - Contains the list of files for the nscd subpackage.
|
||||
# * devel.filelist
|
||||
@ -1328,7 +1311,7 @@ rm -f $RPM_BUILD_ROOT%{_prefix}/lib/debug%{_libdir}/*_p.a
|
||||
-e '\,.*/share/i18n/charmaps/.*,d' \
|
||||
-e '\,/etc/\(localtime\|nsswitch.conf\|ld\.so\.conf\|ld\.so\.cache\|default\|rpc\|gai\.conf\),d' \
|
||||
-e '\,/%{_lib}/lib\(pcprofile\|memusage\)\.so,d' \
|
||||
-e '\,bin/\(memusage\|mtrace\|xtrace\|pcprofiledump\|rpcgen\),d'
|
||||
-e '\,bin/\(memusage\|mtrace\|xtrace\|pcprofiledump\),d'
|
||||
} | sort > rpm.filelist
|
||||
|
||||
touch common.filelist
|
||||
@ -1443,11 +1426,6 @@ cat > utils.filelist <<EOF
|
||||
%{_prefix}/bin/xtrace
|
||||
EOF
|
||||
|
||||
# rpcgen subpackage file list
|
||||
cat > rpcgen.filelist <<EOF
|
||||
%{_prefix}/bin/rpcgen
|
||||
EOF
|
||||
|
||||
# Move the NSS-related files to the NSS subpackages. Be careful not
|
||||
# to pick up .debug files, and the -devel symbolic links.
|
||||
for module in db compat hesiod files dns; do
|
||||
@ -1586,7 +1564,6 @@ find_debuginfo_args='--strict-build-id -g'
|
||||
find_debuginfo_args="$find_debuginfo_args \
|
||||
-l common.filelist \
|
||||
-l utils.filelist \
|
||||
-l rpcgen.filelist \
|
||||
-l nscd.filelist \
|
||||
-p '.*/(sbin|libexec)/.*' \
|
||||
-o debuginfocommon.filelist \
|
||||
@ -1981,9 +1958,6 @@ fi
|
||||
%files -f utils.filelist utils
|
||||
%defattr(-,root,root)
|
||||
|
||||
%files -f rpcgen.filelist rpcgen
|
||||
%defattr(-,root,root)
|
||||
|
||||
%files -f nscd.filelist -n nscd
|
||||
%defattr(-,root,root)
|
||||
%config(noreplace) /etc/nscd.conf
|
||||
@ -2037,6 +2011,7 @@ fi
|
||||
%changelog
|
||||
* Fri Jan 19 2018 Florian Weimer <fweimer@redhat.com> - 2.26.9000-45
|
||||
- Drop static PIE support on aarch64. It leads to crashes at run time.
|
||||
- Remove glibc-rpcgen subpackage. See rpcsvc-proto. (#1531540)
|
||||
|
||||
* Fri Jan 19 2018 Florian Weimer <fweimer@redhat.com> - 2.26.9000-44
|
||||
- Correct the list of static PIE architectures
|
||||
|
Loading…
Reference in New Issue
Block a user