Resolves: #740682
This commit is contained in:
parent
e8db5b4063
commit
61e27a5181
12
glibc-rh740682.patch
Normal file
12
glibc-rh740682.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -rup a/time/sys/time.h b/time/sys/time.h
|
||||
--- a/time/sys/time.h 2012-01-01 05:16:32.000000000 -0700
|
||||
+++ b/time/sys/time.h 2012-01-26 11:16:44.309112430 -0700
|
||||
@@ -78,7 +78,7 @@ extern int gettimeofday (struct timeval
|
||||
This call is restricted to the super-user. */
|
||||
extern int settimeofday (__const struct timeval *__tv,
|
||||
__const struct timezone *__tz)
|
||||
- __THROW __nonnull ((1));
|
||||
+ __THROW;
|
||||
|
||||
/* Adjust the current time of day by the amount in DELTA.
|
||||
If OLDDELTA is not NULL, it is filled in with the amount
|
@ -2,7 +2,7 @@
|
||||
%define glibcversion 2.15
|
||||
%define glibcportsdir glibc-ports-2.15-ad8ae7d
|
||||
### glibc.spec.in follows:
|
||||
%define run_glibc_tests 0
|
||||
%define run_glibc_tests 1
|
||||
%define auxarches athlon alphaev6
|
||||
%define xenarches i686 athlon
|
||||
%ifarch %{xenarches}
|
||||
@ -62,6 +62,7 @@ Patch11: %{name}-rh622499.patch
|
||||
# Depends on systemtap infrastructure, so can't go upstream
|
||||
Patch12: %{name}-rh179072.patch
|
||||
Patch13: %{name}-rh697421.patch
|
||||
Patch14: %{name}-rh740682.patch
|
||||
|
||||
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
Obsoletes: glibc-profile < 2.4
|
||||
@ -293,6 +294,7 @@ rm -rf %{glibcportsdir}
|
||||
%patch11 -p1
|
||||
%patch12 -p1
|
||||
%patch13 -p1
|
||||
%patch14 -p1
|
||||
|
||||
# A lot of programs still misuse memcpy when they have to use
|
||||
# memmove. The memcpy implementation below is not tolerant at
|
||||
@ -1146,6 +1148,7 @@ rm -f *.filelist*
|
||||
|
||||
%changelog
|
||||
* Thu Jan 26 2012 Jeff Law <law@redhat.com> - 2.15-6
|
||||
- First argument to settimeofday can be null (#740682)
|
||||
- Add aliases for ISO-10646-UCS-2 (#697421)
|
||||
|
||||
* Tue Jan 24 2012 Jeff Law <law@redhat.com> - 2.15-4
|
||||
|
Loading…
Reference in New Issue
Block a user