Sync with upstream master and disable Werror on s390x
This commit is contained in:
parent
20d87dfe74
commit
5d3d5d4542
@ -1,18 +0,0 @@
|
|||||||
diff --git a/sysdeps/s390/dl-tls.h b/sysdeps/s390/dl-tls.h
|
|
||||||
index 0fa8045..8132b10 100644
|
|
||||||
--- a/sysdeps/s390/dl-tls.h
|
|
||||||
+++ b/sysdeps/s390/dl-tls.h
|
|
||||||
@@ -33,6 +33,13 @@ extern unsigned long __tls_get_offset (unsigned long got_offset);
|
|
||||||
|
|
||||||
# include <shlib-compat.h>
|
|
||||||
|
|
||||||
+/* dl-tls.c declares __tls_get_addr as an exported symbol if it is not defined
|
|
||||||
+ as a macro. It seems suitable to do that in the generic code because all
|
|
||||||
+ architectures other than s390 export __tls_get_addr. The declaration causes
|
|
||||||
+ problems in s390 though, so we define __tls_get_addr here to avoid declaring
|
|
||||||
+ __tls_get_addr again. */
|
|
||||||
+# define __tls_get_addr __tls_get_addr
|
|
||||||
+
|
|
||||||
extern void *__tls_get_addr (tls_index *ti) attribute_hidden;
|
|
||||||
/* Make a temporary alias of __tls_get_addr to remove the hidden
|
|
||||||
attribute. Then export __tls_get_addr as __tls_get_addr_internal
|
|
18
glibc.spec
18
glibc.spec
@ -1,6 +1,6 @@
|
|||||||
%define glibcsrcdir glibc-2.20-480-g46abb64
|
%define glibcsrcdir glibc-2.20-549-g86bba16
|
||||||
%define glibcversion 2.20.90
|
%define glibcversion 2.20.90
|
||||||
%define glibcrelease 19%{?dist}
|
%define glibcrelease 20%{?dist}
|
||||||
# Pre-release tarballs are pulled in from git using a command that is
|
# Pre-release tarballs are pulled in from git using a command that is
|
||||||
# effectively:
|
# effectively:
|
||||||
#
|
#
|
||||||
@ -18,6 +18,10 @@
|
|||||||
%ifarch %{ix86} x86_64 ppc ppc64le s390x armv7hl aarch64
|
%ifarch %{ix86} x86_64 ppc ppc64le s390x armv7hl aarch64
|
||||||
%define run_valgrind_tests 1
|
%define run_valgrind_tests 1
|
||||||
%endif
|
%endif
|
||||||
|
# Disable -Werror in builds for these architectures
|
||||||
|
%ifarch s390x
|
||||||
|
%define disable_werror 1
|
||||||
|
%endif
|
||||||
##############################################################################
|
##############################################################################
|
||||||
# Auxiliary arches are those arches that can be built in addition
|
# Auxiliary arches are those arches that can be built in addition
|
||||||
# to the core supported arches. You either install an auxarch or
|
# to the core supported arches. You either install an auxarch or
|
||||||
@ -236,8 +240,6 @@ Patch2031: %{name}-rh1070416.patch
|
|||||||
Patch2033: %{name}-aarch64-tls-fixes.patch
|
Patch2033: %{name}-aarch64-tls-fixes.patch
|
||||||
Patch2034: %{name}-aarch64-workaround-nzcv-clobber-in-tlsdesc.patch
|
Patch2034: %{name}-aarch64-workaround-nzcv-clobber-in-tlsdesc.patch
|
||||||
|
|
||||||
Patch2035: glibc-s390-tls-get-addr.patch
|
|
||||||
|
|
||||||
##############################################################################
|
##############################################################################
|
||||||
# End of glibc patches.
|
# End of glibc patches.
|
||||||
##############################################################################
|
##############################################################################
|
||||||
@ -570,7 +572,6 @@ package or when debugging this package.
|
|||||||
%patch0050 -p1
|
%patch0050 -p1
|
||||||
%patch0052 -p1
|
%patch0052 -p1
|
||||||
%patch0053 -p1
|
%patch0053 -p1
|
||||||
%patch2035 -p1
|
|
||||||
|
|
||||||
##############################################################################
|
##############################################################################
|
||||||
# %%prep - Additional prep required...
|
# %%prep - Additional prep required...
|
||||||
@ -716,6 +717,9 @@ build()
|
|||||||
%endif
|
%endif
|
||||||
%ifarch %{lock_elision_arches}
|
%ifarch %{lock_elision_arches}
|
||||||
--enable-lock-elision \
|
--enable-lock-elision \
|
||||||
|
%endif
|
||||||
|
%if 0%{?disable_werror}
|
||||||
|
--disable-werror \
|
||||||
%endif
|
%endif
|
||||||
--disable-profile --enable-nss-crypt ||
|
--disable-profile --enable-nss-crypt ||
|
||||||
{ cat config.log; false; }
|
{ cat config.log; false; }
|
||||||
@ -1740,6 +1744,10 @@ rm -f *.filelist*
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Jan 21 2015 Siddhesh Poyarekar <siddhesh@redhat.com> - 2.20.90-20
|
||||||
|
- Sync with upstream master.
|
||||||
|
- Disable werror on s390x.
|
||||||
|
|
||||||
* Tue Jan 20 2015 Peter Robinson <pbrobinson@fedoraproject.org> 2.20.90-19
|
* Tue Jan 20 2015 Peter Robinson <pbrobinson@fedoraproject.org> 2.20.90-19
|
||||||
- Drop large ancient ChangeLogs (rhbz #1169546)
|
- Drop large ancient ChangeLogs (rhbz #1169546)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user