2.3.3-90
This commit is contained in:
parent
fed967a9be
commit
55a4f67377
@ -1,6 +1,15 @@
|
||||
--- glibc-20041210T0634/ChangeLog 10 Dec 2004 04:41:46 -0000 1.9047
|
||||
+++ glibc-20041210T0634-fedora/ChangeLog 10 Dec 2004 06:50:23 -0000 1.8782.2.54
|
||||
@@ -260,6 +260,14 @@
|
||||
+++ glibc-20041210T0634-fedora/ChangeLog 10 Dec 2004 08:57:52 -0000 1.8782.2.55
|
||||
@@ -1,3 +1,8 @@
|
||||
+2004-12-10 Jakub Jelinek <jakub@redhat.com>
|
||||
+
|
||||
+ * posix/getconf.c (main): Skip over initial underscore in
|
||||
+ $libexecdir/getconf/default symlink target.
|
||||
+
|
||||
2004-11-29 Jakub Jelinek <jakub@redhat.com>
|
||||
|
||||
* stdlib/strtod_l.c (INTERNAL (__STRTOF)): If densize > 2
|
||||
@@ -260,6 +265,14 @@
|
||||
|
||||
2004-11-26 Jakub Jelinek <jakub@redhat.com>
|
||||
|
||||
@ -15,7 +24,7 @@
|
||||
* posix/Makefile (install-others): Add $(inst_libexecdir)/getconf.
|
||||
(CFLAGS-sysconf.c): Add -D_GETCONF_DIR.
|
||||
(CFLAGS-getconf.c): New.
|
||||
@@ -851,6 +859,16 @@
|
||||
@@ -851,6 +864,16 @@
|
||||
* sysdeps/generic/tempname.c (__path_search): Add missing argument
|
||||
TRY_TMPDIR.
|
||||
|
||||
@ -32,7 +41,7 @@
|
||||
2004-10-31 Mariusz Mazur <mmazur@kernel.pl>
|
||||
|
||||
* sysdeps/unix/sysv/linux/alpha/setregid.c: New file.
|
||||
@@ -1146,6 +1164,11 @@
|
||||
@@ -1146,6 +1169,11 @@
|
||||
* posix/execvp.c (execvp): Also ignore ENODEV and ETIMEDOUT errno
|
||||
values.
|
||||
|
||||
@ -44,7 +53,7 @@
|
||||
2004-10-20 Roland McGrath <roland@redhat.com>
|
||||
|
||||
* Makeconfig ($(common-objpfx)shlib-versions.v.i): Check also
|
||||
@@ -1218,6 +1241,11 @@
|
||||
@@ -1218,6 +1246,11 @@
|
||||
* debug/catchsegv.sh: Update copyright year.
|
||||
Use mktemp to create segv_output file.
|
||||
|
||||
@ -56,7 +65,7 @@
|
||||
2004-10-18 Jakub Jelinek <jakub@redhat.com>
|
||||
|
||||
* elf/dl-libc.c (__libc_dlsym_private, __libc_register_dl_open_hook):
|
||||
@@ -2201,6 +2229,22 @@
|
||||
@@ -2201,6 +2234,22 @@
|
||||
* string/string.h: Add __nonnull annotations.
|
||||
* stdlib/stdlib.h: Likewise.
|
||||
|
||||
@ -79,7 +88,7 @@
|
||||
2004-09-20 H.J. Lu <hongjiu.lu@intel.com>
|
||||
|
||||
* sysdeps/unix/sysv/linux/ia64/sysdep.h (DO_INLINE_SYSCALL):
|
||||
@@ -2930,6 +2974,23 @@
|
||||
@@ -2930,6 +2979,23 @@
|
||||
before return type.
|
||||
* locale/localename.c (__current_locale_name): Likewise.
|
||||
|
||||
@ -103,7 +112,7 @@
|
||||
2004-08-30 Roland McGrath <roland@frob.com>
|
||||
|
||||
* scripts/extract-abilist.awk: If `lastversion' variable defined, omit
|
||||
@@ -3086,6 +3147,22 @@
|
||||
@@ -3086,6 +3152,22 @@
|
||||
* resolv/nss_dns/dns-canon.c (_nss_dns_getcanonname_r): Initialize
|
||||
status to NSS_STATUS_UNAVAIL.
|
||||
|
||||
@ -126,7 +135,7 @@
|
||||
2004-08-19 Ulrich Drepper <drepper@redhat.com>
|
||||
|
||||
* sysdeps/posix/getaddrinfo.c (gaih_inet): Use h->h_name in the
|
||||
@@ -3390,6 +3467,12 @@
|
||||
@@ -3390,6 +3472,12 @@
|
||||
|
||||
* iconvdata/testdata/ISO-2022-JP-3: Regenerated.
|
||||
|
||||
@ -1900,6 +1909,35 @@
|
||||
+ | sed -n -e '/START_OF_STRINGS/,$${/_POSIX_V6_/{s/^[^"]*"//;s/".*$$//;p}}' \
|
||||
+ > $@.new
|
||||
+ mv -f $@.new $@
|
||||
--- glibc-20041210T0634/posix/getconf.c 27 Nov 2004 20:56:55 -0000 1.37
|
||||
+++ glibc-20041210T0634-fedora/posix/getconf.c 10 Dec 2004 08:57:56 -0000 1.35.2.3
|
||||
@@ -997,12 +997,14 @@ warranty; not even for MERCHANTABILITY o
|
||||
{
|
||||
char default_name[getconf_dirlen + sizeof "/default"];
|
||||
memcpy (mempcpy (default_name, getconf_dir, getconf_dirlen),
|
||||
- "/default", sizeof "/default");
|
||||
+ "/default", sizeof "/default");
|
||||
int len = readlink (default_name, buf, sizeof buf - 1);
|
||||
if (len > 0)
|
||||
{
|
||||
buf[len] = '\0';
|
||||
spec = buf;
|
||||
+ if (spec[0] == '_')
|
||||
+ spec++;
|
||||
}
|
||||
}
|
||||
|
||||
@@ -1036,8 +1038,8 @@ warranty; not even for MERCHANTABILITY o
|
||||
size_t spec_len = strlen (spec);
|
||||
char getconf_name[getconf_dirlen + 2 + spec_len + 1];
|
||||
memcpy (mempcpy (mempcpy (getconf_name, getconf_dir,
|
||||
- getconf_dirlen),
|
||||
- "/_", 2), spec, spec_len + 1);
|
||||
+ getconf_dirlen),
|
||||
+ "/_", 2), spec, spec_len + 1);
|
||||
args[0] = argv0;
|
||||
args[1] = "-v";
|
||||
args[2] = spec;
|
||||
--- glibc-20041210T0634/posix/getconf.speclist.h 1 Jan 1970 00:00:00 -0000
|
||||
+++ glibc-20041210T0634-fedora/posix/getconf.speclist.h 26 Nov 2004 13:48:46 -0000 1.1.2.1
|
||||
@@ -0,0 +1,15 @@
|
||||
|
Loading…
Reference in New Issue
Block a user