Auto-sync with upstream branch master
Upstream commit: 3fb18fd80c5900cc82748f3320b30516c57d24da - elf: Add <dl-r_debug.h> - Mention _FORTIFY_SOURCE=3 for gcc12 in NEWS - malloc: Fix -Wuse-after-free warning in tst-mallocalign1 [BZ #26779] - Update libc.pot for 2.35 release. - tst-socket-timestamp-compat.c: Check __TIMESIZE [BZ #28837] - Add prelink removal plan on NEWS - Linux: Only generate 64 bit timestamps for 64 bit time_t recvmsg/recvmmsg - linux: Fix ancillary 64-bit time timestamp conversion (BZ #28349, BZ#28350) - support: Add support_socket_so_timestamp_time64 - Fix elf/loadfail test build dependencies - Fix glibc 2.34 ABI omission (missing GLIBC_2.34 in dynamic loader) - x86: Use CHECK_FEATURE_PRESENT to check HLE [BZ #27398] - Guard tst-valgrind-smoke.out with run-built-tests - hurd: Add posix_spawnattr_tc{get,set}pgrp_np on libc.abilist - Avoid -Wuse-after-free in tests [BZ #26779]. - elf: Replace tst-p_alignmod1-editX with a python script - stdlib: Avoid -Wuse-after-free in __add_to_environ [BZ #26779] - io: Fix use-after-free in ftw [BZ #26779] - intl: Avoid -Wuse-after-free [BZ #26779] - elf: Fix use-after-free in ldconfig [BZ #26779] - posix: Add terminal control setting support for posix_spawn
This commit is contained in:
parent
cdf31c9c27
commit
53b2ec4663
@ -1,86 +0,0 @@
|
||||
diff --git a/elf/Makefile b/elf/Makefile
|
||||
index 41e0f2e8c4..95fd4c73a5 100644
|
||||
--- a/elf/Makefile
|
||||
+++ b/elf/Makefile
|
||||
@@ -177,6 +177,8 @@ CFLAGS-dl-write.os += $(rtld-early-cflags)
|
||||
CFLAGS-dl-writev.os += $(rtld-early-cflags)
|
||||
CFLAGS-rtld.os += $(rtld-early-cflags)
|
||||
|
||||
+CFLAGS-ldconfig.c += -Wno-use-after-free
|
||||
+
|
||||
ifeq ($(unwind-find-fde),yes)
|
||||
routines += unwind-dw2-fde-glibc
|
||||
shared-only-routines += unwind-dw2-fde-glibc
|
||||
diff --git a/intl/Makefile b/intl/Makefile
|
||||
index 315c75a18f..00e4c363a5 100644
|
||||
--- a/intl/Makefile
|
||||
+++ b/intl/Makefile
|
||||
@@ -128,6 +128,8 @@ $(objpfx)msgs.h: po2test.awk $(objpfx)tst-gettext-de.po
|
||||
$(make-target-directory)
|
||||
LC_ALL=C $(AWK) -f $^ > $@
|
||||
|
||||
+CFLAGS-localealias.c += -Wno-use-after-free
|
||||
+
|
||||
CFLAGS-tst-gettext.c += -DTESTSTRS_H=\"$(objpfx)msgs.h\"
|
||||
CFLAGS-tst-translit.c += -DOBJPFX=\"$(objpfx)\"
|
||||
CFLAGS-tst-gettext2.c += -DOBJPFX=\"$(objpfx)\"
|
||||
diff --git a/io/Makefile b/io/Makefile
|
||||
index cf265dc9b9..c53cf209ee 100644
|
||||
--- a/io/Makefile
|
||||
+++ b/io/Makefile
|
||||
@@ -123,9 +123,9 @@ CFLAGS-fstatvfs.c += -fexceptions
|
||||
CFLAGS-fts.c += -Wno-uninitialized $(uses-callbacks) -fexceptions
|
||||
CFLAGS-fts64.c += -Wno-uninitialized $(uses-callbacks) -fexceptions
|
||||
CFLAGS-fts64-time64.c += -Wno-uninitialized $(uses-callbacks) -fexceptions
|
||||
-CFLAGS-ftw.c += $(uses-callbacks) -fexceptions
|
||||
-CFLAGS-ftw64.c += $(uses-callbacks) -fexceptions
|
||||
-CFLAGS-ftw64-time64.c += $(uses-callbacks) -fexceptions
|
||||
+CFLAGS-ftw.c += $(uses-callbacks) -fexceptions -Wno-use-after-free
|
||||
+CFLAGS-ftw64.c += $(uses-callbacks) -fexceptions -Wno-use-after-free
|
||||
+CFLAGS-ftw64-time64.c += $(uses-callbacks) -fexceptions -Wno-use-after-free
|
||||
CFLAGS-posix_fallocate.c += -fexceptions
|
||||
CFLAGS-posix_fallocate64.c += -fexceptions
|
||||
CFLAGS-fallocate.c += -fexceptions
|
||||
diff --git a/malloc/Makefile b/malloc/Makefile
|
||||
index 2329cf718a..677773b86b 100644
|
||||
--- a/malloc/Makefile
|
||||
+++ b/malloc/Makefile
|
||||
@@ -259,6 +259,13 @@ include ../Rules
|
||||
CFLAGS-mcheck-init.c += $(PIC-ccflag)
|
||||
CFLAGS-obstack.c += $(uses-callbacks)
|
||||
|
||||
+CFLAGS-tst-realloc.c += -Wno-use-after-free
|
||||
+CFLAGS-tst-obstack.c += -Wno-use-after-free
|
||||
+CFLAGS-tst-malloc-check.c += -Wno-use-after-free
|
||||
+CFLAGS-tst-malloc-backtrace.c += -Wno-use-after-free
|
||||
+CFLAGS-tst-malloc-too-large.c += -Wno-use-after-free
|
||||
+CFLAGS-tst-mallocalign1.c += -Wno-use-after-free
|
||||
+
|
||||
$(objpfx)libmcheck.a: $(objpfx)mcheck-init.o
|
||||
-rm -f $@
|
||||
$(patsubst %/,cd % &&,$(objpfx)) \
|
||||
diff --git a/stdlib/Makefile b/stdlib/Makefile
|
||||
index 8236741984..dbacf88218 100644
|
||||
--- a/stdlib/Makefile
|
||||
+++ b/stdlib/Makefile
|
||||
@@ -196,6 +196,7 @@ extra-test-objs += tst-putenvmod.os
|
||||
|
||||
generated += isomac isomac.out tst-putenvmod.so
|
||||
|
||||
+CFLAGS-setenv.c += -Wno-use-after-free
|
||||
CFLAGS-bsearch.c += $(uses-callbacks)
|
||||
CFLAGS-msort.c += $(uses-callbacks)
|
||||
CFLAGS-qsort.c += $(uses-callbacks)
|
||||
diff --git a/support/Makefile b/support/Makefile
|
||||
index 6dc6c9d49a..7dafcffb71 100644
|
||||
--- a/support/Makefile
|
||||
+++ b/support/Makefile
|
||||
@@ -234,6 +234,8 @@ CFLAGS-support_paths.c = \
|
||||
CFLAGS-timespec.c += -fexcess-precision=standard
|
||||
CFLAGS-timespec-time64.c += -fexcess-precision=standard
|
||||
|
||||
+CFLAGS-tst-support-open-dev-null-range.c += -Wno-use-after-free
|
||||
+
|
||||
ifeq (,$(CXX))
|
||||
LINKS_DSO_PROGRAM = links-dso-program-c
|
||||
else
|
32
glibc.spec
32
glibc.spec
@ -1,4 +1,4 @@
|
||||
%define glibcsrcdir glibc-2.34.9000-578-g5b8e7980c5
|
||||
%define glibcsrcdir glibc-2.34.9000-599-g3fb18fd80c
|
||||
%define glibcversion 2.34.9000
|
||||
# Pre-release tarballs are pulled in from git using a command that is
|
||||
# effectively:
|
||||
@ -152,7 +152,7 @@ end \
|
||||
Summary: The GNU libc libraries
|
||||
Name: glibc
|
||||
Version: %{glibcversion}
|
||||
Release: 38%{?dist}
|
||||
Release: 39%{?dist}
|
||||
|
||||
# In general, GPLv2+ is used by programs, LGPLv2+ is used for
|
||||
# libraries.
|
||||
@ -226,8 +226,6 @@ Patch17: glibc-cs-path.patch
|
||||
Patch23: glibc-python3.patch
|
||||
Patch30: glibc-deprecated-selinux-makedb.patch
|
||||
|
||||
# Temporary until the sources are patched to account for new gcc warning
|
||||
Patch98: glibc-temp-Wno-use-after-free.patch
|
||||
# Temporary until gcc is patched to have -mlong-double-64 override
|
||||
# -mabi=ibmlongdouble instead of conflict with it.
|
||||
Patch99: glibc-temp-ibmldbl64.patch
|
||||
@ -2163,6 +2161,32 @@ update_gconv_modules_cache ()
|
||||
%files -f compat-libpthread-nonshared.filelist -n compat-libpthread-nonshared
|
||||
|
||||
%changelog
|
||||
* Tue Feb 01 2022 Florian Weimer <fweimer@redhat.com> - 2.34.9000-39
|
||||
- Drop glibc-temp-Wno-use-after-free.patch, fixed upstream.
|
||||
- Auto-sync with upstream branch master,
|
||||
commit 3fb18fd80c5900cc82748f3320b30516c57d24da:
|
||||
- elf: Add <dl-r_debug.h>
|
||||
- Mention _FORTIFY_SOURCE=3 for gcc12 in NEWS
|
||||
- malloc: Fix -Wuse-after-free warning in tst-mallocalign1 [BZ #26779]
|
||||
- Update libc.pot for 2.35 release.
|
||||
- tst-socket-timestamp-compat.c: Check __TIMESIZE [BZ #28837]
|
||||
- Add prelink removal plan on NEWS
|
||||
- Linux: Only generate 64 bit timestamps for 64 bit time_t recvmsg/recvmmsg
|
||||
- linux: Fix ancillary 64-bit time timestamp conversion (BZ #28349, BZ#28350)
|
||||
- support: Add support_socket_so_timestamp_time64
|
||||
- Fix elf/loadfail test build dependencies
|
||||
- Fix glibc 2.34 ABI omission (missing GLIBC_2.34 in dynamic loader)
|
||||
- x86: Use CHECK_FEATURE_PRESENT to check HLE [BZ #27398]
|
||||
- Guard tst-valgrind-smoke.out with run-built-tests
|
||||
- hurd: Add posix_spawnattr_tc{get,set}pgrp_np on libc.abilist
|
||||
- Avoid -Wuse-after-free in tests [BZ #26779].
|
||||
- elf: Replace tst-p_alignmod1-editX with a python script
|
||||
- stdlib: Avoid -Wuse-after-free in __add_to_environ [BZ #26779]
|
||||
- io: Fix use-after-free in ftw [BZ #26779]
|
||||
- intl: Avoid -Wuse-after-free [BZ #26779]
|
||||
- elf: Fix use-after-free in ldconfig [BZ #26779]
|
||||
- posix: Add terminal control setting support for posix_spawn
|
||||
|
||||
* Mon Jan 24 2022 DJ Delorie <dj@redhat.com> - 2.34.9000-38
|
||||
- Auto-sync with upstream branch master,
|
||||
commit 5b8e7980c5dabd9aaefeba4f0208baa8cf7653ee.
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (glibc-2.34.9000-578-g5b8e7980c5.tar.xz) = 22f6af54b723a9e44b2c44814a2b0d05bd3cf50e018974454c159bcc05b76147ab775be538c3a31ec590bf65b08f04248eadb2f68d0b5171bf9d609a244c1a1f
|
||||
SHA512 (glibc-2.34.9000-599-g3fb18fd80c.tar.xz) = 94d2662798bcf6051aa343e2b305d3e52d5d27c173c4a7fd918c0ff4a515e8a321db502f665fb06fcbf3e416e98d4aecf6145f98a4e49cb146e6deb401eb145a
|
||||
|
Loading…
Reference in New Issue
Block a user