Auto-sync with upstream branch master
Upstream commit: 28713c06129f8f64f88c423266e6ff2880216509 - elf: Sort tests and modules-names - hurd: nuke all unknown ports on exec - hurd: Fix auth port leak - Remove stale reference to libanl.a - elf: Add <dl-debug.h> - Properly check linker option in LIBC_LINKER_FEATURE [BZ #28738] - hurd: Implement _S_msg_get_dtable - Update automatically-generated copyright dates - Sync move-if-change from Gnulib, updating copyright - Update copyright dates not handled by scripts/update-copyrights. - Update copyright dates with scripts/update-copyrights - hurd: Use __trivfs_server_name instead of trivfs_server_name - hurd: Bump BRK_START to 0x20000000 - hurd: Avoid overzealous shared objects constraints - time: Refactor timesize.h for some ABIs - hurd: Make getrandom a stub inside the random translator - open64: Force O_LARGEFILE on all architectures - x86-64: Add vector tan/tanf implementation to libmvec - x86-64: Add vector erfc/erfcf implementation to libmvec - resolv: Do not install libanl.so symbolic link - resolv: Do not build libanl.so for ABIs starting at 2.35 - timezone: test-case for BZ #28707 - timezone: handle truncated timezones from tzcode-2021d and later (BZ #28707) - x86-64: Add vector asinh/asinhf implementation to libmvec - x86-64: Add vector tanh/tanhf implementation to libmvec - x86-64: Add vector erf/erff implementation to libmvec - x86-64: Add vector acosh/acoshf implementation to libmvec - x86-64: Add vector atanh/atanhf implementation to libmvec - x86-64: Add vector log1p/log1pf implementation to libmvec - x86-64: Add vector log2/log2f implementation to libmvec - x86-64: Add vector log10/log10f implementation to libmvec - x86-64: Add vector atan2/atan2f implementation to libmvec - x86-64: Add vector cbrt/cbrtf implementation to libmvec - x86-64: Add vector sinh/sinhf implementation to libmvec - x86-64: Add vector expm1/expm1f implementation to libmvec - x86-64: Add vector cosh/coshf implementation to libmvec - x86-64: Add vector exp10/exp10f implementation to libmvec - x86-64: Add vector exp2/exp2f implementation to libmvec - x86-64: Add vector hypot/hypotf implementation to libmvec - x86-64: Add vector asin/asinf implementation to libmvec - x86-64: Add vector atan/atanf implementation to libmvec
This commit is contained in:
parent
8d17a555f4
commit
514d6266eb
@ -8,23 +8,24 @@ python3 during a transitional phase.
|
||||
|
||||
Author: Carlos O'Donell <carlos@redhat.com>
|
||||
|
||||
|
||||
diff --git a/benchtests/scripts/compare_bench.py b/benchtests/scripts/compare_bench.py
|
||||
index 6fcbd0803808e5ca..d43db393d63433bc 100755
|
||||
index a85ca3a38be1fdeb..9f1ea9d85f4b833a 100755
|
||||
--- a/benchtests/scripts/compare_bench.py
|
||||
+++ b/benchtests/scripts/compare_bench.py
|
||||
@@ -1,4 +1,4 @@
|
||||
-#!/usr/bin/python
|
||||
+#!/usr/bin/python3
|
||||
# Copyright (C) 2015-2021 Free Software Foundation, Inc.
|
||||
# Copyright (C) 2015-2022 Free Software Foundation, Inc.
|
||||
# This file is part of the GNU C Library.
|
||||
#
|
||||
diff --git a/benchtests/scripts/import_bench.py b/benchtests/scripts/import_bench.py
|
||||
index a799b4e1b7dc6f30..3286e267168e83bf 100644
|
||||
index d8bdde7753885a4d..698c4ff81b13f697 100644
|
||||
--- a/benchtests/scripts/import_bench.py
|
||||
+++ b/benchtests/scripts/import_bench.py
|
||||
@@ -1,4 +1,4 @@
|
||||
-#!/usr/bin/python
|
||||
+#!/usr/bin/python3
|
||||
# Copyright (C) 2015-2021 Free Software Foundation, Inc.
|
||||
# Copyright (C) 2015-2022 Free Software Foundation, Inc.
|
||||
# This file is part of the GNU C Library.
|
||||
#
|
||||
|
49
glibc.spec
49
glibc.spec
@ -1,4 +1,4 @@
|
||||
%define glibcsrcdir glibc-2.34.9000-437-g5d28a8962d
|
||||
%define glibcsrcdir glibc-2.34.9000-478-g28713c0612
|
||||
%define glibcversion 2.34.9000
|
||||
# Pre-release tarballs are pulled in from git using a command that is
|
||||
# effectively:
|
||||
@ -148,7 +148,7 @@ end \
|
||||
Summary: The GNU libc libraries
|
||||
Name: glibc
|
||||
Version: %{glibcversion}
|
||||
Release: 35%{?dist}
|
||||
Release: 36%{?dist}
|
||||
|
||||
# In general, GPLv2+ is used by programs, LGPLv2+ is used for
|
||||
# libraries.
|
||||
@ -2154,6 +2154,51 @@ update_gconv_modules_cache ()
|
||||
%files -f compat-libpthread-nonshared.filelist -n compat-libpthread-nonshared
|
||||
|
||||
%changelog
|
||||
* Tue Jan 04 2022 Florian Weimer <fweimer@redhat.com> - 2.34.9000-36
|
||||
- Auto-sync with upstream branch master,
|
||||
commit 28713c06129f8f64f88c423266e6ff2880216509:
|
||||
- elf: Sort tests and modules-names
|
||||
- hurd: nuke all unknown ports on exec
|
||||
- hurd: Fix auth port leak
|
||||
- Remove stale reference to libanl.a
|
||||
- elf: Add <dl-debug.h>
|
||||
- Properly check linker option in LIBC_LINKER_FEATURE [BZ #28738]
|
||||
- hurd: Implement _S_msg_get_dtable
|
||||
- Update automatically-generated copyright dates
|
||||
- Sync move-if-change from Gnulib, updating copyright
|
||||
- Update copyright dates not handled by scripts/update-copyrights.
|
||||
- Update copyright dates with scripts/update-copyrights
|
||||
- hurd: Use __trivfs_server_name instead of trivfs_server_name
|
||||
- hurd: Bump BRK_START to 0x20000000
|
||||
- hurd: Avoid overzealous shared objects constraints
|
||||
- time: Refactor timesize.h for some ABIs
|
||||
- hurd: Make getrandom a stub inside the random translator
|
||||
- open64: Force O_LARGEFILE on all architectures
|
||||
- x86-64: Add vector tan/tanf implementation to libmvec
|
||||
- x86-64: Add vector erfc/erfcf implementation to libmvec
|
||||
- resolv: Do not install libanl.so symbolic link
|
||||
- resolv: Do not build libanl.so for ABIs starting at 2.35
|
||||
- timezone: test-case for BZ #28707
|
||||
- timezone: handle truncated timezones from tzcode-2021d and later (BZ #28707)
|
||||
- x86-64: Add vector asinh/asinhf implementation to libmvec
|
||||
- x86-64: Add vector tanh/tanhf implementation to libmvec
|
||||
- x86-64: Add vector erf/erff implementation to libmvec
|
||||
- x86-64: Add vector acosh/acoshf implementation to libmvec
|
||||
- x86-64: Add vector atanh/atanhf implementation to libmvec
|
||||
- x86-64: Add vector log1p/log1pf implementation to libmvec
|
||||
- x86-64: Add vector log2/log2f implementation to libmvec
|
||||
- x86-64: Add vector log10/log10f implementation to libmvec
|
||||
- x86-64: Add vector atan2/atan2f implementation to libmvec
|
||||
- x86-64: Add vector cbrt/cbrtf implementation to libmvec
|
||||
- x86-64: Add vector sinh/sinhf implementation to libmvec
|
||||
- x86-64: Add vector expm1/expm1f implementation to libmvec
|
||||
- x86-64: Add vector cosh/coshf implementation to libmvec
|
||||
- x86-64: Add vector exp10/exp10f implementation to libmvec
|
||||
- x86-64: Add vector exp2/exp2f implementation to libmvec
|
||||
- x86-64: Add vector hypot/hypotf implementation to libmvec
|
||||
- x86-64: Add vector asin/asinf implementation to libmvec
|
||||
- x86-64: Add vector atan/atanf implementation to libmvec
|
||||
|
||||
* Wed Dec 29 2021 Florian Weimer <fweimer@redhat.com> - 2.34.9000-35
|
||||
- Auto-sync with upstream branch master,
|
||||
commit 5d28a8962dcb6ec056b81d730e3c6fb57185a210:
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (glibc-2.34.9000-437-g5d28a8962d.tar.xz) = 49cf77663c7ff002fc83b1c1a7fbdc58532d469146dbcb2bdae4b622d50ac398c633f554deb889c66c8fd8db739ea76d2161d66dde13612a1b4a9052868fd337
|
||||
SHA512 (glibc-2.34.9000-478-g28713c0612.tar.xz) = 5accef5c2624018bd71dc1d9ebb6b2ef057c54aff21c393b640ef18b519610dc6f203709eb5bcaffb145c7f9241f1fc711547060e5e0d31d9e21e31a911db82d
|
||||
|
Loading…
Reference in New Issue
Block a user