2.6.90-14
This commit is contained in:
parent
4c53b154b0
commit
4ea15d1afc
@ -1,2 +1,2 @@
|
||||
glibc-20070827T2032.tar.bz2
|
||||
glibc-fedora-20070827T2032.tar.bz2
|
||||
glibc-20070918T1931.tar.bz2
|
||||
glibc-fedora-20070918T1931.tar.bz2
|
||||
|
@ -2149,3 +2149,17 @@
|
||||
|
||||
cfi_startproc;
|
||||
PSEUDO_END (BP_SYM (__clone))
|
||||
--- libc/misc/bits/syslog.h 18 Sep 2007 19:57:16 -0000 1.1.2.2
|
||||
+++ libc/misc/bits/syslog.h 18 Sep 2007 20:33:39 -0000
|
||||
@@ -27,9 +27,9 @@ extern void __syslog_chk (int __pri, int
|
||||
|
||||
#ifdef __va_arg_pack
|
||||
__extern_always_inline void
|
||||
-syslog (int __pri, int __flag, __const char *__fmt, ...)
|
||||
+syslog (int __pri, __const char *__fmt, ...)
|
||||
{
|
||||
- return __syslog_chk (__pri, __flag, __fmt, __va_arg_pack ());
|
||||
+ return __syslog_chk (__pri, __USE_FORTIFY_LEVEL - 1, __fmt, __va_arg_pack ());
|
||||
}
|
||||
#elif !defined __cplusplus
|
||||
# define syslog(pri, ...) \
|
||||
|
21
glibc.spec
21
glibc.spec
@ -1,9 +1,9 @@
|
||||
%define glibcdate 20070827T2032
|
||||
%define glibcdate 20070918T1931
|
||||
%define glibcname glibc
|
||||
%define glibcsrcdir glibc-20070827T2032
|
||||
%define glibcsrcdir glibc-20070918T1931
|
||||
%define glibc_release_tarballs 0
|
||||
%define glibcversion 2.6.90
|
||||
%define glibcrelease 13
|
||||
%define glibcrelease 14
|
||||
%define run_glibc_tests 1
|
||||
%define auxarches i586 i686 athlon sparcv9v sparc64v alphaev6
|
||||
%define xenarches i686 athlon
|
||||
@ -1015,6 +1015,21 @@ rm -f *.filelist*
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Tue Sep 18 2007 Jakub Jelinek <jakub@redhat.com> 2.6.90-14
|
||||
- -D_FORTIFY_SOURCE{,=2} support for C++
|
||||
- fortification of fread{,_unlocked}
|
||||
- support *scanf m allocation modifier (%ms, %mls, %mc, ...)
|
||||
- in -std=c99 or -D_XOPEN_SOURCE=600 mode don't recognize
|
||||
%as, %aS and %a[ as a GNU extension for *scanf
|
||||
- fix splice, vmsplice, tee return value, make them cancellation
|
||||
points
|
||||
- mq_open checking
|
||||
- use inline function rather than function-like macro
|
||||
for open{,at}{,64} checking
|
||||
- IFA_F_OPTIMISTIC handling in getaddrinfo (#259681)
|
||||
- fix an ABBA deadlock in ld.so (#284171)
|
||||
- remove sparc{32,64} unwind info from _start and clone
|
||||
|
||||
* Mon Aug 27 2007 Jakub Jelinek <jakub@redhat.com> 2.6.90-13
|
||||
- fix personality on x86_64/ppc/ppc64 (#256281)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user