2.4.90-20
This commit is contained in:
parent
467134fe2b
commit
4333d793d9
@ -1228,6 +1228,24 @@
|
||||
* tst-cancel17.c (do_test): Check if aio_cancel failed.
|
||||
--- glibc-20060815T0533/nptl/Makefile 13 Aug 2006 01:53:28 -0000 1.184
|
||||
+++ glibc-20060815T0533-fedora/nptl/Makefile 15 Aug 2006 05:53:48 -0000 1.157.2.24
|
||||
@@ -122,7 +122,7 @@ libpthread-routines = init vars events v
|
||||
pthread_mutexattr_getprotocol \
|
||||
pthread_mutexattr_setprotocol \
|
||||
pthread_mutexattr_getprioceiling \
|
||||
- pthread_mutexattr_setprioceiling \
|
||||
+ pthread_mutexattr_setprioceiling tpp \
|
||||
pthread_mutex_getprioceiling pthread_mutex_setprioceiling
|
||||
# pthread_setuid pthread_seteuid pthread_setreuid \
|
||||
# pthread_setresuid \
|
||||
@@ -258,7 +258,7 @@ tests = tst-typesizes \
|
||||
tst-vfork1 tst-vfork2 tst-vfork1x tst-vfork2x \
|
||||
tst-getpid1 tst-getpid2 tst-getpid3 \
|
||||
tst-initializers1 $(patsubst %,tst-initializers1-%,c89 gnu89 c99 gnu99)
|
||||
-xtests = tst-setuid1 tst-setuid1-static
|
||||
+xtests = tst-setuid1 tst-setuid1-static tst-mutexpp1 tst-mutexpp6 tst-mutexpp10
|
||||
|
||||
# Files which must not be linked with libpthread.
|
||||
tests-nolibpthread = tst-unload
|
||||
@@ -524,15 +524,19 @@ $(addprefix $(objpfx), \
|
||||
$(tests) $(xtests) $(test-srcs))): $(objpfx)libpthread.so \
|
||||
$(objpfx)libpthread_nonshared.a
|
||||
|
Loading…
Reference in New Issue
Block a user